17:02:04 <mugsie> #startmeeting Designate
17:02:05 <openstack> Meeting started Wed Nov 11 17:02:04 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:08 <openstack> The meeting name has been set to 'designate'
17:02:22 <mugsie> #topic Roll Call
17:02:29 <mugsie> so, who's here?
17:02:32 <johnbelamaric> o/
17:02:32 <mlavalle> hi
17:02:33 <Kiall> o/
17:03:06 <timsim> o/
17:03:27 <mugsie> #topic Action Items
17:03:31 <mugsie> mugsie finish investigations on his bugs
17:03:32 <pglass> o/
17:03:34 <mugsie> done
17:03:44 <mugsie> Kiall investiagte 1505605
17:04:05 <mugsie> Kiall: ?
17:04:42 <mugsie> OK, i think he is afk :)
17:04:48 <mugsie> #action Kiall investiagte 1505605
17:04:50 <mugsie> mugsie update review dashboard to show Kilo / Liberty
17:04:51 <jmcbride> o/
17:04:55 <mugsie> done
17:05:07 <mugsie> #topic Announcements
17:05:30 <rsyed> o/
17:05:30 <mugsie> anyone have any?
17:05:52 <mugsie> OK then :)
17:05:55 <mugsie> #topic Bug Triage (timsim - recurring)
17:06:02 <mugsie> timsim: over to you
17:06:29 <timsim> looks like https://bugs.launchpad.net/designate/+bug/1491248 is still assigned to you mugsie
17:06:29 <openstack> Launchpad bug 1491248 in Designate "Record is not deleted after terminating a VM+duplicate records " [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:06:51 <mugsie> ah, meant to close that
17:07:08 <timsim> https://bugs.launchpad.net/designate/+bug/1513226
17:07:08 <openstack> Launchpad bug 1513226 in Designate "Quotas in admin API is missing api_export_size" [Undecided,New]
17:07:30 <mugsie> h, m1
17:07:48 <timsim> agreed
17:07:49 <timsim> https://bugs.launchpad.net/designate/+bug/1514602
17:07:49 <openstack> Launchpad bug 1514602 in Designate "Pool manager doesn't start when coordination backend isn't reachable" [Undecided,New]
17:07:49 <Kiall> Is that a quota or a global limit?
17:08:02 <mugsie> quota
17:08:04 <Kiall> K
17:08:14 <Kiall> Saw this one, critical / m1
17:08:17 <Kiall> But disagree with the fix
17:08:34 <Kiall> it should stay running, and continue to try connecting - same as we do for MySQL/RabbitMQ etc
17:08:46 <Kiall> otherwise it forces deployment ordering weirdness
17:09:00 <mugsie> OK, Kiall you want to comment in the bug with ^
17:09:02 <mugsie> ?
17:09:09 <Kiall> K
17:09:13 <mugsie> C / m1 as well
17:09:59 * timsim just checking the two bugs in client, might have gone over them last week
17:10:28 <mugsie> we did
17:10:30 <timsim> yeah we did
17:10:35 <timsim> done :)
17:10:46 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:10:49 <Kiall> #link http://paste.openstack.org/show/478587/
17:10:58 <Kiall> (woo, I did paste.openstack this time ;))
17:11:12 <mugsie> wow, paste openstack is sloooooowwwwww
17:11:17 <Kiall> As usual, take a few mins - review, nominate for backport to K or L
17:11:30 <mugsie> ed2861a Handle NO_DOMAIN status
17:11:42 <mugsie> (liberty + kilo?))
17:11:57 <Kiall> Sounds about right to me
17:12:39 <mugsie> any more?
17:12:52 <timsim> 6113026 Merge "Use assertTrue/False instead of assertEqual(T/F)"
17:12:55 <Kiall> "e6adbb9 Merge "Fixes Output for zone type filter" <-- possibly, looking up the details
17:12:55 <timsim> jk :troll:
17:13:35 <Kiall> mm - maybe? others thoughts?
17:13:49 <mugsie> timsim: http://replygif.net/i/100.gif
17:14:16 <timsim> c679735 Merge "Removes zone files when a zone is deleted" maybe?
17:14:36 <mugsie> e6adbb9 Merge "Fixes Output for zone type filter - yes
17:14:51 <mugsie> c679735 Merge "Removes zone files when a zone is deleted" maybe? - is that a bug or a feature?
17:14:54 <timsim> yeah agreed that's an easy one.
17:15:06 <mugsie> i would lean towards it being a feature, and as such, invalid
17:15:19 <timsim> I'm fine with that.
17:15:20 <mugsie> thoughts?
17:15:24 <mugsie> ok
17:15:25 <elarson> o/
17:15:29 <mugsie> look who showed up
17:15:30 <timsim> I think people might expect that to just happen somehow.
17:15:35 <Kiall> It's both? I'd say yes, it's small enough and given enough time running, can lead to pain?
17:15:50 <elarson> sorry, was #inthezone
17:15:56 <mugsie> it is only compatible with bind 9.10
17:16:08 <mugsie> which is just out right?
17:16:26 <Kiall> true.. Leave it so
17:16:30 <timsim> Yeah.
17:16:43 <Kiall> Anyone running Kilo won't be on a new enough bind to use it ;)
17:17:08 <mugsie> grand. any voulenteers to bp e6adbb9 and ed2861a ?
17:17:27 <Kiall> I'll do the quick+easy one now while I wait for a build = e6adbb9 ;)
17:17:35 <mugsie> timsim: can you do ed2861a ? as you cannot vote on the bp anyway (as its your code)
17:17:46 <timsim> Sure
17:17:55 <mugsie> #action Kiall bp e6adbb9
17:18:09 <mugsie> #action timsim bp ed2861a to L + K
17:18:20 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:18:25 <mlavalle> hi
17:18:30 <mugsie> hey
17:18:48 <mlavalle> functionality for floating ips is complete in Neutron
17:18:56 <mlavalle> that is what we demoed in Tokyo
17:19:22 <mugsie> great.
17:19:34 <mugsie> is there anything on our end blocking this?
17:19:37 <mlavalle> I am adding the same functionality now for ip_addresses for ports on provider networks
17:19:53 <mlavalle> whaich can also be public addresses in Neutron
17:20:05 <mlavalle> it shouldn't take too long
17:20:14 <mlavalle> my goal is to merge this in mitaka-1
17:20:23 <mlavalle> are soon after
17:20:31 <Kiall> Cool, that was one of the Q's from the talk at the Summit, right?
17:20:38 <mlavalle> yeah
17:21:00 * mugsie needs to watch that video
17:21:03 <mlavalle> I also had a 15 minutes conversation with johnthetubaguy (the Nova PTL) in Tokyo
17:21:13 <mlavalle> and another one this morning
17:21:28 <mlavalle> 'he is in support of https://review.openstack.org/#/c/90150/
17:21:40 <mlavalle> I pushed the last revision last Friday
17:21:50 <mlavalle> so things look good on that front as well
17:21:58 <johnthetubaguy> I will totally get to review your spec, I like the general idea, just need to dig back into that post summit
17:22:14 <mlavalle> johnthetubaguy: thanks :-)
17:22:19 <mugsie> great :)
17:22:25 <johnthetubaguy> I have marked it as a spec that blocks another project's progress to try get it more attention
17:22:37 <mugsie> mlavalle: if you need anything from designate just shout :)
17:22:53 <mlavalle> mugsie: will do. That's all from me this week
17:23:00 <mugsie> but it looks like great progress
17:23:11 <mugsie> any questions before we move on?
17:23:25 <Kiall> woo - more progress, that's about it ;)
17:23:36 <mugsie> #topic The big refactor: Domain -> Zone (mugsie)
17:23:43 <mugsie> so, this has started
17:23:50 <mugsie> and it is a massive pain
17:23:56 <mugsie> but I am working through it
17:23:58 <timsim> woohoo
17:24:06 <Kiall> at mugsie's suffering?
17:24:11 <Kiall> not cool timsi
17:24:33 <elarson> !m mugsie
17:24:35 <openstack> elarson: Error: "m" is not a valid command.
17:24:51 <mugsie> I have a family issue that means I will have to take friday off, so if I have not completed it by thursday eve I may need to hand it off
17:25:00 <mugsie> but I think we should be OK
17:25:19 <elarson> mugsie: I believe in you
17:25:19 <mugsie> it does mean we will need everyone to review asap when it goes up
17:25:22 <timsim> We believe
17:25:40 <elarson> can do (says the guy taht can only +1 ;))
17:26:03 <mugsie> http://replygif.net/i/1171.gif
17:26:22 <mugsie> any questions on the rename?
17:26:45 <Kiall> No, but have a comment..
17:27:01 <Kiall> if it's not done by Friday when we scheduled, we should extend till it's done.
17:27:08 <mugsie> ++
17:27:15 <timsim> agreed
17:27:16 <Kiall> i.e. just get it out of the way rather than "abort" and start over next cycle ;)
17:27:37 <mugsie> 100% - but we should treat friday as a hard deadline until we miss it
17:27:54 <mugsie> trust me, I am not abandoning it now ;)
17:28:14 <mugsie> #topic Open Discussion
17:28:20 <mugsie> any off agenda items?
17:28:25 <jmcbride> I have an announcement
17:28:37 <jmcbride> Please welcome a new-ish team member to the rax DNS team: rsyed
17:28:46 <mugsie> hey rsyed !
17:28:47 <rsyed> hey everyone!
17:28:48 <federico3> hello rsyed !
17:28:49 <Kiall> Welcome rsyed :)
17:28:56 <rsyed> thanks!
17:29:03 <jmcbride> (he joined our team a few weeks ago, hence new-ish)
17:29:03 <Kiall> You guys keep hiring, putting everyone else to shame ;)
17:29:09 <johnbelamaric> welcome rsyed
17:29:30 <mugsie> http://replygif.net/i/1412.gif
17:29:37 <Kiall> Side - https://review.openstack.org/#/c/244230/ and https://review.openstack.org/#/c/244231/ for stable/liberty
17:29:51 <elarson> !h5 rsyed
17:29:52 <openstack> elarson: Error: "h5" is not a valid command.
17:29:58 <timsim> No_domain didn't cherry pick cleanly :P
17:30:01 <elarson> #breakingbotonecommandatatime
17:30:36 <rsyed> i've noticed the wider designate community has as strong gif skills as my team does...i have to level up
17:30:39 <Kiall> timsim: of course it didn't!
17:30:42 <jmcbride> (rsyed just got a new grill, so I know he'll appreciate discussing the needful on meat if you have tips)
17:30:54 <Kiall> rsyed: lol - I blame elarson on that.
17:30:56 <Kiall> and mugsie
17:31:02 <elarson> :)
17:31:06 <rsyed> absolutely, my first attempt at steak was mediocre
17:31:10 * elarson points to filler / silkey
17:31:20 <elarson> fwiw, I updated the alias spec with conclusions from the summit
17:31:27 <timsim> I've got the IXFR spec updated: https://review.openstack.org/#/c/132638/ http://docs-draft.openstack.org/38/132638/13/check/gate-designate-specs-docs/87a0565//doc/build/html/specs/mitaka/ixfr.html
17:31:30 <elarson> I'm also putting together some reviews that are meant to be atomic
17:31:33 <mugsie> elarson: I saw that. next week will be spec time for me
17:31:39 <elarson> no worries
17:31:40 <Kiall> elarson: cool - you have code for that too, how close to the spec is it?
17:31:49 <mugsie> atomic as in boom? :P
17:31:58 <Kiall> 9i.e. how much did the summit change what you had coded ;))
17:32:00 <federico3> I was going to say the same
17:32:30 <elarson> Kiall: the basic functionality worked (last I checked) so now I'm adding tests and will start adding the extra bits (ie export, grabbing the upstream a record ttl, etc. )
17:32:36 <elarson> so not much changed
17:32:47 <mugsie> OK, any more items before we break?
17:32:49 <Kiall> elarson: cool, always nice to have it match reality :)
17:33:08 <elarson> I was going submit a small unit test for the mdns handler
17:33:08 <Kiall> Not from me..
17:33:35 <elarson> I only mention it here b/c it is something we can talk about regarding the test suite refactoring
17:33:52 <mugsie> ah
17:34:04 <mugsie> yeah, that diserves a good discussion
17:34:11 <elarson> aka, get more clarity on where we want to things to go
17:34:21 <mugsie> want to add it here for next week elarson https://wiki.openstack.org/wiki/Meetings/Designate ?
17:34:37 <elarson> but basically it is perfect so there really is nothign to discuss ;)
17:34:45 <mugsie> :D
17:34:53 <Kiall> But if you add it, we expect a powerpoint deck on it - purly filled with gifs ;)
17:35:15 <elarson> mugsie: we can leave it off of the meeting as I suspect we'll have a ongoing discussion
17:35:20 <mugsie> ok, cool
17:35:25 <elarson> Kiall: already done
17:35:47 <Kiall> lol
17:35:49 <mugsie> elarson: it better be in a docker container using emacs ascii art
17:36:13 <elarson> mugsie: obviously
17:36:19 <mugsie> :)
17:36:27 <mugsie> ok. is that all for this week?
17:36:45 <Kiall> I think so
17:36:50 * elarson is good
17:36:56 <mugsie> ok, see ya'll in #openstack-dns
17:36:59 <mugsie> #endmeeting