17:00:45 <mugsie> #startmeeting Designate
17:00:46 <openstack> Meeting started Wed Oct  7 17:00:45 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:49 <openstack> The meeting name has been set to 'designate'
17:01:04 <mugsie> hey - whos here?
17:01:06 <federico3> hi there
17:01:27 <ekarlso> yoyo :p
17:01:34 <timsim> o/
17:02:02 <mugsie> #topic action items from last week
17:02:15 <mugsie> Kiall / mugsie to do actions from http://eavesdrop.openstack.org/meetings/designate/2015/designate.2015-09-09-16.59.log.html
17:02:25 <mugsie> done afaik
17:02:32 <Kiall> KInda here - Stuck on something else - but Done
17:02:34 <Kiall> (woo)
17:02:34 <mugsie> kiall to backport 9c37d55 / 4a68605 / 0c034d1 (if possible) / ad180b4
17:02:46 <mugsie> done as well, i think
17:02:47 <mugsie> cores to review backports
17:02:48 <Kiall> 0c034d1 is todo
17:02:54 <Kiall> it wasn't a clean BP
17:03:04 <mugsie> #action kiall backport 0c034d1
17:03:24 <mugsie> reviews are outstanding - but timsim was not in the right group :)
17:03:30 <timsim> :(
17:03:34 <mugsie> federico3 one to backport 6e45b7c 9c37d55 abfc3c0 to Kilo
17:03:42 <federico3> mugsie: the CRs are out
17:03:54 <mugsie> great
17:03:58 <mugsie> mugsie to suck it
17:04:08 <mugsie> :)
17:04:10 <mugsie> Everyone read/understand http://governance.openstack.org/reference/tags/assert_follows-standard-deprecation.html
17:04:17 <mugsie> did everyone read ^ ?
17:04:21 <elarson> o/
17:04:45 <mugsie> i think that might be a few weeks for it to be completed :)
17:04:47 <mugsie> mugsie to add assert:follows-standard-deprication to a future agenda
17:04:58 <mugsie> that will be post summit I think at this point5
17:05:09 <timsim> Yeah I didn't read that :D
17:05:13 <mugsie> :)
17:05:24 <mugsie> #topic Announcements
17:05:33 <mugsie> (i missed the order :) )
17:06:01 <Kiall> https://media.giphy.com/media/LbtSUVrZvnHDa/giphy.gif
17:06:07 <Kiall> (fail)
17:06:11 <mugsie> rc2 is out
17:06:15 <mugsie> #link https://launchpad.net/designate/liberty/liberty-rc2
17:06:33 <mugsie> we have a possiblitly of an RC3?
17:06:46 <mugsie> Kiall: was that agreed yet?
17:06:56 <elarson> Kiall: well done! #allaboardthegiftrain
17:07:07 <Kiall> It's possible, but only if it's a absolutly critical bug
17:07:18 <mugsie> OK
17:07:24 <mugsie> any other announcements>
17:07:26 <mugsie> ?*
17:07:47 <mugsie> #topic Bug Triage (timsim - recurring)
17:07:54 <mugsie> timsim: over to you :)
17:08:25 <timsim> There are the ones still assigned to mugsie
17:08:47 <mugsie> #action mugsie finish investigations on his bugs
17:08:50 <timsim> Apart from that, doesn't look like anything new
17:09:03 <mugsie> \o/
17:09:32 <mugsie> can everyone give some testing to the RC2 builds, to make sure nothing is really broken?
17:10:04 <mugsie> I have been filing bugs with distros for some stuff, but we need a good test for L
17:10:22 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:10:52 <Kiall> Sorry - still on other call, don't have the list handy! Can you gather it real quick mugsie? SSOrry
17:10:58 <mugsie> yup
17:11:44 <mugsie> 1b44c45 Merge "retry creates/deletes in the pool manager"
17:11:44 <mugsie> 94dfad3 retry creates/deletes in the pool manager
17:11:44 <mugsie> fa19a42 Merge "Functional tests: optionally skip admin actions in setups"
17:11:47 <mugsie> d0d2816 Functional tests: optionally skip admin actions in setups
17:11:50 <mugsie> c59a2a0 Fix handling of Pool NS changes
17:11:56 <mugsie> can everyone have a look over ^ ?
17:12:27 <timsim> 94dfad3 retry creates/deletes in the pool manager and c59a2a0 Fix handling of Pool NS changes probably need it.
17:12:32 <federico3> yep
17:12:38 <mugsie> to L ?
17:12:58 <federico3> and 94dfad3 retry creates/deletes  ?
17:13:05 <mugsie> yeah, I would tend to agree - Kiall will need to talk to the release management team
17:13:27 <timsim> Isn't c59a2a0 already in rc2?
17:13:28 <mugsie> #action Kiall sync with rel-man for backports of 94dfad3 and c59a2a0
17:13:39 <timsim> Or are we talkin Kilo
17:13:56 <mugsie> it is
17:14:05 <mugsie> so just 94dfad3
17:14:10 * timsim should wrap up https://review.openstack.org/#/c/230770/2
17:14:22 <mugsie> not sure if that is a new RC level of bug though.
17:14:43 <timsim> If there is one, might as well pop it in.
17:14:49 <mugsie> yeah ++
17:14:53 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:15:01 <mlavalle> hi there
17:15:05 <mugsie> hey :)
17:15:43 <mlavalle> so https://review.openstack.org/#/c/212213/ is functionally complete now
17:16:03 <mlavalle> I incorporated the changes to create PTR in /24 zone
17:16:14 <mlavalle> I don't delete the PTR zones any more
17:16:46 <mugsie> OK, cool.
17:16:49 <mlavalle> and creation of PTR's are optional, based on a configuration parameter
17:17:01 <mugsie> so, we should be testing this patch now?
17:17:15 <mlavalle> yes, you can test it
17:17:33 <mlavalle> I have tested it extesively in my sand box and as far as I can tell is bug free
17:17:55 <mugsie> great :)
17:18:04 <mugsie> #action all to test https://review.openstack.org/#/c/212213/
17:18:10 <mlavalle> I am prioritizing the presentation in Tokyo
17:18:32 <mlavalle> but will aslso be fixing the failures with the neutron unit tests
17:19:11 <mugsie> OK, thanks mlavalle
17:19:15 <mlavalle> and I am also starting to modify nova, so when an instance is created, the instance name is sent in the dns_name attribute of the port
17:19:22 <mugsie> any questions?
17:19:30 <mugsie> ah - that was goign to one of mine :)
17:19:44 <mugsie> great - do we need to resurect the nova spec?
17:19:58 <mlavalle> that way when you assign a neutron floating ip to it, we will be able to publish the instance's name to designate
17:20:13 <mlavalle> mugsie: i'll take care of resurrecting the spec
17:20:30 <mlavalle> i'll just start pushing code along with it
17:20:31 <mugsie> thanks :)
17:20:41 <mlavalle> if i need help, i'll yell
17:20:55 <mugsie> please do
17:20:59 <mlavalle> that's it for today
17:21:16 <mugsie> thanks :) - final call for questions?
17:21:37 <mugsie> #topic M Cycle Summit
17:21:46 <mugsie> #link https://etherpad.openstack.org/p/designate-design-summit-tokyo
17:22:00 <mugsie> I filled in the rooms on the etherpad
17:22:12 <mugsie> we have 5 slots
17:22:19 <mugsie> with one being a fishbowl
17:22:42 <mugsie> is there any topic people think is a must have>
17:22:43 <mugsie> ?*
17:23:37 <timsim> Not _must have_
17:24:09 <mugsie> OK. any that we *should* have?
17:25:11 <timsim> Probably any from https://etherpad.openstack.org/p/designate_2015_summer_midcycle_meetup_mcycle
17:25:20 <timsim> that we don't absolutely know what we're going to do
17:25:39 <timsim> We didn't decide on ixfr
17:25:42 <mugsie> no.
17:25:55 <mugsie> might be a good 40 min bikeshed
17:25:58 <mugsie> :P
17:26:00 <timsim> Always
17:26:21 <timsim> I wanted to talk about embedded services a bit.
17:26:35 <mugsie> as in central in api ?
17:26:47 <timsim> aka https://blueprints.launchpad.net/designate/+spec/embeddable-central
17:26:48 <timsim> eyah
17:26:49 <timsim> yeah
17:26:53 <timsim> And possibly more?
17:26:57 <mugsie> yeah
17:27:05 <mugsie> added
17:27:25 <timsim> Seems like we revist dnssec at every cycle
17:27:31 <timsim> s/cycle/summit
17:27:38 <mugsie> yeah.
17:27:50 <timsim> It'd be good if we came out of the summit with like, 5 things that we REALLY wanted in the cycle.
17:28:03 <timsim> Finishing the pools stuff, although I doubt we really need to talk about that.
17:28:10 <mugsie> I am actually not going to add it for this summit. I think we need some time to think on that, and we will need barbican to do code for us
17:28:26 <timsim> Fair enough.
17:28:27 <timsim> Batch API Actions
17:28:32 <mugsie> ++
17:28:55 <timsim> Sane DB Connection Management would be awesome.
17:28:58 <mugsie> so we have one 40 mins slot left
17:29:49 <mugsie> i think DB Connection management could be a good midcycle - I am not sur we would have anything usful in 40
17:29:53 <mugsie> mins*
17:29:53 <timsim> Maybe get in a room with the nova/neturon folks involved in getting integrated and iron out the rest of the plan?
17:30:13 <timsim> Getting stuff in Nova has to be done early, etc.
17:30:16 <elarson> mugsie: I have a working ALIAS branch, but it has brought up some questions regarding how work gets done. should we consider talking about a slightly more generic worker pattern?
17:30:31 <mugsie> we actually have that spec'd - just need mlavalle to get the code in :)
17:30:48 <mugsie> elarson: so, workers / alias?
17:31:06 <mugsie> we do have a 1/2 day on the friday as well
17:31:16 <elarson> if that seems like a good idea to others
17:31:36 <mugsie> so we can do some deep dives into anything that shakes loose in the 40 mins session
17:31:45 <elarson> sounds good
17:31:50 <mugsie> elarson: yeah, the sounds good for the last slot
17:32:35 <mugsie> everyone agree with what is there now?
17:32:46 <mugsie> elarson: timsim when do you fly home?
17:32:58 <timsim> Saturday evening.
17:33:07 <mugsie> cool.
17:33:41 <mugsie> #vote We should have the design summit as proposed: https://etherpad.openstack.org/p/designate-design-summit-tokyo
17:34:00 <mugsie> meh
17:34:10 <mugsie> so, all agreeed to https://etherpad.openstack.org/p/designate-design-summit-tokyo ?
17:34:16 <mugsie> silence is agreement :)
17:34:25 <timsim> Sounds good to me :)
17:34:38 <Kiall> +
17:34:44 <mugsie> cool
17:34:55 <mugsie> #topic Open Discussion
17:35:03 <mugsie> any off agenda items?
17:35:48 <mugsie> OK, so do we want 25 mins back?
17:36:17 <mugsie> OK, see ya'll in #openstack-dns :)
17:36:18 <Kiall> lol - done with my other thing just in time I see
17:36:19 <Kiall> lol
17:36:24 <mugsie> #endmeeting