17:00:03 <Kiall> #startmeeting Designate
17:00:04 <openstack> Meeting started Wed Sep 16 17:00:03 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:09 <openstack> The meeting name has been set to 'designate'
17:00:13 <Kiall> Hey folks - who's about today?
17:00:14 <timsim> o?
17:00:39 <pglass> o/
17:00:48 <james_li> james li
17:01:00 <Kiall> mugsie's on his way...
17:01:12 <Kiall> ekarlso / federico3 / etc about? :)
17:01:21 <mlavalle> ahoy
17:01:26 <federico3> yup
17:02:11 <ekarlso> Kiall: gonna go out soon but atm here :p
17:02:33 <elarson> o/
17:03:03 <Kiall> Okay, let get going :)
17:03:08 <Kiall> #topic Announcements
17:03:25 <Kiall> It's PTL election season again :)
17:04:20 <Kiall> So - Some of you already know I don't intend to run for PTL again! It's A) time for a change .. I've been running Designate for over 3 years now! and B) My responsibilities inside HP are keeping me just wayy too busy :(
17:04:41 <ekarlso> about time for a new dictator anyways :P
17:04:51 <Kiall> lol
17:05:11 <Kiall> So - I know mugsie intends to run, but it's open for anyone :)
17:05:23 <Kiall> I believe nominations must be in before tomorrow!"
17:05:41 <timsim> Cool :) I trust you'll still be around ;)
17:06:06 <Kiall> Oh yes, my core job @ HP is still Designate :)
17:06:49 <Kiall> #topic Action Items from last week
17:06:49 <mugsie> o/
17:07:00 <mugsie> sorry - got distracted -_-
17:07:13 <timsim> unacceptable.
17:07:23 <mugsie> :D
17:07:25 <Kiall> lol
17:07:28 <mugsie> /kick timsim
17:07:36 <timsim> !slap mugsie
17:07:37 <openstack> timsim: Error: "slap" is not a valid command.
17:08:01 <Kiall> So - a bunch of actions, I managed to get to 0 of mine :( It's been one of those weeks
17:08:31 <Kiall> Will rehash them next week :(
17:08:31 <Kiall> #action kiall / mugsie - get actions done done for next week!
17:08:45 <Kiall> Sorry about that!
17:08:48 <Kiall> #topic Bug Triage (timsim - recurring)
17:08:53 <Kiall> timsim: over to you :)
17:09:14 <timsim> Going to skip the ones that are still assigned to mugsie....
17:09:17 <timsim> https://bugs.launchpad.net/designate/+bug/1493942
17:09:19 <openstack> Launchpad bug 1493942 in Designate "API returns incorrect response when a pool has multiple ns records" [Undecided,New]
17:09:36 <Kiall> This was pglass's one, right?
17:09:48 <pglass> yeah
17:10:21 <Kiall> pglass: did you manage to find a cause etc? But.. Critical / RC1 - Can't ship that.
17:10:44 <pglass> no, I just reported it
17:10:46 <pglass> lol
17:10:53 <Kiall> no worries :)
17:11:02 <mugsie> OK, need to get that fixed ASAP then :/
17:11:04 <Kiall> We'll get it before rc1 :)
17:11:06 <timsim> Alright
17:11:16 <timsim> https://bugs.launchpad.net/designate/+bug/1494132
17:11:17 <openstack> Launchpad bug 1494132 in Designate "designate cli shows the domain was created. BUT, the log show the connection was refused by server" [Undecided,New]
17:12:02 <Kiall> I saw this one go past earlier - I'm  not really sure I understand what's happening. This is same guy mugsie thinks just has this misconfigured?
17:12:25 <timsim> I think his issue is that the client says it's created, even though it'd go to ERROR?
17:12:51 <mugsie> yeah
17:13:01 <mugsie> its the old no status in V1 API issue
17:13:03 <Kiall> That's a "feature" (well - mistake) of the V1 API sadly, V2 API/client fixes itr :(
17:13:10 <timsim> Yeah.
17:13:11 <mugsie> yeah. we can close
17:13:15 <timsim> agreed
17:13:32 <Kiall> Yea, with a explanatory comment ofc ;)
17:13:34 <timsim> I'll close with a message saying the v2 oscli plugin would show that it's error'd?
17:13:57 <mugsie> yeap
17:14:05 <timsim> https://bugs.launchpad.net/designate/+bug/1494277
17:14:07 <openstack> Launchpad bug 1494277 in Designate "Auto record creation with sink- Needed user friendly activation " [Undecided,New]
17:14:09 <Kiall> Yea, and that V1 has no method to return backend fails
17:14:36 <Kiall> That feels like mlavalle's work
17:14:44 <Kiall> (neutron integration)
17:14:49 <mugsie> yeap
17:15:26 <timsim> Close with "we're trying to make this happen in Neutron/Nova?"
17:15:41 <Kiall> Yea - I just left the comment tho :)
17:15:45 <timsim> :)
17:15:54 <timsim> https://bugs.launchpad.net/designate/+bug/1494388
17:15:56 <openstack> Launchpad bug 1494388 in Designate "Designate pdns db upgrade needs to set up masters" [Undecided,New]
17:16:22 <mugsie> H RC1 ? it can just be docs, but we need somethign
17:16:33 <mugsie> poor wikimedia got caught by this
17:16:39 <Kiall> Yea, I think we edit the migration to log a "MANUAL STEP REQUIRED" message for it
17:16:56 <timsim> Cool
17:17:10 <timsim> https://bugs.launchpad.net/designate/+bug/1494799
17:17:11 <openstack> Launchpad bug 1494799 in Designate "500 on listing zones/recordsets with limit=MAX" [Undecided,New]
17:17:40 <mugsie> -_-
17:17:57 <timsim> High RC1? Should be relatively simple
17:18:00 <mugsie> ++
17:18:09 <Kiall> Yea, trivial to fix now that Paul's found it
17:18:33 <timsim> https://bugs.launchpad.net/designate/+bug/1495635
17:18:34 <openstack> Launchpad bug 1495635 in Designate "Designate-dashboard package version not parsed correctly from brief_string()" [Undecided,New]
17:19:14 <timsim> I wonder if there just need to be more docs around getting that installed/where it can be installed/versions/etc
17:19:21 <mugsie> i think so
17:19:35 <mugsie> I know ducttape_ was helping as well
17:19:44 <mugsie> did you find the root of this issue ?
17:20:27 <Kiall> Leave as new + rc1 so it's on the list, but I suspect even the simple pep8/py27 gates would be exploding if this was a code issue rather than a mis-matched lib or user error
17:21:20 <timsim> Alright, that's all of them. We have another one that we still need to report.
17:21:25 <Kiall> K
17:21:28 <ducttape_> ah sorry, waking up
17:21:35 <mugsie> :D
17:21:45 <timsim> Basically, you can create a certain blacklist that recurses and crash Designate real hard on a create domain.
17:21:57 <ducttape_> yeah, it is a pbr version mismatch between horizon and what the dns-dash needs
17:22:18 <mugsie> timsim: ouch
17:22:21 <Kiall> ducttape_: was it the same release of designate-dash + horizon?
17:22:29 <ducttape_> I don't think so
17:22:43 <ducttape_> and there was a question of having a stable / backport branch too
17:22:53 <timsim> Me or pglass will report that asap.
17:23:00 <Kiall> timsim: K thanks
17:23:26 <Kiall> ducttape_: yea, mugsie mentioned that.. we do kinda have a stable branch already for it tho - https://github.com/openstack/designate/tree/stable/kilo/contrib/designate-dashboard
17:23:57 <ducttape_> ah ok.  cool.
17:24:19 <Kiall> Okay, moving on anyway :)
17:24:21 <Kiall> #topic Stable Backport Triage (kiall - recurring)
17:24:29 <Kiall> #link http://paste.openstack.org/show/464962/
17:24:46 <Kiall> as usual, please take a few mins to eyeball em and nominate anything in need of backporting
17:24:47 * timsim waits for paste.openstack
17:24:55 <Kiall> Yea, it's got real slow these days
17:25:09 <Kiall> it's almost etherpad @ the summit speeds ;)
17:25:16 <timsim> lol
17:25:35 <Kiall> 746fa57 Merge "Replace request.request_mac with request.mac" <-- If the same bug exists there.. Though, I don't think it does.
17:25:56 <timsim> eb34b4d Merge "Handling Forbidden Exception" ?
17:25:58 <Kiall> eb34b4d Merge "Handling Forbidden Exception"
17:25:59 <Kiall> heh
17:26:00 <Kiall> yep ;)
17:26:12 <Kiall> timsim: your agent ones, do they need BPing?
17:26:51 <timsim> Naw. The one was a tiny enhancement. Unless the patch that broke the other was BP'd but I don't think it was...
17:27:00 <Kiall> K
17:27:26 <Kiall> Anyone want to take the action of backporting those 2 then?
17:27:45 <timsim> Sure
17:27:48 <Kiall> k
17:27:53 <Kiall> #action timsim to backport 746fa57 and eb34b4d
17:28:09 <Kiall> Moving swiftly on
17:28:12 <Kiall> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:28:17 <Kiall> mlavalle: about?
17:28:22 <mlavalle> Kiall: ahoy
17:28:58 <mlavalle> so this week I took a long weekend vacation (daughter got enaged in Washington DC), so progress was slower
17:29:06 <Kiall> :)
17:29:13 <mlavalle> still managed to work in the airplanes
17:29:20 <mlavalle> while wife was sleeping
17:29:24 <Kiall> hah - I've managed that once, and had the delete all the code after.
17:29:27 <Kiall> mugsie mentiond something yesterday about Kyle asking about the external DNS stuff landing in Neutron L?
17:29:48 <mlavalle> yeah, mestery wants to merger https://review.openstack.org/#/c/212213/ asap
17:30:02 <mestery> mlavalle: ++
17:30:15 <mlavalle> we have the issue of neutron + designate in the gate
17:30:38 <mlavalle> Kiall: did you have a chance to send email to sdague?
17:30:38 <Kiall> So, getting a new gate added this late in the cycle seems somewhat unlikely - it adds lots of risk of CI failures to Neutron..
17:31:04 <mestery> Kiall: +1, and I'd also like to make sure if we try that we include dougwig and armax in those discussions very early
17:31:07 <Kiall> Can it land with experimental, and we add the gate once the M cycle opens?
17:31:16 <mestery> Kiall: +1
17:31:17 <Kiall> s/with/as/
17:31:19 <armax> mestery: hi
17:31:29 <mestery> armax: Sorry, just mentioning a gate for neutron+designate
17:31:33 <armax> hi
17:31:39 <armax> :)
17:31:43 <armax> no worries
17:31:45 * armax catches up
17:32:12 <armax> for anything infra related I’d be happy to be enslaved
17:32:14 <mlavalle> Kiall, mestery: i'd bee happy with that plan....... let's start the neutron + designate cpnversation now, so we can merge this early in M
17:32:58 <mugsie> mlavalle: well, I think we are talking about doing a experimental gate for L, and still merging this in L
17:33:02 <Kiall> Yep, I think that's probably for the best given the gate + the patch still needing work
17:33:12 <Kiall> (and RC in couple of days..)
17:33:16 <mlavalle> Kiall: cool
17:33:53 <Kiall> anyone think that's a terrible plan? ;)
17:34:21 <mlavalle> as far as the patch itself, I added in the airplane the allembic code to migrate the database + code to the designate driver to add PTR records for the floating ip's we publish
17:34:42 <mlavalle> thanks to mugsie for the guidance he gave me yesterday
17:34:58 <mugsie> i think its great to finally see it so close :)
17:35:29 <mlavalle> I will be pushing this update to the patchset in a couple of hours and debug it in my devstack this afternoon / evening
17:35:53 <mugsie> sweet
17:36:10 <Kiall> ++ Okay, anything else / or questions before we move on?
17:36:27 <mlavalle> that's all I have today
17:37:00 <Kiall> Okay :)
17:37:06 <Kiall> Moving on
17:37:08 <Kiall> #topic Liberty RC1 Release
17:37:17 <Kiall> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
17:37:19 <Kiall> RC1 is Sept 21-25th
17:37:25 <Kiall> #link https://launchpad.net/designate/+milestone/liberty-rc1
17:37:53 <Kiall> Anything that wasn't up for review, sadly just isn't going to make it :( I pushed them out earlier today.
17:38:46 <Kiall> So - Similar to last week - quick review of that second link, anything missing? anything not really needed? anything priortized wrong?
17:39:32 <timsim> Pools-> DB :(
17:39:39 <Kiall> Yea :( I know :(
17:39:53 <Kiall> https://review.hpcloud.net/#/c/84650/
17:39:55 <Kiall> eh
17:39:56 <Kiall> wrong link
17:40:05 <federico3> shall we assign the critical triaged bugs?
17:40:25 <Kiall> https://review.openstack.org/#/c/213728/ - is +A'd, which is the last open BP on the page there
17:41:24 <Kiall> federico3: Possibly, but I suspect it's best to get everyone to just people to grab an open one they think they can sort!
17:41:34 <federico3> ok!
17:42:14 <Kiall> So - Nothing missing? To be removed? The list is still list? (bar BP's - but it's just too late to land code that doesn't exist yet)
17:42:39 <mugsie> i think we should aim to get them in
17:42:58 <Kiall> Yea - So nothing to remove is your answer then ;)
17:43:10 <mugsie> basicallyt
17:43:32 <Kiall> Okay, I'll just leave this section with a call - nay - pleed - to have everyone dig into these over the next few days ;)
17:43:53 <Kiall> Moving on :)
17:43:55 <Kiall> #topic Open Discussion
17:44:07 <Kiall> Anything else from anyone else? :)
17:44:24 <elarson> https://bugs.launchpad.net/designate/+bug/1491981
17:44:25 <openstack> Launchpad bug 1491981 in Designate "Using workers > 1 in mdns and the agent breaks the service " [Critical,Triaged]
17:44:49 <elarson> looks like using evenlet.listen isn't going to work. I'm going to look into a better solution for reusing the socket
17:45:11 <mugsie> :/
17:45:14 <Kiall> elarson: cool - sounds like a PITA to debug
17:45:43 <Kiall> Failing a fix, thoughts on leaving it be or choosing to disable workers in K?
17:45:44 <elarson> not *too* bad :)
17:45:46 <Kiall> ehh
17:45:47 <Kiall> in L
17:46:07 <elarson> I'd disable workers for the time being since it really doens't work
17:46:09 <mugsie> if it is that broken
17:46:13 <mugsie> disable
17:46:26 <elarson> others might want to verify
17:46:28 <mugsie> or atleast log a big *****DANGER*****
17:46:58 <Kiall> mugsie: Yea, ^ makes sense.
17:46:59 <elarson> just bump workers > 1 in the agent or mdns and you'll start seeing stalls
17:47:07 <timsim> It was the same type of behavior in mdns right elarson? Not through the proxy?
17:47:37 <Kiall> Well workers >1 works - at least the last time I tried it! But I never checked for leftover connections in netstat ;)
17:47:47 <elarson> timsim: yeah
17:47:51 <timsim> Yeah I thought it worked ok in mdns
17:48:10 <timsim> Maybe not
17:48:13 <elarson> timsim: it was doing the same thing at the agent in our staging env
17:48:31 <james_li> but glance binds to a single port 9292 right?
17:48:35 <james_li> glance-api
17:48:49 <james_li> it seems to be reusing that port well
17:48:50 <elarson> james_li: yes, but they aren't using the SO_REUSEPORT
17:49:09 <elarson> I suspect it reuses the fd
17:49:15 <james_li> elarson: what they are doing for reuse port?
17:49:16 <elarson> which is what I'd consider changing to
17:49:38 <elarson> it isn't as good of load balancing (based on cursory tests) but it still is better than nothign
17:50:03 <Kiall> Well, if dropping the SO_REUSEPORT option and opening the socket before we fork the workers solves the issue.. yea, that seems like a reasonable fix.
17:50:18 <james_li> I agree
17:50:35 <elarson> I'll update that ticket though with any findings. haven't had as much time to mess with it as I've been working on an ALIAS impl
17:50:40 <Kiall> SO_REUSEPORT isn't great at balancing either - it actually tends to skew heavily towards 1 under load anyway!
17:50:59 <elarson> Kiall: yeah I wouldn't expect it to be *that* much better
17:52:00 <Kiall> Yea,.. Okay - a few mins left.. Anything else before we call it a day?
17:52:21 <mugsie> Well, as Kiall said before - I am plannign to run for PTL next cycle
17:52:22 <james_li> Kiall: do we freeze merging on designateclient?
17:52:33 <james_li> for this cycle
17:52:59 <mugsie> but - if you are interested in runing please do :)
17:53:14 <Kiall> james_li: the clients tend to be a bit more open than the "server" components for late merges... But we shouldn't land massive changes ;)
17:53:15 <mugsie> we don;t freeze clients on the same scheduale - or do we now
17:53:17 <Kiall> mugsie: ++
17:53:20 * elarson hopes mugsie made some "Vote for Mugsie" bumper stickers
17:53:26 <mugsie> didnt that change again?
17:53:28 <Kiall> hah
17:53:38 * mugsie goes to sticker mule
17:53:57 <Kiall> So - Anyone else considering running
17:54:04 <Kiall> Is anyone*
17:54:16 <james_li> Kiall: ok makes sense, and usually how often do we publish client code to pypi?
17:54:45 <timsim> I don't think anyone else is considering running :)
17:54:52 <Kiall> james_li: Historically, whenever we've had enough / interesting changes to warrant it
17:55:05 <Kiall> We're def due one with the L release though
17:55:28 <james_li> got it thx!
17:56:00 <Kiall> Okay - Any final takers on off-agenda topics before we call it a day? ;)
17:56:20 <Kiall> According to the time in my IRC client we have 2 mins ;)
17:56:56 * elarson thinks pglass should run, declare martial law and make mugsie Project Dictator
17:57:14 <mugsie> :)
17:57:14 <Kiall> HAH
17:57:15 <Kiall> ++
17:57:17 <federico3> :D
17:57:32 <timsim> ++pglass for PTL
17:57:33 <elarson> #moredramainopenstack
17:57:57 * elarson is done now
17:58:02 <timsim> pglbuttstack
17:58:20 <Kiall> I'm guessing this never ends ;)
17:58:26 <Kiall> I know how to end it!
17:58:26 <timsim> Pretty much.
17:58:29 <elarson> https://s.yimg.com/cd/diminuendo/1.0/original/63e702122d9810bf2c82b9b54098235ec2809b52.gif
17:58:32 <Kiall> #endmeeting