17:03:11 <timsim> #startmeeting designate
17:03:11 <openstack> Meeting started Wed Jul  8 17:03:11 2015 UTC and is due to finish in 60 minutes.  The chair is timsim. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:15 <openstack> The meeting name has been set to 'designate'
17:03:27 <timsim> #topic Action Items from last week
17:03:54 <timsim> kiall Really do the DB rework write up..
17:04:13 <Kiall> Ehh - I've not yet :(
17:04:16 <timsim> Oh yeah. Who's here?
17:04:23 <ducttape_> o/
17:04:31 <timsim> alright...
17:04:37 <johnbelamaric> o/ - sorry i have been AWOL for a few weeks
17:04:40 <Kiall> mugsie / federico3 / ekarlso about?
17:04:55 <ekarlso> yello
17:04:55 <mugsie> o/
17:05:00 <timsim> vinod1 pglass elarson jmcbride
17:05:09 <federico3> o/
17:05:10 <pglass> o/
17:05:19 <Kiall> and - there's my doorbell - plumber. be back as soon as I can.
17:05:20 <vinod1> o/
17:05:26 <timsim> alright...
17:05:26 <timsim> #action kiall Really do the DB rework write up..
17:05:32 <Kiall> wow - full house...
17:05:46 <timsim> put mid-cycle on next week agenda...
17:05:58 <timsim> mugsie did that.
17:06:22 <mugsie> i didnt - but someone put my name on it ;)
17:06:26 <timsim> lol.
17:06:36 <timsim> #topic Bug Triage
17:06:38 * ekarlso turns on the fullhouse party music
17:06:54 * mugsie is listening to The Chainsmokers - #SELFIE
17:07:24 * timsim is listening to Barbie Girl - Aqua
17:07:30 <timsim> #link https://bugs.launchpad.net/designate/+bug/1471161
17:07:30 <openstack> timsim: Error: malone bug 1471161 not found
17:07:48 <mugsie> timsim: that is a private securty bug
17:08:16 <timsim> Ah yeah, I suppose not everyone can see that...
17:08:38 <mugsie> there is potential for a serious DOS with it
17:08:55 <timsim> High L2?
17:09:19 <mugsie> yeah
17:09:42 <timsim> #link https://bugs.launchpad.net/designate/+bug/1471915
17:09:42 <openstack> Launchpad bug 1471915 in Designate "record create / update buttons are not friendly" [Undecided,New] - Assigned to Eric Peterson (ericpeterson-l)
17:10:15 <mugsie> low, l2
17:10:18 <timsim> agreed
17:10:21 <Kiall> Should be closed - https://github.com/openstack/designate-dashboard/commit/71465fd3d85fec4afceef5f487e07d41ee335e77
17:10:27 <Kiall> Fix Comitted i mean
17:10:32 <ducttape_> yep
17:10:50 <Kiall> (back BTW - until I'm called away again)
17:10:56 <timsim> Alright, cool.
17:10:59 <timsim> #link https://bugs.launchpad.net/designate/+bug/1472065
17:10:59 <openstack> Launchpad bug 1472065 in Designate "Outdated doc for Kilo about configuring powerdns backend" [Undecided,New]
17:11:36 <mugsie> med, l2
17:11:50 <mugsie> and on the kilo branch
17:12:55 <timsim> Is there a way to target the kilo branch?
17:13:20 <Kiall> Yep - "Target to series"
17:13:53 <timsim> cool.
17:14:13 <timsim> #link https://bugs.launchpad.net/python-designateclient/+bug/1469992
17:14:13 <openstack> Launchpad bug 1469992 in python-designateclient "--os-endpoint is not working in python designate client" [Undecided,New] - Assigned to Pradeep Kumar Singh (pradeep-singh-u)
17:14:31 <Kiall> Ah - don't target to current release BTW ;) Theirry's release tools break (or don't deal with it? or something)
17:15:35 <Kiall> Med, since it's come up a few times - pksingh is pretty good about providing fixes quickly
17:15:41 <mugsie> ++
17:15:55 <timsim> Alright. That's it.
17:15:59 <timsim> #topic Stable Backport Triage
17:15:59 <timsim> Kiall - over to you
17:16:30 <Kiall> Going to do the last 7 days - of changes, since otherwise it's too long a list to review quickly. http://paste.openstack.org/show/355798/
17:17:05 <Kiall> Can we quickly review them, anything that looks backport worthy, pick someone to make it happen
17:17:29 <mugsie> top 2 are backport worthy
17:18:02 <Kiall> abb30cf Error message for database config
17:18:02 <Kiall> 703a3f4 Correct 'DESIGNATE_SQL_DEBUG' export behaviour
17:18:02 <Kiall> 69c822d Ensure validations account for trailing newlines (backport in progress)
17:18:09 <Kiall> ^ includes mugsie's "top two"
17:18:17 <mugsie> i can do the first 2
17:18:21 <Kiall> The last one is another sec issue report by RedHat
17:18:46 <timsim> Agreed on those.
17:18:55 <Kiall> Thanks mugsie
17:19:01 <Kiall> Any others? Most are py3 changes
17:19:21 <timsim> Doesn't look like it to me.
17:19:49 <mugsie> nope - thats it
17:19:55 <timsim> Alright, moving on...
17:19:56 <Kiall> Okay, simples! Keep an eye out for the reviews, they don't ping the IRC channel, or show on the dashboard mugsie created
17:20:12 <timsim> #topic OpenStack Summit - Tokyo Talks (timsim)
17:20:18 <mugsie> haha
17:20:20 <mugsie> we have 2 days
17:20:29 <timsim> i think it's next Wenesday
17:20:44 <timsim> "CURRENTLY ACCEPTING PRESENTATION SUBMISSIONS UNTIL JULY 15th, 2015, 11:59 PM PDT"
17:20:48 <mlavalle> mugsie: yeah, deadline is 15th
17:20:51 <Kiall> FYI - myself, carl_baldwin and mlavalle have a Designate+Neutron talk proposed ..
17:21:13 <mlavalle> Kiall: + Nova
17:21:20 <timsim> Nice!
17:21:22 <Kiall> :)
17:21:44 <timsim> So we should do a hangout/separate meeting to talk about what we'd like to propose sometime this week, and write up some abstracts to be submitted right after next weeks meet or something like that.
17:21:46 <Kiall> Anyone else planning to submit?
17:21:46 <carl_baldwin> Kiall: I need to get that proposed today.  Thanks for the reminder.  I did get HP approval to submit it yesterday.
17:22:00 <mugsie> timsim: ++
17:22:01 <Kiall> carl_baldwin: awesome :) I always skipped that step ;)
17:22:02 <mlavalle> carl_baldwin: +1
17:22:18 <carl_baldwin> Kiall: Kind of an important step.  ;)
17:22:26 <mugsie> who is reasonably certain they can get to tokyo?
17:22:35 <Kiall> o/
17:22:52 <timsim> o~ probably :P
17:22:53 <mugsie> o/
17:23:03 <federico3> o_
17:23:22 <johnbelamaric> maybe...
17:23:50 <mugsie> right - anyone who is interested in discussing talks this week send me an email to graham.hayes@hp.com
17:24:11 <mugsie> I will set up a hangout for tomrrow  / friday?
17:24:25 <mugsie> that suit? - gives time for stuff to be wrtten over the weekend
17:24:26 <timsim> Sounds good, anytime works for me.
17:24:39 <mugsie> so 9:00 UTC tomrrow ? :p
17:24:54 * mugsie doubts I could even make that
17:25:00 <timsim> :P smartass
17:25:08 <timsim> I'd get up just for you
17:25:46 <timsim> #action everyone send mugsie an email if you want to be in the talk planning session
17:26:00 <mugsie> I think a new workshop where me and timsim give out about Kiall's keyboard is a good one
17:26:05 <timsim> Definitely
17:26:23 <Kiall> You already did that last time!
17:26:29 <timsim> And then another one where Kiall has to use my Macbook
17:26:29 <mugsie> and it went well
17:26:47 <mugsie> if we had used a quality piece of HP hardware there would have been no issue ;P
17:26:47 <Kiall> Moving on!
17:26:51 <timsim> #topic Liberty Mid-Cycle (mugsie)
17:27:05 <Kiall> brb - plumber again.
17:27:21 <mugsie> well, kinda back to you timsim / joe
17:27:24 <timsim> I wish jmcbride was here...I don't have any update from him on this.
17:27:29 <mugsie> :)
17:27:36 <timsim> No clue why you're on there lol
17:27:43 <mugsie> yeah :)
17:27:49 <timsim> #action timsim to find out what's up with midcycle from jmcbride before next week
17:28:00 <timsim> #topic Open Discussion
17:28:15 <mugsie> yeah - we have a kind of long lead time for booking transatlantic travel
17:28:34 <timsim> I'll definitely get something for you next week
17:28:56 <timsim> We can just do it at my apartment ;)
17:29:40 <mugsie> oh - :)
17:29:44 <mlavalle> timsim: I wanted to update the team on the Neutron integration front
17:29:50 <timsim> mlavalle: please do!
17:30:11 <mlavalle> timsim: I got this spec approved yesterday https://review.openstack.org/#/c/88624/
17:30:50 <mugsie> sweet
17:30:50 <timsim> Awesome
17:31:01 <mlavalle> on the internal dns integration with nova, I am coding the neutron server side with excellent progress
17:31:17 <vinod1> I'll be resigning from my core position as I am moving out of Rackspace/Designate Team
17:31:33 <mlavalle> I should be done today with the neutron server piece and tomorrow I will finish the du=hcp agent side
17:31:47 <mugsie> mlavalle: that sounds like good progress
17:32:00 <timsim> good stuff mlavalle
17:32:12 <mugsie> vinod1: that sad to hear - it was good working with you
17:32:14 <mlavalle> and friday i'll start coding for the spec mentioned above
17:32:14 <timsim> vinod1: :'(
17:32:25 <mlavalle> that's all i have
17:32:34 <mugsie> mlavalle: cool. you know where we are if you need anything
17:32:51 <mlavalle> yeap, I connect to that room automatically
17:32:56 <mugsie> vinod1: when are you off?
17:33:10 <vinod1> This Friday
17:33:41 <mlavalle> vinod1: on the bright side, welcome new Racker!
17:34:28 <timsim> He's leaving Rackspace ;) booo former racker
17:34:43 <mlavalle> ohhh I misunderstood
17:34:47 <mlavalle> :-(
17:35:17 <timsim> Does anyone have anything else they'd like to talk about? I suppose we should give Kiall a minute
17:35:23 <mugsie> I have one thing up for review - https://review.openstack.org/190200
17:35:38 <mugsie> makes pep8 / flask8 results much easier to read
17:35:45 <mugsie> flake8 *
17:35:58 <timsim> Nice, will check it out.
17:36:06 <mugsie> it also puts out some html, but that is not being backed up yet
17:36:20 <timsim> I've got a couple that seem to have been buried. https://review.openstack.org/#/c/170612/
17:36:24 <timsim> https://review.openstack.org/#/c/188189/
17:37:01 <mugsie> yup
17:37:27 <timsim> If anyone wants to look at those, it'd be swell.
17:37:37 * mugsie adds them to the todo list
17:38:11 <timsim> Alright. Anyone else have anything?
17:38:43 <timsim> Going once....
17:38:56 <timsim> twice...
17:39:34 <timsim> Thanks vinod1 for all of your contributions :)
17:39:39 <mugsie> 100%
17:39:46 <timsim> I expect 30 more reviews by friday ;)
17:39:51 <mugsie> :)
17:39:59 <mugsie> get the use out that -2 :D
17:40:14 <timsim> Probably on all my changes :P
17:40:22 <timsim> #endmeeting