17:00:06 <Kiall> #startmeeting Designate
17:00:13 <openstack> Meeting started Wed Jun 24 17:00:06 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:18 <openstack> The meeting name has been set to 'designate'
17:00:22 <Kiall> Hey folks - Who's about today?
17:00:24 <elarson> o/
17:00:28 <federico3> o/
17:00:30 <Kiall> #link Agenda https://wiki.openstack.org/wiki/Meetings/Designate
17:00:48 <Kiall> mugsie / timsim / vinod1 - about?
17:00:53 <timsim> o/
17:01:09 * elarson gueses vinod is sleeping
17:01:09 <mugsie> o/
17:01:12 <Kiall> mlavalle is at the neutron mid-cycle, so won't be around
17:01:22 <ducttape_> o/
17:01:46 <Kiall> Okay.. A few short.. No worries :)
17:02:12 <ducttape_> how many are in the neutron mid-cycle?
17:02:15 <Kiall> #topic Action Items from last week
17:02:15 <Kiall> Uhm, 1 item, carried over twice, on me.. Document datbase rework goals.
17:02:47 <Kiall> I've still not managed time to get knock that out yet :( It *will* happen before the next meet
17:02:59 <Kiall> #action kiall Really do the DB rework write up..
17:03:15 <Kiall> #topic Bug triage (timsim - recurring)
17:03:31 <timsim> https://bugs.launchpad.net/designate/+bug/1463988
17:03:32 <openstack> Launchpad bug 1463988 in keystonemiddleware "oslo.config version error in kilo" [Undecided,New]
17:03:41 <Kiall> ducttape_: about 15 from the looks of the Neutron etherpad
17:04:21 <timsim> I think this is confirmed?
17:04:41 <Kiall> timsim: that's open against KS middleware, but it seems there's some argument that we're doing it wrong! Unsure right now
17:05:01 <timsim> Yeah. lifeless was the one who pointed that out
17:05:34 <mugsie> yeah. i think confirmed for us is ok
17:05:36 <Kiall> Yea, while he may be right.. I think there's still an issue that the KS middleware package's kilo branch isn't capping it's requirements to kilo versions
17:05:37 <timsim> I'll move to confirmed in the Designate bits
17:05:44 <timsim> Agreed
17:05:54 <timsim> https://bugs.launchpad.net/designate/+bug/1466265
17:05:55 <openstack> Launchpad bug 1466265 in Designate "designate python client is not showing proper help message when authentication environment variable are missing" [Undecided,New] - Assigned to pradeep kumar singh (pradeep-singh-u)
17:06:00 <timsim> I think this is a dupe of....
17:06:11 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1268310
17:06:12 <openstack> Launchpad bug 1268310 in python-designateclient "Cryptic message if keystone is missing an endpoint for designate" [High,Triaged] - Assigned to Kiall Mac Innes (kiall)
17:06:28 <mugsie> high, triaged
17:06:30 <timsim> Well not quite...
17:06:32 <Kiall> I think there different, one is where designate is missing from the catalog
17:06:40 <mugsie> its related, but separate
17:06:41 <Kiall> vs not supplying creds to access the catalog
17:06:53 <timsim> I'll move it to the client, high, triaged?
17:06:58 <mugsie> ++
17:07:34 <timsim> https://bugs.launchpad.net/designate/+bug/1466300
17:07:35 <openstack> timsim: Error: malone bug 1466300 not found
17:08:13 <Kiall> timsim: private security issue, move to public + High
17:08:19 <timsim> ok
17:08:30 <timsim> https://bugs.launchpad.net/designate/+bug/1466545
17:08:32 <openstack> Launchpad bug 1466545 in Designate "Zone filtering by TTL, Description & Status" [Undecided,New] - Assigned to Mimi Lee (mimi-lee)
17:08:38 <Kiall> It's not something exploitable, just  that a security feature is too secure (and lets nobody in ;))
17:09:09 <mugsie> low, l-1, triaged
17:09:13 <mugsie> l-2*
17:09:21 <mugsie> seen as l-1 just got released
17:09:22 <Kiall> l-1? lol that was released earlier today.
17:09:52 <timsim> It's pretty important, we could backport ;)
17:10:01 <timsim> https://bugs.launchpad.net/designate/+bug/1466649
17:10:02 <openstack> Launchpad bug 1466649 in Designate "Cannot filter on blacklists, records, & tlds" [Undecided,New]
17:10:43 <Kiall> Same again I think
17:10:46 <mugsie> I think we need to start returning 400 bad request when we are asked to filter by stuiff that is not supported
17:10:53 <Kiall> mugsie: ++
17:10:57 <timsim> agreed mugsie
17:11:00 <mugsie> instead of just ignoring it
17:11:10 <Kiall> right now, we discard the extra filters and process as if they didn't get supplied.
17:11:16 <timsim> Would you do the honors of filing that mugsie?
17:11:17 <Kiall> Which just isn't right :)
17:11:33 <timsim> That's all the bugs :)
17:11:39 <mugsie> timsim: sure
17:12:58 <Kiall> Okay, while we're on "bugs" - I've tagged a bunch low-hanging-fruit, people probably saw my mail spam, we should start keeping that up to date too :)
17:13:23 <Kiall> I think most of jmcbride's ended up with that tag ;)
17:13:36 <timsim> Yeah that's a good thing to have
17:13:55 <Kiall> Okay - Moving on to a new recurring section :) Intro this week, rather than starting it this week
17:13:59 <Kiall> #topic Stable Backport triage (kiall - recurring)
17:14:40 <Kiall> I'd like to see us actually start maintaining the stable branches! Better for everyone if known bugs are fixed in the stable release, distros will love us, production clouds will too ;)
17:15:30 <Kiall> So - I'd like to suggest that, each week, we take 5 mins to review the changes landed the previous week and nominate changes for backport. I'll produce a list of these each week, starting from today for next weeks meeting - to keep it short.
17:15:34 <Kiall> Thoughts?
17:15:54 <elarson> +1
17:15:55 <mugsie> sound sane
17:16:03 <mimi> +1
17:16:21 <timsim> Good idea
17:16:42 <Kiall> http://paste.ubuntu.com/11768802/ <-- Current diff from kilo -> master
17:17:15 <federico3> +1 I'd suggest to advertise that stable releases are maintained and for how long
17:17:27 <Kiall> Too many to go through in the meeting today, but if we can review offline and propose backports for  stuff before today
17:17:54 <mugsie> federico3: we maintain stable branches for 1 year by default in OpenStack
17:18:04 <Kiall> federico3: there's a doc on that, somewhere I cant remember right now
17:18:13 <mugsie> but juno will be supported for a bit longer (in debian at least)
17:18:18 <Kiall> Phase I (first 6 months): All bugfixes which are appropriate
17:18:18 <Kiall> Phase II (6-12 months): Only critical bugfixes and security patches are acceptable
17:18:18 <Kiall> Phase III (more than 12 months): Only security patches are acceptable
17:18:24 <Kiall> from https://wiki.openstack.org/wiki/StableBranch
17:18:39 <ekarlso> o/ btw
17:18:44 <Kiall> Hey ekarlso :)
17:19:52 <Kiall> Okay, so, expect to find a etherpad link in the Agenda before next weeks meeting, it will have the the commits in it.. We can tear through them, not 1 by 1, but individually, and then come back and nominate + assign
17:19:55 <Kiall> Okay - Moving on :)
17:20:12 <Kiall> #topic Ceilometer / Zone Exists Spec (kiall)
17:20:14 <Kiall> #link https://review.openstack.org/#/c/188018/
17:20:33 <Kiall> and the first piece of this
17:20:35 <Kiall> #link https://review.openstack.org/#/c/193909
17:20:57 <Kiall> I'd like to make sure everyone is happy with the spec, and that it's merged before we start merging code ;)
17:21:51 <Kiall> ekarlso's been working on these for the last few days, I hope to see it all done + merged before we meet again :)
17:22:17 <Kiall> So - Can people go review that spec ;) Not necessarily right now, but soon pls!
17:22:36 <timsim> I looked at that spec once, but I'd like to do so again, will put it on my list for this afternoon
17:22:46 <mugsie> yeah, me too
17:23:04 <mugsie> have time this evening / tonight, so will do a spree of reviews
17:23:12 <Kiall> thanks - also  timsim - vinod is great at finding issues, if he's in the office ask him to aswell please :)
17:24:28 <Kiall> Also - It's totally failing test right now - but stuff like https://review.openstack.org/#/c/194705/ has become 100x easier once Tooz is in :)
17:24:46 <Kiall> Okay, moving on from my plee for reviews :P
17:24:48 <Kiall> #topic Open Discussion
17:24:57 <timsim> Will do, I think he's travelling from india. Will get him a message
17:25:15 <Kiall> timsim: he better delay his flight to get it done! ;)
17:25:20 <Kiall> kidding.. Leave him be!
17:25:31 <Kiall> Okay Any other off agenda topics from others?
17:25:50 <Kiall> I have one - welcome federico3 :) He's joined HP this week on the DNS team..
17:26:11 <Kiall> federico3, I'm gonna put you  on the spot and ask you to introduce yourself  ;)
17:26:16 * federico3 bows deeply
17:26:24 <timsim> o/ federico3
17:27:02 <federico3> hello everybody :D
17:27:49 <Kiall> ducttape_: still about? re https://review.openstack.org/#/c/193800/ -  new Horizon repo testing.. How familar with Django testing etc are you guys? Because I know nothing ;) I'm hoping we can try and clean up + extend the tests once that lands.
17:28:15 <ducttape_> I am familiar, I have the scars to show
17:28:24 <ducttape_> ;)
17:29:08 <ducttape_> running django tests are weird, at least for most of the horizon stuff.   I'm 100% of favor in updating tests, I have not so far, b/c I didn't have the threat of verification jobs
17:29:16 <Kiall> ducttape_: lol, that's how I feel looking at the current limited tests :) I'm hoping someone who knows how it *should* look can help us out to rework it, then we can actually just follow the right patterns for new stuff.. Know anyone who might be able to help? ;)
17:29:44 <ducttape_> yeah I can do that.  I didn't download that patch and work on it just yet
17:30:02 <ducttape_> it's similar (from what I saw) to what monasca is also doing
17:30:17 <ducttape_> I work with both of those things, can try to get something working
17:30:23 <Kiall> I think that one should land as is - then enable the gates - and start any cleanup/rework/new tests.. Everything passes with that change, so it's a good point to turn the voting gate jobs on at
17:30:38 <ducttape_> +1
17:30:59 <ducttape_> from there we can just worry about increasing coverage
17:31:35 <Kiall> Okay - thanks ducttape_ :) much appreciated
17:31:45 <Kiall> Okay - Any other off agenda items? I'm out
17:31:52 <elarson> Kiall: https://review.openstack.org/#/c/192267/
17:31:53 <Kiall> (out of off agenda stuff)
17:32:01 <ducttape_> I would say thank you, but it means I will have to really worry about tests :p
17:32:15 <mugsie> mid-cycle - if we are having one we need to start planning
17:32:36 <mugsie> give people time to badger management / book stuff
17:32:42 <Kiall> elarson: Ah, I thought I replied to you on that one and voted +2.. I must have forgot the last bit
17:33:09 <elarson> Kiall: ah ok.
17:33:10 <Kiall> Once you explained, it made perfect sense. It's the edge case for during initilization rather than the norm :)
17:33:20 <elarson> right.
17:33:22 * Kiall quickly adds his +2
17:33:46 <elarson> I do think a pre-logging loaded bit could generally be helpful, but I can submit that to oslo_log
17:34:13 <elarson> Kiall: thanks!
17:34:14 <Kiall> elarson: yea, that works :)
17:34:23 <Kiall> mugsie: yep, mid-cycle.. Anyone have thougts on that one?
17:34:23 <Kiall> #link https://wiki.openstack.org/wiki/Sprints
17:35:20 <Kiall> I'm guessing nodoby can commit to anything right here today, but, anyone interested in doing one, let's get that conversation going with your managers ;)
17:35:59 <Kiall> Anyone able to say "Yep, I'm interested" yet?
17:36:41 * elarson is interested
17:36:44 <Kiall> That's a no then... Okay, will circle back to this next week.. Think about it so :)
17:37:03 <Kiall> #action put mid-cycle on next week agena
17:37:23 <Kiall> Anything else before we call it a day?
17:38:02 <Kiall> Okay, thanks all.. See you in #openstack-dns :)
17:38:10 <Kiall> #endmeeting