17:01:00 <Kiall> #startmeeting Designate
17:01:00 <openstack> Meeting started Wed Apr 15 17:01:00 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:05 <openstack> The meeting name has been set to 'designate'
17:01:11 <Kiall> Hey folks - Who's about?
17:01:15 <elarson> o/
17:01:16 <vinod1> o/
17:01:26 <mugsie> o/
17:01:31 <rjrjr> o/
17:01:32 <paul_glass> o/
17:01:35 <bharath_> o/
17:01:37 <timsim> o?
17:01:49 <Kiall> Okay - Let's get started :)
17:01:51 <Kiall> #topic Kilo Release Status (kiall - recurring)
17:01:56 <Kiall> Woo - RC1 is out (finally!)
17:02:05 <Kiall> ttx cut rc1 for us last night :)
17:02:20 <rjrjr> congratulations!
17:02:33 <Kiall> Thanks everyone for the hard work - it's beena  busy 6 months for everyone :)
17:03:10 <bharath_> congrats guys !!!
17:03:17 <Kiall> This also marks the moment of APIv2 == STABLE, v1 == DEPRECIATED :)
17:03:40 <mugsie> \o/
17:03:45 <timsim> Woo!
17:03:46 <elarson> woohoo
17:03:47 <mugsie> so happy :)
17:03:55 * mugsie hates the v1 api
17:04:00 <Kiall> Okay .. So, https://bugs.launchpad.net/designate/+bugs?field.tag=kilo-rc-potential - We've still got a few issues, some not so important, some important enough to warrant an rc2 :)
17:04:07 <rjrjr> mugsie: agreed!
17:04:17 <mugsie> one more year, and we can kill it fully
17:04:18 <Kiall> Bugs which you believe should be considered for kilo final should be tagged "kilo-rc-potential"
17:04:33 <Kiall> (standard for all the projects etc etc)
17:05:05 <Kiall> myself, mugsie and ekarlso have been in a conf room all week standing up a production style deploy, and testing testing testing
17:05:17 <Kiall> We've found a few issues today tho.. bug 1444384 being the only one filed so far
17:05:18 <openstack> bug 1444384 in Designate "mDNS workers - TCP/UDP sockets missing flags" [Critical,In progress] https://launchpad.net/bugs/1444384 - Assigned to Kiall Mac Innes (kiall)
17:05:58 <Kiall> Ideally, even though we're open for Liberty changes, we can get everyone testing and finding+fixing bugs, rather than powering onto L ;)
17:06:18 <Kiall> Any changes needed for K must be pushed to the master branch first, then the proposed/kilo branch.
17:06:24 <Kiall> Any questions on process?
17:07:07 <vinod1> is there a document that lists the way to backport changes from one branch to another?
17:07:11 <rjrjr> i know we are concentrating on bugs, when will the Liberty work be decided/scoped?
17:07:15 <Kiall> Mmm.. Probably!
17:07:47 <mugsie> vinod1: in general it is just cherrypicking commits from master to the proposed/kilo branch
17:07:47 <Kiall> vinod1: https://wiki.openstack.org/wiki/Branch_Model is the one I'm thinking of
17:08:01 <Kiall> But, it's not a "How To" style
17:08:08 <mugsie> rjrjr: scoped in vancouver / planned from now
17:08:11 <mugsie> i think
17:08:20 <mugsie> but we can start scoping things before
17:08:28 <Kiall> rjrjr: I'm thinking we kickoff L talk for half of next week's meet..
17:08:28 <rjrjr> great!
17:09:17 <Kiall> vinod1: https://wiki.openstack.org/wiki/StableBranch found the other page I'm thinking of
17:09:35 <vinod1> Thanks Kiall
17:09:36 <Kiall> proposed/kilo looks very like stable/foo - identical I think from a process POV
17:10:38 <Kiall> Okay, so.. With K-RC1 out, and L stuff not happening till next week's meet at earliest, then, we don't have a huge amount to discuss today :) So.. I'll move to Open Discussion.. and mention a few of the bugs we found today (but haven't filed yet)
17:10:47 <Kiall> #topic Open Discussion
17:10:57 <Kiall> before I do tho, any other topics from other people?
17:11:30 <rjrjr> is there a list started for the Liberty work being proposed?  we have stuff we'd like to add to it.
17:11:42 <mugsie> just the specs
17:11:57 * elarson was curious as well
17:12:01 <rjrjr> so, get some preliminary specs in?
17:12:02 <elarson> mugsie: thanks for confirming
17:12:08 <mugsie> so, specs in gerrit, and blueprints on launchpad
17:12:14 <Kiall> and launchapd :) http://launchpad.net/designate/+milestone/liberty-1  I think.. LP won't load right now
17:12:34 <Kiall> Wow - hotel wifi sucks. 4seconds lag -_-
17:12:36 <mugsie> rjrjr: fire away
17:12:54 <bharath_> good to know where to propose stuff that we'd like to add
17:13:22 <mugsie> i will merge the Open Liberty Specs after this
17:14:01 <mugsie> so the basic process is to file a blueprint on launchpad, and the wite a spec, that references the bp, in openstack/designste-specs
17:14:13 <mugsie> same review process etc will apply
17:14:34 <rjrjr> mugsie: i'll show bharath what i have done in the past for this.
17:14:41 <mugsie> rjrjr: cool :)
17:14:55 <elarson> mugsie: btw, I submitted a patch to add liberty specs
17:15:07 <elarson> b/c I have the hook api spec as well
17:15:15 <mugsie> elarson: yea, I saw it. think it is failing gate atm though...
17:15:22 <elarson> dog gone it
17:15:27 <Kiall> Okay, so.. Bugs myself / ekarlso / mugsie found today...
17:15:27 <Kiall> 1) bug 1444384 - More than 1 worker with mDNS was exploding, hampering performance and limiting you to a single CPU. Hopefully have a patch up.
17:15:28 <Kiall> 2) No #  - Under high load, we're seeing the DB Connection Pool get exhausted.. This *could* be a a config / pool size issue.. or it could be highlighting an issue somewhere
17:15:28 <Kiall> 3) No # - Pool Manager with workers, every worker runs the periodic tasks
17:15:28 <openstack> bug 1444384 in Designate "mDNS workers - TCP/UDP sockets missing flags" [Critical,In progress] https://launchpad.net/bugs/1444384 - Assigned to Kiall Mac Innes (kiall)
17:15:29 <mugsie> will look at it in a bit :)
17:15:42 <Kiall> 4) No # - Multiple Pool Manager - every PM is running periodic sync
17:16:58 <mugsie> elarson: ah, you combined them :)
17:17:01 <Kiall> and - I think, but haven't verified, 6) every pool manager's sync's are syncing zones for every pool..
17:17:24 <Kiall> 5*
17:17:30 <timsim> Those make sense.
17:17:30 <elarson> mugsie: yeah, I sort of had to b/c you can't add a directory in vcs
17:18:04 <rjrjr> i wouldn't mind tackling 3,4,6
17:18:11 <rjrjr> :)
17:18:20 <elarson> of course that didn't stop me from being confused as to why I couldn't rebase my hook api spec on top of the libery branch ;)
17:18:41 <Kiall> I was going to tackle 3 tomorrow, as it's not helping out testing :D
17:18:52 <rjrjr> k
17:18:53 <Kiall> But other than that, there all open.. I just need to file some bugs
17:20:06 <Kiall> So - Has anyone else managed to get testing Kilo properly now that we're - in theory - done?
17:20:11 <timsim> Do we want to do bug triage?
17:20:21 <Kiall> yea, mugsie mentioned I skipped it ;)
17:20:57 <Kiall> https://bugs.launchpad.net/designate/+bugs?field.tag=kilo-rc-potential <-- should also be triaged, rejecting bugs we don't think are worth another RC for.
17:21:09 <rjrjr> you are going to use Kilo for the workshop in Vancouver, correct?
17:21:19 <Kiall> Yep, we will :)
17:21:20 <mugsie> rjrjr: that would be the plan
17:21:45 <mugsie> or tip of liberty if it has some stuff we want to show off :)
17:21:58 <Kiall> Oh.. Also found bug 1444414 today... Bind AXFR's from the "first" master in it's list.. which leads to a very busy mdns-001 instance ;)
17:21:59 <openstack> bug 1444414 in Designate "Order of nameservers is not random" [Medium,Triaged] https://launchpad.net/bugs/1444414
17:22:40 <mugsie> so, bug triage?
17:22:44 <timsim> Alright, should we go through the bugs? We can do the kilo-rc-potential ones first?
17:22:50 <mugsie> rc first i think
17:22:51 <Kiall> timsim: sounds good :)
17:23:02 <timsim> https://bugs.launchpad.net/designate/+bug/1444384
17:23:03 <openstack> Launchpad bug 1444384 in Designate "mDNS workers - TCP/UDP sockets missing flags" [Critical,In progress] - Assigned to Kiall Mac Innes (kiall)
17:23:11 <mugsie> ++ for rc2
17:23:17 <rjrjr> +1
17:23:18 <timsim> Yep critical/high rc2 for me
17:23:19 <vinod1> +1
17:23:38 <mugsie> yeah, critical i think
17:23:48 <Kiall> Yea, we've known mDNS will be a bottleneck since day 1.. and this just makes it worse! We noticed a HUGE improvement going from 1 -> 2 workers.. More than 2x oddly enough.
17:24:03 <Kiall> We don't have a rc2 milestone.. I'll get one
17:24:15 <timsim> Alright, so we just add them to a list for now?
17:24:27 <mugsie> add an k-rc2 tag to them?
17:24:38 <Kiall> timsim: yea, #info bug 123 for rc2 will add them to the meeting logs
17:24:40 <openstack> bug 123 in Launchpad itself "There's no direct way to see the project info when translating it" [Medium,Fix released] https://launchpad.net/bugs/123
17:24:42 <Kiall> #action kiall to ask ttx to create a a rc2
17:24:47 <Kiall> milestone
17:24:53 <timsim> Alright.
17:25:10 <timsim> #info bug 1444384 to kilo-rc2
17:25:11 <openstack> bug 1444384 in Designate "mDNS workers - TCP/UDP sockets missing flags" [Critical,In progress] https://launchpad.net/bugs/1444384 - Assigned to Kiall Mac Innes (kiall)
17:25:18 <Kiall> That'll do it :)
17:25:25 <timsim> https://bugs.launchpad.net/designate/+bug/1437699
17:25:27 <openstack> Launchpad bug 1437699 in Designate "mDNS should Handle Bad File Descriptor" [Medium,New] - Assigned to Ron Rickard (rjrjr)
17:26:04 <Kiall> -1, in that, if it happens to get fixed, great.. But it only logs the exception in exceptional circumstances.. So I'm personally not too pushed
17:26:24 <rjrjr> seems like it can wait.
17:26:27 <Kiall> Not sure if others agreed, hence I added it
17:26:38 <mugsie> push to l
17:26:41 <rjrjr> reproducing it is going to be fun.
17:26:43 <vinod1> currently it is marked for liberty
17:26:54 <timsim> If it's an easy fix, it'd be good to add if someone has time, but if not, no big. Alright it'll stay liberty-1 then.
17:27:29 <timsim> https://bugs.launchpad.net/designate/+bug/1444414
17:27:30 <openstack> Launchpad bug 1444414 in Designate "Order of nameservers is not random" [Medium,Triaged]
17:27:39 <Kiall> timsim: yea, if it's easy.. and it might be! I just haven't looked.. then landing it is no issue IMO after we have at least one other RC2 patch landed
17:27:54 <Kiall> (e.g. when we already know an RC2 is 100% coming, vs that alone causing a RC2)
17:27:58 <rjrjr> i think 1444414 is high.
17:28:20 <mugsie> yeah
17:28:28 <mugsie> and RC2
17:28:29 <timsim> I think this one should be in rc2 fo sho
17:28:45 <Kiall> Yea, it's a small fix to balance out the load.
17:28:48 <rjrjr> +1
17:29:00 <vinod1> +1 for rc2
17:29:01 <timsim> #info bug 1444414 to rc2
17:29:02 <openstack> bug 1444414 in Designate "Order of nameservers is not random" [Medium,Triaged] https://launchpad.net/bugs/1444414
17:29:11 <timsim> https://bugs.launchpad.net/designate/+bug/1442141
17:29:13 <openstack> Launchpad bug 1442141 in Designate "designate-api Throws Error on stop()" [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:29:24 <mugsie> not rc2 imho
17:29:36 <Kiall> mugsie was looking into this.. I'd love to see it fixed, but it seems be a buried inside eventlet :(
17:29:48 <timsim> Yeah, probably not worth it then.
17:29:58 <rjrjr> what is the ramifications of the problem?
17:30:01 <Kiall> One of the glance folks made a change  to eventlet.wsgi for their use case, and it's caused this for us :(
17:30:31 <timsim> So liberty, medium?
17:30:37 <mugsie> ++
17:30:44 <Kiall> https://github.com/eventlet/eventlet/commit/1c30e9b39f4330babcb3665df4c1a3ba694bc6c1 <-- was the commit that caused it
17:30:52 <mugsie> rjrjr: not much, just the error message that shows on stop()
17:31:02 <rjrjr> okay.  in that case +1
17:31:09 <vinod1> is only designate-api affected and not the other services?
17:31:19 <Kiall> vinod1: yep, only affects the API
17:31:30 <Kiall> Well.. 1 other reason we might want to say rc2
17:31:34 * elarson tried to fix that the other day
17:31:44 <rjrjr> i've seen the "greenthreads will never terminate" in Juno.
17:31:50 <Kiall> not fixing it means restarting with break open connections rather than wait for them to complete, I believe.
17:31:51 <rjrjr> just not the stuff after that.
17:32:49 <vinod1> good to have for rc2 if it is an easy fix
17:32:54 <mugsie> i think l - due to the time and effort needed, and the limited impact
17:33:10 <mugsie> it is most likey not going to have an easy fix
17:33:14 <Kiall> vinod1: it doesn't look to be an easy fix.. mugsie spent a few hours at it last week and kept hitting more edge cases
17:33:18 <mugsie> but, need more time to dig into it
17:33:28 <vinod1> in that case - liberty
17:33:28 <rjrjr> liberty
17:33:36 <timsim> Seems like it's probably too much work/too small impact to get into kilo
17:33:54 <mugsie> ++
17:34:08 <timsim> We good to move on?
17:34:14 <Kiall> Yea, let's call it L and if we find a easy fix, great.. back into K if there's another RC
17:34:19 <timsim> Cool
17:34:20 <timsim> https://bugs.launchpad.net/designate/+bug/1442890
17:34:21 <openstack> Launchpad bug 1442890 in Designate "Remove support for sqlite" [Wishlist,New] - Assigned to Endre Karlson (endre-karlson)
17:34:21 <Kiall> IRC lag SUCKS -_-
17:34:45 <mugsie> move to L
17:34:53 <mugsie> 100% not a rc2 thing
17:34:57 <Kiall> That's more of a blueprint I reckon, but ++ 100
17:35:04 <Kiall> (and yea.. ++100 in L ;)
17:35:04 <timsim> Yeah we're done with the rc1 potential ones, FYI
17:35:10 <mugsie> ah
17:35:11 <mugsie> :)
17:35:29 <timsim> https://bugs.launchpad.net/designate/+bug/1442699
17:35:30 <openstack> Launchpad bug 1442699 in Designate "Add admin endpoint to the list of versions" [Undecided,In progress] - Assigned to Vinod Mangalpally (vinod-mang)
17:35:30 <mugsie> i would move to a medium,
17:36:27 <Kiall> Again, L.. Medium?
17:36:32 <vinod1> liberty
17:36:34 <rjrjr> low-medium liberty
17:36:43 <timsim> Alright, medium-liberty it is
17:36:56 <Kiall> (Side track I've asked theirry re a RC2 milestone, I suspect he's gone home for the day though)
17:37:04 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1443858
17:37:05 <openstack> Launchpad bug 1443858 in python-designateclient "Designateclient does not support to provide domain names instead of domain ids" [Undecided,In progress] - Assigned to Cedric Brandily (cbrandily)
17:37:41 <mugsie> we have tagged for kilo there, so high
17:37:47 <Kiall> So... here's one that's changed recently. clients now have stable branches, and work closer to the server projects than they used to. I'm not 100% familar with the process now.
17:37:52 <mugsie> (we dont have milestones in the client)
17:38:54 <timsim> So I guess we just slap importance->high on it?
17:39:00 <rjrjr> seems aggressive for kilo.
17:39:04 <Kiall> anyway, code is up for it (I haven't reviewed yet tho).. So let's say Medium+L?
17:39:14 <rjrjr> never mind then. :(
17:39:24 <rjrjr> didn't realize we already had the code for it.
17:39:43 <timsim> So should we be getting milestones for the client?
17:39:48 <rjrjr> so, no more IDs for domains in the client I'm all for.
17:39:53 <Kiall> Yea, and I have no clue what the new client release process is.. hasn't entirely settled in yet.. etc
17:40:06 <Kiall> I'll find out before next week's meet.
17:40:20 <timsim> Ok. I'll ust put medium on it.
17:40:26 <rjrjr> so, the client will support domain names or IDs, correct?
17:40:27 <Kiall> Humm .. actually.. I likely will have to miss next weeks meet.
17:40:27 <elarson> there is also the openstack-sdk to consider. not sure if that is still really far out though
17:40:38 <mugsie> is -sdk still a thing?
17:40:47 <mugsie> there is openstackclient
17:40:47 * elarson was under the impression it was
17:41:14 <mugsie> if it is -  great :)
17:41:20 * elarson does a good job bringing up things that can only be answered with more questions ;)
17:41:28 <Kiall> lol :)
17:41:33 <elarson> mugsie: I can send an email about it
17:41:41 <mugsie> but the new client should be based on openstack-client for the cli
17:41:42 <Kiall> Okay, was that the end of the list timsim?
17:41:48 <mugsie> elarson: cool, that would be good
17:41:50 <timsim> 2 more quick ones
17:41:50 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1443858
17:41:52 <openstack> Launchpad bug 1443858 in python-designateclient "Designateclient does not support to provide domain names instead of domain ids" [Undecided,In progress] - Assigned to Cedric Brandily (cbrandily)
17:41:57 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1444452
17:41:58 <openstack> Launchpad bug 1444452 in python-designateclient " Designateclient does not support relative names in record-create command" [Undecided,In progress] - Assigned to Cedric Brandily (cbrandily)
17:42:18 <timsim> https://bugs.launchpad.net/designate/+bug/1443588
17:42:19 <openstack> Launchpad bug 1443588 in Designate "designate-dashboard reuses update domain screen as view details screen" [Undecided,In progress] - Assigned to Eric Peterson (ericpeterson-l)
17:42:22 <Kiall> I can *feel* rjrjr dancing @ his desk right now for both of those ;)
17:42:34 <timsim> Sorry, that first one was what we just did
17:42:48 <rjrjr> actually, whoever is doing the workshop walkthrough will appreciate these changes. :)
17:43:03 <rjrjr> but yeah, loving these items.
17:43:29 <mugsie> dashboard - high, l
17:43:34 <Kiall> bug 1443588 - L+Medium again.. Code is up, we can likely merge to master today/tomorrow..
17:43:35 <openstack> bug 1443588 in Designate "designate-dashboard reuses update domain screen as view details screen" [Undecided,In progress] https://launchpad.net/bugs/1443588 - Assigned to Eric Peterson (ericpeterson-l)
17:43:46 <timsim> Alrighty
17:43:49 <mugsie> it just needs a +A afaik
17:43:58 <rjrjr> +1
17:44:21 <timsim> Alright, done :)
17:44:54 <Kiall> Sorted :)
17:45:28 <Kiall> So - Any final topics?
17:45:48 <rjrjr> you'll have the other bugs written up for triage next week?
17:45:54 <timsim> Not from me
17:45:58 <rjrjr> and can they still be kilo rc-2 candidates next week?
17:46:14 <rjrjr> some of those bugs you mentioned earlier seem important.
17:46:17 <Kiall> rjrjr: Yep, I'll get them filed
17:46:29 <Kiall> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
17:46:56 <Kiall> final release date is Apr 30 - In theory, we could release an RC as late as then.. I wouldn't exactly want to though.
17:47:28 <rjrjr> we'd be shipping a Kilo with a severely disabled PM.
17:47:55 <rjrjr> sorry, crippled, not disabled. :)
17:47:59 <Kiall> Yea, there all small little issues tho.. So they should all be easy enough to fix! (Famous last works!)
17:48:02 <Kiall> words*
17:48:32 <rjrjr> we can jump on some of those when you get them written up.
17:48:46 <Kiall> Okay, well, sounds like were done. Thanks guys, please get as much testing of.. everything.. as you can :)
17:49:08 <Kiall> Myself / mugsie / ekarlso will be locked back up in the conference room again tomorrow to do our bit ;)
17:49:19 <rjrjr> thanks guys.
17:49:21 <Kiall> Cya!
17:49:25 <mugsie> o/
17:49:32 <Kiall> #endmeeting