17:01:11 <Kiall> #startmeeting Designate
17:01:12 <openstack> Meeting started Wed Feb 25 17:01:11 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:16 <openstack> The meeting name has been set to 'designate'
17:01:18 <Kiall> Hey folks, who's about?
17:01:20 <rjrjr> \o
17:01:21 <timsim> o/
17:01:22 <vinod1> o/
17:01:24 <timsim> o?
17:01:36 <Kiall> Apologies for starting a tad late.. totally lost track of time.
17:01:40 <mugsie> :)
17:01:55 <mugsie> 70 seconds is not too bad
17:01:58 <ashleighfarnham> :)
17:02:06 <Kiall> I would have been much longer had you not pinged me mugsie ;)
17:02:32 <Kiall> Okay, no actions from last week - so skipping that section.
17:02:44 <Kiall> #topic Kilo Release Status (kiall - recurring)
17:03:14 <Kiall> Overall, we're seeing some good progress with the first few chunks of the pools stability/reliability work landing
17:03:42 <Kiall> Hoepfully, we'll have them all in by next week and can move onto the other issues like validation/old style backends/etc
17:03:50 <Kiall> Anyone have anything specific to call out?
17:04:09 <mugsie> There is the postgres bug
17:04:12 <vinod1> I will have the last of the pool reliability patchsets out today
17:04:16 <mugsie> not marked on k3 yet
17:04:30 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1425117
17:04:30 <openstack> Launchpad bug 1425117 in Designate "Designate does not work with postgres" [High,New]
17:04:43 <mugsie> do we think that shoud be k3?
17:04:55 <Kiall> vinod1: excellent :) Have you had any reviews on the current one you have up? (I know I haven't yet)
17:05:54 <timsim> Doesn't look like it
17:06:03 <mugsie> no that I can see
17:06:07 <mugsie> none*
17:06:23 <Kiall> K, I'll do some reviews over the next few hours.. today has been an odd day ;)
17:06:41 <Kiall> mugsie: re bug 1425117
17:06:42 <openstack> bug 1425117 in Designate "Designate does not work with postgres" [High,New] https://launchpad.net/bugs/1425117
17:06:50 <Kiall> Have you looked into what's involved in fixing it?
17:06:56 <mugsie> not yet
17:07:09 <mugsie> been working on the start of the record validation stuff
17:07:26 <Kiall> And - Is it worth fixing until we can get postgres back into the gate, so more issues don't keep coming up?
17:07:43 <mugsie> thats the question I was posing :)
17:07:53 <timsim> Why can't we get it in there?
17:07:58 <Kiall> Ah - Use more words then :P
17:08:05 <mugsie> I am of the opinion that it can wait till post k3
17:08:11 <mugsie> [17:04] <      mugsie> | do we think that shoud be k3?
17:08:13 <mugsie> ;)
17:08:31 <Kiall> timsim: we can, it should be available to us, I've just not looked into how to do it since we moved from self hosted CI slaves -> Infra Hosted CI slaves
17:08:40 <mugsie> timsim: no reason other than engineer time looking at -infra
17:08:51 <timsim> Ah, ok.
17:08:53 <mugsie> and if that would be better spent on other bugs
17:09:09 <timsim> Seems like it would, +1 for after k3
17:09:45 <mugsie> it has been broken a while ;) - no one has shouted at us yet
17:09:47 <Kiall> Yea, I think I agree .. Anyone disagree?
17:09:48 <mugsie> so +1
17:10:02 <rjrjr> +1
17:10:17 <Kiall> Okay.. Any other k3 issues to raise?
17:10:59 <timsim> Nope
17:11:16 <mugsie> I am good
17:11:20 <Kiall> Okay - Moving on so...
17:11:20 <Kiall> #topic "Old Style" Backend - Status/What's TODO? (kiall)
17:11:55 <Kiall> johnbelamaric reached out to me a few days back about this re the InfoBlox stuff
17:12:14 <johnbelamaric> Kiall: hello - i am here
17:12:22 <Kiall> timsim, how far along is the agent stuff? Since it's going to underpin getting old style backends fully supported again
17:12:43 <timsim> It's ready to hack on
17:13:08 <timsim> The pool changes (being able to specify different hosts for NOTIFY and polling) is holding up integration with the Pool Manager.
17:13:22 <timsim> But the crappy WIP hack patch I have out there solves that for the moment.
17:13:35 <timsim> I've had it working with Bind9 for quite a while.
17:13:42 <Kiall> Yea, that's going to hold up production style setups with it - but for simple testing and dev on the new code, it should be OK with current PM code, right?
17:13:53 <timsim> Plus that Agent backend, yeah.
17:14:03 <rjrjr> are the problems with the old bind9 driver worked out?
17:14:40 <timsim> Kiall: This one: https://review.openstack.org/#/c/144510/
17:14:54 <timsim> Which basically lets you put a target_host and port in there.
17:15:06 <Kiall> Okay - So, Is anyone in a position to try move forward with the plan? I'm spending all my non-meeting hours on the pools/targets/db-config stuff tim metiond as blocking..
17:15:16 <timsim> The interface for Backends is simple atm. only CUD domains. So I don't know if you want to expand that to records.
17:16:30 <timsim> Remind me, we want to port all the old backends over, yeah?
17:16:48 <mugsie> timsim: the ones that cannot be done with AFXR yeah
17:17:07 <mugsie> and if people have a particulr need for others, (like BIND) we can look at them
17:17:15 <Kiall> Mostly the translation into the "old style" backend API from the agent, to support backends which we can't AXFR straight to
17:18:23 <Kiall> Anyway.. I'm going to take silence as a nope! Okay, I can try knock up POC quality code for it today/tomorrow.. But will have to pick between the pools/targets/db-config and it - I'd love it someone could take it up once I've got that far?
17:18:37 <timsim> I think if we add the CUD recordset/record to the Agent's backend API it should be real easy
17:19:01 <timsim> The challenge there is figuring that out from a zone transfer, you've got to parse and figure out the differences.
17:19:06 <Kiall> Exactly :)
17:19:48 <timsim> Which backend do you want to tackle first?
17:20:22 <timsim> I would think that the way you do that logic would differ by backend
17:20:41 <Kiall> the noop/test one? I'm not sure the specific backend is that important - We're wanting this for InfoBlox and IPA so far, if we have to pick a specific one it's one of those I guess
17:21:26 <johnbelamaric> Kiall: i may be able to have someone help out starting next week if needed
17:21:44 <timsim> An issue I see there is those backends expect a Designate object, where the current agent backends expect a DNSpy object. But i suppose you can convert it.
17:22:28 <Kiall> timsim: yea - I suspect we convert for today, and remove the need for conversion later to save the CPU cycles..
17:22:48 <Kiall> johnbelamaric: that sounds good :) I can write up the POC, and some documentation around it today/tomorrow and we can go from there
17:23:05 <johnbelamaric> Kiall: ok, sounds good
17:24:12 <johnbelamaric> Kiall: ping me on IRC when it's ready, i'll see if I can get Ko (who will do the actual work…) up to speed
17:24:35 <Kiall> johnbelamaric: will do.
17:24:51 <Kiall> Okay - timsim re the blocking on targets stuff you have, I have the first chunk of that change nearly ready to go.. Just fixing up tests etc..
17:24:53 <johnbelamaric> He's working on our Neutron adapter right now so he hasn't been in designate yet but shouldn't be a problem to ramp up
17:25:25 <Kiall> That chunk is the hardest one, as it's the chunk with all the changes to existing code rather than new stuff ;)
17:25:53 <Kiall> Hopefully I can get the core of it up this week, so mugsie can finish our the API on top of it he started at the mid-cycle...
17:26:03 <Kiall> finish out*
17:26:07 <timsim> Sounds good!
17:26:40 <Kiall> #action kiall to build POC of the old-style backend support via the agent
17:26:52 <Kiall> #action kiall to put old-style backends back on agenda for next week
17:26:55 <Kiall> Moving on :)
17:27:07 <Kiall> #topic Bug triage (timsim - recurring)
17:27:31 <timsim> We took care of the only one out there earlier in the meeting (postgres) so I think we're good here.
17:27:57 <Kiall> Well - That was easy.
17:27:57 <mugsie> yup
17:28:06 <Kiall> #topic Open Discussion
17:28:22 <Kiall> No other agenda items today, does anyone have anything off-agenda they would like to discuss?
17:28:32 <rjrjr> no bugs to look at?
17:28:44 <timsim> I think the gate is jammed: http://logs.openstack.org/95/157995/4/check/gate-designate-python27/d9978b5/console.html#_2015-02-25_15_43_16_342
17:28:45 <Kiall> No new ones
17:28:50 <rjrjr> cool.
17:29:02 <Kiall> timsim: Oh, nice :'(
17:29:10 <timsim> Both the translations and elarson's doc change are hitting up against the same thing.
17:29:16 <vinod1> there seem to have been failures around dnspython
17:29:16 <Kiall> Has anyone dug into the cause yet?
17:29:39 <timsim> Yeah I just saw tests failing because DNSpython objects couldn't be patched. But it seemed to be installing ok
17:29:48 <Kiall> 2015-02-25 15:43:16.592 | dnspython==1.12.0 <-- Version hasn't changed.
17:29:56 <Kiall> but.. this one has:
17:29:56 <Kiall> 2015-02-25 15:43:16.582 | eventlet==0.17.1
17:30:41 <Kiall> eventlet 0.17.0 was the one that broke us, and 0.17.1 is the bugfix they released today to fix the issue :(
17:30:55 <Kiall> (eventlet does some stuff with dnspython.. )
17:31:01 <Kiall> I suspect it's bit is.
17:31:02 <Kiall> us*
17:31:16 <mugsie> they did somehting to dns.resolver
17:31:17 <mugsie> https://github.com/eventlet/eventlet/commit/3de49aef1399594b2cab0652d9ff3976d19b5e72
17:31:24 <mugsie> but havent dug in yet
17:32:11 <Kiall> https://github.com/eventlet/eventlet/compare/v0.17...v0.17.1
17:32:44 <Kiall> I actually think it might be our issue, rather than theirs though.
17:33:13 <Kiall> I'll have a quick check after this meet
17:34:05 <Kiall> Any other off-agenda items?
17:34:37 <rjrjr> i am good.
17:34:38 <Kiall> I'll add one.. mugsie has taken over finishing the V2 API missing validation stuff from me, I had too much on my plate ;)
17:34:53 <Kiall> So - exepect that to land soon ;)
17:35:12 <mugsie> yay?
17:35:15 <mugsie> -_-
17:35:19 <Kiall> No pressure.
17:35:20 <mugsie> :)
17:35:55 <timsim> Nice. Need that pretty bad
17:36:14 <Kiall> vinod1 / johnbelamaric / timsim / anyone else - anything else before we call it a day?
17:36:28 <mugsie> timsim: tell me about it
17:36:40 <johnbelamaric> Kiall: nothign from me
17:36:45 <vinod1> nothing from me
17:36:50 <mugsie> I am good
17:37:00 <Kiall> Okay - Let's call it so :) Thanks all, see you in #openstack-dns ;)
17:37:07 <Kiall> #endmeeting