17:01:17 <Kiall> #startmeeting Designate
17:01:18 <openstack> Meeting started Wed Jan 14 17:01:17 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:21 <openstack> The meeting name has been set to 'designate'
17:01:24 <Kiall> thanks timsim ;)
17:01:28 <timsim> :P
17:01:35 <Kiall> Who's about?
17:01:37 <rjrjr__> o/
17:01:43 <timsim> o/
17:02:05 <johnbelamaric> john b here
17:02:10 <betsy> o/
17:02:46 <Kiall> #topic Kilo Release Status (kiall - recurring)
17:02:52 <Kiall> #link https://launchpad.net/designate/+milestone/kilo-2
17:03:07 <Kiall> k2 is Feb 5th
17:03:14 <mugsie> ccccccdtrunhehtvltctilgluehhhrbeljikkfchdchg
17:03:20 <Kiall> nice mugsie
17:03:21 <timsim> lol
17:03:23 <mugsie> sshhh
17:04:08 <Kiall> So - Status wise, We're mostly there.. What we're really falling behind on is updating the "old-style" backends - timsim's done a lot of work in the area, but we'll want to get reviewing it etc to start getting it merged
17:04:28 <Kiall> with the midcycle next week, I think we''ll hammer out a lot of the remaining pools quirks etc :)
17:04:42 <Kiall> Am I missing anything we should have in k2?
17:04:51 <mugsie> dont think so
17:05:22 <Kiall> Anyone else? :)
17:05:25 <timsim> Vinod's change maybe?
17:05:33 <timsim> The admin api pool business
17:05:48 <mugsie> is there a BP for that?
17:05:57 <timsim> Don't think so
17:05:59 <Kiall> No - Code is up for review @ https://review.openstack.org/#/c/139748/
17:06:10 <Kiall> guess we upset him ;)
17:06:10 <mugsie> if there is  - we should mark it, or just review it.
17:06:29 <Kiall> Anyway - It's in good shape, just needs a proper review or two I think..
17:06:50 <timsim> That's all i've got
17:06:55 <mugsie> cool
17:06:59 <Kiall> We should also file a stub BP in launchpad, so it's on the tracking page.. I'll do that after
17:07:20 <Kiall> #action kiall file stub BP for vinod's pools admin-api review..
17:07:37 <Kiall> #topic Pools - Where are we? (kiall - recurring)
17:07:53 <Kiall> rjrjr__: about? You're always the most up to date on pools status? :)
17:08:15 <rjrjr__> just submitted some unit tests a short while ago.
17:08:41 <rjrjr__> fixed several bugs after the meeting last week and will look at the comments on the patches i submitted and fix those up shortly.
17:08:59 <rjrjr__> i think testing is the key now.  most of the bugs i know about have been squashed.
17:08:59 <Kiall> Oh, cool.. That can give us a base more pools tests for tomorrow :)
17:09:38 <Kiall> Yea, agreed... Hopefully we can knock out a good chunck of that tomorrow dueing the testing sprint..
17:09:39 <rjrjr__> one more patch i'm aware of is to remove the cache entries when we are done with them.  it is on my plate and will be done by the end of the week.
17:10:32 <Kiall> Okay - Everyone able to make it to the sprint tomorrow?
17:10:46 <vinod1> yes
17:10:49 <betsy> +1
17:10:54 <timsim> Yep
17:11:01 <ekarlso-> o/
17:11:02 <rjrjr__> tenative.  i'll join, but not necessarily participate.
17:11:06 <mugsie> i'll think about it ...
17:11:07 <mugsie> :D
17:11:10 <vinod1> Kiall: You mentioned doing some prep work in preparation for tomorrow's sprint
17:11:17 <Kiall> lol.. rjrjr__try your best :)
17:11:50 <Kiall> vinod1: yep, it's on my plate for today - I'd like to get us setup to do better integration testing..
17:12:02 <Kiall> (We're in seattle - so it's still on 9am ;))
17:12:07 <Kiall> only*
17:12:37 <Kiall> Okay - Any other areas of pools needing a look at?
17:13:12 <mugsie> dont think so bar load of testing
17:13:16 <mugsie> loads*[5~
17:13:52 <Kiall> Okay - We'll move on so :)
17:13:58 <Kiall> #topic Monthly Topic Sprints (kiall)
17:14:36 <Kiall> We already discussed this ;) But - If everyone can try and make it, we'll be covering unit/integration testing work that's fallen behind
17:14:56 <timsim> Tomorrow, 9-1 PST, yeah?
17:15:07 <timsim> No
17:15:11 <mugsie> 11-3 ?
17:15:12 <vinod1> 11-3 PST
17:15:13 <timsim> 11-3 PST
17:15:28 <mugsie> timsim: giving me a heart attack
17:15:30 <Kiall> Ideally, people can get familar with how to create/read coverage reports locally (tox -e cover), and maybe pick an area they'd like to try cover :)
17:15:34 <Kiall> mugsie: lol
17:15:35 <timsim> hahaha
17:15:38 <betsy> 9 - 1 CST :)
17:16:04 <timsim> 1-5 CST ;) betsy
17:16:34 <timsim> Anyway. Sounds like fun!
17:16:36 <betsy> oops
17:16:36 <Kiall> Also - Can we review rjrjr__'s pools unit tests as a matter of priority? ideally, we have that merged before we start tomorrow as a basis for more pools tests...
17:16:49 <timsim> Kiall: +1
17:16:53 <vinod1> Kiall - would be good if you list the top things we like to cover - makes the decision process easier
17:16:58 <rjrjr__> i'll have it finished in a few hours.  it is WIP right now.
17:17:10 <Kiall> vinod1: sure, I can do that..
17:17:23 <rjrjr__> unfortunately, it relies on a patch i submitted friday.  just have to get it past vinod. LOL
17:17:30 <Kiall> haha
17:18:15 <Kiall> #action kiall to list out top areas needing test attention on an etherpad
17:18:50 <Kiall> #topic Open Discussion
17:18:53 <Kiall> Okay - That's the last of our agenda items, any other topics?
17:19:15 <Kiall> Areas needing attention will be on https://etherpad.openstack.org/p/designate-testing-sprint
17:19:40 <Kiall> None from anybody?
17:19:43 <rjrjr__> i hope everyone saw the email i sent out yesterday.  i have a room booked in SJ for us.
17:19:58 <rjrjr__> that was fun.
17:20:01 <Kiall> I did, excellent :)
17:20:07 <timsim> Yep, thanks rjrjr__
17:20:08 <timsim> vinod1 is going to be at the mid-cycle. Not sure if that was shared yet
17:20:13 <Kiall> lol - didn't just open outlook and click "Find room"? ;)
17:20:15 <vinod1> Paul had filed a bug 1409824
17:20:17 <rjrjr__> good news!
17:20:22 <Kiall> vinod1: excellent :D
17:20:40 <vinod1> That should be for Kilo2 I think
17:21:04 <Kiall> "The API does not return a status field for recordsets" <-- bug 1409824
17:21:08 <timsim> #link https://bugs.launchpad.net/designate/+bug/1409824
17:21:47 <Kiall> Yea - That seems like a same
17:22:34 <Kiall> sorry - distracted at desk
17:22:56 <Kiall> back..
17:23:09 <Kiall> Seems like a sane thing I reckon
17:23:14 <Kiall> Let's tag t2
17:23:15 <Kiall> k2
17:23:18 <timsim> Yep
17:23:26 <mugsie> it already done ;)
17:23:26 <vinod1> The backlog of code reviews is growing - would be could to get more eyes on them
17:23:33 <mugsie> vinod1: +1
17:23:36 <Kiall> mugsie: really?
17:23:59 <Kiall> I don't see a review for it?
17:24:04 <mugsie> maked as k2
17:24:07 <Kiall> Ah
17:24:09 <mugsie> marked*
17:24:14 <Kiall> I just changed it as I said it ;)
17:25:15 <Kiall> Re backlog, yea.. We have a bunch of them to knock out.. I'll make more time to work through them as soon as I can.. Hopefully others can do the same.
17:25:26 <Kiall> paul_glass: here BTW?
17:25:27 <rjrjr__> zuul is bogged down today.  lots of jobs.
17:25:35 <paul_glass> I'm around
17:26:04 <Kiall> paul_glass: heya - Just wanted to say Hi! and thanks for all the bug reports.. Theve been helpful :D
17:26:15 <paul_glass> no problem!
17:26:42 <clarkb> rjrjr__: we are currentl operating without half our cloud capacity
17:26:49 <clarkb> so things are backed up, but moving
17:27:03 <rjrjr__> clarkb: good to know. thanks!
17:27:10 <mugsie> clarkb: which side died this time?
17:27:14 <clarkb> mugsie: hpcloud
17:27:23 <Kiall> clarkb: ouch, issues in HPC? Let me know if I can annoy anyone internally for you ;)
17:27:42 <clarkb> Kiall: we have already suckered somone into helping :) tteggel has been a ton of help
17:27:51 <Kiall> :D
17:27:59 <Kiall> Okay - Any other topics?
17:28:07 <vinod1> None from me.
17:28:16 <betsy> not from me
17:28:17 <mugsie> Nope - I am good
17:28:24 <timsim> I was wondering when people are getting to SJ, where they were staying.
17:28:37 <Kiall> let me check..
17:28:42 <rjrjr__> i'll be at the extended stay.
17:28:51 <timsim> vinod1 and I are in the very poorly yelp-reviewed http://www.yelp.com/biz/extended-stay-america-san-jose-airport-san-jose
17:28:53 <rjrjr__> it is right across the street from the campus.
17:29:02 <mugsie> We are in a Hilton, a couple of blocks over...
17:29:11 <rjrjr__> timsim: same place.
17:29:16 <timsim> Party
17:29:24 <timsim> We get there Sunday evening.
17:29:47 <Kiall> We'll be in Saturday afternoon
17:29:52 <rjrjr__> i'll be there around midnight Sunday.
17:30:19 <timsim> Cool :)
17:30:48 <Kiall> Okay - Any last minute topics before we call it a day? :)
17:31:07 <rjrjr__> so, tomorrow at 11 PST, correct?
17:31:17 <Kiall> Yes - 11-3 PST
17:31:44 <rjrjr__> i'm good then.
17:31:58 <Kiall> Okay - Thanks all - See you tomorrow @ 11-3 PST :)
17:32:10 <Kiall> #endmeeting