17:02:08 <mugsie> #startmeeting Designate
17:02:08 <openstack> Meeting started Wed Apr 23 17:02:08 2014 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:09 <rkukura> thanks
17:02:11 <openstack> The meeting name has been set to 'designate'
17:02:18 <kiall> Heya :)
17:02:21 <mugsie> hey - whos here?
17:02:23 <rjrjr_> hee
17:02:26 <rjrjr_> here
17:02:26 <eankutse1> heya :-)
17:02:28 <dtx00ff> hey
17:02:29 <vinod> here
17:02:29 <richm> here
17:02:38 <mugsie> cool
17:02:38 <betsy> here
17:02:47 <mugsie> #topic Review action items from last week
17:02:57 <mugsie> Joe Work with mugsie to get an application in for https://www.openstack.org/blog/2014/03/call-for-proposals-open-source-openstack-summit/
17:03:00 <mugsie> that was done
17:03:08 <mugsie> hopefully should hear back soon
17:03:31 <mugsie> #topic DNSpy update
17:03:43 <mugsie> Who added this?
17:03:49 <eankutse1> Making good progress
17:03:59 <mugsie> cool - anything of note to report?
17:04:00 <eankutse1> I have committed sample code
17:04:15 <eankutse1> to poc code base for
17:04:17 <kiall> eankutse1: cool - where?
17:04:20 <eankutse1> notify
17:04:29 <mugsie> #link https://github.com/designate-dns/minidns-poc
17:04:31 <eankutse1> and axfr_from a server
17:04:33 <kiall> ah
17:04:38 <eankutse1> mugsie: thx
17:04:41 <mugsie> np
17:04:53 <eankutse1> next step is axfr from NS
17:04:57 <eankutse1> nameserver
17:04:59 <mugsie> should we make it an action for people to have a look at ^
17:05:00 <mugsie> ?
17:05:14 <kiall> Not sure that needs to be an action ;) But I know I will
17:05:15 <eankutse1> Yes.
17:05:31 <eankutse1> It's still very basic but good to look at
17:05:37 <mugsie> #action everyone - review eankutse's MiniDNS POC
17:05:59 <mugsie> eankutse1: cool - thanks
17:06:15 <eankutse1> np
17:06:21 <mugsie> we ok to move on, or do people have questions?
17:06:27 <kiall> I do
17:06:35 <kiall> eankutse1: overall, are you thinking it will do everything we need?
17:06:42 <mugsie> kiall: you have the floor
17:06:48 <kiall> already asked ;)
17:06:55 <eankutse1> yes. I think dnspython is capable
17:07:08 <eankutse1> I'll be more firm when I complete axfr
17:07:44 <kiall> eankutse1: Okay, cool.. I'll have a read of your code so-far after the meet
17:07:52 <eankutse1> thx
17:07:58 <mugsie> ok to move on?
17:08:31 <eankutse1> yes
17:08:53 <mugsie> the agenda on the wiki looks like last weeks one - vinod do you want to talk about rrdata again?
17:09:02 <mugsie> or shall we move to open disccussion?
17:09:38 <vinod> nothing more about rrdata - i talked to kiall yesterday
17:09:44 <mugsie> #topic Open Discussion
17:09:45 <vinod> and updated the code
17:09:55 <mugsie> cool - anyone have anything they want to talk about?
17:09:57 <kiall> vinod: I gave the patchset a quick review earlier today, it looks good
17:10:20 <vinod> kiall did you get a chance to further investigate the object transmission bug across rpc
17:10:23 <kiall> Wanted to come back to it again before commenting etc.. But I didn't notice anything with a quick read
17:10:53 <kiall> vinod: yes, I'm eyeing up this as the cause: https://github.com/stackforge/designate/blob/master/designate/rpc.py#L107
17:11:27 <kiall> But, I can't see where it's coming into play
17:11:54 <rjrjr_> i noticed the Fixed IP PTR API code i submitted is now failing.  i'll review the problem and update accordingly.  can it get reviewed shortly after to avoid this problem?
17:12:04 <mugsie> rjrjr_: no problem
17:12:16 <mugsie> it most likely just needs to be rebased
17:12:23 <kiall> rjrjr_: was that not still marked as a WIP? Apologies if it wasn't
17:12:52 <rjrjr_> it is, but 4+ weeks later, other changes came in and broke the code.
17:13:34 <kiall> rjrjr_: ah.. Well, once rebased, well give it a final round of reviews
17:13:41 <rjrjr_> great!
17:14:04 <mugsie> cool  - anythign else?
17:14:16 <eankutse1> Kiall: regarding summit
17:14:24 <eankutse1> is this ready to use: https://github.com/designate-dns/designate-workshop-packer?
17:14:26 <rjrjr_> info on using the VM for Atlanta?
17:14:29 <kiall> vinod: re the messaging bug, I have setup, but not had a chance to test out, a copy of the old pre-o.m code
17:14:55 <rjrjr_> eankutsel, exactly what i was thinking.
17:14:56 <kiall> (Just to verify the pre-o.m code does what I expected)
17:15:24 <vinod> thanks kiall
17:15:36 <kiall> eankutse1: yes, it should be ready to use with everything pre-installed etc.. There's some quick+dirty docs on setting the build off, and adding anything needed for the other parts
17:15:59 <kiall> (I asked mugsie for everyones emails yesterday afternoon, and we both promptly forgot)
17:16:01 <richm> I'll be using RH OS1 for my VMs
17:16:09 <eankutse1> Kiall: thx. I'll check it out
17:16:10 <eankutse1> :-)
17:16:26 <kiall> richm: makes sense :)
17:16:53 <kiall> eankutse1: 1 tip for running the build.. keep your hands OFF THE KEYBOARD until it's well underway ;)
17:17:07 <eankutse1> ok. I will :-)
17:17:11 <kiall> (You'll understand why when you run the build...)
17:17:12 <eankutse1> no interruptions
17:17:13 <mugsie> yep - I found that out the hard way
17:17:25 <eankutse1> thx :-)
17:17:33 <rjrjr_> mugsie, anything catastrophic?
17:17:45 <mugsie> it just totally breaks the build bit
17:17:46 <kiall> rjrjr_: wasted 30 mins from memory ;)
17:17:53 <mugsie> yeah ^
17:18:06 <rjrjr_> :)
17:18:17 <mugsie> for the design summit - our session has been schedualed - http://sched.co/1eJqs6h
17:18:30 <mugsie> Tuesday 12-12.45
17:18:35 <kiall> It takes a while to build (30-60 mins, depending on your laptop) but it's repeatable in a way that doing it by hand just isnt
17:18:42 <eankutse1> Great! Thx mugsie
17:19:03 <mugsie> it is only 40 mins - so we will have to be clear about what we will be talking about
17:19:13 <mugsie> but that will be done closer to the time
17:19:31 <eankutse1> Kiall: thx for the headsup on the build
17:19:34 <kiall> +
17:20:00 <mugsie> ok - anyone have anything else?
17:20:14 <kiall> So moving on (again) if people don't mind :) I've had a few people from inside and outside HP ping me re Designate Incubation
17:20:48 <eankutse1> ok
17:21:07 <kiall> Where do people stand on getting the application re-written before the Summit, and "working the room" while we're there with the TC etc?
17:21:39 <eankutse1> If I remember we had a list
17:21:42 <eankutse1> of what to complete
17:21:48 <eankutse1> before we apply again
17:22:02 <eankutse1> I wonder how much of that list we've completed so far
17:22:16 <kiall> I believe we meet all (at the least most) the tickboxes, but we'd need to dig out the list and recheck
17:22:30 <eankutse1> we only have 3 weeks
17:22:59 <kiall> Yep - Not huge amounts of time left before the summit
17:23:14 <vinod> will the TC entertain incubation requests at the summit?
17:23:19 <kiall> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/incubation-integration-requirements
17:23:23 <kiall> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/new-programs-requirements.rst
17:23:31 <mugsie> vinod: no - but it doesnt hurt to talk to them
17:23:51 <mugsie> there will be new members on the TC in atlanta
17:23:52 <kiall> vinod: Honestly, no idea. But having it ready + in hand while face to face can't hurt
17:24:06 <rjrjr_> kiall, what can we do to help?
17:24:38 <kiall> rjrjr_: look over those 2 docs and figure out where we'll get -1's :)
17:24:55 <betsy> kiall: Are you thinking Designate will be a new program or part of an existing one?
17:25:02 <mugsie> betsy: new
17:25:06 <mugsie> (hopefully)
17:25:26 <kiall> betsy: Not sure, I'd prefer not to be under Neutron, as I don't see enough overlap...
17:25:39 <betsy> mugsie: okay. I’ll look at the new program req. doc. Haven’t looked at that yet
17:26:00 <vinod> kiall do you have a link to the TC meeting minutes - i wanted to look at how the recent incubation requests went
17:26:20 <mugsie> vinod: they should be in the same place as our minitues
17:26:29 <vinod> ok will look there
17:26:32 <rjrjr_> so action item for everyone to review incubation documents.
17:26:37 <kiall> #link http://eavesdrop.openstack.org/meetings/tc/
17:26:38 <kiall> I think
17:26:54 <mugsie> #action everyone - review incubationn requirments
17:27:31 <kiall> Anyway - If we think we hit all the marks (or enough/the important marks), we should use the next meet to write out the application
17:27:40 <kiall> (Switch the next meet to a hangout?)
17:28:02 <mugsie> that suits me - how do other people feel?
17:28:07 <eankutse1> sounds good
17:28:11 <richm> works for me
17:28:20 <vinod> works for me too
17:28:33 <mugsie> cool. Same time same place - on a hangout?
17:28:41 <mugsie> 1 item agenda - Incubation
17:28:43 <vinod> yes
17:28:49 <kiall> Yea, easiest for everyone I reckon
17:28:52 <mugsie> grand
17:28:59 <richm> Mark M. says that it is preferred that Designate _not_ be part of an existing program/project
17:29:02 <rjrjr_> +1
17:29:16 <kiall> richm: Any reasoning given?
17:29:28 <kiall> (Not that I disagree, just wondering what the reasoning us)
17:29:29 <kiall> is*
17:29:40 <kiall> (Also - Apologies for missing the HO on Monday, was a holiday here and I was out with family..)
17:29:46 <richm> He doesn't think any of the existing projects will want to take us (people, code) on board
17:30:01 <eankutse1> By the way, any advantages or disadvantages either way? ( program/project…)?
17:30:01 <richm> they are too busy to worry about integrating another big pile of code
17:30:34 <kiall> richm: sounds like a good reason
17:30:43 <richm> Mark M. also said the biggest problem with the first round was that there were too few contributors, which shouldn't be a problem now
17:31:07 <kiall> richm: you talking to him now? (Say "Hi" for me..)
17:31:55 <richm> no, not right now
17:32:05 <richm> this was a while ago, after our meeting in Austin
17:32:34 <kiall> Okay - Anyway, let's circle back to this next week once we're re-read the linked docs
17:32:43 <mugsie> yup.
17:32:49 <mugsie> moving on - anything else?
17:32:52 <eankutse1> cool
17:33:25 <mugsie> fyi - just sent out the invite for next week
17:33:50 <mugsie> ok - we good to say we are done for this week?
17:34:04 <rjrjr_> yep
17:34:09 <vinod> yes
17:34:10 <betsy> I’m good
17:34:17 <eankutse1> good
17:34:22 <kiall> Yep :)
17:34:25 <mugsie> ok
17:34:28 <mugsie> #endmeeting