17:01:41 <mugsie> #startmeeting Designate
17:01:42 <openstack> Meeting started Wed Jan 15 17:01:41 2014 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:45 <openstack> The meeting name has been set to 'designate'
17:01:58 <mugsie> so, lets have a look at the agenda
17:02:14 <mugsie> #topic Review proposed Austin workshop details (a.k.a. 'mini-summit')
17:02:39 <jmcbride> Hi guys, I assembled some rough details and a registration page.
17:02:57 <mugsie> #link https://etherpad.openstack.org/p/DesignateAustinWorkshop2014-01
17:02:57 <jmcbride> Details about the agenda can be found at https://etherpad.openstack.org/p/DesignateAustinWorkshop2014-01
17:03:10 <jmcbride> To register, you sign up at https://www.eventbrite.com/e/designate-development-workshop-january-2014-tickets-10180041779
17:03:20 <jmcbride> #link https://www.eventbrite.com/e/designate-development-workshop-january-2014-tickets-10180041779
17:03:45 <jmcbride> I'll get a detailed agenda together next week.
17:03:51 <mugsie> cool, thanks jmcbride
17:04:03 <jmcbride> So, I'd like to make sure: everyone is aware of the details
17:04:31 <jmcbride> and if there are no objections, I'd like to send it out to the Openstack Dev mailing list
17:04:31 <mugsie> anyone questions / comments etc?
17:04:44 <mugsie> i think that is a good idea (mailing list)
17:04:52 <kiall> (Just wrapping up a call ATM ..)
17:05:12 <mugsie> anyone have any major issue with the mailing list?
17:05:40 <tsimmons> It'll be a good thing.
17:05:58 <mugsie> cool, we will say that is happening then
17:06:07 <mugsie> ok to move on?
17:06:13 <kiall> jmcbride: no objections at all :)
17:06:16 <jmcbride> #action send email to Openstack mailing list
17:06:30 <mugsie> #topic Gating reviews on DevStack with MySQL and PostgreSQL (kiall)
17:06:41 <mugsie> kiall - you have the floor
17:07:00 <kiall> Heya :) So - I wanted to give you guys a heads up about some additionall testing we're doing
17:07:23 <kiall> We had some "complaints" on the mailing list about our PostgreSQL support being broken etc
17:07:57 <kiall> So - I took our devstack forked, turned it into a new devstack plugin, and setup a Jenkins instance to run against mysql and postgres for every commit
17:08:04 <kiall> #link http://15.126.220.179:8080/
17:08:12 <kiall> It currently lives there ^ .. It'll get a name soon
17:08:38 <kiall> The extracted plugin for devstack is in https://github.com/designate-dns/devstack-designate
17:09:20 <kiall> Anyway, I think this gives us a good opportunity for better functional testing - e.g. real testing with powerdns, bind etc
17:10:09 <tsimmons> That'd be cool.
17:10:18 <kiall> But - I'm wondering who's up for helping to maintain the devstack plugin, add support for bind to it, updated it to always would with the latest upstream devstack etc etc
17:10:27 <artom> Could we start thinking about testing with Tempest?
17:10:31 <kiall> updating*
17:11:10 <kiall> artom: I looked at at, and I don't believe there's an easy way to "plugin" to it.. Which sucks, and makes the maintenance burden shoot up
17:11:25 <kiall> If it's doable - great!
17:12:25 <kiall> We can do poor-mans functional testing with simple devstack exercise scirpts - https://github.com/designate-dns/devstack-designate/blob/master/exercises/designate.sh
17:13:22 <kiall> Anyway - Anyone who has submitted a review in the last few days will have noticed "me" commenting on the reviews with -1/+1 .. I have a ticke filed to get a dedicated account for that ..
17:13:27 <kiall> ticket*
17:14:06 <mugsie> cool. thanks kiall. Any comments / queries?
17:14:18 <tsimmons> Good stuff, you've been crazy busy lately :P
17:14:40 <kiall> So - Back to - who's willing to help get more functional tests (exercises, or tempest), bind support, etc written?
17:15:24 <kiall> tsimmons: yea - we've had a lot of patches land over the last few days :)
17:15:46 <tsimmons> I wouldn't want to speak for people, but I'd think that bind support would be something that we could help with soon.
17:17:19 <kiall> Cool :) I was planning on spending a few hours later this week getting it to properly standup powerdns, and some really basic functional tests
17:17:42 <tsimmons> I'd imagine we could use that as a sort of template to get something stood up.
17:18:01 <kiall> Great :) I'll ping you guys when I have that up ..
17:18:17 <artom> "Standup" powerdns?
17:18:19 <tsimmons> Cool. Most of my team isn't here. Well…all of them probably. I'm sure they'll have more comments.
17:18:49 <kiall> artom: install, configure it to point at the right databases etc .. e.g. after running `./stack.sh` you should be able to issue DNS queries to 127.0.0.1 and get results
17:19:00 <kiall> tsimmons: day off for RackSpace? :D
17:19:22 <tsimmons> Hah, they're in some training :) I'm at school so I can't be there atm.
17:19:24 <artom> Ah, devstack to "standup" powerdns
17:19:26 <artom> Gotcha.
17:19:53 <mugsie> cool
17:19:56 <mugsie> #topic grahamhayes/dt211-SI
17:20:03 <kiall> lol
17:20:08 <mugsie> #topic Open Disscusion
17:20:11 <mugsie> there we go
17:20:44 <mugsie> anyone have anything else?
17:21:07 <kiall> This has defiantly been one of our shortest meetings since we're real light on people here today :)
17:21:20 <mugsie> yup
17:21:27 <tsimmons> kiall: if you have a minute
17:21:27 <mugsie> we call it done?
17:21:36 <mugsie> tsimmons: go for it
17:22:20 <tsimmons> I have some questions that aren't really relevant to the group at large about changing the storage db interactions to transactions that rollback automatically.
17:23:01 <kiall> Ok - Sure, we could take them to the #openstack-dns room rather than having them in the meeting logs forever? ;)
17:23:10 <tsimmons> That'd be good :)
17:23:20 <mugsie> #endmeeting