17:23:04 <kiall> #startmeeting designate
17:23:05 <openstack> Meeting started Wed Oct 30 17:23:04 2013 UTC and is due to finish in 60 minutes.  The chair is kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:23:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:23:08 <openstack> The meeting name has been set to 'designate'
17:23:18 <eankutse> here
17:23:28 <vinod1> here
17:23:32 <kiall> Again - Apologies.. DST switched here, and both myself and mugsie we're thinking it was still at 6pm local!
17:23:43 <eankutse> :-)
17:23:48 <betsy> here
17:24:05 <kiall> Graham is on another call at the minute .. DST makes things painful :) He might be along
17:24:14 <artom2> that saved daylight better be worth all this trouble ;)
17:24:48 <betsy> We got off daylight savings this coming weekend
17:24:59 <kiall> Since we're going to keep this short, and most people with action items are AFK, I'll skip that until next week.
17:25:04 <kiall> #topic Havana Release
17:25:36 <kiall> I added this item earlier today, I'd like to see us get a solid release, including .deb's, released over the next few days - before the Summit.
17:26:31 <kiall> The idea being A) We can mail out to the openstack and openstack-dev lists, possibly getting more traction
17:26:37 <eankutse> I saw those. Looking over them to learn
17:26:39 <eankutse> :-)
17:26:49 <betsy> Sounds like an excellent idea
17:26:56 <betsy> Anything we can do to help?
17:27:16 <kiall> and B) demo the install at the simmit
17:27:24 <kiall> (sorry - distracting phone call)
17:27:46 <kiall> So - I'm working through getting out deps in sync with the "official havana" list today
17:27:49 <artom2> enovance will have guys at the summit
17:28:13 <artom2> some might have deb packaging experience
17:28:16 <betsy> kiall: Are you going to the summit?
17:28:18 <kiall> But, proper testing is going to be tough given the time.. I'd love to get some help from everything making sure it works
17:28:22 <kiall> betsy: yea, leaving on Sunday
17:28:55 <kiall> artom2: .deb's are a personal specialty of mine - you should see what happens when someone puts something unpackaged (aka unclean) on a server I maintain ;)
17:29:03 <kiall> It ain't pretty
17:29:11 <artom2> hahaha
17:29:14 <artom2> ok then
17:29:41 <kiall> Anyway - I'm hoping to get the .deb's out, using all the deps from the Ubuntu Havana cloud archive tomorrow morning
17:30:19 <kiall> But there's no way any of us at HP will have enough time to fully test them before the week is out
17:30:28 <betsy> I'll be happy to help with the testing
17:30:43 <betsy> Let me know when it's ready and if  you want me to test a certain functionality
17:30:44 <kiall> betsy: lifesaver :)
17:30:56 <betsy> or just in general
17:30:57 <artom2> I can test too
17:31:12 <kiall> artom2: excellent!
17:32:06 <kiall> I'll have some install notes on the install using .deb's, but there probably going to be pretty rough! I'll ping you both tomorrow when there ready
17:32:47 <betsy> kiall: sounds good
17:32:49 <artom2> k
17:33:27 <kiall> So .. Moving on to part 2 of "Havana Release" - I think now, after cutting a release and announcing, and with the summit soon, is a great time to try and bring in more people and users..
17:34:28 <artom2> I'm about to open up a proof of concept setup with nsd4 over here
17:34:38 <artom2> so more users
17:34:51 <kiall> I'm hoping to try and "hijack" the "We've released a Havana version" thread to pull people in .. I expect we'll see a bunch of general questions, install help etc type mails after.. I'd love to see everyone answering these and showing people from outside HP are involved :)
17:34:53 <artom2> albeit in an "existing" company
17:35:37 <kiall> i.e. if your not subscribed to the openstack and openstack-dev lists .. http://lists.openstack.org/ :)
17:35:53 <artom2> I'll sub to the list
17:36:01 <betsy> I'm on openstack-dev, but not openstack.
17:36:04 <betsy> I'll add that one
17:36:06 <eankutse> Kiall: good idea. We'll do our best
17:37:06 <kiall> And, all this leads up to post-summit discussion around incubation.. I know RAX is dying to have that one ;)
17:37:42 <artom2> rack space?
17:37:44 <betsy> Definitely :)
17:37:56 <betsy> artom2: yes
17:39:10 <kiall> Okay .. So, Graham is still stuck on another call - I know there was some Q's for him around pools etc.. If he's finished up before this, we'll move back to that.. But, for now..
17:39:13 <kiall> #topic Open Discussion
17:39:32 <kiall> So - Anyone else besides myself going to the Summit? :)
17:40:17 <betsy> None of us on the Designate project from Rackspace
17:40:24 <betsy> :(
17:40:47 <kiall> Myself and Patrick will be giving a talk on Designate - I'm going to try and squeeze a "Look how easy this is" demo in there to bring some users on, and a general overview of Designate. But .. Does anyone have suggestions for things to cover?
17:41:08 <kiall> betsy: ah well, will Nicole be over again?
17:41:23 <eankutse> Mention future features - DNSSEC, etc
17:41:25 <betsy> kiall: Nope
17:41:50 <kiall> i.e. what would you guys have found useful to hear at a talk a few months ago :)
17:42:05 <tsimmons> hmmm
17:42:46 <kiall> eankutse: noted. We have a slide on future but.. nothing to much yet
17:42:53 <kiall> nothing too much*
17:43:06 <betsy> Maybe -- Designate represent's the whole stack -- from API to backend and has extentions for different backends (powerdns, Bind)
17:43:11 <tsimmons> I would have liked to see it in action and a solid overview of the architecture.
17:43:39 <betsy> A demo is always the most helpful
17:43:41 <tsimmons> Perhaps focusing a lot on the future, exciting things that folks can get involved in?
17:43:56 <kiall> tsimmons: yea, that's something we didn't cover too well last year (the demo bit), and I plan on doing a demo from Install -> actually serving traffic
17:43:58 <eankutse> Server Pools to enable Private DNS
17:44:22 <tsimmons> kiall: Nice, that would be cool.
17:44:29 <betsy> kiall: So I assume you're demoing v1?
17:44:50 <kiall> betsy: yea.. I'm going to demo using the client, People can't reason JSON from the other side of the room
17:45:24 <kiall> can't read*
17:46:35 <kiall> tsimmons: yea, I think we had a 50/50 mix of dev and users at the talk last year, so we'll try and use the talk to bring both kinds of people in :)
17:47:11 <kiall> so - other than demo, future and architecture overview - anything else that would have been useful a few months back? (or still might be useful?)
17:48:07 <eankutse> Would it be OK to mention who are currently looking into using Designate?
17:48:23 <tsimmons> For people looking to contribute, a slide or two about the available tools, the client, the docs, guides, launchpad links, stuff like that. That's all standard though.
17:48:29 <kiall> Only if those people give explicit permission to myself or patrick saying it's OK
17:49:59 <tsimmons> Would it be helpful to say that RAX was involved?
17:50:13 <kiall> So .. Speaking of permission, if anyone here wants to let us drop your company name/logo onto the slides.. drop me and email saying so - kiall@hp.com :)
17:50:50 <kiall> tsimmons: noted, We'll have a bunch of links to that kinda stuff at the end.. But .. I'm thinking we link to http://designate.readthedocs.org/en/latest/related.html
17:50:50 <kiall> and make sure that list is complete in advance
17:50:50 <tsimmons> kiall: that works.
17:50:50 <kiall> tsimmons: I'd love to, if you guys can get me permission to say/use RAX's name :)
17:51:04 <tsimmons> We'll work on it. Our managers aren't in the meeting...
17:51:14 <kiall> tsimmons: sure :)
17:51:23 <kiall> artom: same goes to you ;)
17:51:24 <betsy> kiall: Yeah. We'll ask them to send you something
17:51:26 <artom> I'll ask around :)
17:51:48 <kiall> Totally OK if the answers from mgmt come back as a NO .. It happens ;)
17:52:32 <kiall> Anyway, If we manage to find enough time to finish the slides this week.. I'll drop a link into the openstack-dns room, hopefully you guys can review for us!
17:52:47 <kiall> So .. Any other topics? or more on this? or .. :)
17:52:51 <eankutse> Cool :-)
17:52:59 <eankutse> looking forward to seeing the slides
17:53:14 <artom> Unrelated to summit, but can I push for a decision re import/export API endpoint?
17:53:25 <artom> Or are we missing too many people today?
17:54:24 <kiall> I think the HP crowd prefer the option for using POST /zones with COntent-Type: text/dns etc
17:54:29 <kiall> what do others think?
17:54:53 <eankutse> Let's go for it
17:54:54 <kiall> (I'm the only HP person here today, everyone else is on holidays or stuck on another call)
17:55:09 <tsimmons> That's the approach I like as well.
17:55:10 <kiall> Okay .. artom .. the current review uses /zonefile/ correct?
17:55:19 <artom> Yep.
17:55:52 <kiall> I *think* the general consensus is to use POST /zones with COntent-Type: text/dns and GET /zones/{id} with Accept: text/dns
17:56:05 <kiall> Let's update it for that, and we'll get it merged ASAP :)
17:56:13 <artom> Awesomesauce.
17:56:20 <artom> I'll start working on the change.
17:56:25 <kiall> Thanks!
17:56:29 <eankutse> Mugsie/Kiall: On Server Pools/Async - Would we be departing from any OpenStack conventions if we rename the Pool Scheduler to "Pool Allocator" or "Pool Assigner" or something along those lines?
17:56:42 <kiall> #action kiall to get slides into openstack-dns room as soon as there done.
17:56:59 <kiall> #action kiall to ping artom / betsy with .deb's when completed tomorrow morning
17:57:19 <kiall> #action artom to update import/export review for POST /zones etc rather than POST /zonefiles
17:57:41 <tsimmons> ^ I wasn't here but I'd like to help with that too if you need it. ( The .deb's)
17:57:57 <kiall> eankutse: Yea, I think the scheduler name is pretty embedded in other openstack projects..
17:58:05 <eankutse> Ok. Thx
17:58:13 <kiall> I actually dislike the name too, but it seems to have stuck elsewhere
17:58:29 <kiall> And, functionally, it's way to similar to nova-scheduler to call it anything else
17:58:48 <eankutse> ok.
17:58:50 <betsy> kiall: Yeah. Even tho it doesn't exactly function as a scheduler, as I think of one
17:58:54 <kiall> tsimmons: great :) I'll ping you too
17:59:04 <betsy> That's what Nova calls it
17:59:44 <kiall> betsy: exactly. Lots of names have been given new meanings within openstack! It's awful, but too late for some things :)
18:00:15 <betsy> kiall: Sad, but true
18:00:50 <kiall> Yup! Okay, Anything else from anywhere else before I close up? Not sure if this room is used now or not :)
18:01:03 <eankutse> done
18:01:05 <betsy> Good luck at the summit!
18:01:08 <artom> I'm not going to the summit, but should I try to get the eNovance people who are going to... I dunno, do something?
18:01:20 <kiall> thanks betsy  :)
18:01:22 <kiall> artom: ehh ..
18:01:25 <kiall> no idea :)
18:01:28 <artom> Hah
18:01:35 <kiall> Get them to come to the talk ;)
18:02:01 <artom> I'll bring the Designate/summit thing up to management, they can figure out what to do.
18:02:03 <betsy> I know other Rackspace folks will be there
18:02:12 <betsy> -- at your talk
18:02:23 <kiall> betsy: cool, the more the merrier :)
18:02:31 <kiall> Okay .. I guess that's it then! Thanks all
18:02:34 <kiall> #endmeeting