16:00:45 <markvoelker> #startmeeting defcore
16:00:46 <openstack> Meeting started Wed Oct  5 16:00:45 2016 UTC and is due to finish in 60 minutes.  The chair is markvoelker. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:49 <eglute_s> o/
16:00:50 <openstack> The meeting name has been set to 'defcore'
16:00:54 <catherine_d|1> o/
16:00:57 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreLunar.21 Today's Agenda
16:01:01 <shamail> Hi everyone
16:01:06 <markvoelker> #chair eglute_s hogepodge
16:01:07 <openstack> Current chairs: eglute_s hogepodge markvoelker
16:01:20 <hogepodge> o/
16:01:23 <brunssen> o/
16:01:24 <GheRivero> o/
16:01:40 <Rockyg> o/
16:02:04 <markvoelker> Hi everyone.  Just a few weeks until Barcelona left!  Let's get to it...
16:02:08 <eglute_s> should we be in 20 not 21?
16:02:27 <gema> o/
16:02:35 <markvoelker> eglute: 20 was last week, no?
16:02:45 <eglute_s> i thought it was 19 last week
16:02:59 <markvoelker> Heh...both pads show the same date
16:03:18 <eglute_s> i created 20 yesterday but didnt change the date
16:03:21 <eglute_s> my bad
16:03:27 <markvoelker> Ah, ok then.
16:03:44 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreLunar.20 Today's Agenda (for real this time)
16:04:14 <markvoelker> #topic 2017.01 Guideline
16:04:29 <markvoelker> If folks could take a quick moment to update their status on the etherpad there please...
16:04:58 <eglute_s> done...
16:05:12 <eglute_s> I would like to talk about Ceilometer!
16:05:26 <markvoelker> eglute_s: the floor is yours
16:05:43 <eglute_s> I talked to the PTL of telemetry, and as my notes indicate, there are a couple issues
16:05:56 <eglute_s> the major one is that they are deprecating Ceilometer API
16:06:09 <eglute_s> #link http://lists.openstack.org/pipermail/openstack-dev/2016-October/105042.html
16:06:21 <Rockyg> yup.  That's why it's interesting
16:06:30 <markvoelker> eglute_s: has that been decided?  I lost the thread yesterday in a barage of meetings and haven't caught up yet.
16:06:31 <eglute_s> if there is no API for it, I don't think we can include it in defcore
16:06:49 <eglute_s> the PTL sounded pretty sure that it has been decided
16:07:26 <eglute_s> but, reading the email, seems like it might be still up for discussion
16:08:16 <markvoelker> Ok.  The basic idea there was that Ceilometer had basically been decomopsed into Aodh/Panko/Gnocchi.  Those are currently not tc-approved-release.
16:08:28 <Rockyg> they've been talking abour it for a while
16:08:54 <markvoelker> Was the PTL aware that we can't consider projects that aren't tc-approved-release?  Are they interested in getting the decomposed projects tagged?
16:09:14 <eglute_s> i told him we cant consider it if there are no APIs
16:09:55 <eglute_s> he didnt seem to be interested in defcore, though he was very helpful
16:10:11 <catherine_d|1> Even with the new APIs ... we still need to wait for adoption and tests to mature?
16:10:11 <shamail> My take was that it is still up for discussion after heat auto-scaling was brought up
16:10:14 <eglute_s> additionally, ceilometer's tests are in tempest plugin
16:10:46 <eglute_s> shamail i do hope it will be discussed more
16:10:50 <Rockyg> I think they are more focused on getting everything lined up and in good shape without ceilometer
16:11:07 <eglute_s> though at this point, since it's future is uncertain, i do not think we should push it forward with scoring
16:11:35 <hogepodge> I'm not so worried about plugins, as we can work on moving tests over if they're good candidates.
16:11:36 <catherine_d|1> don't think it is a good candidate for interop if the project itself does not seem to be stable
16:11:41 <Rockyg> good to wait until at least next cycle
16:11:52 <eglute_s> catherine_d|1, Rockyg i agree
16:12:19 <Rockyg> they are doing good and importannt work, but it's still midflight
16:12:20 <markvoelker> eglute_s: Agreed, but I think we should start evaluating a future path.  E.g. does it make sense to ask for tc-approved-release on some or all of the decomp projects, can tests for them be moved to tempest, etc.
16:12:26 <eglute_s> hogepodge PTL was willing to work on moving the tests, so not too much of an issue
16:12:42 <markvoelker> The answer to all of those might be "no", but we should start that discussion sooner rather than later. =)
16:13:29 <eglute_s> markvoelker i think we should wait for the projects to settle. right now there is too much change going on there in my opinion...
16:13:32 * markvoelker is also curious if heat autoscaling is going to eventually move to senlin, but that's another topic
16:14:17 <eglute_s> for the decomp projects, i think we need to wait to see how the adoption goes
16:14:54 <markvoelker> Are Aodh/Gnocchi/Panko listed in the user survey this time around?
16:14:55 <eglute_s> and what the deprecated API will be replaced with, if it is in fact, deprecated.
16:15:12 <Rockyg> At last gnocchi and aodh are getting good adoption with other opnstack projcts
16:16:59 <markvoelker> So, I think there's a couple of things here then.
16:17:26 <Rockyg> yup.
16:17:30 <markvoelker> First, let's see if we can talk to the user survey folks about making sure Aodh/Gnocchi/Panko get listed (so we can guage adoption down the line)
16:17:49 <eglute_s> i am looking at the survey now and only see Ceilometer
16:17:53 <markvoelker> Second, obviously let's follow the decision around the old Ceilometer API
16:18:46 <markvoelker> Third, once that decision has been reached we should think about future potential paths for Ceilometer.
16:19:02 <Rockyg> anything on telemetry?
16:19:14 <eglute_s> Rockyg no telemetry either.
16:19:24 <markvoelker> E.g. it'd be a shame if they decide next week that Ceilometer goes away and Gnocchi/Aodh/Panko are the future, but nobody even starts work on porting tests or whatnot for six more months
16:19:59 <markvoelker> Make sense?
16:20:04 <Rockyg> ++
16:20:04 <eglute_s> markvoelker yes
16:20:09 * gema sneaks out for dinner, will read logs later o/
16:20:35 <hogepodge> What would be nice is a telemetry api and all the projects could plug in to that. Would make our jobs easier.
16:20:47 <eglute_s> hogepodge ++
16:20:48 <eglute_s> agree
16:20:50 <markvoelker> Ok.  So eglute_s would you be able to handle those AI's for the moment?
16:21:23 <eglute_s> markvoelker yes, i don't think anything is immediate though
16:21:46 <markvoelker> eglute_s: sure, mostly keeping abreast of things at the moment
16:22:01 <eglute_s> i guess user survey is more immediate. i will send some emails :)
16:22:22 <markvoelker> Sounds good.  Thanks!
16:22:37 <markvoelker> #action eglute_s to follow up with user survey folks about telemetry projects
16:22:47 <hogepodge> (speaking of user survey, newest data was just released)
16:23:07 <markvoelker> #action eglute_s will keep abreast of the Ceilometer API deprecation discussion
16:23:29 <markvoelker> Ok, further discussion on Ceilometer?  Or shall we move on?
16:23:32 <eglute_s> hogepodge do you have a link?
16:23:38 <eglute_s> move on!
16:24:05 <markvoelker> shamail: around?
16:24:20 <shamail_> Here!
16:24:32 <markvoelker> Anything to discuss on Cinder?
16:25:25 <shamail_> Not much yet, I got guidance from yourself and hodgepodge on how to start with scoring... I will be reviewing third party sources tonight.  I have a meeting scheduled for Friday with the PTL
16:25:34 <markvoelker> Ok, thanks
16:25:48 <shamail_> I think I bit off more than I can chew for the first time helping but I'll get through it :)
16:26:02 <markvoelker> For those not aware, Cinder may be a little interesting too...they revved the CURRENT API from v2 to v3 in Mitaka.
16:26:45 <markvoelker> (functionally the same, but with microversions...but v3 was completely undocumented until a few weeks ago, so adoption possibly not great right now...)
16:27:06 <markvoelker> Anything else on Cinder?
16:27:22 <shamail_> Not at the moment
16:27:40 <markvoelker> Ok, next up: Glance
16:28:05 <catherine_d|1> markvoelker: the current Cinder tests in DefCore guideline is based on v2 right?
16:28:12 <hogepodge> catherine_d|1: right
16:28:14 <markvoelker> I've spoken with the PTL and should have a patch up today-ish.  Got delayed last week by a ridiculous pile of pre-summit stuff that's piling up.
16:28:34 <hogepodge> if it's just a microversion with guaranteed backwards compatibility, it may not be a problem
16:28:47 <markvoelker> Barring objections I'll probably also be submitting a governance patch to add glance_store as tc-approved-release
16:28:54 <catherine_d|1> I would imagine there will be a conf parameter to set v2 vs v3 just like Keystone in tempest.conf
16:29:00 <markvoelker> And then consider adding the non-driver bits of it as designated sections
16:29:06 <Rockyg> same for cindr except for possible additions
16:29:37 * markvoelker switches back to Cinder for a moment since it seems I moved on too quickly
16:30:17 <markvoelker> So, one thing to bear in mind with Cinder is that 2017.01 will include Liberty (in whcih v3 didn't exist)
16:30:25 <catherine_d|1> it tool us a cycle or two to drop v2 Keystone tests from the must-pass list .. I guess we will do the same for Cinder?
16:30:41 <catherine_d|1> tool --> took
16:31:08 <markvoelker> So basically we'll need to consider how that transition will work and when/if we switch guidelines to v3
16:31:57 * catherine_d|1 API version change really does not help Interop
16:31:57 * markvoelker sees he and catherine_d|1 are thinking along similar lines here
16:32:37 <Rockyg> yup.  api revs are bears
16:32:42 <markvoelker> Also worth noting: there's nothing that says both API's can't be required in the same Guideline, so it's not like there has to be an either/or.  v2 is not DEPRECATED, it's SUPPORTED
16:33:06 <Rockyg> exactly
16:33:14 <markvoelker> But I'll leave it to our Cinder point folks (hi shamail_ !) to come up with proposals to discuss.
16:33:37 <Rockyg> I'm not sur we've even managd the nova tests for that all that wll.
16:34:03 <markvoelker> OK, anything else on Cinder?
16:34:05 <Rockyg> We've just let th nova team gnerate the tests as they see fit
16:34:08 * markvoelker pauses a little longer this time
16:34:24 <hogepodge> it appears that v3 will be backwards compatible with v2 because microversions
16:34:35 <hogepodge> (confirmed with cinder devs)
16:34:48 <shamail_> I'll confirm when I meet
16:34:53 <shamail_> Ah ok
16:34:54 <hogepodge> so this should not be a major issue for us. v3 should just work with interop tests
16:34:58 <catherine_d|1> hogepodge: that is good news ..
16:35:29 <hogepodge> (that's assuming the host api supports an early enough microversion, but that's the case with all microversion apis)
16:36:36 <markvoelker> Move on?
16:36:45 <hogepodge> yes
16:36:47 <Rockyg> yeah
16:37:00 <markvoelker> Ok, back to Glance: see above.  Any questions there?
16:38:03 <eglute_s> looks good to me
16:38:07 <markvoelker> Hearing none, let's move on to Heat.
16:38:16 <markvoelker> catherine_d|1: what's the word? =)
16:38:50 <catherine_d|1> I added a summit session request to the Heat team after contact the PTL
16:38:50 <markvoelker> Sounds like we're mostly in the same boat as last time where we don't have good tests in Tempest?
16:39:18 <catherine_d|1> yes
16:39:47 <catherine_d|1> basically need the Heat team to put priority to move the tests to Tempest
16:41:05 <catherine_d|1> that all for Heat ..
16:41:18 <markvoelker> Ok.  We may also want to discuss/think through whether the API alone is all we want to define capabilities for down the road.
16:41:23 <catherine_d|1> Heat summit eitherpad https://etherpad.openstack.org/p/ocata-heat-sessions
16:41:46 <markvoelker> Heat's a little different than some projects in that we might want to define capabilities that test support for various resources in templates, for example.
16:41:56 <hogepodge> heat is kind of a funny case because the api doesn't do a whole lot, most of the action is in the templates with is heavily deployment dependent.
16:42:08 <markvoelker> hogepodge: exactly.
16:43:08 <markvoelker> I'll defer to catherine_d|1 on figuring out a proposal around how to deal with that though, since she's playing point and I have way too much on my hands as it is. =)
16:43:18 <catherine_d|1> resources may not be capabilities that should be scope for interop ... but those ae discussion we can bring up
16:43:56 <markvoelker> Ok, anything else on Heat?
16:43:59 <hogepodge> it's the case for scenario testing
16:44:05 <hogepodge> nothing more from me
16:44:13 <catherine_d|1> that is it from me
16:44:23 <markvoelker> Ok, moving on then
16:44:27 <markvoelker> Next up is Keystone
16:44:51 <markvoelker> Last week hogepodge asked for some help here, and I've sent an email to the PTL and started (barely) digging in to look for capabilities
16:45:08 <markvoelker> Not a lot to report here this week I guess, unless hogepodge has any updates
16:45:48 <markvoelker> Any questions/comments on Keystone?
16:46:01 <hogepodge> I don't, I can begin to look again next week. My backlog and lingering illness has buried me for the short term
16:46:22 * markvoelker hopes hogepodge feels better soon and will continue to work on this too
16:46:52 <markvoelker> Ok, time's short...let's move on to nova
16:46:59 <markvoelker> shamail_: that's you again
16:47:16 <markvoelker> or shamail: whichever of you is actually Shamail today. =)
16:47:44 <markvoelker> Looks like you're meeting with the PTL tomorrow?
16:48:01 <shamail_> Hi, Nova is same status as Cinder.  I have a meeting scheduled with the PTL tomorrow.
16:48:20 <markvoelker> Ok, thanks.  Anything else?
16:48:52 <shamail_> I am going to be looking at sources tonight
16:48:52 <shamail_> Yes, that's the plan (and hopefully go in prepared)
16:49:36 <markvoelker> Ok.  If nothing further, let's move on to Neutron
16:49:46 <markvoelker> which is me again
16:50:10 <markvoelker> I spoke with the PTL and did some looking myself too.  The TC approved adding neutron-lib to tc-approved-release
16:50:15 <markvoelker> I have a scoring patch up here:
16:50:23 <markvoelker> #link https://review.openstack.org/#/c/381393/ Neutron scoring patch
16:50:46 <markvoelker> There's one additional capability I'm still looking at that's a bit more recent
16:50:57 <markvoelker> But the existing patch there is pretty simple.
16:51:06 <markvoelker> Have a look and feel free to start discussing anytime
16:51:22 <markvoelker> Questions/comments on Neutron right now?
16:51:30 <shamail_> Not at the moment
16:51:35 <eglute_s> not right now...
16:51:49 <markvoelker> Ok then, on to Swift.  eglute_s: that's you!
16:51:55 <eglute_s> markvoelker should we wait to review your patch on neutron?
16:51:56 <notmyname> oh hai
16:52:08 <markvoelker> eglute_s: nah, go ahead and start commenting.
16:52:10 <eglute_s> notmyname did a lot of work on swift!
16:52:20 <eglute_s> #link https://gist.github.com/notmyname/102e4aba7084598638f47cee47f62bb1
16:52:25 <eglute_s> i have not had a chance to review it.
16:52:35 <eglute_s> once I do, i will start scoring
16:52:55 <eglute_s> i am sure i will need help with scoring
16:53:09 <notmyname> please work with me as you go through that. I'm happy to help clarify my intent, etc
16:53:27 <notmyname> there's some new things, yeah, but also som renames and better classifications for existing stuff
16:53:32 <eglute_s> notmyname i will! and really appreciate your help
16:53:35 <markvoelker> Cool.  Sounds like you and notmyname are making good progress.
16:53:43 <eglute_s> mostly notmyname yes, :)
16:53:51 <markvoelker> When do you think we can expect to see a patch up?
16:54:19 <eglute_s> hopefully by friday. I am swamped by some other things, so not sure how much time i will have today
16:54:42 <notmyname> so, as an asside, something that the defcore team could produce that would be *super* helpful would be a script that lists current capabilites and tests (i wrote my own) and then correlates that with what's available in tempest (I did that part by hand)
16:54:44 <markvoelker> Ok, I'll keep an eye out.  Remember, first rev doesn't need to be perfect, just needs to be enough to kickstart discussion in gerrit
16:55:08 <eglute_s> notmyname can you share the scripts with us?
16:55:18 <markvoelker> I think catherined|2 did something like that a while back maybe?
16:56:13 <catherine_d|1> yea I did that a few cycle ago ... strictly by name ... not very accurate ...
16:56:15 <notmyname> this is all I have https://gist.github.com/notmyname/586fab93aab607d36b2bc6861b638afb
16:56:38 <eglute_s> thank you notmyname
16:56:43 <notmyname> the .sh is run from inside a tempest directory
16:57:17 <markvoelker> Ok gang, down to the last couple of minutes unfortunately
16:57:18 <notmyname> gives every test name found, what file it's in, and its idempotent id
16:57:32 <eglute_s> notmyname that looks good!
16:57:44 <notmyname> then I used some nice features of sublime text to clean it up
16:58:07 <notmyname> thus resulting in the original gist i sent you (or that's what i used to do the capabilities correlation)
16:58:10 <markvoelker> Certainly worth looking over for folks who are still test hunting
16:58:25 <markvoelker> Two quick notes before we have to close for today
16:58:31 <hogepodge> notmyname: I write that script all the time  :-D
16:58:38 <markvoelker> #topic Summit Planing
16:58:43 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreBarcelona Summit Planning pad
16:59:06 <markvoelker> If you have any other topics, get them on that pad today.  We'll start hammering out the agenda shortly.
16:59:24 <markvoelker> And lastly
16:59:30 <markvoelker> #topic RefStack Updates
16:59:45 <markvoelker> #link https://etherpad.openstack.org/p/refstack-ocata-summit RefStack Planning pad
17:00:08 <markvoelker> Please take note of the RefStack pad and add topics if necessary
17:00:13 <markvoelker> And with that, we're all out of time
17:00:22 <markvoelker> Over to #openstack-defcore
17:00:25 <markvoelker> Thanks!
17:00:28 <markvoelker> #endmeeting