16:02:06 <eglute> #startmeeting defcore
16:02:06 <openstack> Meeting started Wed Sep 14 16:02:06 2016 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:11 <openstack> The meeting name has been set to 'defcore'
16:02:11 <markvoelker> o/
16:02:17 <eglute> #chair markvoelker hogepodge
16:02:18 <openstack> Current chairs: eglute hogepodge markvoelker
16:02:33 <eglute> #topic agenda
16:02:36 <eglute> #link https://etherpad.openstack.org/p/DefCoreLunar.17
16:02:51 <eglute> Morning everyone, please review the agenda and add/update as needed!
16:03:02 <catherine_d|1> o/
16:03:07 <tongli> o/
16:03:21 <shamail> Hi everyone
16:03:33 <eglute> #topic summit
16:04:01 <eglute> hogepodge where you able to get us time for working group session?
16:04:19 <hogepodge> egallen: I submitted the request, and I'll hear back once the scheduling is completed
16:04:35 <eglute> great, thank you!
16:04:45 <hogepodge> I asked for Tuesday PM by popular request
16:04:56 <eglute> do we need to do anything else besides wait?
16:05:14 <hogepodge> I don't think so.
16:05:26 <eglute> great, thank you
16:05:35 <eglute> #topic 2017.01 Guideline
16:05:50 <eglute> markvoelker, want to take this?
16:05:54 <markvoelker> Sure
16:05:58 <eglute> thank you!
16:06:16 <markvoelker> So, hopefully folks who were not familiar with the scoring process or needed a refresher were able to attend the how-to session last week
16:06:27 <markvoelker> If not, be sure to check out:
16:06:36 <markvoelker> #link https://plus.google.com/events/cuejgn5k8keg0j0c11qi3k4j15c Scoring Intro Session
16:06:57 <markvoelker> If you've done this before, nothing really new here...the process is pretty well established now.
16:06:59 <eglute> thanks hogepodge for preparing the slides and doing the presentation!
16:07:10 <markvoelker> What we need to do now is get people signed up to play point on the various projects
16:07:29 <markvoelker> There's a signup form in today's etherpad, so please jump in
16:07:39 <markvoelker> I'll send out a note to the ML as well
16:07:57 <markvoelker> Remember that you're not actually doing this all alone
16:08:00 <eglute> thanks markvoelker!
16:08:28 <markvoelker> Your job is to make a start by sending up an initial proposal, and then the rest of the committee will help with the final evaluation via gerrit
16:08:36 <shamail> +1, thanks hogepodge
16:08:44 <markvoelker> (which might involve changing the initial scores, adding new capabilities, etC)
16:09:06 <markvoelker> So, think of this is "you're volunteering to make the initial pass"
16:09:47 <markvoelker> One thing that's a little new this time: there's been some interest in Heat as a separate component
16:09:53 <hogepodge> markvoelker: do we have a deadline for getting the initial pass sent up? (as someone who is oversubscribed I've found deadlines to be a good motivator)
16:10:16 <eglute> September 21
16:10:27 <eglute> that means 2 weeks from today
16:10:36 <eglute> err
16:10:39 <eglute> I cannot math
16:10:44 <catherine_d|1> markvoelker: The issue with Heat is still on test coverage .. I will request for a Heat design session at Barcelona
16:10:47 <eglute> one week. is that enough time?
16:10:50 <eglute> i am guessing not
16:11:34 <markvoelker> Well, we have until Oct 12th to get scoring finished so if we need to bleed over a bit we can...but generally we need to get this underway ASAP
16:12:01 <markvoelker> 2016.08 was a pretty major change with networking coming in--I suspect this time will be a bit less exciting. =)
16:12:21 <eglute> markvoelker i think keeping it less exciting would be good!
16:13:22 <markvoelker> catherine_d|1: Yes, that could potentially be a big landmine.  Part of what I'd like us to do this time around is understand if we'd actually have test coverage for meaningful capabilities yet.  If not, this should be a short exercise.
16:13:53 <markvoelker> (as a reminder folks: the TC has asked us to only consider Temepst tests--not in-tre tests--when evaluating, so projects with limited coverage in Tempest are at a disadvantage)
16:14:18 <markvoelker> Or put another way: they have some work to do to migrate tests before we can really meaningfully include them.
16:14:52 <catherine_d|1> markvoelker: exactly... on last check not (Heat) test get into Tempest yet ...and that would be the topic for the design session wewill  request
16:15:56 <catherine_d|1> markvoelker: however, they are working on implementing the Tempest plugin interface which is the first step
16:16:09 <markvoelker> Ok, so let's see if we can get folks signed up....feel free to volunteer for more than one project if you wish and have bandwidth.
16:16:15 <markvoelker> Also
16:16:24 <hogepodge> yes, please work with teams and qa on migrating tests if they want them to be considered
16:16:41 <markvoelker> When we start sending in patches, some of those may end up proposing changes to next.json (if we discover new capabilities that should be added)
16:16:54 <markvoelker> So we need to do a bit of housekeeping to get next.json ready to receive updates
16:17:01 <markvoelker> I have a patch up for that:
16:17:10 <hogepodge> Also, be mindful that this could be a hard sell. Asking teams to move part of the CI and project code may come across as presumptuous.
16:17:12 <markvoelker> #link https://review.openstack.org/#/c/367066/ Clean up next.json
16:18:06 <eglute> markvoelker did you use 2016.08 for creating next.json?
16:18:11 <markvoelker> hogepodge: I've run across a couple of folks who were somehow unaware of the TC resolution on this, by the way...so it's good to point out that it's a TC directive, not ours.
16:18:22 <markvoelker> eglute: yes, this patch reconciles the differences between them
16:18:29 <eglute> great, thank you!
16:18:42 <markvoelker> eglute (see item 1 in the commit message)
16:19:06 <markvoelker> Ok, anything further on scoring?
16:19:10 * eglute reads commit message
16:19:25 <hogepodge> markvoelker: yes, that's true. there's also a burden on us to convince project leadership that it's worth participating in defcore/interop
16:20:16 * hogepodge is just relaying some of the understandable pushback he's felt over the last month or so
16:20:32 <Rockyg> we might ge some movement/discussion if we score out of tempest capabilities
16:20:42 <hogepodge> #link http://git.openstack.org/cgit/openstack/governance/tree/resolutions/20160504-defcore-test-location.rst
16:21:09 <hogepodge> anyway, sorry to distract from the review at hand
16:22:25 <markvoelker> hogepodge: nope, that's good stuff to be aware of =)
16:22:33 <markvoelker> Ok, if nothing further on scoring, let's move on
16:22:43 <markvoelker> #action markvoelker Send email about scoring signups
16:23:00 <markvoelker> #topic Name change updates (if any)
16:23:33 <markvoelker> hogepodge: So this one's sort of lower in the priority queue, but I guess we need to do some coordination with the Foundation on changing things up on Foundation websites
16:23:50 <markvoelker> Should we maybe corner someone for a hallway chat in Barcelona or something?
16:24:29 <hogepodge> markvoelker: sure, that sounds good.
16:24:31 <shamail> We can talk to Jimmy most likely…
16:24:44 <eglute> i think hogepodge and shamail were going to come up with a list of things as well
16:24:49 <hogepodge> shamail: let's get on a call today or tomorrow to do the initial work list
16:25:14 <shamail> hogepodge: tomorrow is better, lets decide on the time when we are on the phone for the next meeting
16:26:07 <markvoelker> Ok, sounds like you guys can work on that one offline. =)  NExt topic?
16:26:13 <eglute> yes!
16:26:33 <eglute> #topic DT Public Cloud
16:26:40 <eglute> hogepodge, all yours!
16:26:52 <hogepodge> I wanted to bring attention to a public cloud that's working on the interoperability tests
16:27:02 <hogepodge> The mailing list has most of the relevant issues.
16:27:08 <eglute> good discussion on the mailing list!
16:27:46 <hogepodge> There are a couple of tests I'd like to work on that make some pre and post condition assumptions about the test environment, but I'm working with the team to help them resolve the rest of the outstanding API issues
16:27:58 <hogepodge> I'm not sure if anyone from the DT team is here and wants to expand
16:28:47 <eglute> hogepodge, would changing the glance tests help with the issue?
16:29:22 <Rockyg> I'm here, and I loved hogepodge's response to monty
16:29:22 <hogepodge> eglute: in some instances changing the tests would work. for example, one failure is in testing volume attachments
16:30:02 <hogepodge> eglute: so if a vm is booted from volume, it will show an extra volume attachment because the assertion that there are zero at boot is false in that case
16:30:03 <Rockyg> I'm not on DT team, but clos to all of it
16:30:48 <hogepodge> eglute: in others, the downstream code needs to change, because if you're "booting from image id" but then you can't list the vms booted from that id, the API abstraction is leaking
16:31:21 <eglute> i liked hogepodge response to monty as well, but i am not sure of the impact. how many tests would need to be flagged?
16:31:55 <hogepodge> eglute: I'm hoping zero tests, and two or three modified (perhaps during the next week at the qa mid-cycle)
16:32:13 <Rockyg> The ral issue in most instancs is fixing the code itself to fully impement the abstraction of boot my vm
16:32:48 <catherine_d|1> This is sort of like "give me an external network"
16:32:57 <Rockyg> I think we need to file som bugs against the missing/divergent code
16:33:03 <hogepodge> I'm bringing this discussion up in the interest of transparency and community engagement too, so we can have an understanding of what a large public vendor is facing.
16:33:17 <catherine_d|1> in this case "boot a VM for me" should be the upper abstraction layer
16:33:51 <Rockyg> Yup.  different ways of booting is sort of like flavors.  Do you want to boot fast?  Save state? start from clean slate?
16:34:05 <catherine_d|1> whether boot from image or volume should be configurable parameters
16:34:27 <Rockyg> ++
16:34:58 <catherine_d|1> end-user should not care about the backend storage
16:35:30 <Rockyg> enterprise and providers could favor boot from volume because all the info is in the assigned storage.  It doesn't go away when the vm is gone
16:35:38 <catherine_d|1> backend storage would be the differentiator that the vendors want to advertise
16:36:30 <Rockyg> right.  type of boot prferred is part of type of workload.
16:37:23 <markvoelker> Ok, anything further to talk about on this one right now?
16:37:26 <eglute> i agree that it should be a bit more abstracted.
16:38:06 <eglute> hogepodge Rockyg can you let us know if you expect to flag some tests?
16:38:24 <hogepodge> eglute: yes, we will definitely do that
16:38:24 <eglute> if no flagging is needed, that is of course ideal
16:38:45 <Rockyg> I will.  But, as hogepodge said, some could be rseolved at midcycle
16:38:46 <hogepodge> eglute: the community and working group review process for flagging is important
16:39:09 <eglute> agreed
16:39:34 <Rockyg> I think we may be all right, but as DerfCore, we should broadcast our thinking about fixing the abstraction
16:40:07 <eglute> perhaps the discussion could be shared on the dev mailing list as well
16:40:24 <eglute> or a new one started
16:40:28 <Rockyg> sounds good.
16:40:59 <Rockyg> should we expand to dev list or ops list?
16:41:09 <eglute> both!
16:41:57 <eglute> if there is nothing else, looks like we can end early
16:42:07 <eglute> catherine_d|1 do you have anything refstack related?
16:42:54 <catherine_d|1> eglute: thank you for your review on the RefStack spec
16:43:10 <catherine_d|1> It would be nice to have a few more +1s :-)
16:43:21 <eglute> can you post links again?
16:43:35 <catherine_d|1> https://review.openstack.org/#/c/343954/
16:43:39 <hogepodge> #topic refstack updates
16:43:55 <eglute> #action everyone review https://review.openstack.org/#/c/343954/
16:43:57 <catherine_d|1> and https://review.openstack.org/#/c/332260/
16:44:08 <catherine_d|1> eglute: thank you!
16:44:18 <eglute> #action everyone review https://review.openstack.org/#/c/332260/
16:44:25 <eglute> thanks catherine_d|1!
16:44:31 <eglute> anything else?
16:44:38 <eglute> #topic open floor
16:45:12 <eglute> looks like we can end early. thanks everyone!
16:45:22 <eglute> #endmeeting