16:01:37 <hogepodge> #startmeeting defcore
16:01:37 <openstack> Meeting started Wed Sep  7 16:01:37 2016 UTC and is due to finish in 60 minutes.  The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:41 <openstack> The meeting name has been set to 'defcore'
16:01:48 <hogepodge> #chair markvoelker eglute
16:01:49 <openstack> Current chairs: eglute hogepodge markvoelker
16:01:50 <eglute> o/
16:01:52 <markvoelker> o/
16:01:56 <catherine_d|1> o/
16:02:00 <shamail> o/
16:02:04 <hogepodge> #topic agenda and roll call
16:02:13 <eglute> #link https://etherpad.openstack.org/p/DefCoreLunar.16
16:02:14 <hogepodge> #link https://etherpad.openstack.org/p/DefCoreLunar.16
16:02:24 <hogepodge> I'll let egle and markvoelker take it from here :-D
16:02:31 <markvoelker> hogepodge: =p
16:02:51 <markvoelker> Well hogepodge, I think the first agenda item is you actually. =)
16:03:00 <eglute> :D
16:03:13 <hogepodge> #topic Working Group Preferred Time for Barcelona
16:03:26 <hogepodge> The topic speaks for itself. I'm going to submit a request for a working group session.
16:03:34 <hogepodge> Time and space is tight, so we'll likely only get one.
16:03:38 <Rockyg> o/
16:03:48 <eglute> I would prefer Tuesday afternoon i think!
16:04:00 <hogepodge> Our choices are Tu/W/Th and AM/PM
16:04:28 <markvoelker> I'd prefer "not Thursday" personally.
16:04:33 <shamail> W, PM
16:04:35 <markvoelker> Other than that I'll make adjustments.
16:05:09 <eglute> Same here, not Thursday would be great :)
16:05:27 <hogepodge> Can everyone put +1 and -1 in the etherpad as a vote?
16:05:43 <hogepodge> And I'll file for the best time from there.
16:05:54 <markvoelker> hogepodge: Do we need a Doodle poll, or do we need to move faster than that?
16:06:11 <markvoelker> Doh...disconnected a sec there and missed that last comment
16:06:13 <markvoelker> Etherpad it is
16:06:18 <hogepodge> I guess doodle could work too, I've never really set one up before
16:06:41 <eglute> doodles are easy, but ehterpad now works great
16:06:48 <markvoelker> hogepodge: nah, don't worry about it.  I think we're good with the pad.
16:07:08 <hogepodge> That's it for me, I'll put in the request once the meeting winds down
16:07:19 <hogepodge> #action hogepodge to request working group time at summit
16:07:23 <markvoelker> hogepodge: thanks
16:07:38 <markvoelker> #topic Name Change (hogepodge/shamail)
16:07:39 <eglute> thank you hogepodge
16:07:40 <hogepodge> I request two slots, but no promises
16:07:55 <eglute> thanks!
16:08:03 <markvoelker> hogepodge/shamail: take it away
16:08:14 <hogepodge> shamail and I volunteered for this last week, but I haven't moved it forward yet
16:08:24 <hogepodge> shamail: how about you?
16:08:28 <shamail> Negative
16:08:43 <shamail> The plan is to setup an etherpad and then hogepodge and I will add all the items we think need to be modified
16:08:47 <shamail> then divide/conquer
16:09:05 <eglute> works for me
16:09:07 <hogepodge> and create work items in launchpad so we can track them and delegate as necessary
16:09:08 <shamail> and also set some items as “priority” (more visible aspects) since we will be announcing the name change at Barcelona
16:09:18 <shamail> hogepodge: +1
16:09:28 <markvoelker> 'k.  FYI https://review.openstack.org/#/c/327086/ is out there with some doc updates if you want to add that to whatever etherpad.
16:09:30 <Rockyg> storyboard is now connectd to gerrit...just saying
16:09:54 <shamail> Thanks markvoelker, we’ll go through that as a starting point
16:10:00 <shamail> good point Rockyg
16:10:05 <hogepodge> Rockyg: I'm a bit suspicious of storyboard after having been burned by moving refstack to it last year
16:10:19 <hogepodge> then the project being abandoned
16:10:36 <Zara> aw, it's changed a lot in the interim. :)
16:10:59 <emagana> I just wanted to say hi everybody!
16:11:08 <eglute> hello emagana!
16:11:34 <emagana> eglute: Hey, I trust you are doing great.
16:11:35 <markvoelker> #action hogepodge/shamail to work on enumerating work for name change
16:11:43 <shamail> hi emagana
16:11:47 <hogepodge> but, IMO, that could be a post-summit work item if we want to move to a different tracker
16:11:54 <markvoelker> hogepodge: ++
16:11:54 <emagana> shamail: Hi buddy!
16:12:21 <markvoelker> Ok, anything further on the name change then?
16:12:30 <shamail> Nothing from my end for now
16:12:48 <markvoelker> #topic 2017.01 Guideline
16:13:13 <eglute> I put together a quick reading list... anything missing from it?
16:13:41 <eglute> and by quick, i dont mean that the reading will be quick :)
16:14:09 * shamail thought he was done with homework by now
16:14:24 <eglute> shamail, you asked for it :D
16:14:28 <Rockyg> Beklieve it or not, it was longer ago than last year, hogepodge and there is a team workin on it now. Plus, its a short term task
16:14:28 <markvoelker> eglute: Looks like a reasonable starting point.  hogepodge, I was out at a conference last week but thanks for volunteering to lead a how-to session
16:14:58 <markvoelker> #link http://doodle.com/poll/gucmhwpcu9sqv65n Poll for intro-to-creating-guidelines session date
16:15:12 <eglute> hogepodge volunteered to hold a session on creating next guideline. We will attempt to record it
16:16:09 <markvoelker> One very important thing to keep in mind folks: we usually use a divide-and-conquer approach where we get volunteers to play point on identifying new capabilities for each of the projects.
16:16:17 <markvoelker> So be thinking about what you'd like to volunteer for
16:16:58 <eglute> we hope to have a lot of volunteers after hogepodge session!
16:17:26 <markvoelker> I have a patch locally that I need to push up with a few changes to next.json to get ready for the next Guideline...I'll do that this afternoon.
16:17:34 <eglute> thank you markvoelker
16:17:36 <markvoelker> We need to start cracking on IDing new capabilities soon though.
16:18:19 <Rockyg> are we going to score Trove?
16:18:27 <markvoelker> I'd suggest that after hogepodge's session we assign volunteers and start work so folks know what tehy're signing up for.
16:18:49 <eglute> hogepodge proposed that the 2017.01 guideline would be a bit lighter than the 2016.08
16:18:57 * amrith wonders what 'scoring trove' means
16:19:12 <eglute> amrith, attend the session: http://doodle.com/poll/gucmhwpcu9sqv65n
16:19:48 <eglute> in short, scoring is to determine whether trove is ready to be added to defcore
16:20:18 <amrith> what are the 'criteria'?
16:20:31 <eglute> reading list: https://etherpad.openstack.org/p/DefCoreLunar.16
16:20:41 <catherine_d|1> markvoelker: will the next.json be based on 2016.08?  They are very different now ...
16:20:46 <hogepodge> amrith: we take a look at the public apis and evaluate their adoption, stability, and so on, then determine if they can be considered as part of the guideline for an openstack powered project
16:20:46 <markvoelker> amrith: attend the session to find out. =)  Or read: https://github.com/openstack/defcore/blob/master/doc/source/process/CoreCriteria.rst
16:21:12 <markvoelker> catherine_d|1: yes, the patch I was working on locally reconciles them.
16:21:24 <catherine_d|1> markvoelker: +1
16:21:34 <eglute> thanks markvoelker and hogepodge for summarizing, much nicer than me sending the whole laundry list of links to read :)
16:21:42 * markvoelker spends too much time on aeroplanes nowadays where using git is a pain and thus has more local patches than he'd like at the moment
16:22:30 * eglute is impressed markvoelker can get work done on planes
16:22:56 <amrith> markvoelker, eglute when will the actual meeting time be decided? I've voted on the doodle but realize that one of the options is tomorrow
16:23:35 <eglute> amrith will decide soon after this meeting i think
16:23:40 <markvoelker> amrith: I believe hogepodge was going to close that out this afternoon
16:23:51 <eglute> i will send out calendar invite to defcore mailing list
16:23:58 <amrith> is there a mailing list which will be notified?
16:24:03 <amrith> or is it openstack-dev
16:24:12 <eglute> amrith are you subscribed to defcore-committee@lists.openstack.org
16:24:26 <amrith> this is literally the first I've heard of it and only because Rockyg mentioned the word 'trove'
16:24:30 <amrith> eglute, likely no
16:24:36 <amrith> but I can check
16:24:49 <eglute> ok, we should probably send the invite to other mailing lists then too :)
16:25:06 <shamail> eglute: +1, best place to find new recruits is outside the current base
16:25:12 <amrith> thanks Rockyg for mentioning the word trove here
16:25:29 <amrith> does defcore have designated project liaisons?
16:25:30 <Rockyg> Np ;-)
16:25:35 <amrith> sorry if I'm derailing your meeting
16:26:05 <hogepodge> amrith: we usually assign liaisons around scoring time
16:26:14 <hogepodge> which is around now
16:26:16 <markvoelker> amrith: yes and no.  Not permanent ones, but with each scoring cycle someone plays point for scoring each project, so that person becomes the "liaison" for that round of scoring.
16:26:18 <Rockyg> No one "designated", but PTLs usually gt notified...
16:26:41 <eglute> amrith, good questions! we have a light agenda today, so appreciate questions
16:26:43 <amrith> well, i'm the trove ptl so I guess I was notified as 12:18:17 today in IRC
16:27:10 <markvoelker> Speaking of which.... =)  My plan is that after hogepodge's session I'll start signing up volunteers via an etherpad.  So be ready to volunteer by the end of the week, please.
16:27:36 <markvoelker> #action: defcore-committee be ready to volunteer for scoring a project (or two) this week.
16:27:40 <eglute> markvoelker great idea on etherpad. we can start one before the session too
16:28:14 <markvoelker> Sure, I'll put one up and send it over to hogepodge...but I'd like to have him do the session first so folks know what they're signing up for.  It's not a trivial amount of work.=)
16:28:34 <eglute> markvoelker agree, would like to share it at the end of the session :)
16:29:17 <markvoelker> Ok, anything else to discuss about this right now?
16:29:44 <eglute> other than we are on a shorter than usual timeline for this guideline
16:30:10 <amrith> one last question. is there something that I should prepare for, given that this meeting to score trove is like tomorrow or the day after? I'd like to help you with information to make the decision but given the short notice, could I request one of you to volunteer to give me a crash course on this thing, after your meeting please. markvoelker ... would you?
16:30:37 <markvoelker> amrith: we won't be scoring Trove this week.  That meeting is just an intro to the scoring process
16:30:43 <eglute> amrith the session is meant to be an intro into scoring.
16:30:52 <amrith> oh, good
16:30:56 <amrith> that answers the question
16:30:57 <amrith> thanks!
16:31:01 <markvoelker> Sure thing
16:31:15 <markvoelker> Ok, moving along to our last agenda item...
16:31:19 <markvoelker> #topic Reviews
16:31:21 <eglute> amrith we would like to have everything scored by October 12
16:31:22 <markvoelker> #link https://review.openstack.org/#/c/366360/
16:31:47 <amrith> thx, lmk how I can help with trove. sorry to interrupt your meeting
16:31:50 <markvoelker> catherine_d|1 do you want to speak to this?  Anything we need to know other than "please review it"? =)
16:31:59 <markvoelker> amrith: no worries, and thanks
16:32:08 <catherine_d|1> I put that oon WIP until the tempest patch merges
16:32:44 <catherine_d|1> I did not add next.json on the patch because I feel like we need a new next,json and markvoelker: is working on it
16:33:18 <markvoelker> catherine_d|1: yep.  I'll get that posted later today and we can go from there...if it lands before the Tempest patch we can just ammend this one with another patchset and include it there.
16:33:21 <catherine_d|1> basically Tempest moves some of the tests to a different file and thus the name will change and need aliases
16:33:36 <catherine_d|1> markvoelker: sure
16:34:10 <catherine_d|1> It is nice the the Tempest folk actually alert us on such change ... good team work
16:34:19 <eglute> indeed!
16:34:26 <markvoelker> ++
16:34:30 <markvoelker> Ok, anything else today folks?
16:34:59 <eglute> i am good! I will send the calendar invite for hogepodge session later today
16:35:06 <catherine_d|1> thank you all for reviewing the Refstacj patches ...
16:35:28 <catherine_d|1> I know we have too many revision ... please stay with us
16:35:31 <eglute> catherine_d|1 do you have anything refstack related to review for us today?
16:35:44 <catherine_d|1> still the same 2 patches :-(
16:36:19 <catherine_d|1> https://review.openstack.org/#/c/343954/ and https://review.openstack.org/#/c/332260/
16:36:26 <eglute> thanks catherine_d|1
16:36:28 <markvoelker> I'm delinquent on reviewing those since I've been out at conferences most of the past two weeks, so I'll try to make a point to do that today or tomorrow
16:36:50 <catherine_d|1> markvoelker: thank you!
16:37:11 <markvoelker> Anything else?  If not, looks like we may actually get to wrap up early for a change...
16:37:12 * markvoelker 's mind is blown
16:37:25 <mugsie> just one quick question
16:37:32 <eglute> mugsie go for it!
16:37:41 <mugsie> how are projet chosen for being scored?
16:37:45 <mugsie> projects*
16:38:02 * amrith tunes in again
16:38:20 <markvoelker> I believe hogepodge will cover that as well. =)  But basically we look at how the project stacks up to the Criteria.
16:38:26 <markvoelker> Usually a good indicator is adoption
16:38:31 <eglute> #link https://github.com/openstack/defcore/blob/master/doc/source/process/CoreCriteria.rst
16:38:31 <mugsie> OK
16:38:42 <markvoelker> (b/c if a project is poorly adopted it tends to score low on a lot of other criteria generally)
16:38:42 <amrith> hello mugsie maybe you should register for http://doodle.com/poll/gucmhwpcu9sqv65n
16:38:46 <mugsie> so what projects are on the list then?
16:38:46 <Rockyg> Also maturity.
16:39:13 <markvoelker> And for those not aware, we're currently only scoring tc-approved-release projects.
16:39:20 <eglute> mugsie do you have a particular project in mind?
16:39:31 <mugsie> markvoelker: whick only this committee can add projects too
16:39:43 <markvoelker> Nope, that's a TC decision not ours.
16:39:44 <Rockyg> nova, glance, keystone, neutron, cinder, swift.
16:40:01 <markvoelker> Rockyg: no, it's more than that.  https://governance.openstack.org/reference/tags/tc-approved-release.html
16:40:40 <mugsie> OK., its a little clearer
16:40:41 <Rockyg> no, I'm talking about current defcore included projcts
16:41:10 <mugsie> possibly send this info and the session on to PTLs?
16:41:21 <Rockyg> We pick from the TC approved list and look at the user surveys for adoption to see whther to considr scoring
16:41:51 <eglute> mugsie i will send invite to dev mailing list. if PTLs have their own list, perhaps someone can forward it.
16:41:56 <Rockyg> Actually, posting the session to dev ML might be a fgood thing
16:42:09 <markvoelker> mugsie: sure.  Usually once we have volunteers to score the individual projects, those people will contact the PTL's of the projects they're playing point on scoring for but we can send out hogepodge's session wider too.
16:42:16 <mugsie> OK - so we need to get on that list then.
16:43:05 <eglute> mugsie we also have a defcore mailing list: defcore-committee@lists.openstack.org  if you do not want to miss anything as well as irc channel openstack-defcore
16:43:10 <amrith> eglute, ptl's don't have a list. just add [ptl] to the subject line
16:43:16 <mugsie> eglute: if you tag it [PTL] most of us will get it
16:43:21 <eglute> amrith thanks!
16:43:40 <amrith> I've subscribed to defcore list defcore-committee@lists.openstack.org
16:43:52 <eglute> great!
16:43:57 <eglute> any other questions?
16:44:45 <markvoelker> OK folks, I think we're done with the meeting for the day.  We'll be around in the usual haunts (#openstack-defcore, ML, etc).  Thanks!
16:44:49 <Rockyg> RTW/RTR
16:44:52 <markvoelker> #endmeeting