15:59:55 <eglute> #startmeeting defcore
15:59:55 <openstack> Meeting started Wed Aug 31 15:59:55 2016 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:59 <openstack> The meeting name has been set to 'defcore'
16:00:04 <eglute> #chair hogepodge
16:00:07 <openstack> Current chairs: eglute hogepodge
16:00:10 <hogepodge> o/
16:00:21 <eglute> #topic agenda
16:00:27 <shamail> \o
16:00:30 <eglute> #link https://etherpad.openstack.org/p/DefCoreLunar.15
16:00:39 <eglute> please add as needed!
16:01:14 <eglute> Mark is at VMWorld today, so he will not be here today
16:01:54 <eglute> Anyone else here for defcore meeting?
16:02:00 <gema> o/
16:02:04 <shamail> here
16:02:07 <gema> half here half on a deployment
16:02:12 <eglute> :)
16:02:12 <catherine_d|1> o/
16:02:25 <eglute> #topic Board meeting update
16:02:39 * notmyname lurks
16:02:49 <eglute> couple weeks ago we presented the defcore report to the board
16:02:59 <VanL> o/
16:03:09 <eglute> #link https://docs.google.com/document/d/1a4OWcGARqfuTAk5uax4d3LJGXeKiO5gZZ62jiEM4RDk/edit?usp=sharing
16:03:27 <eglute> The board approved the 1.6 guideline and 2016.08 guideline
16:03:47 <eglute> they also approved the name change
16:03:59 <woodster_> o/
16:04:06 <eglute> board members were excited about the change,
16:04:27 <eglute> so going forward we will need to start calling ourselves Interop Working Group
16:04:38 <eglute> hogepodge can you help us with all the renames?
16:04:53 <hogepodge> We'll need a sub-working group to handle the name change process
16:04:56 <shamail> eglute: Are we going to update the meeting ID on eavesdrop as well?  This will mean that new logs will be in a different location than older ones.  Not an issue but we should add a pointer to “archive meeting logs” with the old folder location.
16:05:08 <shamail> I can help hogepodge
16:05:17 <eglute> shamail good point
16:05:18 <hogepodge> I'm assuming we'll want new irc room, mailing list name, as well as documentation changes?
16:05:21 <hogepodge> New repository?
16:05:38 <gema> oh wow, it is more radical than I thought :D
16:05:42 <eglute> well, how confusing would it be if we kept mailing list/irc as the same?
16:05:43 <hogepodge> This is actually a pretty big undertaking if we want a comprehensive name change.
16:05:45 <eglute> and repo?
16:06:03 <eglute> so do we need a comprehensive one?
16:06:05 <shamail> Coin toss on repository name… It could stay the same since the repo name doesn’t have to be the same but programs.yaml would need to be updated at least
16:06:11 <hogepodge> Which I'm ok with, we just need to put together a work list and methodically get through it. I'm happy to lead those efforts with shamail
16:06:32 <eglute> #action hogepodge and shamail to lead rename efforts
16:06:36 <shamail> Any desired completion timeframe?
16:06:40 <hogepodge> As a rebranding effort, I expect it to take a few months.
16:06:57 <hogepodge> shamail: I'd be conservative and target Jan 1
16:07:02 <shamail> hogepodge: +1
16:07:07 <eglute> thanks hogepodge. i am ok with conservative
16:07:29 <rockyg> o/
16:07:39 <hj-hpe> Greetings and salutations all
16:07:42 <eglute> i am also ok with keeping some things called defcore, like IRC channel
16:07:55 <eglute> what does everyone else think?
16:08:20 <hogepodge> eglute: I'm worried that we'll continue the confusion of what defcore is, and it's marked as one of the major issues in our report
16:08:38 <gema> yeah, hogepodge has a point, let's move it all to the new name
16:08:41 <hogepodge> eglute: so even though it will be painful, consistency is important. that's just my opinion on the matter
16:08:42 <eglute> hogepodge good point
16:08:44 <gema> over time
16:08:52 <hj-hpe> Agreed
16:08:53 <rockyg> don't have a scrollback to view, but I agree with hogepodge in that the TC is starting to talk about "core" again.
16:08:55 <gema> +1 on consistency
16:08:58 <shamail> I agree with hogepodge, painful but will pay dividends in the long run
16:09:04 <woodster_> so will summit be where the name change is officially announced, or should it be changed over before that?
16:09:35 <rockyg> we should do a redirect for the defcore channel, though, when it gets a new name
16:09:51 <eglute> woodster_ we have not discussed that yet! but we do need to make an announcement
16:09:55 <hogepodge> woodster_: summit is as good a place as any, and gets us all in the same room to start pushing the last items through
16:10:17 * woodster_ might even be last minute name changes to bike shed over? :)
16:10:17 <shamail> hogepodge: Does it make sense to prioritize some areas to be renamed before the summit from the exhaustive list that we will build?  That way some of the more recognizable artifacts are renamed prior to announcement.
16:10:32 <hogepodge> shamail: I think so
16:10:39 <eglute> +1
16:11:33 <eglute> I think this will be a hard change but will help talking about defcore/interop going forward.
16:11:55 <eglute> anything else regarding the name change? any comments?
16:12:19 <eglute> #topic Summit
16:12:27 <VanL> I'll still probably call it defcore in private ;)
16:12:40 <hj-hpe> Shun the non believer!
16:12:42 <eglute> VanL i bet your are not the only one ;)
16:12:44 <eglute> heh
16:12:56 <eglute> We are less than 2 months away from the summit!
16:12:57 <shamail> lol
16:13:02 <eglute> i hope to see everyone there
16:13:16 <eglute> hogepodge told me he will be working on getting us a time slot for a WG
16:13:19 * shamail is already exhausted from the summit
16:13:21 <shamail> :P
16:13:40 * gema hopes not to have to make slides
16:14:13 <eglute> i have not looked if any defcore presentations got selected for the summit
16:14:14 <rockyg> unfortunately, I'm talking twice, so I'll be there.  One talk will be on the interop challenge and refstack
16:14:21 <hogepodge> from what I understand the UC will be sending out WG invitations, and DefCore will be included in the scheduling (as will any other non-UC governed working groups)
16:14:35 <eglute> thanks hogepodge
16:14:37 <gema> rockyg: it was unclear to me who will be talking on the interop challenge
16:14:49 <hogepodge> I'm on a panel that was accepted
16:15:02 <rockyg> For the one session, refstack and beyond, it's me and Catherine
16:15:12 <gema> rockyg: +1
16:15:30 <eglute> hogepodge what is the panel that you are on?
16:15:51 <rockyg> we might ping the ml for info/comments
16:16:04 <eglute> rockyg please do
16:16:24 <hogepodge> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16339/interop-you-keep-using-that-word-i-do-not-think-it-means-what-you-think-it-means
16:16:41 <eglute> oh nice
16:16:45 <eglute> thanks
16:17:11 <rockyg> Kewl!
16:17:21 <eglute> any other comments regarding summit?
16:17:22 <gema> nice indeed, will try to ask questions :D
16:17:28 <rockyg> I actually think I want to go to that one!
16:17:30 <hogepodge> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16412/beyond-refstack-the-interop-challenge
16:17:51 <hogepodge> I don't see anything else matching defcore or interop in the schedule
16:18:33 <eglute> thanks for checking hogepodge. we will have the WG as well
16:18:46 <rockyg> You didn't hear this from me, but expect interop in a keynote.
16:19:06 <gema> rockyg: you realize you are on record, right? :D
16:19:18 <eglute> is that going to be the interop challenge? I expect IBM will be talking about that
16:19:19 <rockyg> yeah ;P
16:19:40 <eglute> #topic 2017.01 guideline
16:19:42 <rockyg> Not positive on what, just know that it will be part of one.
16:20:11 <eglute> since the latest guideline was approved in August, the timeline for a new one will be a little compressed
16:20:25 <rockyg> Oh, and I'm not here anyways, because I'm on vacation.
16:20:39 <eglute> the next guideline will be 2017.01, approved in January 2017 board meeting
16:20:40 <gema> :)
16:21:03 <hogepodge> eglute: I'm ok with the next guideline being much more iterative. I have a feeling the one just approved will be a pretty big shock with the addition of direct APIs
16:21:06 * gema volunteers to do heat or keystone
16:21:26 <gema> let's get on with it, shall we? :)
16:21:42 <eglute> we have two months to ID new capabilities and create a preliminary draft
16:21:58 <eglute> thanks gema for volunteering to do keystone and heat!
16:22:03 <eglute> any other volunteers?
16:22:15 <gema> ¬¬' I said or!
16:22:19 <gema> :D
16:22:27 <eglute> i agree with hogepodge, we can have fewer new additions
16:22:42 <hogepodge> neutron capabilities need work in progress with updating the tests
16:23:03 <rockyg> ++ a bit of stability after the shock of 2016.08 would be good.
16:23:08 <hogepodge> I hesitate to volunteer for it because my dance card is filled up until Barcelona :-P
16:23:09 <eglute> hogepodge i think Mark had some tests in progress, is that correct?
16:23:17 <gema> hogepodge: so is mine
16:23:30 <rockyg> eglute, yeah, he does/did
16:23:43 <shamail> Can I schedule a session with someone to come up to speed on the process (after reading through what’s available)? // any volunteers?  I’m fairly packed in as well but I can try to help as time permits.
16:23:50 <hogepodge> but I will be in Germany for the QA meetup, so I can raise some issues there and see if we can move those tests forward while we have the team in the room
16:24:04 <eglute> hogepodge that would be great
16:24:30 <hogepodge> shamail: I'd be happy to help get you up to speed
16:24:36 <shamail> Thank you hogepodge
16:24:39 <rockyg> We have a guy in China who is supposed to get up to speed on this group, so if we schedule late afternoon, he can also be in the training/kickoff class
16:24:48 <eglute> hogepodge when is the QA meeting?
16:25:05 <gema> sept 19-21
16:25:09 <hogepodge> #link https://wiki.openstack.org/wiki/Sprints
16:25:10 <gema> I will be there too
16:25:13 <eglute> thanks gema
16:25:23 <shamail> rockyg: Connect him with me and I will make sure to include him when scheduling a follow-up with hogepodge
16:25:29 <gema> nodding to all the comments from hogepodge
16:25:32 <gema> for support
16:25:36 <eglute> we can probably schedule interactive video session for those who want to attend
16:25:58 <shamail> eglute: +1
16:26:02 <eglute> i would be happy to help hogepodge
16:26:13 <rockyg> ++ shamail
16:26:15 <eglute> is next week too soon?
16:26:40 <hogepodge> depending on our agenda load, we could use next week's meeting as a defcore process 101
16:26:40 <shamail> Latter half of next week is doable, I want to make sure I leave some time to read HACKING.rst, etc. first.
16:27:06 <eglute> #action hogepodge eglute to schedule intro to the guideline session
16:27:29 <shamail> hogepodge: If that is the plan then I would recommend also sending an email to other ML to let others know who might be interested that this would be a good session to join if planning to help with interop in the future.
16:27:32 <eglute> #action eglute to send a doodle to the mailing list to gage interest and collect convenient times
16:27:55 <eglute> hogepodge i agree
16:27:58 <shamail> It could be education/recruitment all in one :)
16:28:04 <rockyg> Actually what shamail said is good.  Produce a reading list for those attending to review before the meeting.
16:28:04 <eglute> :)
16:28:16 <hogepodge> eglute: shamail: at the risk of creating a ton of new work, record a webinar?
16:28:32 <eglute> #action eglute and hogepodge create a reading list prior to the session
16:28:35 <eglute> hogepodge i like that idea
16:28:38 <rockyg> It will also be a great "getting started with "whatever we call ourselves going forward"
16:29:05 <shamail> hogepodge: I would say we should do that after the intial 101 session, that way you can address questions left open (even after reading the docs) that come up
16:29:14 <shamail> Or we could record the Q&A session itself
16:29:41 <eglute> i am ok with either
16:29:58 <shamail> Sorry to go off-track eglute, I want to help with the guidelines but I need help on how to help first
16:30:27 <eglute> shamail fair enough, i am all for onboarding people :)
16:30:46 <rockyg> eglute, ++
16:30:51 <eglute> besides, we do have some other people who are new to this group :)
16:30:58 <shamail> thank you
16:31:44 <eglute> ok, so we will hold of asking for volunteers for scoring other components after the training session
16:31:57 <eglute> i know catherine_d|1 has done heat in the past
16:32:16 <catherine_d|1> eglute: yea ... but the issue wit heat is
16:32:28 <catherine_d|1> they still do not have tests in Tempest ..
16:32:31 <eglute> perhaps catherine_d|1 could follow up with the heat team to see if they made any changes since we talked to them last time
16:32:44 <eglute> catherine_d|1 do you know if they are planning on moving to tempest?
16:32:47 <rockyg> catherine_d|1, they are on the verge....
16:33:12 <catherine_d|1> eglute: rockyg: they are on the plan to implement the Tempest plugin
16:33:35 <eglute> catherine_d|1 any idea what their timeline is?
16:33:40 <catherine_d|1> but no plan for moving tests to Tempest yet ... this is news as of last month . I can check with them again
16:33:52 <eglute> thank you catherine_d|1
16:34:05 <eglute> we will talk about other components next time then
16:34:06 <catherine_d|1> eglute: will do
16:34:20 <hogepodge> catherine_d|1: can you work with Heat to get design summit time for that topic?
16:34:31 <hogepodge> (moving tests)
16:34:42 <catherine_d|1> hogepodge: great idea! will do
16:34:50 <rockyg> great idea, hogepodge
16:35:09 <rockyg> catherine_d|1, types faster than I do
16:36:14 <catherine_d|1> :rockyg: -) only this time
16:36:35 <eglute> so far, i have come up with a preliminary timeline, and i propose that we ID new capabilities by September 14th. this is very aggressive timeline, but works if we are going to go easy on trying to add new capabilities. We could also combine ID capabilities and scoring
16:37:46 <eglute> any thoughts on the timeline?
16:37:51 <hogepodge> #info the timeline changes are at the bottom of the etherpad
16:38:03 <hogepodge> #link https://etherpad.openstack.org/p/DefCoreLunar.15
16:38:08 <eglute> thanks hogepodge
16:38:10 <gema> eglute: I am not sure I can make it
16:38:20 <gema> eglute: in fact I am sure I cannot make it for that date x)
16:38:21 <eglute> i need to finish the second part
16:38:31 <eglute> gema would adding a week help?
16:38:39 <gema> nope, september is packed for me
16:38:48 <gema> qa/infra midcycle and linaro connect
16:39:18 <gema> I can get to it before ODS, though, if it helps
16:39:31 <gema> or if anyone else has the time, they can also do it :D
16:39:36 <eglute> when is ODS?
16:39:47 <eglute> what is ODS?
16:39:47 <gema> October 20thish
16:39:54 <gema> the summit?
16:40:01 <eglute> oh
16:40:23 <gema> sorry, I thought it was a generic acronym, that's the barcelona developer summit
16:40:28 <eglute> i think we need to have them scored by the summit
16:40:43 <eglute> but the ID part should be done before then
16:41:03 <eglute> lets see how much help we can get after the training session
16:41:07 <gema> ack
16:41:15 <eglute> hogepodge what is your opinion on the timeline?
16:41:41 <hogepodge> It's tight
16:41:49 <eglute> the 2017.01 draft should be done by October 25th, so we can get feedback
16:42:03 <hogepodge> For me the first half of September will be in a hardware build, and the second half is travel
16:42:09 <gema> eglute: I can have it by that date, I just don't have time to touch it during september
16:42:40 <hogepodge> More time frees up for me October 1, but a lot of the ground work has been done for the previous release, so this will me mostly iterative
16:42:53 <hogepodge> s/me/be
16:43:05 <catherine_d|1> hogepodge: eglute: at the minumun we do have advisory capability in 2016.08 that can be moved to required section ..
16:43:23 <rockyg> catherine_d|1, +1
16:43:25 <eglute> i am ok with us not sticking to the timeline too much, and i hope hogepodge is right that we will not have too many new capabilities
16:43:28 <eglute> catherine_d|1 +1
16:43:38 <hogepodge> catherine_d|1: yeah, and some of the advisory is dependent on test changes, which we have until December to get landed
16:43:41 <catherine_d|1> new;y scoring capablities can be added interactively over the next few months as we did in the past?
16:43:47 <rockyg> Also, look at items just below the cutoff score and see if they move up for this round
16:44:03 <eglute> catherine_d|1 i think so!
16:44:11 <eglute> rockyg good point
16:44:28 <hogepodge> #link http://git.openstack.org/cgit/openstack/defcore/tree/working_materials/scoring.txt
16:44:40 <eglute> thanks hogepodge
16:45:07 <eglute> any other comments on the new guideline?
16:45:35 <eglute> #topic RefStack
16:45:44 <eglute> catherine_d|1 go ahead!
16:46:34 <catherine_d|1> Thanks to your review on https://review.openstack.org/#/c/353903/  .. it was merged .. and we start implementing that already
16:47:10 <eglute> nice!
16:47:14 <catherine_d|1> we have two more foundation specs ..  https://review.openstack.org/#/c/343954/ and https://review.openstack.org/#/c/332260/
16:47:15 <rockyg> ++
16:47:44 <catherine_d|1> could you pleaser review so that we can proceed to  implementation ...
16:48:04 <eglute> #action everyone review https://review.openstack.org/#/c/343954/ and https://review.openstack.org/#/c/332260/
16:48:15 <eglute> catherine_d|1 i will review them later today
16:48:29 <catherine_d|1> our plan is to get all the implementatin done end of Sept ... so we allow 3 weeks to update the website .. in case there is issue
16:48:46 <catherine_d|1> eglute: thank you very much!
16:49:15 <catherine_d|1> hogepodge: want to confirm with you on the term "certification" vs "validation"
16:49:33 <hogepodge> catherine_d|1: oh gosh, I keep forgetting
16:49:39 <gema> catherine_d|1: validation didn't say much to me, does it mean that the result has been validated by chris?
16:50:02 <gema> and if the user wants to withdraw they contact chris and he unvalidates it?
16:50:16 <hogepodge> gema: I would avoid saying by chris and say against guideline
16:50:39 <gema> hogepodge: I could say the foundation but the way it is worded it does require someone's intervention
16:50:46 <catherine_d|1> This was a feedback from Mark
16:51:35 <hogepodge> yeah, I don't want to be seen as the gatekeeper, and the language should focus on the guideline and some governing authority checking against the guideline as used in a license agreement
16:51:53 <gema> hogepodge: +1
16:52:03 <eglute> foundation is the governing authority, correct?
16:52:09 <hogepodge> but I'm not the governing authority, the interop working group and openstack foundation are the important parts of the process
16:52:40 <gema> hogepodge: but practically, if a user sends the foundation a link to results for validation you validate them and mark it as validated
16:52:46 <gema> which means they are certified, correct?
16:53:03 <gema> you as in someone in the foundation
16:53:09 <rockyg> hogepodge, is acting for the foundation
16:53:12 <gema> yep
16:54:14 <rockyg> he is the assigned representative of the foundation
16:54:28 <gema> sure, I was just trying to understand the process
16:54:33 <gema> catherine_d|1: works for me as you have it now
16:55:04 <hogepodge> ok, I think we need to use the word verify, as certify means to make an official pledge and has deeper legal meeting
16:55:17 <rockyg> verify is good
16:55:23 <gema> verify sounds good
16:55:34 <catherine_d|1> hogepodge: gema: I can change to verify
16:55:55 <hogepodge> gema: right now, one step in the licensing process is to send me a refstack link that shows the product meets the testing requirements for the logo program
16:55:57 <catherine_d|1> it is better now than later
16:56:05 <gema> hogepodge: ok
16:56:09 <gema> catherine_d|1: yep, sounds better
16:56:33 <hogepodge> gema: I then signal to our legal team that the vendor is qualified to sign the license agreement, which is generated and sent to the vendor
16:56:33 <catherine_d|1> ok thank you ... I will make the change ..
16:56:43 <gema> hogepodge: ah, ok
16:56:59 <hogepodge> gema: the contract comes back and is then countersigned by a foundation representative
16:57:19 <catherine_d|1> let me update the patch and please review again!  thank you all!
16:57:25 <hogepodge> which is not me
16:57:27 <gema> thank you catherine_d|1
16:57:31 <gema> hogepodge: ok, makes sense
16:57:40 <rockyg> hogepodge, true dat
16:57:54 <catherine_d|1> gema: thanks for your review and bring up this question ... that is what review is for ..
16:58:01 <gema> catherine_d|1: +1
16:58:13 <eglute> i think we are almost out of time... catherine_d|1 anything else?
16:58:22 <catherine_d|1> no thx
16:58:31 <eglute> thank you everyone!!
16:58:42 <eglute> #endmeeting