16:00:12 <eglute> #startmeeting defcore
16:00:17 <openstack> Meeting started Wed Aug 10 16:00:12 2016 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:21 <openstack> The meeting name has been set to 'defcore'
16:00:23 <openstack> markvoelker: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:00:30 <eglute> #chair markvoelker hogepodge
16:00:31 <openstack> Current chairs: eglute hogepodge markvoelker
16:00:44 <eglute> beat markvoelker by 1 sec! :)
16:00:51 <markvoelker> =)
16:00:55 <catherine_d|1> :-)
16:00:56 <gema> o/
16:01:04 <catherine_d|1> o/
16:01:12 <eglute> #link https://etherpad.openstack.org/p/DefCoreLunar.13
16:01:17 <markvoelker> eglute: let's have you drive the meeting today then.  I may have to step out briefly anyway.
16:01:17 <eglute> #topic agenda
16:01:28 <eglute> thansk markvoelker
16:01:40 <hogepodge> o/
16:01:43 <eglute> #topic Follow up from Summer Sprint
16:02:07 <eglute> thanks everyone for coming out to San Antonio, was great having you all here!
16:02:15 <gema> eglute: thanks for having us :D
16:02:35 <eglute> we did a lot of things!
16:02:50 <eglute> now that the spec has landed, whats next?
16:03:23 <markvoelker> eglute: I think hogepodge was looking into getting some of our docs published on docs.oo.o (or somewhere).  Maybe this is a good candidate?
16:03:41 <markvoelker> Also, we have some poeple going to the QA midcycle I think, and they were going to discuss it with the QA folks.
16:03:49 <markvoelker> (hogepodge again?)
16:03:59 <eglute> when is the QA midcycle, and who is going?
16:04:00 <hogepodge> yeah, I can take it to the next qa meeting
16:04:29 <hogepodge> #link Sept 19 in Frankfurt https://wiki.openstack.org/wiki/Sprints
16:04:38 <hogepodge> I'm going
16:04:43 <shamail> o/
16:05:00 <eglute> nice.
16:05:04 <gema> I am also going
16:06:16 <eglute> #action hogepodge gema to discuss defcore spec at the QA midcycle
16:06:49 <eglute> regarding our docs published on docs- markvoelker hogepodge have you spoken to anyone so far?
16:07:10 <hogepodge> eglute: no, not yet
16:07:32 <eglute> ok, i will start the conversation then
16:07:45 <hogepodge> eglute: I could possibly get to it on Monday next week, I'm on travel again starting this afternoon, but I'm happy to have you take it
16:08:05 <eglute> #action eglute contact the docs team regarding moving defcore docs to docs
16:08:45 <eglute> so we want the docs moved from our own repo to be under the docs repo, correct?
16:09:07 <markvoelker> eglute: I think we just want to get published versions out on the website
16:09:27 <eglute> markvoelker do you mean the guidelines?
16:09:33 <hogepodge> no movement is necessary, it's just a job to publish to docs.openstack.org
16:09:33 <markvoelker> We can leave the actual files in our repo.
16:09:38 <eglute> ah ok
16:09:48 <eglute> thanks hogepodge and markvoelker
16:09:53 <markvoelker> Yes, Guidelines and also some of our other docs that we point people to regularly (the test spec may be one of those going forward)
16:10:11 <eglute> sounds good
16:10:12 <gema> it may need moving to the right folder in our repo, though
16:10:16 <gema> since it is in the working folder
16:10:24 <markvoelker> sure
16:10:39 <eglute> thats ok, shouldnt be too hard
16:10:54 <hogepodge> gema: +1 to moving it to our official docs
16:11:01 <eglute> next topic: Major issues report status
16:11:05 <eglute> #topic Major issues report status
16:11:06 <gema> hogepodge: will do that
16:11:31 <markvoelker> I got most of the first cut done on the plane on the way home from Texas
16:11:44 <markvoelker> I should have a first cut posted up to gerrit tonight or possibly tomorrow
16:11:48 <eglute> thanks markvoelker!
16:11:56 <eglute> look forward to seeing it
16:12:05 <gema> +1
16:12:19 <markvoelker> Once that's posted we can iterate in gerrit per the norm
16:12:21 <eglute> anything else on this subject? i am really excited about this report
16:12:49 <shamail> eglute: +1, same here
16:12:54 <gema> yep
16:12:59 <markvoelker> I should mention: I'm doing the formatting in RST since that's our usual doc format
16:13:13 <eglute> thanks markvoelker
16:13:16 <markvoelker> That means we could publish it to the websites, transform it to other formats, etc.
16:13:17 * shamail just realized +1 == same here, doh.
16:13:36 <eglute> lol
16:13:43 <eglute> #topic DefCore name change status
16:14:07 <eglute> so we voted to have the name changed to Interop Working Group
16:14:14 <markvoelker> One of my action items from the midcycle was to update the POC patch I already have out with the name "Interop Working Group"
16:14:32 <markvoelker> I haven't gotten to it yet. =)  But it's a trivially small change, so I'll add it to my queue for this afternoon.
16:14:45 <markvoelker> We will also want to get that on the Board agenda
16:14:52 <eglute> thanks markvoelker
16:15:04 <eglute> #action eglute to add name change to the board agenda
16:15:35 <eglute> next board meeting is on August 23rd
16:15:35 <eglute> so we have a little time
16:15:45 <markvoelker> Just to be clear, I think it's likely that the name won't change immediately...we'll want to coordinate messaging with the Foundation/BoD.
16:16:14 <eglute> right
16:16:23 <markvoelker> But the patch will at least show what's changing and what the name will be so we can work on the next steps
16:16:30 <eglute> :)
16:16:55 <eglute> talking of the board, we will also need the board to approve 2016.08 json document
16:16:58 <markvoelker> (in other words: review it, but don't worry about workflow+1 yet =p)
16:17:08 <eglute> right :)
16:17:18 <eglute> or markvoelker could -1 workflow
16:17:34 <markvoelker> eglute: I already marked it WIP and will do so again when the new patchset goes up
16:17:37 <eglute> :)
16:17:40 <eglute> thank markvoelker!
16:18:08 <eglute> gerrit makes it very easy to +1 workflow. i try hard not to click it accidentally
16:18:45 <eglute> did we have any defcore process docs changed in the last couple months?
16:18:54 <eglute> besides the name change?
16:19:12 <AlanClark> I set time on the agenda for DefCore at the August meeting.
16:19:20 <markvoelker> eglute: 2016A hasn't actually been approved
16:19:24 <eglute> thank you AlanClark!
16:19:32 <markvoelker> https://github.com/openstack/defcore/blob/master/doc/source/process/2016A.rst (note "draft" status)
16:19:49 <eglute> #action eglute to add 2016A to the board report for approval
16:20:22 <eglute> markvoelker i thought it was-- but i will double check
16:21:19 <eglute> anything else from midcycle? we got a lot done
16:21:40 * gema still recovering from all the food :D
16:21:40 <shamail> I agree eglute, he new version of Gerrit makes it really easy.
16:21:43 <eglute> there are a lot of action items in the ehterpad
16:21:44 <shamail> the*
16:22:00 <eglute> gema hope you enjoyed it :)
16:22:06 <gema> eglute: absolutely
16:22:34 <eglute> #topic 2016.08 Guideline Final Reviews
16:22:40 <markvoelker> eglute: I have an AI to work on updates to HACKING.  I made a start on it, but backburned it in favor of the 2016.08 and major issues report.  ETA next week probably.
16:22:44 <eglute> #link https://review.openstack.org/#/c/351339/
16:22:50 <eglute> thank markvoelker
16:23:00 <eglute> ^^thank you!
16:23:25 <markvoelker> ditto for the FAQ-on-configuring-tempest-for-refstack thing
16:24:03 <eglute> thanks!
16:24:36 <markvoelker> Ok, on the 2016.08 patch: I made a couple of additions today to pick up changes we had in flight in next.json when we created teh 2016.08 draft
16:24:49 <eglute> we can go over all the AIs next meeting. I didnt think people would have too much time to get to them between travels and this meeting
16:25:11 <markvoelker> Those include dropping some tests for networking that (genuinely) need admin, and the image sharing stuff that needs multiple user accounts
16:25:34 <eglute> thank you markvoelker
16:25:40 <eglute> i will review it later today
16:25:52 <eglute> everyone else please review it as well!
16:26:04 <markvoelker> It would be good if someone could check flags vs 2016.01 and see if there's anything that looks out of place
16:26:19 <catherine_d|1> I think we should land https://review.openstack.org/#/c/338609/ before the 2016.08
16:26:23 <markvoelker> (e.g. flags we unintentionally dropped or unintentionally carried when we meant to drop them)
16:27:00 <markvoelker> catherine_d|1: yeah, I just saw your new patchset on that one.  Will review shortly
16:27:08 <eglute> catherine_d|1 you are right! will review it today
16:27:30 <eglute> we will not merge 2016.08 until the board approves it
16:27:46 <catherine_d|1> the new addition here is we remove images-v2-remove since it has no test
16:27:50 <markvoelker> I think it does for next.json exactly what one of my last patchsets did for 2016.08, so we're in sync...just need to actually land it.
16:28:41 <catherine_d|1> yea they are in sync ...
16:29:01 <eglute> #action eglute to review flags between 2016.01 and 2016.08 and make sure none were dropped
16:29:59 <markvoelker> eglute: would also be good to double check test aliases in 2016.08
16:30:19 <eglute> #action eglute to double check test aliases in 2016.08
16:30:37 <eglute> everyone else are welcome to check aliases and flags as well
16:30:50 <catherine_d|1> will do
16:30:54 <eglute> or if you see something that should not be there. or if you dont see something that should be there :)
16:31:05 <eglute> thank you catherine_d|1
16:31:54 <eglute> catherine_d|1 already talked about https://review.openstack.org/#/c/338609/
16:32:00 <eglute> everyone please review it
16:32:23 <eglute> and https://review.openstack.org/#/c/353287/
16:32:50 <eglute> both markvoelker and i have already +2, it is ready to merge unless someone brings up any concerns
16:33:57 <eglute> Talking of reviews, please review https://review.openstack.org/#/c/351363/
16:34:21 <eglute> hogepodge i think it needs something to make the ghost of Jenkins happy
16:34:57 <hogepodge> eglute: I probably messed up the dependency chain, it needs 2016.08 to exist to work
16:35:12 <eglute> ah ok
16:35:31 <markvoelker> From the log: "2015.08.json: : [Errno 2] No such file or directory: '2015.08.json'"
16:35:36 <markvoelker> Notice 2015.08 vs 2016.08
16:36:01 <eglute> nice catch markvoelker
16:36:02 <hogepodge> markvoelker: ah ha, a tpyo
16:36:19 <hogepodge> I'll update
16:36:35 <eglute> thank you hogepodge
16:36:41 <eglute> anything else regarding 2016.08 Guideline?
16:37:10 <eglute> #topic v2.0 of Guideline Format
16:37:14 <markvoelker> just one thing
16:37:29 <eglute> go ahead markvoelker
16:37:33 <markvoelker> There's the still the matter of a few neutron tests that use admin creds *unnecessarily*.
16:37:57 <markvoelker> I have a patch up for to fix that in tempest that needs some more work.  But if it doesn't land, we need to drop those back to advisory
16:38:03 <markvoelker> Before 2016.08 is approved
16:38:12 <eglute> do we have a launchpad for this?
16:38:13 <markvoelker> So I'll plan on putting up a backup patch to do that
16:38:17 <hogepodge> I would suggest that we include them flagged or advisory for now, unless the changes land before the update
16:38:40 <hogepodge> either way they wouldn't be required if they don't work before approval
16:38:52 <markvoelker> hogepodge: Ok, that's probably reasonable...given that we only have a couple weeks that's probably the more likely scenario
16:39:04 <catherine_d|1> once we incldue them as flagged we can not un-flagged them ..
16:39:26 <catherine_d|1> on an approved guideline
16:39:33 <markvoelker> So I'll update my 2016.08 review with another patchset with that change and we can unflag them before 2016.08 goes from draft to approved if the tempest patch lands in time
16:40:45 <eglute> ok, we just need to be sure to do final review of 2016.08 before taking it to the board
16:40:59 <markvoelker> catherine_d|1: correct.  The idea here would be basically flag them now since we think the tempest change may not make it in time.
16:41:12 <markvoelker> If it does, we'll update 2016.08 before we send it up to the board for approval
16:41:36 <markvoelker> But if the tempest change doesn't land, they'll stay flagged until next Guideline.
16:41:49 <catherine_d|1> that is good
16:43:06 <eglute> markvoelker will they be advisory and flagged if patch doesnt land?
16:43:43 <markvoelker> eglute: in cases where that would leave no tests for an entire capability I'll leave it as advisory.  For cases where there are still good tests, I'll flag them.
16:44:00 <eglute> ok
16:44:03 <eglute> thank you!
16:44:14 <eglute> anything else on the guideline?
16:44:31 <catherine_d|1> markvoelker: should that statement be capture in the hacking file?
16:44:58 <markvoelker> catherine_d|1: I'll look into that with the HACKING updates I have in flight.
16:45:35 <eglute> thanks markvoelker
16:45:52 <catherine_d|1> markvoelker: thx
16:45:55 <eglute> #topic v2.0 of Guideline Format
16:46:04 <eglute> #link https://review.openstack.org/#/c/310621/
16:46:20 <eglute> hogepodge any changes since last week?
16:46:31 <hogepodge> There's not a whole lot to say about this. I spoke with Andrey yesterday, and he's ok with me landing our changes on top of his patch
16:47:09 <hogepodge> It's going to take a bit of work to capture all of the design we did last week. I'm planning on sending the revision on Friday.
16:47:18 <eglute> thank you hogepodge
16:47:31 <eglute> do you need anything from us before then?
16:47:43 <markvoelker> Neat.  And I think we decided we'll plan on using 1.6 for 2016.08 still since we don't actually plan to add any new target programs in 2016.08, right?
16:48:30 <hogepodge> yeah
16:48:32 <markvoelker> (err....1.5 I mean)
16:49:11 <hogepodge> 1.5/1.6. The difference is 1.6 is more restrictive to prevent some things from sneaking in like we found at the sprint.
16:49:39 <eglute> and 2016.08 will be updated to 1.6 correct?
16:49:45 <hogepodge> eglute: yes
16:50:09 <markvoelker> Ok, right...sorry, couldn't remember which number was in flight for a sec there. =)
16:50:36 <markvoelker> eglute: Yeah, my patch is written with 1.5, hogepodge has a patch that's dependent on mine that will take it up to 1.6
16:50:50 <eglute> great! thanks markvoelker and hogepodge
16:51:01 <markvoelker> (hogepodge's patch also creates 1.6...it doesn't actually exist in our repo yet =p)
16:51:33 <eglute> anything else on this topic?
16:51:42 <hogepodge> no
16:51:50 <eglute> #topic name change
16:51:58 <eglute> #link https://review.openstack.org/#/c/327086/
16:52:10 <eglute> we already talked a little bit about it
16:52:27 <eglute> anything in addition to what was already discussed?
16:52:52 <markvoelker> Yeah, I think we basically already covered this.  In a nutshell: I'll post a new patchset, people will review it, we won't merge it until we coordinate with the Foundation/BoD
16:53:49 <eglute> sounds good to me. anyone else want to add anything?
16:54:20 <eglute> if not, we have a few minutes left.
16:54:33 <eglute> anybody want to discuss anything?
16:54:36 <eglute> or end now?
16:54:57 <markvoelker> I'm good.
16:55:00 <gema> good here
16:55:08 <catherine_d|1> me too
16:55:14 <eglute> thanks everyone!!
16:55:18 * markvoelker is also hungry and would totally use that extra 5 minutes to go get a sammich
16:55:18 <eglute> #endmeeting