16:00:06 <eglute> #startmeeting defcore
16:00:07 <openstack> Meeting started Wed Jan 27 16:00:06 2016 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'defcore'
16:00:32 <eglute> Hello everyone, please raise your hand if you are here for DefCore meeting
16:00:36 <eglute> #topic agenda
16:00:44 <gema> o/
16:00:55 <eglute> Agenda: #link https://etherpad.openstack.org/p/DefCoreRing.10 please review and add/edit as needed
16:01:04 <markvoelker> o/
16:01:20 <eglute> Hello gema and markvoelker!
16:01:28 <gema> hello :D
16:01:31 <eglute> Chris Hoge will not be able attend today's meeting
16:02:32 <eglute> not sure if we are getting more people to join us today
16:02:48 <eglute> #topic board report
16:02:51 <dwalleck> o/
16:03:20 <eglute> yesterday during the board meeting board approved 2016.01.json guideline
16:03:32 <markvoelker> \o/
16:03:37 <eglute> as well as 2016A process document
16:04:11 <markvoelker> \o/\o/
16:04:20 <eglute> had a couple questions, but nothing major.
16:04:46 <eglute> the next board meeting is at the end of February, so if we need something approved then, we can
16:05:01 <eglute> #topic Electing DefCore CoChair during next meeting
16:05:28 <eglute> So the patch for changing defcore cochair description was out for a very short time
16:05:40 <eglute> #link https://review.openstack.org/#/c/271908/
16:06:01 <eglute> markvoelker and Rob commented, but I didnt really get other feedback
16:06:40 <eglute> since it was a bit rushed, I want everyone to know that if we need to make changes to the process, we can. The reason for rushing was that the process document requires board approval
16:07:39 <markvoelker> eglute: I got the impression that moving to a WG was something Board wanted to move toward anyway, so I'm generally fine with it.
16:07:55 <eglute> markvoelker correct.
16:08:28 <eglute> I spoke to Alan Clark, chairman of the board, about Rob's replacement as a co-chair (not that he is easy to replace)
16:08:47 <gema> what is a WG?
16:08:53 <eglute> Working group
16:08:55 <gema> ack
16:09:03 <eglute> Committee usually implies board committee
16:09:17 <eglute> meaning, run by the board, responsible to the board
16:09:26 <eglute> DefCore WG would still require board oversight
16:09:55 <eglute> as is now, it will continue requiring approval to process documents as well as new capabilities
16:10:20 <eglute> the main change is that both cochairs would not be board appointed
16:10:31 <eglute> only one
16:11:08 <eglute> if anyone have reservations/concerns about the change, i am available to talk about it here, or via email/phone. just let me know
16:11:23 <eglute> i do hope that everyone sees this as a positive change
16:11:55 <markvoelker> eglute: I think the change invites more community participation, so ++./
16:11:58 <dwalleck> makes perfect sense to me
16:12:06 <eglute> markvoelker i agree!
16:12:43 <gema> eglute: +1
16:12:45 <eglute> which brings up the next question: elections of the cochair
16:13:07 <eglute> right now, the only requirement in the process document is that elections are announced 1 week before
16:13:27 <eglute> and
16:13:29 <eglute> One DefCore CoChair needs to be elected by DefCore working group. Election
16:13:29 <eglute> quorum is composed of attendees present during the election meeting.
16:14:01 <eglute> this means we have to figure out a good election process
16:14:28 <eglute> i would like the voting people to be comprised of people that usually participate, or have participated in the defcore discussions
16:14:47 <eglute> and for people nominated/running to be active participants
16:15:50 <eglute> one of the suggestions i received was for people running to submit a gerrit patch, and voters do +1.
16:15:53 * markvoelker notes that there was very brief discussion around this in https://review.openstack.org/#/c/271908/
16:16:28 <dwalleck> eglute: To handle nominations or the actual vote?
16:16:52 <eglute> dwalleck suggestion was for both
16:17:01 <markvoelker> eglute: Submit a patch to...what, exactly?  E.g. are we creating a new text file that lists co-chairs or something?
16:17:04 <eglute> another suggestion is to have it in some form during actual meeting
16:17:52 <eglute> markvoelker i think it would be a patch to declare candidacy. voters would +1 their candidate. this might be too formal though
16:18:11 <eglute> i am ok with IRC polling as well
16:18:27 <eglute> but would like to hear ideas from others
16:18:56 <gema> eglute: the voting in the same way you did the choosing of midcycle location would also work
16:19:13 <markvoelker> Hmm...I think I'd prefer something that doesn't require a specific time/place to cast a ballot so we can be more inclusive.  E.g. not at an IRC meeting.  But honestly everyone that's likely to cast a ballot it probably at our meetings anyway.
16:19:18 <eglute> doodle? Yes, I agree. I thought of it
16:19:20 <dwalleck> I don't mind the idea of nominations through Gerrit, but doing the actual voting in Gerrit might be a bit complicated
16:19:37 <markvoelker> What about setting up a Condorcet?
16:19:42 <purp> o/ (sorry to be late, catching up)
16:19:47 <gema> markvoelker: yeah, but you are right, someone may miss a meeting due to other commitments and miss the opportunity to vote
16:20:08 <eglute> markvoelker i thought of condorcet, that would mean we dont know who is voting i believe
16:20:28 <eglute> hello purp we are discussing how to elect a cochair
16:20:55 <purp> Got it. All caught up.
16:21:16 <eglute> so, i am all for being inclusive, and we could open voting next week and close it one week later? whichever voting method we choose
16:21:49 <dwalleck> eglute: +1
16:21:53 <gema> eglute: +1
16:22:09 <markvoelker> Works for me
16:22:24 <purp> eglute +1
16:22:24 <eglute> now, the next question would be, open voting, where we see who votes for who, or closed
16:22:57 <purp> I'd suggest if you've attended *n* DefCore meetings over the past cycle/period/minute, you're a voter.
16:23:07 <purp> It's equivalent to being an ATC to vote for PTL.
16:23:14 <eglute> also, Rob has volunteered to be ombudsman for collecting votes if needed
16:23:23 <eglute> purp i like that suggestion
16:23:31 <dwalleck> I do also
16:23:55 <markvoelker> Well, for this election the Board pretty much already set who gets a vote, no?  "quorum is composed of attendees present during the election meeting."
16:23:56 <purp> I think 12 > n > 3
16:24:10 <eglute> so, more than 3 meetings in 12 months?
16:24:12 <markvoelker> But we could obviously fix that for next time
16:24:12 <purp> markvoelker: Yeah, that was the bit I had a problem with.
16:24:42 <purp> I'd say 3+ meetings in past cycle/6 months.
16:25:02 <eglute> markvoelker purp -- we could amend that during February board meeting i think. I am ok with having one week long elections
16:26:22 <eglute> and not insisting on being present during the meeting
16:26:29 <purp> eglute: +1 to amend for Condorcet elections and a criteria for "ATCs"
16:27:33 <eglute> ok, I will work on the patch, but will wait for after these elections. I suspect we will have more changes
16:27:56 <markvoelker> purp: I think I need to noodle on ATC criteria a bit.  I like the idea of regular participation being more a metric than "contribution" (since we're not actually producing code here).  Not quite sure how to structure it though.
16:28:21 <markvoelker> Generally ++ on the idea though
16:28:39 <eglute> so, for defcore ATC-- we do have irc logs, we would have to go through them and get a list of people
16:28:50 <purp> markvoelker: fair, and no hurry. Do you have a particular concern, or just generally uneasy?
16:29:15 <purp> eglute: Happy to write a snippet of code to do that. =]
16:29:24 * purp never gets to write much code these days.
16:29:25 <dwalleck> I think the summary at the end of each log lists the participants also
16:29:26 <eglute> thanks purp!
16:29:29 <markvoelker> Not a particular concern, just want to be sure we're setting good criteria.
16:30:06 <purp> #action purp to write a tool to summarize logged DefCore participation for a given time period
16:30:09 * eglute lets purp know over the last 6 months we used 3 different chat rooms and need to account for midcycles which were in person
16:30:13 <rockyg> Reviews of stuff would help as an indicaor
16:30:21 <markvoelker> dwalleck: true, though not necessarily a good measure of "participation".  E.g. you get your name on the log by simply saying o/. =)
16:30:51 <rockyg> Everyone who "speaks" gets listed
16:31:09 <dwalleck> markvoelker: Very true :D
16:31:18 <markvoelker> Anyway, I suggest we table the discussion for the moment and think on it some more, then come prepared next week with suggestions (or just propose patches to the process doc).
16:31:29 <eglute> i think the o/ at the end of the log indicates they were here, and most do speak. very rarely it is just o/
16:31:32 <catherineD|2> markvoelker: and sometime we forget to sau /o
16:31:33 * rockyg sheepishly hopes no one notices she overslept
16:31:51 <purp> markvoelker dwalleck rockyg: Figuring I'll start by summarizing the stats of attendance, # of meetings with participation, and overall IRC linecount during the period.
16:31:57 <rockyg> or even o/
16:32:06 <markvoelker> purp: sounds useful
16:32:19 <gema> and sometimes people have weird nicknames like catherineD|2 today
16:32:25 <purp> markvoelker: at least gives us a dataset to look at
16:32:26 <rockyg> Oh yeah, the attendance also has number of lines spoken...
16:32:38 <eglute> So, when do we want to start elections? I am selfish and dont want to wait too long
16:32:38 * purp nods at rockyg
16:32:39 <catherineD|2> gema: :-)
16:33:26 <brunssen> I think the sooner we can start elections the better, but we need to make sure we allow enough time to gather quality candidates.
16:33:32 <gema> eglute: as soon as we have a list of candidates?
16:33:41 <gema> and voters
16:33:54 <rockyg> Well, one week after the list is complete....
16:34:01 <purp> eglute: you intend this one by the "whoever's in the meeting" rule, correct?
16:34:03 <eglute> how do we want to gather the list of candidates? self nominations? nominations by others? nominations via mailing list?
16:34:10 <markvoelker> I think we can probably get started proposing candidates right away, just need to work out the mechanics of the voting.
16:34:11 <brunssen> I think send an email and let the community know that we are going to hold an election and there is a two week window to raise your hand or be nominated
16:34:50 <eglute> purp i think if there are enough objections i dont have to stick to that rule. I am ok with having one week long elections
16:34:52 <rockyg> Yeah, my China comrades have already been pushing me.
16:35:32 <purp> Can I suggest that we mirror the PTL process relatively closely, then?
16:35:43 <rockyg> They've finally gotten the hang of how to follow DefCore ;-)
16:35:47 <eglute> which, if we have 1 week for candidates, 1 week to vote, that puts us out at least 2 weeks
16:36:00 <rockyg> +1 on PTL process
16:36:01 <purp> Take noms, self or other, determine what an ATC looks like here, then vote?
16:36:11 <eglute> purp i like that
16:36:19 <brunssen> +1
16:36:20 <dwalleck> 1 week for each seems fair
16:36:24 <purp> rockyg: How? *I* still haven't got the hang of it.
16:36:48 <eglute> Start nominations today? I will send out an email after the meeting
16:36:50 <rockyg> I'll give you a hand :-)
16:36:55 <markvoelker> eglute: ++
16:37:03 <purp> eglute: +1
16:37:16 <brunssen> eglute: +1
16:37:24 <purp> eglute: If I nominate someone, do they have to ratify it?
16:37:27 <rockyg> Yeah.  Self nominations with statement in an email to list
16:37:31 <eglute> nominations will close next week by 10 AM CST: is everyone ok with that?
16:37:36 * purp looks evilly at markvoelker and rockyg
16:37:47 <dwalleck> eglute: sounds good
16:37:50 <eglute> purp yes, would like people to respond to the nomination accepting it
16:37:53 <gema> purp: you probably don't want a cochair that doesn't have the time
16:37:56 <gema> :D
16:38:00 <rockyg> oh you sneaky purp!
16:38:17 <brunssen> Yes, I agree, that the nominee has to accept to be on the ballot
16:38:29 <rockyg> ++
16:38:31 <eglute> so condorcet we need a list of voters emails, correct?
16:38:46 <markvoelker> eglute: yes
16:39:10 <eglute> ok, we will need to get a list of emails based on IRC handles
16:39:11 <rockyg> infra can help with the election.  Or ttx
16:39:18 <eglute> rockyg good idea
16:40:06 * purp is writing code already.
16:40:31 <catherineD|2> eglute: Also who can also get a list of people who had submitted, reviewed DefCore patches
16:41:02 <rockyg> catherineD|2, ++
16:41:07 <purp> catherineD|2 I can grab that from Stackalytics.
16:41:20 <purp> Will grab commits, emails, reviews as contribs.
16:41:29 <eglute> I propose voting period to be from February 3rd till February 9th. so by February 10 we can be done
16:41:35 <catherineD|2> great, I think that is one way to measure participation ...
16:41:58 <eglute> i agree on participation to include commits
16:42:01 <rockyg> There can be reviewers that arn't on the IRC logs.   They may not be able to make the meetings.  But, that doesn't mean they don't follow all of this
16:42:12 <eglute> right
16:43:17 <eglute> so does anyone have issues with the timeline? nominations until next Wednesday, elections start next Wednesday, close before defcore meeting the following week?
16:43:33 <gema> +1
16:43:37 <purp> I'm pretty sure I can have interesting data up in an etherpad by end of weekend.
16:43:41 <rockyg> +1
16:43:48 <purp> +1
16:43:49 * eglute thanks purp
16:43:52 <markvoelker> +1
16:43:52 <dwalleck> +1
16:44:20 <catherineD|2> +1
16:44:23 * rockyg thinks purp knows more than he's letting on
16:44:30 <eglute> and eveyone ok with condorcet voting?
16:44:43 <brunssen> +1
16:45:06 <rockyg> +1
16:45:13 <markvoelker> +1
16:45:13 <purp> +1
16:45:14 <dwalleck> +1
16:45:15 <purp> rockyg: yeah, but it's mostly '80s trivia and recipes for cooking game.
16:45:34 <eglute> any other comments regarding elections? we will ask the board to approve new process during the february meeting
16:46:36 <rockyg> sounds like we have it
16:47:03 <eglute> great, thank you everyone for your input.
16:47:11 <eglute> #topic DefCore Capabilities should have more than one test.
16:47:22 <eglute> #link https://review.openstack.org/#/c/233814/
16:48:02 <eglute> i dont think we have a consensus on this. I would suggest we either review it again, or drop it
16:48:41 <markvoelker> eglute: actually, I think it just needs a commit message update.  The most recent patchset doesn't actually include a rule change at all.  It's just a re-grouping of tests.
16:49:19 <markvoelker> So it's no longer about whether or not Capabilities should have more than one test or not at all
16:49:26 <eglute> ok, so if we update the commit message, move forward with regrouping?
16:49:27 <markvoelker> (which was the controversial point)
16:49:38 <rockyg> I'd say ask for more reviews/comments on mailing list and if still quiet, go for it.
16:49:40 <markvoelker> YEah, I think the regrouping was fine by most.
16:49:52 <eglute> ok, sounds good to me
16:50:04 <eglute> markvoelker would you update the commit message?
16:50:12 <markvoelker> eglute: sure, I can do that
16:50:17 <eglute> thank you!
16:50:30 <eglute> #topic Next guideline will be 2016.08, to be approved during August 23rd board meeting.
16:50:31 <rockyg> markvoelker, could you take a look at my comment and see if I'm just an idiot?  Might be a dupe line in the file...
16:50:48 <markvoelker> #action markvoelker will rewrite commit message for https://review.openstack.org/#/c/233814/ and everyone will review
16:50:53 <markvoelker> rockyg: will do
16:50:55 <eglute> thank you markvoelker!
16:51:17 <markvoelker> rockyg: you're right, I'll remove the dupe too
16:51:23 * gema has to run early today, sorry!
16:51:26 <rockyg> Thanks!
16:51:30 <eglute> regarding the next timeline, please review it in etherpad, see if it makes sense
16:51:45 * eglute waves goodbye to gema
16:52:37 <eglute> since there is no board meeting in July, the approval would happen in august. meaning, next guideline would be 2016.08
16:53:11 * markvoelker notes that the scoring deadline is a couple weeks after the midcycle, so would love to have folks ready to discuss in Austin
16:53:23 <eglute> markvoelker good point
16:53:29 <rockyg> ++
16:53:57 <eglute> if there are no other questions/comments, next topic
16:54:01 <markvoelker> Are we pretty firm on the date/place for that now, by the way?  Enough that I should be booking a flight?
16:54:20 <eglute> i am waiting for final confirmation from brunssen
16:54:51 <brunssen> I am working with our facilities folks to get everything finalized.
16:55:01 <rockyg> Oooh!  At IBM again?  Lonestar Motel, here I come!
16:55:04 <brunssen> I am not worried about getting the space, just need to get final confirmation
16:55:08 <markvoelker> Ok, cool.  Just light the bat signal when we're good to go. =)
16:55:19 <eglute> brunssen do you have estimated time for confirmation?
16:55:23 <brunssen> I will do that.  Hope to know by the end of the day today.
16:55:32 <eglute> that would be great!
16:55:32 <markvoelker> excellent
16:55:48 <brunssen> Once I know, I will send an email to eglute so she can distribute to the team.
16:55:55 <purp> Cool. brunssen if something falls through, I can probably commit to hosting there, but need ~2 weeks notice to get contacts and logistics lined up.
16:55:58 <eglute> and yes, Lone Star hotel has the best prices. I actually made reservations yesterday, thinking i can cancel just in case
16:56:25 <purp> Are we talking about http://www.lonestarcourt.com/ ?
16:56:32 <eglute> yes
16:56:33 <rockyg> It's a great place to congregate after, too.
16:56:40 <rockyg> Yup
16:56:48 <brunssen> There also a bunch of new hotels near the IBM site that look nice in case any of you are working on points or airline miles :-)
16:56:57 <purp> Wow. Braker and Burnet has upgraded a bit since back when.
16:57:13 <brunssen> The Domain is a very nice area
16:57:21 <rockyg> ++
16:57:37 <eglute> brunssen yes, but that one my corporate tool told to book, since it is the cheapest at the moment. lots of great other options too
16:57:44 <eglute> well, we are almost out of time
16:57:46 <eglute> #topic DefCore submissions for OpenStack Summit
16:57:57 <eglute> please submit defcore related proposals!
16:58:09 <eglute> i submitted the working group session, but no others
16:58:45 <eglute> also, sorry markvoelker we ran out of time for your topic. move it to defcore irc or wait for next week?
16:58:57 <rockyg> With the progress refstack is making, we might be ready for a "corporate" show and tell and demo
16:59:01 <markvoelker> It's not urgent; it'll keep till next week
16:59:06 <eglute> rockyg that would be great!
16:59:11 <eglute> thank you markvoelker
16:59:30 <catherineD|2> rockyg: I think so ... The RefStack team is very busy in making this happens ...
16:59:31 <eglute> i will be around in defcore irc if anyone wants to chat
16:59:34 <eglute> thanks everyone!
16:59:43 <rockyg> Thanks!
16:59:48 <eglute> #endmeeting