01:00:25 <eglute> #startmeeting DefCore
01:00:27 <openstack> Meeting started Thu Jun 25 01:00:25 2015 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:00:30 <openstack> The meeting name has been set to 'defcore'
01:00:35 <hogepodge> o/
01:00:59 <eglute> Hello Everyone! Raise your hand if you are here and include time zone.
01:01:04 <eglute> o/ CST
01:01:09 <hogepodge> o/ PDT
01:01:12 <markvoelker> o/ EDT
01:01:19 <catherineD> o/PDT
01:01:21 <dwalleck> o/ CST
01:01:58 <hogepodge> agenda #link https://etherpad.openstack.org/p/DefCoreFlag.5
01:02:13 <eglute> Rob said he won't be able to attend today, so if anyone else wants to chair the meeting with me let me know!
01:02:34 <eglute> #chair hogepodge
01:02:35 <openstack> Current chairs: eglute hogepodge
01:03:26 <eglute> #topic agenda
01:03:46 <eglute> do we have enough people attending the meeting?
01:04:18 <markvoelker> eglute: you mean in general or in this particular timeslot?
01:04:30 <eglute> for this evening
01:04:38 <eglute> i counted 5 :(
01:04:46 <markvoelker> I think we have enough to do useful things.
01:04:51 <nzhou> pls also count me :)
01:05:05 <eglute> welcome nzhou! what time zone are you in?
01:06:00 * markvoelker reminds folks that we're supposed to review whether this meeting schedule is working out during the Flag.7 meeting on July 8
01:06:27 <nzhou> GMT+8 :)
01:06:46 <Rockyg> o/
01:06:47 <eglute> I agree markvoelker we can get enough stuff done! we do have agenda on the etherpad. do you want to tackle it in order or start with more pressing items?
01:07:08 <markvoelker> eglute: the first several items should be pretty short I think
01:07:14 <hogepodge> I generally try to do things in order
01:07:29 <eglute> #topic mid-cycle planning
01:08:09 <eglute> we have set the date last week, right now Rob is waiting to hear on confirmation for the space.
01:08:40 <eglute> if we don't hear back, we will work on location B, which most likely be Rackspace Austin office
01:09:35 <markvoelker> #info Still waiting on venue confirmation for July 29-30 midcycle meetup
01:09:37 <Rockyg> that could be a tight fit
01:10:08 <eglute> Rockyg what do you mean?
01:10:22 <eglute> In terms or planning, or having space?
01:10:33 <Rockyg> space
01:10:46 <Rockyg> Defcore has become much more popular
01:10:46 <hogepodge> rax has loads of space in the Austin office
01:11:07 <hogepodge> (at least afaik from my last visit there)
01:11:23 <eglute> we have two offices there too... yes, it is pretty big
01:11:40 <hogepodge> Foundation offices would be much tougher. It was tight last time, and sure to be much tighter this time.
01:11:47 <markvoelker> I'm not worried about space...we had 10 people reply to the Doodle
01:11:56 <eglute> from the doodle, it did not appear that we would get too many people attending. Though I am sure a lot of rackers will attend if it is there
01:12:13 <eglute> markvoelker agree! i would be surprised if we get 20 in person
01:12:14 <markvoelker> And a couple of those said they weren't coming or were going to be remote IIRC
01:12:50 <markvoelker> eglute: before we move on from midcycle planning, does someone have an AI to draft an agenda?  Don'
01:12:57 <markvoelker> t think we need to do that here, but it wants doing.
01:13:01 <Rockyg> oops I saw rackspace and thought foundation - which is tiny
01:13:40 <eglute> markvoelker yes, I was thinking we need to start agenda, but thought it might be a bit early still
01:13:52 <eglute> Rockyg yes, foundation office is very cozy!
01:14:13 <markvoelker> eglute: I'm thinking now is a good time to start drafting.  We're only about 4 weeks away, right?
01:14:33 <eglute> if other people think that we should start working on agenda now, we can start etherpad.
01:14:48 <eglute> yes, only 4 weeks, but I was thinking we might resolve some issues in these meetings
01:15:00 <eglute> I am ok with starting early too
01:15:21 <markvoelker> eglute: +1 to starting soon.  I've got a couple of things to add to a prospective agenda.
01:15:32 <eglute> #action eglute start etherpad for mid-cycle agenda
01:16:21 <eglute> ready for next topic?
01:16:34 <markvoelker> eglute: thanks.  Also, for travel planning purposes: I presume we're planning to use the full day both days?  E.g. 9-5 or something?
01:16:49 <eglute> yes, I would think so
01:17:03 <hogepodge> markvoelker: We had a full agenda last time, so I would hope 2 full days
01:17:03 <markvoelker> Excellent.  Ok, next topic!
01:17:13 <eglute> also, Foundation Board has a meeting the day before, so the board members will be there early
01:17:28 <eglute> #topic capabilities subdivision
01:17:57 <eglute> #link https://review.openstack.org/#/c/194975/1
01:18:23 <eglute> thank you hogepodge for starting this, i think it is still work in progress, correct?
01:18:37 <markvoelker> hogepodge: Haven't had time for more than a cursory look at this today, sorry.  Will try to spend more time on it tomorrow or Friday.
01:19:18 <hogepodge> It's based off of the work that VanL and catherineD have been doing in the google sheet.
01:19:26 <hogepodge> That's where the json file comes from
01:19:59 <hogepodge> There's a bug in the name, and dwalleck has some good points on the categorization and tests
01:20:00 <dwalleck> I hopefully didn't brain dump too much feedback, but I still have a bit more to poke around through
01:20:15 * dwalleck spends way too much time looking at tests
01:20:20 <hogepodge> Plus the descriptions could be better.
01:21:07 <eglute> hogepodge dwalleck is it ready to be reviewed?
01:21:09 <hogepodge> Since the json is generative, anything that can go back to the capabilities json file will help to reduce the hand-editing of the next.json file
01:21:14 <markvoelker> dwalleck: thanks for having a look.  hogepodge: might be useful to have Catherine look at this too, I'll add her
01:21:33 <catherineD> dwalleck: Thanks for the suggestion on the categorization and tests ... so if we are going to make some changes ... will we start with the spreadsheet?
01:21:35 <hogepodge> One thing to note is that I'm just capturing existing capabilities/tests.
01:21:53 <hogepodge> So refactoring the current state. I know that Van wants to add a lot more tests.
01:21:54 <catherineD> we should decide on which is the source ...
01:22:33 <hogepodge> Also, zehicle had a good point about how we keep information on removed tests. Maybe a new category in the next.json file that lists them for reference.
01:22:45 <markvoelker> +1 on limiting this change to refactoring current state
01:22:51 <eglute> sounds like we should finish with the refactoring and then add new tests separately?
01:23:01 <hogepodge> eglute: that's what I was thinking
01:23:04 <dwalleck> that might be easier
01:23:05 <catherineD> eglute: +1
01:23:07 <eglute> thank you hogepodge
01:23:20 <markvoelker> eglute: yes.  We have a lot of work to do on adding tests and expect we'll spend some time on that in Austin. =)
01:23:30 <hogepodge> #link http://lists.openstack.org/pipermail/defcore-committee/2015-June/000869.html
01:23:31 <eglute> markvoelker true!
01:24:40 <markvoelker> Ok, so action is for all of us to review this....anything else on that topic?
01:24:58 <markvoelker> #action Everyone please review https://review.openstack.org/#/c/194975/
01:25:29 <eglute> #link midcycle ehterpad for planning purposes: https://etherpad.openstack.org/p/DefCoreFlag.MidCycle
01:26:20 <eglute> agree on need time to review it.
01:26:32 <eglute> next topic?
01:26:56 <eglute> #topic review hacking file
01:27:17 <eglute> #link https://review.openstack.org/#/c/188661/6
01:27:31 <eglute> we had action item from the last meeting for everyone to review it
01:27:55 <markvoelker> eglute: actually https://review.openstack.org/#/c/188661/7 now.  Rob added a new patchset earlier today (in lieu of purp I guess?)
01:28:13 <eglute> oh sorry, took the link from etherpad
01:28:19 <eglute> #link https://review.openstack.org/#/c/188661/7
01:29:31 <eglute> has everyone had a chance to look at it?
01:29:54 <markvoelker> eglute: since that patchset is so new (just uploaded this morning) I don't think most of us have had a chance to look at it much yet.
01:30:21 <eglute> ok, so will have an action item for everyone to look it over
01:30:41 <hogepodge> aside from whitespace issues it's a good start
01:30:44 <eglute> #action Everyone review and provide feedback https://review.openstack.org/#/c/188661/7
01:30:56 <eglute> are there any points that people would like to discuss now?
01:31:16 <markvoelker> eglute: I think we still haven't settled the security question
01:31:47 <hogepodge> I'm actually a bit confused by the language and what it's trying to convey
01:31:50 <Rockyg> I had reviewed it last week (but wasn't signed in)  This is much clearer around D404
01:31:51 <markvoelker> Rob said he wanted a security clause, but I actually don't see one in the latest patchset.
01:32:29 <markvoelker> But actually since Rob isn't able to be here tonight maybe we should just continue that discussion in gerrit.....
01:32:58 <eglute> markvoelker you are right, I thought it was included. yes, gerrit comments would be great
01:33:18 <markvoelker> eglute: ok, so AI for folks to review it and move on?
01:33:26 <eglute> Rockyg i really like 404
01:33:52 <eglute> markvoelker yes, i already posted AI
01:34:14 <eglute> #topic strategic test planning
01:34:52 <eglute> #link http://lists.openstack.org/pipermail/defcore-committee/2015-June/000818.html
01:35:16 <markvoelker> hogepodge: to me this feels like a thing that would well benefit from some face-to-face discussion in Austin, though I'm happy to continue commenting via email in the interim
01:35:22 <hogepodge> topic kind of fell flat with the nova/glance discussions going on.
01:35:51 <hogepodge> I would like to get a sense of how we can start matching tests up to APIs and give guidance to devs as to what defcore means for interop
01:36:37 <hogepodge> happy to wait to f2f on this
01:36:42 <dwalleck> hogepodge: as in a list of API request a given test makes?
01:37:07 <hogepodge> dwalleck: yes, but also what we really want to support.
01:37:13 <eglute> hogepodge I think it might help if it was an issue in gerrit, what do you think?
01:37:48 <eglute> get some discussion that way, and finish in f2f
01:38:00 <Rockyg> dwalleck:Yeah.  Essentially a test coverage/distribution/case analysis and see how we can create a plan and layout that is more effective (from my perspective)
01:38:36 <hogepodge> If a dev wants to boot a machine with a public IP, what's the interoperable way to do that, for example
01:39:05 <markvoelker> hogepodge: the developer community <-> DefCore relationship is actually one of the most interesting parts of this I think.  Whatever happened to the idea of colocating DefCore and QA midcycles?
01:39:17 <dwalleck> I've been doing some sanity checking over the tests. There might be a way to generate the actual list of requests per test so you can see it step by step
01:39:19 <Rockyg> User centric use/test cases that translate into the Api work flow
01:39:37 <eglute> markvoelker co-location didnt work out because QA midcycle was too late/not set
01:39:43 <hogepodge> dwalleck: Tempest logs it, from what I gather
01:39:45 <dwalleck> Rockyg: +1 to user test cases
01:39:47 <hogepodge> dwalleck: or it can
01:39:56 <markvoelker> eglute: Bummer, thought that might be the case.
01:40:27 <dwalleck> hogepodge: It does, but it doesn't isolate it per test case I think. There might be something I missed
01:40:29 <markvoelker> I see a big part of this initiative as needing some buy-in from the Tempest folks, for example.  Would be neat if we could set an agenda early enough that we could invite some of them in for that part of the dicussion
01:40:31 <eglute> markvoelker i think it is in the meeting notes somewhere, I do not remember which meeting though. 2 or 3?
01:40:45 <Rockyg> dwalleck: maybe you, me and Ievgenia can get together on IRC and plan something out
01:41:15 <eglute> markvoelker: good idea. https://etherpad.openstack.org/p/DefCoreFlag.MidCycle
01:41:39 <dwalleck> Rockyg: sounds good to me!
01:41:59 <Rockyg> hogepodge: the logs only capture what is logged.  The APIs are currently incosistent on reporting. and events are almost totally missed
01:42:43 <hogepodge> Looking at the qa meeting logs I'm not seeing much discussion on mid cycle yet
01:42:59 <hogepodge> there are full logs and abbreviated logs of the meetings
01:43:07 <Rockyg> dwalleck: you've been digging in more.  Wanna put together a strawman we can start with?  We'll send out email on Defcore list for that irc meet
01:43:43 <dwalleck> Rockyg: I'm hoping that should be fixable. They are working from one base rest client, so there's a solid injection point. It just has to be used consistently, which is maybe something we can help with
01:43:43 <eglute> Rockyg dwalleck i think it would be great if you could do that
01:43:54 <markvoelker> hogepodge: no worries, if we can alert those folks to when we'll be talking about it in Austin we could potentially get them to join us via Hangout or whatever (or in person, even).  Would be good to hear from them on this.
01:44:11 <Rockyg> hogepodge: too many logs;-) I was talking test run logs
01:44:38 * markvoelker notes we're down to 15 minutes remaining
01:44:53 <Rockyg> dwalleck: ++ I'm driving the log improvement effort.  Nuff said on this.  Next topic?
01:45:00 <dwalleck> Rockyg: Sure, can do.
01:45:12 <dwalleck> That makes it easy then :)
01:45:27 <hogepodge> Rockyg: I have an engineer looking at capturing the api information, so it's a priority to figure it out
01:45:32 <eglute> #action Rockyg dwalleck work together on tests and logs
01:45:52 <eglute> #topic flagged tests
01:46:52 <eglute> #link https://review.openstack.org/#/c/189927/
01:47:03 <eglute> this one is still from last week in our notes
01:47:35 <markvoelker> eglute: On this one I think the big question was just whether we go ahead and flag it or wait and see if the fixes upstream land
01:47:40 <hogepodge> I'd like to see if that can be cleared without flagging again since a fix is in progress
01:47:49 <hogepodge> But if we can't wait then I'm ok with flagging
01:48:03 <eglute> hogepodge yes, you are right.
01:48:22 <markvoelker> If we have somebody waiting for logo certification that needs this, we should flag it (IMO).  The remaining upstream fix looks like it could be a while yet.
01:48:35 <markvoelker> But if it's not actually bothering anyone, no real harm either way
01:49:32 * markvoelker notes the remaining patch has been active since March but hasn't yet attracted a +2, so could be a while yet.
01:50:40 <hogepodge> I can try to poke on it
01:51:16 <eglute> for certification, people can still certify on the previous defcore cycle as well.
01:51:48 <markvoelker> eglute: I'd hate to force somebody back to an old version for something that's still broken upstream though.
01:52:08 <eglute> hogepodge are you getting any requests that are held because of the flagged tests?
01:52:13 <eglute> markvoelker yes, not ideal
01:52:34 <hogepodge> no
01:52:45 <Rockyg> knock on wood
01:52:49 <markvoelker> E.g. ideally we want lots of people using the same Guideline so we know we've actually got some level of interoperability
01:52:53 <hogepodge> I only have one pending review.
01:53:17 <eglute> ok, so not an issue now, hogepodge  please raise it if it comes up
01:53:19 <hogepodge> I can report back next week and we can make a decision.
01:53:25 <catherineD> hogepodge: the only spec with flagged tests right now is 2015.04
01:53:50 <markvoelker> catherineD: just the thing I was going to bring up next =)
01:54:06 <eglute> thank you hogepodge
01:54:29 <hogepodge> To start I'd like us to remove the tests that are flagged and won't be part of the standard
01:54:57 <hogepodge> But that also means considering adding a new field of permanently removed tests, which I think would be good to prevent test/flag churn.
01:55:29 <hogepodge> I'm also ok with not waiting for fixes too.
01:56:01 <eglute> ok, time check: 5 min. next topic?
01:56:32 <markvoelker> hogepodge: in related news, we have no flags in 2015.05 even though we know we probably should.  I'll put up some patches for that this week.
01:56:34 <catherineD> since 2015.05 is the only spec for Kilo, without flagged tests in 2105.05 ... we won't be able to certify Kilo
01:56:40 <hogepodge> Can we have an action for everyone to start reviewing the flagged changes?
01:56:58 <eglute> #action Everyone start reviewing flagged changes
01:57:17 <markvoelker> catherineD: agreed, was just discussing this w/hogepodge earlier in the week.  We're behind on some housekeeping and I'll start working on that this week
01:57:20 <hogepodge> particularly for tests that we want to remove flags on. I'd like for those who were running into troubles to check to see if it's ok to remove the flags
01:57:42 <hogepodge> (I removed my -1 on the ssh tests)
01:57:55 <eglute> #topic capabilities review
01:58:24 <eglute> we had not reviewed capabilities yet in IRC meeting, do you think we need a separate meeting?
01:58:25 * markvoelker throws in a quick promo for https://review.openstack.org/#/c/193727/ while we're talking housekeeping
01:58:30 <eglute> I think we always run out of time
01:58:47 <hogepodge> markvoelker: I can review my patches to target 05 too
01:58:53 <hogepodge> s/review/revise
01:59:24 <markvoelker> eglute: Also a thing I've been thinking about.  So far the combined meeting hasn't really allotted any time, but we are a bit early yet accorindg ot the 2015A timeline
01:59:51 <markvoelker> I think maybe we just need to set aside some time in the next couple of meetings to divvy up the work of identifying new capabilities amongst ourselves.
01:59:52 <eglute> catherineD Rockyg hogepodge dwalleck what do you think?
02:00:07 <eglute> markvoelker i think that could work too
02:00:14 <dwalleck> That might be a good idea so we have the time to focus
02:00:20 <markvoelker> Then later we can converge with patches in gerrit and add contentious ones to the agenda here.  If we're spending a lot of time on that, we'll break out a meeting.
02:00:24 <catherineD> agreed
02:00:33 <eglute> would it be helpful to start an email thread so people start reviewing?
02:01:09 <Rockyg> Yeah.  That sounds possible.  I think we will eventually need a separate meeting to wrap it up, though.
02:01:39 <eglute> Rockyg I think you might be right
02:02:28 <eglute> we are once again out of time- anything else you want to discuss while we are here?
02:03:40 <eglute> thank you everyone!
02:03:42 <eglute> #endmeeting