20:07:55 <zigo> #startmeeting deb_packaging
20:07:56 <openstack> Meeting started Mon Oct 10 20:07:55 2016 UTC and is due to finish in 60 minutes.  The chair is zigo. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:07:59 <openstack> The meeting name has been set to 'deb_packaging'
20:08:28 <zigo> #topic Project status: upload to unstable
20:08:45 <zigo> I uploaded everything to Unstable this week.
20:08:57 <zigo> #link https://qa.debian.org/developer.php?login=openstack-devel@lists.alioth.debian.org
20:09:01 <tlbr> mistral-dashboard too ?
20:09:18 <zigo> Only networking-scf and neutron-taas aren't migrated.
20:09:22 <zigo> They wouldn't build.
20:09:27 <zigo> mistra-dashboard too yeah.
20:09:30 <tlbr> cool!
20:09:46 <zigo> I made the package today, it's in the NEW queue now.
20:10:07 <tlbr> yeah, i've seen ITP
20:10:08 <zigo> senlin-dashboard was fixed for Django 1.10
20:10:09 <zigo> I also uploaded it.
20:10:09 <tlbr> from you
20:10:27 <zigo> Only trove-dashboard is missing.
20:10:37 <tlbr> i'm still working on it
20:10:40 <zigo> tlbr: You saw the patch from rob, right?
20:10:41 <tlbr> sec
20:10:49 <tlbr> to trove-dashboard ?
20:10:54 <tlbr> zigo, ^^^
20:11:10 <zigo> #link https://review.openstack.org/#/c/381999/
20:11:12 <zigo> This one !
20:11:17 <tlbr> sec
20:11:25 <tlbr> gosh!
20:11:29 <tlbr> thanks!
20:11:43 <zigo> It's still not a 100% with it.
20:11:50 <zigo> There's 3/4 failures still.
20:12:02 <tlbr> which one ?
20:12:07 <zigo> I can't upload without the fixes.
20:12:11 <zigo> Hang on, let me show you.
20:12:18 <tlbr> "NoReverseMatch: u'en-us' is not a registered namespace"
20:12:24 <tlbr> this is what i'm curently checking
20:12:56 <zigo> FAIL: test_add_parameter_invalid_value (trove_dashboard.content.database_configurations.tests.DatabaseConfigurationsTests)
20:12:56 <zigo> ----------------------------------------------------------------------
20:12:56 <zigo> Traceback (most recent call last):
20:12:56 <zigo> File "/usr/lib/python2.7/dist-packages/openstack_dashboard/test/helpers.py", line 115, in instance_stub_out
20:12:56 <zigo> return fn(self, *args, **kwargs)
20:12:57 <zigo> File "/home/zigo/sources/openstack/newton/trove-dashboard/build-area/trove-dashboard-7.0.0~rc2/trove_dashboard/content/database_configurations/tests.py", line 341, in test_add_parameter_invalid_value
20:12:59 <zigo> ['Value must be a number.'])
20:13:01 <zigo> File "/usr/lib/python2.7/dist-packages/django/test/testcases.py", line 406, in assertFormError
20:13:03 <zigo> self.fail(msg_prefix + "Response did not use any contexts to render the response")
20:13:05 <zigo> AssertionError: Response did not use any contexts to render the response
20:13:10 <zigo> Thats' the only one remaining.
20:13:16 <tlbr> hm
20:13:31 <zigo> Then we got to actually TRY it, and make sure there's no exceptions.
20:13:43 <zigo> Just in case some problems aren't caught by the unit tests ...
20:14:02 <zigo> Same with the other dashboards, we need to check for them (at least browse in Horizon).
20:14:06 <tlbr> have you uploaded the changes to gerrit ?
20:14:17 <zigo> For trove-dashboard, no.
20:14:19 <tlbr> i want to pick your changes and try to fix it
20:14:28 <zigo> The rest of, yes.
20:14:33 <tlbr> ok
20:14:38 <zigo> Though mistral-dashboard isn't in Gerrit yet, just in Alioth.
20:14:43 <tlbr> ok
20:15:01 <zigo> Oh, we also need to do python-glareclient...
20:15:12 <tlbr> yes :) Michael told me about it
20:15:12 <zigo> And move both glare and glareclient to Gerrit.
20:15:38 <tlbr> yeah, he will also release a new version soon, with nice improvements
20:15:52 <tlbr> i'm talking about Glare
20:15:57 <zigo> #topic Project status: Still heat_integration problem with tempest
20:16:05 <zigo> That one, I'm really not sure how to fix.
20:16:28 <zigo> Currently, keystonemiddleware doesn't produce an auth_type = password kind of directives.
20:16:30 <tlbr> is it the same issue you showed a week earlier ?
20:16:39 <zigo> Yup.
20:16:53 <zigo> Same issue, I guess we don't need to discuss it again.
20:17:02 <zigo> I need to chat with some Keystone specialists.
20:17:16 <zigo> stevemar for example.
20:17:22 <tlbr> ok
20:17:31 <zigo> IMO, it's ok to delay the work on it.
20:17:52 <zigo> #topic Project status: BTS clean-up in progress
20:18:05 <zigo> I've cleaned-up about 15 bugs today! :)
20:18:11 <tlbr> :)
20:18:26 <zigo> #link https://bugs.debian.org/cgi-bin/pkgreport.cgi?which=maint&data=openstack-devel%40lists.alioth.debian.org&archive=no&raw=yes&bug-rev=yes&pend-exc=fixed&pend-exc=done
20:18:41 <zigo> There's more to come.
20:18:55 <zigo> I'm satisfied when we reach a level where no action can be made.
20:19:05 <zigo> That should be around 10 bugs, no more.
20:19:31 <zigo> I've been slowed down a lot by "Hash mismatch" issues on the CI though.
20:19:51 <zigo> Hopefully, we'll have a "real" debian mirror some day to avoid these.
20:20:00 <tlbr> is it still happening ?
20:20:05 <zigo> A LOT !!!
20:20:10 <tlbr> =\
20:20:10 <tlbr> ok
20:20:12 <zigo> Some patches when up to 8 rechecks, still in error ... :(
20:20:27 <tlbr> =(
20:20:47 <tlbr> #link https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837238
20:20:47 <openstack> Debian bug 837238 in src:trove-dashboard "trove-dashboard: FTBFS: compressor.exceptions.OfflineGenerationError: No template loaders defined. You must set TEMPLATE_LOADERS in your settings or set 'loaders' in your TEMPLATES dictionary." [Serious,Open]
20:20:56 <tlbr> shall we patch settings.py ?
20:21:14 <zigo> That one was before the upload of all of Newton to Sid.
20:21:23 <zigo> I didn't close the bug, because we have another one with Django 1.10.
20:21:30 <tlbr> got it, thanks
20:21:31 <zigo> Though the topic and the reason is now completely different.
20:21:51 <zigo> Maybe we should close that one and open a new bug...
20:21:57 <zigo> I'd say: useless if we have the fix.
20:21:58 <tlbr> i agree
20:22:20 <zigo> I'll continue working on closing issues tomorrow.
20:22:44 <zigo> #topic Opening Ocata dev
20:23:02 <zigo> I need to have infra guys to help with that.
20:23:19 <zigo> pabelanger will need to add new ocata repo for example.
20:23:20 <tlbr> you mean make branches for projects ?
20:23:26 <tlbr> ah, got it
20:23:31 <zigo> Branches is another thing, bug yes ! :)
20:23:32 <tlbr> new repo along with branches
20:23:39 <tlbr> ok :)
20:23:43 <zigo> I don't really want to open 250+ branches by hand... :P
20:23:53 <zigo> We can in theory do it in Gerrit though.
20:24:03 <zigo> Do you know if we could script clicking on Gerrit?
20:24:07 <tlbr> sec, i'll check if we have rights
20:24:20 <zigo> We do have the rights to make new branches on Gerrit, that's for sure.
20:24:27 <zigo> The only question is how to automate that ...
20:24:36 <clarkb> zigo: the release team typically handles branch creation fwiw
20:24:43 <clarkb> I think they may have scripts for it
20:24:44 <tlbr> no, we can't do that by button
20:24:55 <zigo> clarkb: Ah, thanks a lot for your input ! :)
20:25:18 <tlbr> clarkb, is there anyway to do it ourselves ?
20:25:34 <tlbr> *any way
20:25:35 <zigo> clarkb: Our workflow is a little bit different though, instead of "master" (which is upstream master), we would like to open "debian/ocata" right away now.
20:25:53 <clarkb> zigo: I am sure that can be parameterized
20:26:07 <zigo> clarkb: Great, who should I ask? Doug?
20:26:41 <clarkb> ya I think I would start with Doug
20:26:47 <zigo> Ok, will do.
20:27:07 <zigo> #action Zigo to ask Doug about opening new debian/ocata branches when we are to start
20:27:29 <zigo> tlbr: I prefer finishing the BTS clean-up first though, so I don't have to backport the fixes.
20:27:54 <zigo> tlbr: I'd like to start doing packaging from trunk though, which means packaging each and every release of libs, clients, etc...
20:28:06 <zigo> tlbr: So it has to happen fast ...
20:28:18 <tlbr> zigo, got it
20:28:23 <zigo> tlbr: Do you think starting next week is reasonable?
20:28:38 <tlbr> zigo, i guess so
20:28:40 <zigo> ie: one week to clean-up everything ...
20:28:44 <zigo> Ok, let's do that then.
20:28:50 <tlbr> do you need help with bugs ?
20:29:00 <zigo> Contrib is always welcome! :)
20:29:04 <tlbr> :)
20:29:06 <zigo> So, yes for sure ...
20:29:11 <zigo> #topic install-guide contribution
20:29:26 <zigo> #link https://wiki.openstack.org/wiki/Documentation/NewtonDocTesting#Testers
20:29:34 <zigo> I started reviewing every bits ...
20:29:41 <zigo> And a few CR
20:29:51 <zigo> tlbr: Do you have time for that work as well?
20:30:05 <tlbr> zigo, what should I add there ?
20:30:10 <zigo> annegentle: ping
20:30:15 <tlbr> i'll try to spend some time on it
20:30:34 <zigo> tlbr: The thing is, the doc team insist that we "test" the install-guide, and make sure it works.
20:31:03 <zigo> I know the packages so well that I don't need to do actual tests for all. For example, for glance, I know it works, so I marked the debconf one as passed...
20:31:17 <zigo> Need to add some stuff from the non-debconf bits though.
20:31:22 <zigo> This type of things ...
20:31:36 <zigo> Everything is in the status though.
20:31:54 <zigo> The hardest bits will be networking.
20:32:02 <tlbr> we have tests for services
20:32:05 <zigo> The problem is that I don't have enough space available on my laptop.
20:32:12 <tlbr> Nova, Neutron, Glance, etc.
20:32:18 <zigo> tlbr: Do we have hardware available somewhere for this type of testing?
20:32:21 <tlbr> I mean functional tests
20:32:28 <tlbr> nope =\
20:32:42 <zigo> The goal is *not* to test if packages work, but if the install-guide is accurate and works.
20:32:55 <zigo> I do know packages are working ! :)
20:33:00 <zigo> (thanks to tempest testing...)
20:33:13 <tlbr> ok, i can try to do so
20:33:31 <zigo> tlbr: Do you have enough space on your computer to do the network tests?
20:33:45 <zigo> That's really the hardest part ...
20:33:47 <tlbr> zigo, yes, i can find it
20:33:57 <zigo> Because you got to have all of the other parts working.
20:34:03 <tlbr> let's discuss it on #openstack-pkg
20:34:07 <zigo> Ok.
20:34:26 <zigo> #topic Open discussion
20:34:26 <tlbr> i'll need some help with it
20:34:51 <zigo> tlbr: On this topic, I wanted to know: who's taking care of that sync git script for MOS ?
20:35:02 <zigo> A. Tsamutali ?
20:35:14 <tlbr> zigo, we haven't started yet
20:35:22 <tlbr> there are still CI preparation
20:35:23 <zigo> tlbr: Yeah, but who's doing it?
20:35:32 <tlbr> zigo, no one at this moment
20:35:35 <zigo> Ok.
20:35:43 <tlbr> yes, we have Sync, but it thinks to branch
20:35:46 <tlbr> all the changes
20:35:51 <zigo> Well, it has to sync from git.openstack.org now, I guess you know that ... :P
20:36:02 <tlbr> yeah, I've Sasha about it today
20:36:08 <tlbr> we will see what we can do
20:36:14 <tlbr> *i've told
20:36:18 <zigo> Ok.
20:36:36 <zigo> Anything else?
20:36:57 <tlbr> I guess no.
20:37:00 <tlbr> Thank you!
20:37:04 <zigo> :)
20:37:09 <zigo> have a good night then.
20:37:17 <zigo> #endmeeting