20:01:02 <zigo> #startmeeting deb_packaging
20:01:03 <openstack> Meeting started Mon Sep 19 20:01:02 2016 UTC and is due to finish in 60 minutes.  The chair is zigo. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:06 <openstack> The meeting name has been set to 'deb_packaging'
20:01:25 <zigo> #topic Current project status
20:01:44 <zigo> Most of all services already built in b3 in OpenStack infra.
20:01:54 <zigo> aodh, barbican, ceilometer, cinder, designate, glance, heat, keystone, manila, mistral, murano, nova, neutron, sahara, senlin, watcher, zaqar
20:01:59 <zigo> All of them are already there.
20:02:08 <zigo> I've even started doing a few rc1.
20:02:28 <tlbr> horizon is still in progress, I'm working on it.
20:03:03 <tlbr> what about swift ?
20:03:15 <zigo> Remaining to do:
20:03:15 <zigo> congress: needs to backport antlr3 in infra, this will require a lot of dependencies to be able to build because of antlr3
20:03:15 <zigo> gnocchi (I didn't look)
20:03:15 <zigo> horizon (see below)
20:03:15 <zigo> ironic
20:03:15 <zigo> magnum (needs to build k8sclient)
20:03:17 <zigo> murano-agent
20:03:19 <zigo> neutron-*aas plugins
20:03:21 <zigo> networking-* plugins
20:03:24 <zigo> trove (needs to wait until python-xmltodict 0.10.2 reaches Debian mirrors)
20:03:30 <zigo> onovy: Yeah, what's the status for Swift?
20:03:45 <onovy> zigo: done
20:03:54 <strigazi> the magnum job succeeded on the merge of tag 3.0.0
20:03:56 <zigo> onovy: Good ! :)
20:03:58 <onovy> ah sry, not
20:04:04 <onovy> newton swift is uploaded
20:04:06 <onovy> but not in infra
20:04:15 <zigo> strigazi: Ah, great! :)
20:05:03 <zigo> strigazi: I just validated it, so now you can propose some packaging enhancement if you'd like.
20:05:10 <zigo> (after it merges, of course...)
20:05:24 <zigo> onovy: Do you know how to make a patch to add it to infra?
20:05:31 <onovy> zigo: no
20:05:33 <zigo> onovy: Or do you want me to do it for you, maybe?
20:05:38 <onovy> please :)
20:05:41 <zigo> onovy: Ok, will do.
20:05:55 <zigo> #action zigo to make a patch to add all stuff for deb-swift* in infra
20:06:19 <zigo> onovy: You have to prepare all the /git/openstack/deb-* in Alioth though.
20:06:20 <strigazi> ok, I have a patch waiting to rebase. I'll see if we can add the creation of the magnum_domain in debconf
20:06:38 <onovy> zigo: any manual for it?
20:06:57 <zigo> onovy: The structure is only a debian/newton (no other branch), then the tip of master from upstream.
20:07:02 <zigo> That's all there is to know.
20:07:07 <zigo> And call them all deb-*
20:07:09 <onovy> ok, i will prepare it
20:07:19 <zigo> onovy: Let me know when done, and I'll make the infra patch.
20:07:24 <onovy> ok
20:07:31 <zigo> #actoin onovy to prepare the swift deb-* git repositories on Alioth
20:07:42 <zigo> onovy: I think we should make you core as well.
20:07:46 <zigo> tlbr: Do you agree ?
20:07:54 <tlbr> zigo, of course
20:07:57 <zigo> :)
20:07:59 <tlbr> #action onovy to prepare the swift deb-* git repositories on Alioth
20:08:01 <onovy> cool :)
20:08:18 <zigo> #action zigo to propose onovy as core for packaging_deb
20:08:19 <tlbr> :)
20:08:32 <zigo> onovy: Without core, you can push merge commits, so it's important.
20:08:41 <onovy> *can't?
20:08:42 <zigo> (you can't push tags as well, but that's fine...)
20:08:46 <zigo> can't, right.
20:08:47 <zigo> sorry
20:08:49 <onovy> ok
20:09:25 <zigo> As for the uploads to Debian experimental, I did so far only aodh (because first in alpha order...
20:09:37 <zigo> And Keystone.
20:09:55 <zigo> #topic Issue with taskflow and Py3
20:10:08 <zigo> It looks like taskflow fails with Py3 in Sid.
20:10:12 <zigo> I couldn't build it.
20:10:20 <zigo> It built fine in Jessie in infra though.
20:10:29 <zigo> Does any of you want to work on that?
20:10:41 <zigo> It's to be dealt with harlowja IMO.
20:10:48 <harlowja> whatttt
20:10:51 <zigo> He's by far the top commiter of taskflow.
20:11:05 <harlowja> sup
20:11:14 <zigo> harlowja: It looks like taskflow fails to build in Sid with issues in Py3 tests.
20:11:19 <harlowja> any idea what failure?
20:11:29 <zigo> Let me get my build log ...
20:11:32 <harlowja> cool
20:12:01 <zigo> harlowja: http://paste.debian.net/829951/
20:12:16 <zigo> (if you don't run debian, ignore the cert error...)
20:12:34 <harlowja> can u get me a pip freeze
20:12:43 <harlowja> almost looks like a testtools or mock or something issue
20:13:35 <zigo> hogepodge: Oh, maybe I didn't clean my env before building ... :/
20:13:46 <zigo> hogepodge: Sorry, wrong person.
20:13:49 <harlowja> :-P
20:13:52 <zigo> harlowja: http://paste.openstack.org/show/581226/
20:13:52 <harlowja> close
20:14:08 <zigo> harlowja: I'll attempt to rebuild with a clean env, and let you know.
20:14:11 <harlowja> kk
20:14:13 <harlowja> also py3.4
20:14:15 <harlowja> which py3
20:14:18 <harlowja> ?
20:14:35 <zigo> harlowja: 3.5
20:14:38 <harlowja> btw, since this seems to be a meeting, ping me after in #openstack-oslo if u want
20:14:44 <harlowja> don't want to take all your guys time
20:14:46 <zigo> Will do, thanks.
20:14:52 <harlowja> np
20:14:58 <tlbr> 3.5.1 is in sid
20:15:02 <zigo> #topic Re-enabling unit tests that were disabled
20:15:14 <zigo> #link end of https://etherpad.openstack.org/p/openstack-deb-packaging
20:15:52 <zigo> We got to re-enable all of these tests that were temporarily disabled until all build-depends were available.
20:16:00 <zigo> Does anyone have time for that?
20:16:24 <zigo> It's trivial work, just uncomment in debian/rules and debian/control, and send the patch for review.
20:16:29 <tlbr> zigo, I can take a look once I finished with Horizon
20:16:37 <zigo> tlbr: Ok.
20:16:56 <zigo> #action tlbr to have a look once his finished with Horizon
20:17:12 <zigo> #topic Horizon status
20:17:21 <zigo> tlbr: How far are you in?
20:17:49 <tlbr> zigo, I'm on the way of pushing tv4 with removed non-free stuff
20:18:50 <zigo> I had some chat with robcresswell, he says there's now almost full support for Django 1.10 there, so that's a good thing. The only thing that fails is the "manage.py compress", so functional tests aren't fully working yet, but it will be finished soon, he said.
20:18:57 <tlbr> cool!
20:19:03 <zigo> tlbr: Is there some non-free stuff in the other one?
20:19:15 <zigo> Angular-Schema-Form
20:19:29 <zigo> Or is it good to go for an upload to Sid?
20:20:06 <zigo> #action tlbr to finish his work on removing non-free files in libjs-tv4, then we're good with it
20:20:39 <tlbr> zigo,  python-xstatic-angular-schema-form_0.8.13.0-1.dsc is ok
20:20:48 <zigo> #link last horizon Django 1.10 patch under review https://review.openstack.org/357829
20:20:56 <tlbr> lintian show non of unfree stuff
20:21:00 <tlbr> *s
20:21:18 <zigo> #action zigo to review tlbr package for xstatic-angular-schema-form
20:21:36 <zigo> #topic Stackalytic status
20:21:43 <zigo> tlbr: Any news from Ilya ?
20:21:54 <zigo> I failed to try again to get in touch, sorry... :(
20:22:04 <zigo> Newton release is taking all of my time.
20:22:32 <tlbr> zigo, I had a conversation with Ilya, as for now there is no easy fix for it. We will have a call tomorrow's afternoon
20:22:44 <zigo> Good.
20:23:00 <tlbr> Anyway we should fine a workaround for it.
20:23:04 <tlbr> *find
20:23:20 <zigo> #action tlbr to have a call with Ilya about how to fix Stackalytics, workaround should be possible
20:23:47 <zigo> #topic Tempest testing with packages on infra
20:24:02 <zigo> So, I have my scripts that worked until Newton b2.
20:24:12 <zigo> Now, the question is: will it work on infra
20:24:44 <zigo> mordred: clarkb: fungi: Any of you around?
20:24:46 <tlbr> what might go wrong ?
20:25:33 <zigo> tlbr: During the setup, the script is building a bridge, and that bridge is normally facing the public internet.
20:26:05 <zigo> With such a setup, if the different cloud running OpenStack infra have a mac filter, then no network packet will go through.
20:26:27 <zigo> tlbr: Do you know if we could run a different kind of setup?
20:26:49 <zigo> Also, I'm not sure if 8GB is enough.
20:27:09 <zigo> The other possibility would be to continue validating with real hardware, as I used to do with Jenkins.
20:27:13 <tlbr> zigo, you mean another way to deploy openstack ?
20:27:17 <zigo> But that's kind of cluky...
20:27:21 <zigo> tlbr: Yup.
20:27:51 <tlbr> with devstack may be
20:28:01 <zigo> tlbr: The point is to test packages ...
20:28:17 <zigo> The jenkins solution isn't good as well because we wouldn't be able to use it as a gate / check in other jobs.
20:28:30 <zigo> Anyway, maybe postpone that for next week?
20:28:52 <zigo> #topic Barcelona summit
20:29:08 <zigo> Who's attending?
20:29:14 <zigo> onovy: strigazi: Are you comming?
20:29:24 * onovy 
20:29:40 <strigazi> yeap
20:29:51 <zigo> It looks like my company isn't willing to pay for my trip, but I'll go anyway.
20:30:04 <onovy> huh
20:30:24 <zigo> It's *very* cheap to fligh (100 EUR), I just need to find a place to stay.
20:30:39 <zigo> I may ask a friend ... :P
20:31:13 <zigo> tlbr: onovy: strigazi: Anything you'd like to see on the agenda?
20:31:33 <onovy> no
20:31:47 <zigo> We still have a month to think about it...
20:31:49 <tlbr> zigo, i guess i have no questions for now
20:32:06 <zigo> Ok, let's all think about it then! :)
20:32:07 <strigazi> I'll think of it
20:32:18 * onovy too
20:32:34 <zigo> #action everyone to think about the agenda for Barcelona Summit, and we'll discuss it next week.
20:32:44 <zigo> #topic open discussion
20:32:53 <zigo> Anything else?
20:33:43 <zigo> I think we're good then...
20:34:21 <zigo> #endmeeting