22:11:11 <jog0> #startmeeting db
22:11:12 <openstack> Meeting started Thu Nov 29 22:11:11 2012 UTC.  The chair is jog0. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:11:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:11:15 <openstack> The meeting name has been set to 'db'
22:11:23 <russellb> jkyle: very top of that wiki page
22:11:37 <jog0> I am sitting in for devananda who is on a plane
22:11:59 * jkyle got it
22:12:04 <jog0> who's here?
22:12:16 <russellb> \o sorta
22:12:42 <dripton_> here
22:14:16 <jog0> #link http://wiki.openstack.org/Meetings/DBTeamMeeting
22:14:26 <jog0> thats the agenda
22:14:32 <jog0> lets start with last weeks action items
22:15:38 <jog0> were any of the HP guys able to release the db-archive code for mysql?
22:15:59 <jog0> dripton_: ?
22:16:14 <dripton_> I didn't hear anything from devananda about that.
22:16:29 <jog0> ok, we will put that back up for next week
22:16:45 <jog0> #action devananda to find and post existing db-archive code for MySQL
22:17:03 <jog0> russellb: it looks like you had some more blueprints to create
22:17:24 <russellb> orly
22:17:34 <jog0> db blueprints #8 and 9 it looks like  :)
22:17:48 <russellb> oh yes
22:17:52 <russellb> and in fact the patch already went in
22:17:54 <russellb> sooooo
22:18:01 <russellb> comstud wrote it and i think it's merged
22:18:25 <jog0> link to the merge?
22:18:31 <russellb> looking
22:18:54 <russellb> https://review.openstack.org/#/c/16596/
22:19:15 <jog0> excellent
22:19:50 <jog0> #topic thread pool
22:20:03 <russellb> done!  \o/
22:20:05 <jog0> #link  https://review.openstack.org/#/c/16596/
22:20:08 <russellb> so yeah, i'll put a blueprint up for it
22:20:11 <russellb> so it's on the record
22:20:17 <jog0> #info done!
22:20:33 <jog0> #action russellb put up blueprint for record keeping
22:20:54 <jog0> #topic db-unique-key
22:21:02 <jog0> you had this blueprint creation as well
22:21:19 <dripton> that's devananda's BP, right?
22:21:43 <jog0> I think so, but russellb  volunteered to create it
22:21:56 <russellb> i did?
22:21:59 * russellb doesn't know what that is
22:22:22 <dripton> I thought devananda volunteered to create it.
22:22:24 * jog0 going over http://eavesdrop.openstack.org/meetings/db/2012/db.2012-11-15-22.05.log.html again
22:22:49 <jog0> ohh my mistake
22:23:06 <russellb> btw, link to non-blocking-db blueprint - https://blueprints.launchpad.net/nova/+spec/non-blocking-db
22:23:07 <jog0> #action devananda to post db-unique-key blueprint
22:23:13 <sdague> so the existing db-unique-key review I've seen has issues - https://review.openstack.org/#/c/16940/ because mysql is sloppy :)
22:23:21 <sdague> but postgresql isn't
22:24:11 <sdague> deleted=False is a type error in postgresql unless the column is a boolean
22:24:25 <jog0> #link https://blueprints.launchpad.net/nova/+spec/non-blocking-db
22:25:17 <dripton> So that non-blocking-db blueprint is only for mysql. Do we need to add a parallel one for postgres?
22:25:24 <jog0> ahh devananda did create the blueprint, just hasn't been approved
22:26:46 <jog0> dripton:  lets come back to that in a minute, and finish unique-keys first
22:27:57 <jog0> sdague: it sounds like we need to keep working on this one
22:28:14 <jog0> sdague:  https://blueprints.launchpad.net/nova/+spec/db-unique-keys has no assignee, do you want to take it on?
22:28:30 <jog0> it also needs approval, russellb
22:28:34 <sdague> jog0: yeh, the reality is that False != 0 thing actually caught us other places in tempest trying to get postgresql up
22:28:42 <russellb> jog0: ack
22:28:58 <sdague> jog0: I wasn't actually trying to take it on, I was hoping who ever was working the review would be on so I could help explain things
22:29:20 <russellb> thoughts on the priority?
22:29:40 <dripton> it's a prereq for db-archiving, so fairly high priority
22:30:03 <russellb> grizzly-2?
22:30:10 <jog0> dripton: I thought doing the unique delete column gets around the prereq part
22:30:42 <dripton> jog0: ok, I must be mixing up the blueprints
22:30:57 <jog0> dripton:  I may be as well, we do have something like 9 bps now
22:31:40 <jog0> sdague: do know if boris is around?
22:31:45 <sdague> I do not
22:32:24 <jog0> so should we just give him the bp anyay?
22:32:29 <dripton> I agree with jog0; db-unique-keys is no longer a prereq for db-archiving.
22:33:31 <jog0> so Devananda, has the bp for now.  Lets move on… or rather back to db pool
22:33:40 <jog0> #topic db pool
22:33:56 <jog0> dripton: you pointed out the current patch only works for mysql
22:34:06 <jog0> so do we still need a postrgres solution?
22:34:16 <dripton> The current blueprint only mentions mysql. I haven't tested the patch on postgres.
22:34:28 <russellb> i looked at the patch, it is indeed mysql specific
22:35:06 <jog0> would a postgres solution be completely different or can it reuse part of the code?
22:36:46 <sdague> I think at this point as long as we don't break postgresql it's ok, people that care can optimize there
22:37:02 <jog0> sdague:  works for me
22:37:49 <dripton> ok, I'll take a look at whether it's easy to port to postgres
22:38:05 <dripton> It's hacking around in the mysql driver, and it's possible that the parallel hack is possible in psycopg2
22:38:12 <jog0> #action dripton explore dbp pool for postgres
22:38:39 <jog0> if you want to pursue that option we can just generalize the current blueprint to cover postgres as well
22:38:50 <jog0> moving on ...
22:38:58 <dripton> Let me look first, and if it's practical we can edit the BP
22:39:06 <jog0> anyone here from db-common?
22:39:38 <jog0> ewindisch: ?
22:40:24 <jog0> #topic no-db-compute
22:40:32 <jog0> russellb: it looks like things are moving along nicely
22:40:46 <russellb> yes
22:41:00 <russellb> making good progress, hard to say what percentage we're at
22:41:15 <russellb> we've started moving things to nova-conductor, and we're exposing some issues here and there along the way
22:41:28 <russellb> hopefully it will speed up once we understand the types of issues we're going to hit while doing it
22:41:58 <russellb> we need to be on the lookout for property-style access for db models in the compute code
22:42:01 <russellb> i know there's more still in there
22:42:14 <jog0> yeah, I am working on attribute access for my bp as well
22:42:15 <russellb> and they're going to turn into bugs either when we move db access, or you stop model leaks
22:42:24 <russellb> yeah, saw a patch for that
22:42:44 <russellb> i guess we just hope for good test coverage to expose it
22:43:06 <jog0> I am using my PoC  no sqlalchemy leaks to detect the attribute  accesses
22:43:15 <russellb> cool
22:43:37 <russellb> very helpful
22:43:51 <jog0> I have another patch I am working  right now
22:44:23 <jog0> what happens to nova-conductor if its not finished by Grizzly release?
22:44:32 <jog0> as in still db writes from nova-compute?
22:45:03 <russellb> depends how far along we are
22:45:13 <russellb> if we stopped right where we are today
22:45:24 <russellb> we'd probably just change the default config so [conductor] use_local=True is the default
22:45:38 <russellb> which would make it so you don't have to run nova-conductor
22:45:43 <jog0> cool
22:45:45 <russellb> since it wouldn't provide much value
22:46:01 <jog0> with 15 min to go  we have a bunch of BPs to cover so lets move on
22:46:06 <russellb> ack
22:46:12 <jog0> #topic db-api-cleanup
22:46:22 <jog0> as I just said, this one is moving along nicely
22:46:58 <jog0> hope to have the whole thing done by g3 but targeting nova.db.api only returning primitives by Grizzly-2
22:47:12 <jog0> leaving db.api consolidation for G3
22:47:29 <jog0> #topic db-archive
22:47:39 <jog0> dripton: take it away
22:47:39 <dripton> Not started on db-archive yet.
22:47:47 <dripton> I'll have something for you next week
22:47:54 <jog0> can you target it to a milestone
22:47:59 <jog0> is this G2 or G3?
22:48:34 <dripton> G3 is safer for now.  I think it's easy enough that we'll probably hit G2, but I don't want to promise yet.
22:49:05 <jog0> sounds good
22:49:22 <jog0> #action dripton  target db-archive for G3, with goal of hitting G2
22:49:39 <jog0> #topic db-reconnect
22:49:48 <jog0> it looks like this one hasn't been started either
22:50:03 <jog0> #action devananda target db-reconnect
22:50:31 <jog0> #topic db-session-cleanup
22:50:53 <jog0> looks like this one is moving along nicely, anyone have any comments?
22:51:19 <jog0> #action devananda target db-session-cleanup to milestone
22:51:40 <jog0> #topic backportable-db-migrations
22:51:51 <jog0> dripton: any comments on this one
22:52:13 <jog0> you talked about working on it and alembic last time
22:52:16 <dripton> I have a work in progress alembic conversion but have not submitted to the dev list yet.
22:52:29 <dripton> I want to make sure it passes all tests first since it will be controversial.
22:52:49 <dripton> It's currently failing a couple.  When it works I will send mail to openstack-dev asking for comments.
22:52:54 <jog0> ETA on that?
22:53:01 <dripton> Monday of next week
22:53:29 <jog0> #action dripton prepare alembic patch to discuss on openstack-dev
22:55:01 <jog0> I think that brings us to the end
22:55:04 <jog0> #open discussion
22:55:12 <jog0> #action open discussion
22:55:17 <jog0> #undo
22:55:18 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x2351dd0>
22:55:25 <jog0> #topic open discussion
22:55:28 <jog0> anything else?
22:57:05 <dripton> I guess we're done.
22:57:08 <jog0> thank you everyone
22:57:17 <dripton> thanks dog0
22:57:20 <dripton> jog0
22:57:24 <jog0> #endmeeting