07:59:50 <huzhj> #startmeeting daisycloud
07:59:51 <openstack> Meeting started Fri Oct 21 07:59:50 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:59:54 <openstack> The meeting name has been set to 'daisycloud'
08:00:20 <huzhj> #topic Roll Call
08:00:33 <huzhj> #info Zhijiang
08:00:37 <zhuzeyu> #info zhuzeyu
08:00:48 <zhouya> #info zhouya
08:02:54 <huzhj> today's topic
08:03:05 <huzhj> 2) OPNFV: Escalator Support
08:03:06 <huzhj> 3) OPNFV: Daisy4nfv CI Framework Progress
08:03:06 <huzhj> 4) Core Code Abstraction
08:03:06 <huzhj> 5) Newton Release Related
08:03:41 <luyao> #info luyao
08:03:46 <huzhj> #topic OPNFV: Escalator Support
08:04:29 <huzhj> seem still can not contact Wei this time.
08:04:57 <zhouya> maybe he is busy with CI
08:06:02 <huzhj> Hi @kongwei
08:06:05 <huzhj> are you there?
08:06:06 <kongwei> hi all
08:06:12 <kongwei> yes
08:06:12 <zhouya> Hi
08:06:15 <huzhj> Finally hehe
08:06:29 <huzhj> So we are here: Escalator Support
08:06:38 <kongwei> ok
08:06:48 <huzhj> do you have any thing share with us about Escalator?
08:07:17 <kongwei> escalator jion the D version
08:07:50 <huzhj> #info @kongwei said escalator decide to join the D version
08:08:11 <kongwei> hujie post the plan
08:08:55 <huzhj> Great, so there must be some opptunity to colaborat
08:09:08 <kongwei> the link is:
08:11:57 <huzhj> is that #link https://wiki.opnfv.org/display/escalator/Release+Plan+for+Danube  ?
08:12:10 <kongwei> Yes
08:12:44 <kongwei> Sorry I can not copy link here
08:13:11 <huzhj> no sweat,  all good :0
08:13:15 <huzhj> :)
08:13:16 <kongwei> The kiwi ice
08:13:24 <kongwei> Too slowly
08:13:52 <huzhj> #info escalator plan for D: #link https://wiki.opnfv.org/display/escalator/Release+Plan+for+Danube
08:14:02 <huzhj> Got the plan.
08:14:24 <kongwei> Escalator will work with daisy
08:14:31 <zhouya1> sound wonderful
08:14:37 <huzhj> Installing OpenStack via Daisy4NFV on scenarios "os-nosdn-nofeature-ha"  ....  For this , I think we need to have more detail discussions
08:14:44 <kongwei> Thanks
08:15:35 <huzhj> for example the config file format , the api used to control daisy...
08:16:33 <kongwei> That's all
08:16:35 <huzhj> If escalator can use CLI of daisy, I think currently it is sufficient for escalator to deploy openstack through daisy.
08:17:12 <huzhj> But, IMHO, escalator shall not talk directly to a specific installer
08:17:34 <huzhj> So we  need a middle layer
08:17:53 <huzhj> to abstract the more general API
08:17:57 <kongwei> Yes
08:18:25 <kongwei> Escalator use cli first
08:18:41 <huzhj> agree
08:19:08 <huzhj> OK, let move to next topic
08:19:52 <huzhj> #info Escalator first uses daisy CLI , then futher , a abstracted layer is needed to impl.  general API
08:20:08 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:20:56 <huzhj> Good news for this is that now jenkins job can be triggered by our code changes
08:21:06 <huzhj> You can see this patch as example.
08:21:08 <huzhj> https://gerrit.opnfv.org/gerrit/#/c/23483/
08:21:28 <huzhj> #info now opnfv  jenkins job can be triggered by daisy4nfv code changes
08:21:39 <zhouya1> great
08:21:42 <luyao1> good
08:22:23 <huzhj> But , we still have a problem , that is some parameters are missing such as GERRIT_REFSPEC
08:22:58 <huzhj> I guess it is becasue the master job forgot to pass them to subsequence jobs.
08:23:23 <huzhj> So I made another patch for releng trying to solve this issue
08:23:40 <huzhj> https://gerrit.opnfv.org/gerrit/#/c/23493/
08:25:04 <huzhj> I will recheck this problem to see if it still exists, right after  https://gerrit.opnfv.org/gerrit/#/c/23493/  is merged.
08:26:01 <huzhj> #info  a patch #link https://gerrit.opnfv.org/gerrit/#/c/23493/  was sent to releng trying to solve parameter missing problem
08:26:40 <huzhj> Since we do not have Jing  online, that is all I got for this topic.
08:27:04 <huzhj> Is there anything to add to it
08:27:08 <huzhj> ?
08:27:31 <luyao1> no
08:27:35 <zhouya1> no
08:28:08 <huzhj> OK, thanks
08:28:13 <huzhj> #topic Core Code Abstraction
08:29:06 <huzhj> where are we now on this USF journey? :)
08:29:51 <zhouya1> we almost have the glance code cleaned up in our daisy code
08:30:09 <zhouya1> and the os abstraction is in progress
08:30:33 <huzhj> Good progress!
08:30:39 <kongwei> Yes
08:30:55 <zhouya1> I think we will clean up all the glance code till next week
08:31:08 <kongwei> Next is hwm
08:31:19 <zhouya1> absolutely
08:31:32 <huzhj> Is there any guy preopare to reimpl. HWM ? @kongwei
08:31:39 <kongwei> There are 403 diff , now
08:31:56 <huzhj> still lots of diffs..
08:32:04 <kongwei> Yes
08:32:47 <huzhj> Good
08:33:05 <kongwei> Zhanghui and wuwei are working on this job
08:34:02 <huzhj> what about the original author? I remember it is Shiping.
08:34:03 <kongwei> Sorry. I forget zhouya.
08:34:27 <huzhj> hope we can get more support from the original author too.
08:34:29 <zhouya1> Never mind .
08:34:31 <huzhj> Thanks guys.
08:35:16 <zhouya1> May be zhushiping can help us with the HWM.
08:35:33 <huzhj> And I think @luyao is working on another issue similar to core code abstraction
08:35:38 <kongwei> There are four person doing this job
08:35:48 <kongwei> Yes
08:36:13 <luyao1> yes
08:36:16 <huzhj> @luyao1 is working on how to add extra files into artifact
08:36:23 <huzhj> @luyao1 is working on how to add extra files into artifact for OPNFV
08:36:36 <kongwei> Great
08:37:20 <huzhj1> such as adding centos iso image and kolla image.
08:37:38 <luyao1> now can add iso and tar to our bin in opnfv build
08:37:53 <huzhj1> #info said @zhouya, we almost have the glance code cleaned up in our daisy code
08:37:59 <huzhj1> #info next step is HWM
08:38:12 <huzhj1> #info @luyao1 is working on how to add extra files into artifact for OPNFV
08:39:45 <huzhj1> guys, I would like to add another info for the last topic Daisy4nfv CI Framework Progress
08:40:23 <huzhj1> #info add another info for the last topic Daisy4nfv CI Framework Progress:Daisy decide to use single machine to build , deploy and test.
08:41:15 <huzhj1> that is because if we use more that one machine, then we have to deal with moving artifacts from one machine to another proble,
08:42:08 <huzhj1> OK, any thing else for the current topic?
08:42:58 <zhouya> no
08:43:06 <zhuzeyu> no
08:43:43 <huzhj1> @kongwei, I think @luyao's work can also be reused by inner daisy team to do extensions such as adding rpm packages into artifact...
08:43:44 <kongwei> None
08:43:47 <huzhj1> what do you think?
08:43:55 <kongwei> Yes
08:44:04 <kongwei> Agree
08:44:11 <zhouya> #agreed
08:44:12 <huzhj1> OK
08:44:20 <huzhj1> #topic Newton Release Related
08:45:22 <huzhj1> For this, I have successfully have the Newton version kolla images built
08:45:30 <huzhj1> You can get them from ftp://openuser:123@120.76.145.166/registry-3.0.0.tgz
08:45:40 <huzhj1> #info successfully have the Newton version kolla images built  for the very first time
08:45:40 <zhouya> great
08:45:44 <kongwei> Great job
08:46:04 <huzhj1> #can get from  ftp://openuser:123@120.76.145.166/registry-3.0.0.tgz
08:46:04 <zhouya> Have it be deployed?
08:46:10 <huzhj1> #info can get from  ftp://openuser:123@120.76.145.166/registry-3.0.0.tgz
08:46:15 <huzhj1> not yet
08:46:21 <huzhj1> I will do it next week
08:46:37 <huzhj1> @action do newton deplyment
08:46:42 <huzhj1> #action do newton deplyment
08:47:22 <huzhj1> for the image version, it is tagged as 3.0.0
08:47:45 <huzhj1> when it comes to the image version , it seems we have a little problem
08:47:46 <zhouya> Check if it has solved the problem of django
08:48:02 <huzhj1> @zhouya, OK, will do that
08:48:46 <huzhj1> the problem is we do not currently have any way to tell what is the exactly version of each component in each docker image
08:49:09 <huzhj1> I think we can contribute to kolla project to get this type of things done.
08:49:31 <kongwei> Yes
08:49:41 <huzhj1> I knew fuel do abstact the git version out from each rpm
08:49:41 <zhuzeyu> agree
08:50:11 <huzhj1> then build a file called something like version_describing_file.txt
08:50:59 <huzhj1> without it , downstream developers are hard to find out what version they are working on
08:51:26 <huzhj1> only if after deploy the image
08:52:27 <huzhj1> @zhuzeyu, as you are working on subjects much upper stream, could you please take a look at this ?
08:53:13 <zhuzeyu> Just began to read
08:53:52 <huzhj1> All good. let's talk offline about this new feature.
08:54:43 <huzhj1> OK, that is all for this topic for me
08:54:54 <huzhj1> anything else?
08:54:59 <zhouya> no
08:55:35 <zhuzeyu> no
08:55:44 <kongwei> Null
08:56:48 <huzhj1> OK. time is right to wrap up
08:57:30 <huzhj1> Have a good weekend.
08:57:43 <zhouya> The same to you,boss
08:57:45 <huzhj1> hope no more rain for this weekend
08:58:05 <kongwei> Thanks
08:58:10 <kongwei> Bye
08:58:13 <zhouya> Me neither
08:58:18 <zhouya> Bye
08:58:18 <zhuzeyu> bye
08:58:18 <luyao> thanks,bye
08:58:19 <huzhj1> Bye
08:58:29 <huzhj1> #endmeeting
08:59:37 <huzhj1> Seem i have to relogin to my account to issue endmeeting cmd hehe
09:00:30 <huzhj> #endmeeting