08:02:33 <huzhj> #startmeeting daisycloud
08:02:34 <openstack> Meeting started Fri Oct 14 08:02:33 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:02:37 <openstack> The meeting name has been set to 'daisycloud'
08:02:53 <huzhj> #topic Roll Call
08:03:04 <zhouya> #info zhouya
08:03:07 <huzhj> #info Zhijiang
08:03:18 <zhuzeyu> #info zhuzeyu
08:03:19 <huzhj> hello Ya & Jing
08:03:26 <huzhj> hello Zeyu
08:03:30 <zhouya> hello
08:04:08 <Jingsun> #info sunjing
08:04:13 <Jingsun> hello
08:04:23 <huzhj> Let's wait Wei for a while
08:04:33 <zhouya> OK
08:05:10 <Jingsun> ok
08:05:36 <huzhj> Or may be we can move on to OPNFV: Daisy4nfv CI Framework Progress first and move back to OPNFV: Escalator Support later?
08:06:02 <zhouya> OK
08:06:04 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:06:08 <zhouya> #agree
08:06:37 <huzhj> @Jingsun , any update from your side?
08:06:59 <huzhj> I saw your patch. Now it is Ok for me
08:07:04 <huzhj> +2 already
08:07:45 <Jingsun> I have commit a patch for daisy4nfv verify build job.
08:07:57 <huzhj> No verify job currently, I dont know why, may be becasue the project name issue in our JJB.
08:08:37 <Jingsun> I guess it is the cause.
08:09:02 <huzhj> OK
08:09:45 <huzhj> beside ,I also sync your rpm dependence triming work to upstream
08:10:08 <huzhj> by this patch: https://review.openstack.org/#/c/386409
08:10:29 <Jingsun> I will modify this with a bug commit with releng.
08:10:36 <huzhj> #info @jingsun have commit a patch for daisy4nfv verify build job.  https://gerrit.opnfv.org/gerrit/#/c/23053
08:11:15 <huzhj> #info @huzhj  syncrpm dependence triming work to upstream  by this patch: https://review.openstack.org/#/c/386409
08:11:33 <Jingsun> And I have commit the code about with releng.
08:12:04 <huzhj> @Jingsu please use #action command to add your action, so we can follow up easily
08:12:24 <huzhj> for example #action @Jingsun will modify this with a bug commit with releng.
08:13:00 <huzhj> Thanks
08:13:07 <Jingsun> https://Gerrit.opnfv.org/Gerrit/#/23057
08:13:45 <Jingsun> sorry for the phone is not so good for this meeting.
08:14:12 <huzhj> You need a bluetooth keyboard:)
08:14:30 <Jingsun> It will change the word to capital.
08:15:19 <huzhj> It's OK, let's talk later offline.
08:15:40 <huzhj> naything else?
08:15:42 <Jingsun> ok
08:15:45 <huzhj> anything else?
08:15:58 <huzhj> How about the vm deployment?
08:16:37 <huzhj> Hope julien's enviroment is ready to be connected to OPNFV master
08:16:58 <Jingsun> There will be a slave for daisy verify deploy job.
08:18:10 <Jingsun> Julien will support with a E9000.we can deploy with it.
08:18:14 <huzhj> Just remind that we have to finish build/vm deploy/functest smoke test before MS3, thus, 11/30/2016
08:18:24 <huzhj> Good!
08:18:33 <huzhj> E9000 is awesome
08:19:51 <Jingsun> The six vm on the board we can use for deploy purpose.
08:20:31 <Jingsun> Ok.I will work on this job all the next month.
08:20:36 <huzhj> I think we should push julien's team a little to remind them  to connect that blade to jenkins master.
08:20:46 <huzhj> Thank you
08:21:12 <Jingsun> I will email to them after meeting.
08:21:57 <huzhj> #action @Jingsun will email to julien's team   to remind them to connect that E9000 to  jenkins master.
08:22:24 <huzhj> OK,shall we move on to next topic?
08:22:30 <Jingsun> ok
08:22:41 <zhouya> ok
08:22:47 <huzhj> #topic Host Interface Configration Function Regression
08:23:12 <huzhj> @zhouya, I saw you found out this Regression issue
08:23:25 <zhouya> yes
08:23:37 <huzhj> which impact host interface configuration function
08:24:01 <huzhj> what is the next step we take to get ride of it?
08:24:57 <zhouya> 有 mean os.json and mac.json?
08:25:09 <huzhj> exactly
08:25:16 <zhouya> you mean
08:25:39 <zhuzeyu> 0.0
08:26:34 <zhouya> I think we should dive into these file to see which data is needed by US
08:27:36 <zhouya> for example,os.json is saved in /home/os-install dir in target node
08:27:37 <huzhj> Yes, that is important. but for this bug, I think we can align function from inner daisy first.
08:27:57 <zhouya> exactly
08:28:31 <zhouya> and the information such as MANAGEMENT is needed by us
08:29:06 <zhouya> these data is read from Daisy db
08:29:21 <zhouya> but do not rewrite daisy db
08:29:24 <huzhj> we have already have the ability to get MANAGEMENT from user then put it to Kolla right?
08:29:45 <zhouya> yes
08:30:00 <huzhj> the only thing we are missing now is pass this json to target host
08:30:23 <huzhj> and let target host to config NIC base on it
08:31:27 <zhouya> but such as root-disk glance-lv-is not ne
08:31:33 <huzhj> About MANAGEMENT IP, I am writing a doc to describe how it value come and go.
08:32:01 <zhouya> when we install os on target node
08:32:22 <zhouya> should we do some config of the target node?
08:32:38 <huzhj> sure, that is nessesary
08:32:42 <zhouya> it is also in os.json
08:33:13 <huzhj> I think we can align this function from inner daisy withour any modification
08:33:24 <huzhj> without any modification
08:33:34 <huzhj> right?
08:33:36 <zhouya> exactly
08:34:47 <huzhj> becasue it has nothing about the differrence between tecs and openstack. it is totally about OS installation
08:35:00 <zhouya> yes
08:35:04 <huzhj> OK, anything else?
08:35:13 <zhouya> no
08:36:13 <huzhj> #action @zhouya will align Host Interface Configration Function as well as  root-disk ...
08:36:16 <huzhj> Thanks
08:36:30 <huzhj> #topic Core Code Abstraction
08:38:23 <huzhj> I am thinking about the completeness of our OS abstraction
08:38:44 <zhouya> about bifrost?
08:38:47 <huzhj> So currently , we have already had the installation abstract
08:38:56 <zhouya> yes
08:39:23 <huzhj> but we do not have the api abstracted
08:39:36 <huzhj> I mean how to accesss host info
08:39:38 <zhouya> #agreed
08:39:52 <huzhj> from daisy or from ironic/bifrost
08:40:14 <huzhj> I would like to make a BP to this
08:40:28 <zhouya> agree
08:40:34 <huzhj> do it in near future, it is not urgent
08:41:13 <huzhj> For bifrost, I have split out mitaka branch
08:41:51 <huzhj> so now our master branch is free to support Newton release which we can use bifrost provided by kolla
08:42:21 <huzhj> Hello @Julien-zte
08:42:41 <zhouya> so the change we will commit to master about bifrost?
08:42:53 <huzhj> yes
08:42:59 <zhouya> OK
08:43:32 <huzhj> But please cherry pick any patch to mitaka if it is also needed by mitata
08:43:48 <zhouya> got it
08:44:29 <huzhj> OK, anything else for this topic?
08:45:14 <zhouya> no
08:45:40 <huzhj> Good, now we only left one topic OPNFV: Escalator Support
08:46:45 <huzhj> One thing sure is taht Escalator will also release in OPNFV D version
08:46:57 <zhouya> great
08:47:50 <huzhj> the basic API it want installer to support is to return the version of each component on each host we depolyed
08:48:14 <huzhj> for example the version of nova on compute001
08:48:17 <Jingsun> Will daisy support escalator with Opnfv D?
08:48:47 <huzhj> I hope so
08:49:25 <huzhj> Opnfv D got a magnificent name "Danube"
08:49:35 <zhouya> so we should call Nova api?
08:50:18 <huzhj> Not really , just return the nova package version is enough. my 0.02$
08:50:32 <zhouya> OK
08:50:35 <huzhj> Need to contact to kongwei to make sure
08:50:57 <Jingsun> Maybe version Api?
08:51:25 <huzhj> yes @Jing new API should be impl. in daisy-api
08:52:05 <Jingsun> got it.
08:53:05 <huzhj> well since we lost kongwei, there is not quite alot for this topic
08:53:56 <huzhj> nothing for today according to our agenda. anything else to discuss?
08:54:06 <zhouya> we could discuss this off line
08:54:14 <huzhj> Good.
08:54:42 <huzhj> Guys, how was your vacation?
08:55:00 <zhouya> just so so
08:55:17 <zhouya> lots of wedding to attend
08:55:29 <huzhj> average ordinary ? hehe
08:55:34 <Jingsun> Enjoied much.
08:55:45 <zhouya> yes
08:55:47 <huzhj> Oh, wedding...
08:56:12 <huzhj> A big expense hehe
08:56:26 <zhouya> #agreed
08:56:39 <zhuzeyu> haha
08:56:44 <Jingsun> agree
08:57:10 <huzhj> :)
08:57:49 <huzhj> OK, let's call it a meeting
08:57:56 <zhouya> OK
08:57:57 <huzhj> have a good weekend
08:58:08 <zhouya> same to you,bye
08:58:36 <huzhj> 8  work day is crazy, take a good rest
08:58:41 <huzhj> bye
08:58:43 <Jingsun> Bye
08:58:50 <zhuzeyu> bye
08:58:52 <huzhj> #endmeeting