07:59:50 <huzhj> #startmeeting daisycloud
07:59:51 <openstack> Meeting started Fri Sep 23 07:59:50 2016 UTC and is due to finish in 60 minutes.  The chair is huzhj. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:59:55 <openstack> The meeting name has been set to 'daisycloud'
08:00:30 <huzhj> Hi @zhouya
08:00:44 <zhouya> Hi
08:01:25 <huzhj> Let's wait for a while for others
08:01:33 <zhouya> OK
08:02:47 <huzhj> Hi @kongwei
08:03:02 <kongwei> hi
08:03:04 <huzhj> how is your day:)
08:03:19 <kongwei> I am fine, thank you.
08:03:54 <huzhj> Good
08:04:20 <huzhj> #topic Roll Call
08:04:25 <huzhj> #info Zhijiang
08:04:31 <kongwei> #info kongwei
08:04:39 <zhouya> #info zhouya
08:04:48 <kongwei> Hi zhouya
08:05:04 <huzhj> Hi @JingSun
08:05:08 <JingSun> #info SunJing
08:05:14 <JingSun> hi
08:05:35 <zhouya> Hi wei
08:06:21 <huzhj> OK, let's move on
08:06:24 <huzhj> #topic Core Code Abstraction
08:07:46 <luyao> #info luyao
08:07:51 <huzhj> @zhouya, any good news from your side ? I saw you seem have finished a patch to abstract a general layer for the baremetal privitioning
08:08:09 <zhouya> yes
08:08:13 <huzhj> sorry, provision
08:08:44 <zhouya> I just finish the patch of abstract OS installation type
08:09:07 <huzhj> Can you please simply describe the basic architecture about that layer?
08:09:19 <zhouya> but,we have a little problem on dashboard
08:09:47 <zhouya> I have notify sunjing to modify it
08:10:31 <zhouya> I split the os.py to pxe and bifrost
08:10:42 <huzhj> was the problem related to your work ?
08:10:57 <zhouya> so we can use bifrost in the future to install OS
08:11:23 <zhouya> no,the problem is the OS version problem
08:11:42 <huzhj> Yes, I saw your spliting work, but I don't understand why you create two file named api.py and install.py for each of them
08:12:34 <huzhj> @zhouya could you please show us the url of your patch?
08:12:55 <zhouya> api.py is the interface pxe or bifrost exposed to osdriver.py
08:13:05 <zhouya> OK
08:13:12 <zhuzeyu> sorry, I am late
08:13:34 <huzhj> #info @zhouya created a patch to abstract a general layer for baremetal provisioning
08:13:45 <huzhj> Hi @zhuzeyu, it is OK
08:13:52 <huzhj> Nice to see you
08:13:54 <zhouya> review.openstack.org/#/c/372867/
08:14:20 <zhouya> actually
08:14:29 <huzhj> #info #link http://review.openstack.org/#/c/372867/
08:14:44 <zhouya> we can just use install.py to realize this interface
08:15:09 <huzhj> OK
08:15:44 <huzhj> I hope everyone can take a couple of minutes to review @zhouya's work
08:15:57 <zhouya> We can discuss the realization of api.py together
08:16:17 <huzhj> Sure
08:16:21 <zhouya> I will test this patch tomorrow
08:16:29 <huzhj> Good.
08:16:45 <zhouya> while sunjing“s patch merged
08:17:27 <huzhj> @JingSun can you also provide the url of the patch which solve @zhouya's problem ?
08:17:37 <JingSun> @zhouya I have commit the bug to Gerrit.
08:18:07 <zhouya> OK, thank you
08:19:09 <JingSun> @huzhj ok,
08:19:42 <zhouya> http://review.openstack.org/#/c/375296/!
08:20:09 <zhouya> this one?
08:20:51 <zhouya> @JingSun
08:21:50 <huzhj> @JingSun, if it helps , you can provide the url after the meeting.
08:22:08 <JingSun> ok
08:22:21 <huzhj> Please do remember to add us as reviewer
08:22:25 <JingSun> send you later
08:22:33 <huzhj> otherwise, we may miss it.
08:22:56 <zhouya> exactly
08:23:05 <huzhj> OK, anything else from @zhouya?
08:23:19 <zhouya> no
08:23:25 <huzhj> Good.
08:23:54 <huzhj> For me, I have delete a whole bunch of glance code.
08:24:03 <zhouya> great
08:24:05 <huzhj> #link https://review.openstack.org/#/c/364098/
08:24:05 <huzhj> #link https://review.openstack.org/#/c/369117/
08:24:05 <huzhj> #link https://review.openstack.org/#/c/372004/
08:24:05 <huzhj> #link https://review.openstack.org/#/c/372021/
08:24:05 <huzhj> #link https://review.openstack.org/#/c/372049/
08:24:05 <huzhj> #link https://review.openstack.org/#/c/372078/
08:24:06 <huzhj> #link https://review.openstack.org/#/c/372207/
08:24:06 <huzhj> #link https://review.openstack.org/#/c/375278/
08:24:12 <kongwei> great!
08:24:16 <huzhj> #info These above patch delete approx. 37600 lines of glance code.
08:24:28 <luyao> good
08:24:50 <zhouya> so many
08:24:53 <huzhj> I hope now we can have a clearer view of our code.
08:25:37 <JingSun> huge code
08:26:10 <huzhj> @luyao, anything from your side about this topic?
08:26:42 <JingSun> @huzhj review.openstack.org/#/c/375296
08:27:30 <huzhj> @JingSun, got it.
08:27:53 <luyao> I think it is good
08:28:31 <huzhj> I think @luyao also work on this topic because she is diving into template and auto scaling code.
08:28:56 <luyao> I test auto scaling code
08:29:29 <huzhj> But need more time to figure out if these functions can be splited as general layer and specific layer
08:29:34 <luyao> and find a little need to modify
08:29:41 <huzhj> Good
08:30:04 <huzhj> release your code early so that everybody can get invoved
08:30:12 <luyao> I think auto scale code are general code
08:30:17 <luyao> all
08:30:24 <huzhj> Good news
08:30:42 <huzhj> ANything else?
08:30:58 <luyao> and I alsoread config code
08:31:12 <huzhj> you mean the configset code?
08:31:30 <luyao> I think service and component can be special for tecs
08:31:38 <luyao> yes
08:33:41 <huzhj> #info @luyao is working on service and component code and auto scaling code. auto scaling is a general functionality while  service and component  are not , they may be only for a special backend
08:34:17 <huzhj> @luyao, about  service and component  let's discuss offline for lacking of time
08:34:37 <luyao> ok
08:34:47 <huzhj> OK, shall we move to the next topic?
08:34:52 <luyao> yes
08:35:00 <huzhj> #topic Bifrost/Ironic Integration
08:36:03 <huzhj> For this topic , only we can do now is contribute to ironic to let ironic agent to get more detail pci device info.
08:36:27 <huzhj> so, @zhouya, any progress update from your side?
08:36:44 <huzhj> what about the patch for ironic agent ?
08:37:10 <zhouya> I modify the code last week
08:37:43 <zhouya> But unfortunately,my code didnot pass the unittest
08:38:23 <zhouya> Iwill dive into the commit to see if I can modify the unittest
08:38:56 <zhouya> And to make it pass the unittest
08:38:58 <huzhj> Yes, That is the right way. May be you can ask for help from ironic team
08:39:51 <zhouya> OK,thank you I think I should send a email to ironic team
08:40:02 <huzhj> Good
08:40:25 <huzhj> #action @zhouya will ask for help from ironic team to solve unittest problem
08:41:40 <huzhj> Anything else for this topic?
08:42:02 <zhouya> no
08:42:24 <huzhj> I think we need more time to spend on studying kolla/bifrost , because newton is comming
08:42:53 <huzhj> OK, next topic
08:42:53 <zhouya> #agree
08:43:16 <huzhj> #topic OPNFV: Daisy4nfv CI Framework Progress
08:43:38 <huzhj> @JingSun , for this topic , I saw your patch has been commited to OPNFV
08:43:52 <JingSun> Yes
08:44:10 <huzhj> But it has some little issues to rectify
08:45:01 <JingSun> we have made a conference call this week.
08:45:08 <huzhj> I think we need to contact to the OPNFV infra wg to see if we are using the env in a right way
08:45:21 <huzhj> with whom?
08:45:28 <JingSun> talked something about pod issues.
08:45:42 <huzhj> guys from OPNFV?
08:45:58 <JingSun> yes
08:46:03 <huzhj> Good
08:46:08 <huzhj> any conclution?
08:47:13 <JingSun> maybe I can use opnfv pods with opnfv-build-Ubuntu for build jobs.
08:48:04 <JingSun> And virtual deployment jobs can run with ate-pod2.
08:48:31 <huzhj> #info @JingSun said we can use opnfv-build-Ubuntu for build jobs and  virtual deployment jobs can run on zte-pod2
08:48:40 <JingSun> zte-posix?
08:49:15 <JingSun> maybe need a new vm for deploy.
08:49:17 <huzhj> @JingSun I don't know what zte-posix is
08:49:31 <fdegir> please ping me on #opnfv-octopus regarding opnfv-build-ubuntu hosts and pass me the packages your builds might depend so we can install them for you
08:49:38 <JingSun> If we can supply ourself
08:50:13 <huzhj> @fdegir thanks for the infomation, we will do that.
08:50:32 <JingSun> I mean Zte-pod x
08:50:38 <JingSun> a new pod
08:50:58 <huzhj> Really? we got a new pod, that great.
08:51:25 <JingSun> @fdegir thank you
08:51:57 <huzhj> @JingSun could you please contact with @fdegir for further collaboration?
08:52:06 <JingSun> Ok
08:52:14 <JingSun> I will do that
08:53:01 <huzhj> @action @JingSun will contact with @fdegir on #opnfv-octopus regarding opnfv-build-ubuntu hosts usage.
08:53:07 <huzhj> #action @JingSun will contact with @fdegir on #opnfv-octopus regarding opnfv-build-ubuntu hosts usage.
08:53:57 <huzhj> OK, anything else for this topic?
08:54:20 <JingSun> nothing for me
08:54:24 <huzhj> Good
08:54:30 <huzhj> #topic Bare Metal Deployment(PXE/IPMI) Test
08:55:03 <huzhj> I think @luyao and @zhouya are working on this test , any result until now?
08:56:02 <zhouya> Ijust test the PXE/IPMI baremetal deployment
08:56:04 <luyao> we can deploy success with pxe/ipmi but need merge sunjing's above code
08:56:20 <zhouya> #agree
08:58:21 <huzhj> OK, I will give priority to that patch
08:59:12 <luyao> I forget another patch also needed witch not merge
08:59:23 <huzhj> #info we can deploy success with pxe/ipmi with a patch from @JingSun (#link https://review.openstack.org/#/c/375296/)
08:59:29 <huzhj> #link https://review.openstack.org/#/c/375296/
08:59:55 <luyao> https://review.openstack.org/#/c/373675
09:00:16 <zhouya> this patch conflict with mine
09:00:23 <luyao> It can also merge after zhouya code merge
09:00:29 <zhouya> I will deal with the conflict
09:01:07 <luyao> you can merge first,Imodify it later
09:01:15 <zhouya> OK
09:01:21 <huzhj> let's hold https://review.openstack.org/#/c/373675 for a while to let @zhouya's refactory code to go in first, OK?
09:01:30 <luyao> ok
09:01:33 <huzhj> Good, consensus
09:01:48 <huzhj> Guys, we are running out of time
09:02:22 <huzhj> The last thing, I'm thinking about whether or not to cancel the next meeting. because of the national day vacation.
09:02:45 <huzhj> so if you have any opinion, please send email to me.
09:02:50 <zhouya> #agree
09:02:58 <zhuzeyu> ok
09:03:01 <luyao> ok
09:03:05 <kongwei> ok
09:03:16 <huzhj> OK, that is all for today
09:03:17 <huzhj> Bye
09:03:21 <luyao> bye
09:03:23 <zhuzeyu> Bye
09:03:23 <kongwei> bye
09:03:28 <huzhj> #endmeeting