21:01:36 <thingee> #startmeeting crossproject
21:01:37 <openstack> Meeting started Tue Sep 22 21:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:40 <openstack> The meeting name has been set to 'crossproject'
21:01:53 <jroll> \o
21:01:55 <thingee> courtesy ping for david-lyle flaper87 dims dtroyer johnthetubaguy rakhmerov
21:01:55 <thingee> courtesy ping for smelikyan morganfainberg adrian_otto bswartz slagle
21:01:55 <thingee> courtesy ping for adrian_otto mestery kiall jeblair thinrichs j^2 stevebaker
21:01:55 <thingee> courtesy ping for mtreinish Daisy Piet notmyname ttx isviridov gordc SlickNik
21:01:55 <thingee> courtesy ping for cloudnull loquacities thingee hyakuhei redrobot dirk TravT
21:01:55 <thingee> courtesy ping for vipul lifeless annegentle SergeyLukjanov devananda boris-42 nikhil_k
21:01:59 <jokke_> o/
21:01:59 <mestery> o/
21:02:00 <lifeless> o/
21:02:02 <devananda> o/
21:02:03 <thingee> hi everyone!
21:02:03 <EmilienM> o/
21:02:03 <dims> o/
21:02:05 <SergeyLukjanov> o/
21:02:07 <elmiko> o/
21:02:12 <redrobot> o/
21:02:16 <j^2> O7
21:02:18 <notmyname> here
21:02:19 <thingee> Agenda: https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
21:02:25 <j^2> o7
21:02:28 <Rockyg> o/
21:02:30 <stevebaker> \o
21:02:31 <dtroyer> o/
21:02:35 <thingee> #topic review past action items
21:02:42 <tpatil> Hi
21:02:54 <thingee> #info Add string freeze to common cycle with milestones merged thanks to johnthetubaguy and TC!
21:03:07 <thingee> #link https://review.openstack.org/#/c/223011/
21:03:15 <thingee> #info Base feature deprecation policy merged thanks to ttx and the rest of TC!
21:03:27 <thingee> #link https://review.openstack.org/#/c/207467/
21:03:43 <ttx> Yeah, I'll be in touch with PTLs to explain if and how they should assert it
21:03:56 <thingee> #info Return request ID to caller merged thanks to Abhishek and TC!
21:04:03 <ttx> #action ttx to communicate about base deprecation policy
21:04:14 <thingee> #link https://review.openstack.org/#/c/156508/
21:04:16 <ttx> well, the tC just put the stamp on that one, no credits
21:04:32 <ttx> Abhishek should get all the credit
21:04:37 <SlickNik> o/
21:04:54 <mordred> ttx: yes will sync
21:05:16 <thingee> lifeless: lets talk about avoiding using testr in environment under test
21:05:19 <thingee> #link https://review.openstack.org/#/c/218070/
21:05:40 <tpatil> I would like to say thank you to everyone who helped in getting the spec "Return request Id to caller" approved
21:05:51 <thingee> I think we're still in the same place from last cross project meeting?
21:05:56 <lifeless> thingee: we talked last week; its on me to get more refinement
21:06:14 <lifeless> thingee: I've been working the backwards-compat-and-branchless stuff this week
21:06:18 <dhellmann> tpatil: that was a long effort, thanks for sticking with it
21:06:59 <thingee> got it, ok, we'll circle back next week?
21:07:00 <tpatil> dhellmann, Thanks. I have few questions about next steps which I would like to discuss in Open discussion
21:07:06 <thingee> lifeless: ^
21:07:27 <Rockyg> abhishek, tpatil Thank you.  It *will* be extremely helpful moving forward
21:07:31 <thingee> ok!
21:07:38 <thingee> #topic Team announcements (horizontal, vertical, diagonal)
21:07:47 <ttx> On the release management front, we are 3 weeks before the end of the liberty dev cycle
21:07:56 <ttx> We are chasing the last FFEs which should have been merged a long time ago
21:08:01 <ttx> We started issuing RC1s today
21:08:06 <ttx> Most projects should issue those this week
21:08:18 <tpatil> Rockyg: Thanks
21:08:21 <ttx> Intermediary-released projects (like swift and ironic) are expected to release a likely-final Liberty version before end of month as well
21:08:26 <stevebaker> ttx: do you want a releases review for the rc1 commit?
21:08:39 <thingee> #info release management says 3 weeks before end of the liberty dev cycle
21:08:43 <ttx> stevebaker: no. I do have an "open-mitaka" commit though
21:08:45 <dhellmann> I believe we've finished all the library releases and stable branches for this cycle, but if you manage one that I missed please get in touch with me
21:09:00 <lifeless> thingee: yes, hopefully ;)
21:09:01 <thingee> #info release management: RC1s have started today!
21:09:03 <ttx> stevebaker: see https://review.openstack.org/#/q/branch:master+topic:open-mitaka,n,z
21:09:10 <ttx> Starting now don't hesitate to flag things that may impact the final release(s), especially cross-project issues, in #openstack-relmgr-office
21:09:37 <stevebaker> do these coverage 4.0 changes need to be in the rc1s? https://review.openstack.org/#/c/225736/1
21:09:52 <stevebaker> mordred: ^?
21:10:01 <jroll> so, would this be a good time to ask why a new development cycle needs a major semver bump? :)
21:10:03 <ttx> I think that's more forward-looking... mordred ?
21:10:21 <thingee> #info release-management: don't hesitate to flag things that main impact final release, especially cross-project issues in #openstack-relmgr-office
21:10:27 <jroll> I asked this earlier and the answer was "that's what most projects seem to want"
21:10:38 <ttx> jroll: it doesn't, for intermediary-released projects
21:10:39 <jroll> but it's not really semver, so I just wanted to throw the question out there
21:10:49 <clarkb> I would put coverage fixes in releases so coverage works but its not required to releease aince the joba run post merge
21:10:56 <jroll> ttx: I'm asking in general, not about ironic specifically
21:11:00 <ttx> see swift, they don't bump X on cycle boundaries
21:11:16 <mordred> arro?
21:11:22 <jroll> ttx: asking because we say "now we're doing semver" but we aren't actually doing semver
21:11:25 <ttx> jroll: it's a bit of an artifact from pre-versioning
21:11:38 <ttx> jroll: which we may get rid of early next cycle
21:11:40 <mordred> stevebaker: it's only urgent if you have gating on your coverage tests working
21:11:42 <devananda> jroll: I think ttx is saying that projects may choose, and likely both swift and ironic will choose _not_ to bump major version number on release cycle boundaries
21:11:52 <mordred> stevebaker: if you do not have gating on coverage, then you can land those whenever
21:11:57 <devananda> whereas other projects will choose to do that
21:12:08 <stevebaker> mordred: ah. we don't and I wish we did
21:12:13 <mordred> stevebaker: although, if you land them now, it gets them off of y gerrit screen, which make me happy
21:12:20 <jroll> devananda: rephrased, my question is "why are projects not doing semver right" :) "because that's their choice" is a fine answer
21:12:44 <thingee> ok, anything else for announcements?
21:12:50 <fungi> jroll: that also seems to be the actual answer
21:12:59 <ttx> jroll: so to answer your initial question, no it's not a good time to ask *now*, as we are deep down in the middle of the process
21:13:08 <clarkb> thingee translation reviews
21:13:16 <bknudson> for keystone looks like we can remove eventlet support since it was deprecated
21:13:20 <clarkb> they should get into RCs
21:13:24 <ttx> but asking at the start of the next cycle is a good thing :)
21:13:32 <jroll> ttx: sure, thanks
21:13:39 <fungi> ahh, yes, wet all your rubber stamps, there are translation reviews awaiting
21:13:50 <clarkb> topic is zanata/translationd
21:13:58 <clarkb> er zanata/translations
21:14:23 <ttx> clarkb: new rules for StringFreeze (from johnthetubaguy) are that we give them a week post RC1 to merge them into a RC2
21:14:40 <thingee> clarkb: https://review.openstack.org/#/c/223011/
21:14:41 <ttx> basically translators finalize translations based on the RC1 drop
21:15:03 <ttx> but yeah, they are coming in
21:15:09 <bknudson> do translations go into master?
21:15:15 <ttx> bknudson: I was about to ask that
21:15:30 <jokke_> afaik yes
21:15:41 <clarkb> today its master only, yesterday we got asked to aupport the release branches too
21:15:43 <ttx> if they go to master, most will be lost and require hackish scripts from AJaeger to backport
21:15:47 <clarkb> I am working on that
21:16:11 <ttx> clarkb: check with AJaeger he had the magic script to sync only relevant things
21:16:13 <devananda> clarkb: is there still a % threshhold below which the translation bot won't propose it?
21:16:21 <clarkb> ttx ya he has reviewed
21:16:27 <clarkb> devananda yes
21:16:56 <thingee> ok great, going to move on...
21:17:16 <thingee> #topic Making the cross-project meeting more useful
21:17:19 <thingee> so this meeting...
21:17:53 <thingee> Anne Gentle brought up the thread of asking how we could make this meeting more useful http://lists.openstack.org/pipermail/openstack-dev/2015-September/074521.html
21:19:02 <thingee> I think the basic breakdown is, in this meeting we ideas proposed that just aren't ready to be discussed here sometimes. Mainly because the right people haven't commented on a spec.
21:19:15 <thingee> we have ideas proposed*
21:19:48 <bknudson> it's hard to get behind a x-project spec that you don't know if every project is going to accept it.
21:20:01 <bknudson> or that it's going to take so long to implement that it might never be done
21:20:08 <thingee> That brought light to the purpose of the product working group, which likes to follow these cross project ideas, and ensure the right projects are aware of them and give thoughts on those ideas. This helps with the idea of a spec for example becoming stale, or not getting the right attention.
21:20:40 <bknudson> e.g., if you have a 50% chance to get into nova and 50% chance to get into keystone, etc., pretty soon there's a ~0% chance it's done.
21:21:38 <ttx> thingee: one aspect of it is that some of those specs aren't really glamorous, but sometimes just plumbing
21:21:56 <ttx> so hard to see as part of a key objective or a larger vision
21:22:32 <ttx> http://specs.openstack.org/openstack/openstack-specs/
21:22:37 <anteaya> ensuring any discussion is prefaced with a larger vision is helpful
21:22:42 <notmyname> is the question what we can do to be better, or that something is broken now that we need to fix?
21:23:13 <jokke_> notmyname: you put my thoughts extremely well above
21:23:21 <ttx> notmyname: my feeling (which I expressed on the thread) is that it's broken -- it's really a painful experience to drive something through that process
21:23:56 <notmyname> ttx: the cross-project spec process? or are we talking about making this meeting betteR?
21:24:02 <jokke_> ttx: but does that break x-project meeting or just x-project specs?
21:24:09 <fungi> a related note is http://lists.openstack.org/pipermail/openstack-dev/2015-September/075129.html which indicates that our cross-project discussions really are a foreign language to at least some entrenched developers in our community
21:24:13 <thingee> yeah I think things got derailed a bit. Let me try again...
21:24:36 <bknudson> a lot of boring work is hard to get reviewers of it.
21:24:38 <ttx> notmyname: thought you were talking about the xproject specs process.
21:24:46 <dims> fungi: y i tried explaining :)
21:24:50 <bknudson> the release / spec process is geared towards adding new features.
21:25:09 <thingee> So from what I was getting from this thread, how can we make this meeting better.
21:25:19 <notmyname> no, sorry. I thought the topic was about this meeting
21:25:38 <thingee> I think sometimes we're not ready to have this meeting. The proposed specs still need attention or a good solution
21:25:39 <ttx> notmyname: as far as the meeting goes, I feel like it fails to be used as a way to have direct discussions on cross-project issues. Almost nobody adds topics to discuss
21:25:39 <annegentle> the thread is about all the channels and the outcomes we need from cross-project work.
21:25:54 <thingee> oh hi annegentle !
21:25:54 <annegentle> this meeting being "a channel"
21:25:58 * annegentle waves
21:26:02 <jroll> thingee: we aren't ready, or agenda items aren't ready? :)
21:26:11 <thingee> agenda items aren't ready
21:26:26 <jroll> thingee: I think we need to encourage only adding things to agenda if they're ready for discussion, or someone wants confirmation it's a thing they should work on, or whatever
21:26:33 <thingee> so I've given thought on the process for ideas that become cross project can come to light in this meeting http://lists.openstack.org/pipermail/openstack-dev/2015-September/074867.html
21:26:39 <thingee> my proposal^
21:26:41 <bknudson> for cross-project you really need some backing that it's a good idea early since it's going to be a lot of work
21:26:51 <jroll> ++
21:26:56 <bknudson> so I think it's a good idea to bring half-baked ideas here
21:27:11 <jokke_> ttx: I'd like to disagree ... this hour is extremely valuable at least for me to keep up what's going on around as I genuinely don't have time to crawl through the mailing list or spec repos to figure that out
21:27:35 <fungi> well, and also that there are likely to be others who will help you convince all the various projects involved that whatever you need their help to get implemented is really worth the effort
21:27:36 <thingee> jokke_: I'll be answering that bit of keeping up with the ML later :)
21:27:45 <annegentle> to me a meeting lets you get more real-time input and feedback
21:28:28 <thingee> So the main point of my proposal is cross project idea discussions should not be on IRC, ML, here and there.
21:28:32 <jroll> yeah, I'm personally ok with topics in this meeting being "is this crazy?" but not "let's review this spec in real time"
21:28:49 <thingee> it makes conversations difficult if you have to know where some people's views are in different places.
21:28:59 <thingee> The first proposal is encouraging discussion to stay in the spec
21:29:03 <thingee> in gerrit
21:29:10 <ttx> jokke_: that's good fedback thx
21:29:14 <ttx> +e
21:29:16 <EmilienM> thingee: +1
21:29:18 <elmiko> jroll: +1
21:29:23 <jroll> thingee: I think there's value in finding out if everyone hates the idea before writing the spec :)
21:29:32 <jokke_> ++
21:29:58 <jroll> thingee: if we *do* want to solve that case outside of the meeting, the initial spec could just be the first section or two, to see if it should proceed further. or we could just spend 5 minutes on it here
21:30:01 <thingee> jroll: right! so going back to my first thing on the proposal, the idea starts on the ML, or a single project patch
21:30:22 <thingee> assuming that's good, all discussions are encoruaged to stay in the gerrit review spec
21:30:26 <ttx> jokke_: yeah, the key aspect being you have a predetermined agenda that lets you decide if it's worth attending / staying up
21:30:36 <Rockyg> This meeting is really good to see where we are and provide some direction, but I think that cross project specs might benefit from a "virtual sprint" of interested people to focus on getting it past initial phase and into ready for "meeting" discussion
21:31:01 <jroll> thingee: sure, but like annegentle said, it's much quicker feedback here. I'm fine with either way but she does have a point :)
21:31:09 <anteaya> are we saying the meeting is only about specs?
21:31:17 <jokke_> ttx: that and I do have this slot booked in my calendar to catch up what's going on rather than trying to "justify" that time from something else through the week
21:31:17 <fungi> jroll: on the other hand, it may be pretty quick to push up a one-paragraph placeholder/wip spec and ask for input there
21:31:24 <thingee> jroll: right, so my main point of wanting to do this, is so that these meetings become more interesting to people.
21:31:30 <thingee> the problem is not everyone attends this meeting.
21:31:38 <jroll> fungi: yep, I mentioned that, I'm good with that
21:31:41 <thingee> I think that might have to do with the fact that progress is kind of slow here.
21:31:46 <thingee> things aren't ready
21:31:49 <thingee> so people get bored
21:32:15 <fungi> jroll: indeed. i should have read further before responding
21:32:28 <jroll> :D
21:32:31 * Rockyg is starting to get bored...just kidding!
21:32:39 <thingee> instead, if we had specs in more of a consensus point, these meetings would be fewer because of the number of topics that get to that point, and makes the meeting more interesting when there are stuff to look over.
21:32:40 <elmiko> haha
21:33:00 <devananda> thingee: well, it often takes > 1 cycle just to get some concensus on a spec in this group. developers who are focused on landing a patch dont want to wait that long. PTL's often have more time-sensitive things to deal with
21:33:10 <fungi> i have already justified this chunk of my tuesday evenings to my wife, so there is some effort involved in rejustifying new timeslots ;)
21:33:38 <jokke_> sorry to jump bit off topic, just gotta get this out of my mind before I loose the point. x-project spec is really painful, how about moving it from single person effort to the stage where it's single person effort to convince TC that the _idea_ is worth of pursuing after which it would be driven by TC to wider community. Rather than that one person trying to convince all the big eevil oldtimers?
21:34:24 <annegentle> jokke_: so, smaller first test group?
21:34:35 <fungi> jokke_: i don't think it's by necessity a single-person effort, but if you think the spec is a good idea then you may need to find other people to help. the tc can't unilaterally assign resources to help you implement it
21:34:57 <Rockyg> fungi, thingee not saying *another* meeting for everything, but that a good idea spec gets a mini sprint to flesh it out and get it into a real spec shape
21:35:23 <anteaya> gets a mini sprint? anyone can book a sprint for themselves
21:35:26 <fungi> jokke_: some tc members may sign on to help implement the spec, but that's not limited just to the tc
21:35:37 <jokke_> annegentle: not really, but rather insight from the folks who are supposed to be representing the technical community and could most probably tell already at the idea level if it will never get through or not
21:35:51 <anteaya> #link https://wiki.openstack.org/wiki/VirtualSprints
21:36:27 <Rockyg> anteaya, yes, thanks!  If the mini sprint were decided timewise in the cross project meeting, then maybe more interested people would turn up and get the spec in shape in that one meeting instead of over months
21:36:42 <fungi> jokke_: "is this a good idea/is it likely to ever find enough backing to be implemented" strikes me as the reason why the tc votes on cross-project specs anyway
21:37:01 <annegentle> jokke_:  so not really size as much as experience/instinct
21:37:10 <anteaya> maybe, but noone is standing in the way of anyone booking their own sprint, just sign up for the space
21:37:24 <jokke_> fungi: I'm not saying that TC has magical unlimited resources to pour, but one would have way easier path to bring stuff up to the wide audience if the TC is in general behind the idea and perhaps helping to form the first iteration of the spec to the form it has even chanse to get to the point in next weeks rather than months/cycles
21:37:25 <bknudson> for the amount of work that x-proj specs take to implement, we'd want something stronger than "maybe this is going to be implemented"
21:37:35 <jokke_> annegentle: exactly
21:37:39 <annegentle> jokke_: fungi: What I experienced with service catalog is that I couldn't implement it all and have to find people who can.
21:37:47 <jroll> anteaya: Rockyg: I don't see any need for an official sprint, nor deciding on a time in this meeting. could just send an email to the list "hey I'm hacking on this spec at x time in #openstack-channel, interested parties welcome"
21:37:54 <annegentle> bknudson: yeah that makes sense
21:37:57 <elmiko> bknudson: +1
21:38:08 <anteaya> jroll: sprints aren't official that is my point
21:38:10 <ttx> jokke_: I'd rather have it be an open group. Could be a TC workgroup, with TC members but opened to anyone interested
21:38:22 <anteaya> jroll: and yes the workflow you propose is my expectation
21:38:32 <jroll> anteaya: yep +1
21:38:43 <fungi> i think helping you get your spec into sufficient shape that it's implementable is part of why the tc is acting as the approving body for those specs
21:38:50 <thingee> ok, well I encourage folks to respond to the thread. I think having specs with solutions and ready for feedback would be great. There's ideas for the product working group to help with that and get the relevant projects involved with a proposed spec. http://lists.openstack.org/pipermail/openstack-dev/2015-September/074867.html
21:38:53 <annegentle> ttx: I wondered about a TC workgroup stood up just for particular x-project efforts/specs
21:39:15 <bknudson> requiring a team dedicated to getting a x-proj spec makes sense to me -- you don't want the effort to fail just because one person lost interest
21:39:15 <Rockyg> annegentle, ++  how do you recruit devs for a spec you need help designing/implementing to fit the openstack architecture?
21:39:22 <ttx> annegentle: I tried to motivate TC members to form one for all the cycle. I can't drive them all
21:39:33 <jokke_> ttx: that would work
21:39:40 <fungi> i'm unconvinced that waving a royal sceptre at a "working group" and making it official accomplishes much of anything
21:39:40 * thingee is not sure if he made his point
21:39:41 <annegentle> Rockyg: zactly
21:39:52 * thingee or made things worse
21:40:04 <annegentle> ttx: and yes, we'd have to pick and choose (strategically if you will) based on the availability
21:40:07 <anteaya> thingee: no not worse
21:40:08 <fungi> thingee: i think people have simply ignored your call to move on
21:40:31 <thingee> #topic open discussion
21:40:31 <fungi> perhaps time to just use your #topic powers to force the issue ;)
21:40:37 <annegentle> oh shoot sorry thingee I didn't realize you closed it up
21:40:42 <annegentle> :)
21:40:47 <ttx> fungi: I wish the meeting chair would have a magic wand to suddenly call all cats attention. I would use that
21:40:47 <tpatil> I would like to talk about next steps for spec : Return request id to caller
21:40:55 <tpatil> #link: https://review.openstack.org/#/c/156508
21:41:02 <tpatil> It got merged today. Thanks everyone again
21:41:03 <lifeless> ttx: its called kitty-treats
21:41:13 <tpatil> Should I reach to individual python-*client PTLs and request them to approve the blueprints?
21:41:34 <Rockyg> lifeless, I have a cat who doesn't consider treats to be a treat
21:42:05 <thingee> tpatil: would really recommend you start looking for liaisons for each project to be the point of contact.
21:42:10 <lifeless> Rockyg: more cowbell ?
21:42:13 <jokke_> ttx: that should be easy ... op the chair ... IRC has really powerful tools and channel flags to suppress noise ;)
21:42:27 <tpatil> thingee: Ok, got it. I will follow up with them then.
21:42:34 <tpatil> Thank you
21:42:36 <lifeless> tpatil: I don't think you should need per-project blueprints at this point
21:42:43 <lifeless> tpatil: you have a cross-project blueprint
21:42:50 <fungi> yeah, we could get more aggressive with mode +/-v
21:43:01 <jroll> lifeless: meh, blueprints are nice for tracking at release time though
21:43:01 <lifeless> tpatil: the whole point of this exercise has been building cross project consensus :)
21:43:03 <fungi> but that seems a tad draconian at this scale of participation
21:43:11 <Rockyg> lifeless, tpatil: might want per project for tracking purposes
21:43:12 <ttx> fungi: ++
21:43:12 <jroll> lifeless: not to say it's the right thing to do, just sayin'
21:43:25 <jroll> perhaps the liasion can file the BPs
21:43:30 <jroll> for the respective project
21:43:32 <lifeless> jroll: I'll leave that to the projects
21:43:38 <jroll> because it's just paperwork, no need for tpatil to do it all
21:43:39 <lifeless> jroll: its not a release notes thing in M though
21:43:46 <lifeless> jroll: exactly
21:43:46 <Rockyg> Just placeholder bps, but when the are closed, you know another project is aligned
21:43:48 <fungi> "the chair recognizes the gentlewoman in the blue nick"
21:43:56 <jroll> lifeless: why wouldn't this be a release notes thing?
21:43:58 <thingee> bps that link to the cross project spec. It's good for tracking in the individual projects.
21:44:04 <lifeless> jroll: because reno
21:44:11 <jroll> reno?
21:44:17 <lifeless> jroll: I mean, blueprints are now decoupled from release notes
21:44:18 <ttx> also playing with -v usually results in privmsg hell
21:44:25 <Rockyg> thingee, ++ xactly
21:44:35 <lifeless> jroll: we put together an in-project-tree thing to do release notes
21:44:41 <thingee> the blueprint just needs the link, that's it. simple
21:44:42 <jroll> lifeless: well, how do you think folks compile release notes? :)
21:44:58 <lifeless> jroll: with reno, by writing the section when they propose the code
21:45:07 <jroll> ooooooooooo
21:45:13 <lifeless> jroll: yeah, exactly
21:45:13 <jroll> that's a fantastic idea I never thought of
21:45:17 <jroll> somehow.
21:45:24 <jokke_> are/can we finally mova away from launchpad? :P
21:45:29 <jokke_> move
21:45:30 <ttx> jroll: will be enabled on stable/liberty for now
21:45:33 <thingee> I would like to bring something to people's attention and specifically on with what jokke_ mentioned and what I hear all the time from people involved in OpenStack in some way..
21:45:42 <thingee> Being able to keep up with the Dev ML...
21:45:58 <thingee> so i know you all read the newsletter weekly and excited for it's distribution that you probably noticed the new section
21:46:00 <thingee> http://www.openstack.org/blog/2015/09/openstack-community-weekly-newsletter-sept-12-18/
21:46:03 <fungi> jokke_: we're getting closer, but the last 10% requires 90% of the effort, or something like that
21:46:17 <thingee> "What you need to know from the developer’s list"
21:46:29 <jroll> fungi: I volunteer ironic to be a maniphest beta tester
21:46:49 <jokke_> #link http://www.openstack.org/blog/2015/09/openstack-community-weekly-newsletter-sept-12-18/
21:46:51 <thingee> I'm going to start writing bullet point only quick important info from the dev list
21:46:58 <tpatil> thingee: I will add bps under each project and start submitting code patches, also update whiteboard with crossproject spec approval
21:47:17 <Rockyg> jroll, link from maniphest task/issue to crossproject spec would work instead of project bps
21:47:21 <thingee> would love feedback on that first attempt...but I think if you read that, you'll be pretty much caught up from last week.
21:47:34 <ttx> thingee: I like them a lot, but you already know that.
21:47:41 <fungi> jroll: well, there's maniphest (or some other defect/lifecycle tracker), openstackid (authentication use cases) and also release artifacts (i'm starting work on improving that bit in the upcoming cycle)
21:47:43 <lifeless> jroll: this thread - http://lists.openstack.org/pipermail/openstack-dev/2015-August/072385.html
21:47:48 <jokke_> thingee: _this_ is why this hour is so valuable! ;)
21:47:50 <Rockyg> thingee, I used them to update the prod_wg
21:47:58 <jroll> Rockyg: indeed, reason number 3761429 I'd like to get on maniphest :D
21:48:15 <jroll> fungi: yeah, just throwing my name out for when it's ready
21:48:17 <thingee> you would also know that mordred really hates floating ips
21:48:21 <lifeless> thingee: so two topics for that
21:48:23 <thingee> from reading it
21:48:32 <lifeless> thingee: the constraints stuff seems to be not widely enough socialised
21:48:36 <mordred> yah
21:48:36 <fungi> jroll: noted, ironic seems to like to live by the seat of its pants
21:48:38 <ttx> jroll, Rockyg: so... the trick with Phabricator is that the component that does change tracking is not written yet
21:48:42 <lifeless> thingee: despite lots of emails trying to do Just THat
21:48:49 <lifeless> thingee: secondly the release notes thing
21:48:53 <ttx> so we'd have to emulate that somehow
21:48:57 <lifeless> thingee: will be worth socialising
21:49:01 <mordred> thingee: do I need to rant about them more?
21:49:03 <jroll> lifeless: yep, I'm aware of the reno stuff, just never occurred to me to update while proposing code :)
21:49:29 <thingee> mordred: get me a network
21:49:41 <thingee> lifeless: constraints was already on my list.
21:49:47 <thingee> :)
21:49:59 <jokke_> mordred: I think you need to find new topic for persistent rant unless you were allowed to order HP work laptop :P
21:50:18 <fungi> mordred: we'll get you a spot on coffee talk and you can rant about floating ips there
21:50:21 <ttx> jroll: you can track my adventures at https://wiki.openstack.org/wiki/Phabricator
21:50:24 <mordred> fungi: awesome
21:50:38 <Rockyg> thanks, ttx!
21:50:41 <mordred> jokke_: but why would I stop ranting about these? people till seem to think they're a great default operational model
21:50:48 <mordred> jokke_: :)
21:50:52 <jroll> ttx: yep, I've started watching that :)
21:50:53 <jokke_> :D
21:51:24 <jokke_> mordred: I was more thinking of that it would be as good topic as any
21:51:34 <thingee> ok anything else?
21:51:37 <mordred> jokke_: AH! then yes, I'm with you
21:51:56 <thingee> alriiiight!
21:51:58 <thingee> #endmeeting