21:01:04 <markmcclain> #startmeeting crossproject
21:01:05 <openstack> Meeting started Tue Jun  9 21:01:04 2015 UTC and is due to finish in 60 minutes.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:05 <jeblair> markmcclain: infra announcement bit set
21:01:06 * mestery stops waving
21:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:09 <openstack> The meeting name has been set to 'crossproject'
21:01:11 <ameade> o/
21:01:14 <j^2> hey hey everyone
21:01:15 <pshige> o/
21:01:19 <edleafe> o/
21:01:24 <ttx> o/
21:01:29 <markmcclain> Ok... so it's my turn in the chair this week
21:01:34 <ttx> yay
21:01:38 <markmcclain> #link https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
21:01:38 <dhellmann> thanks, markmcclain !
21:01:38 <thingee> o/
21:01:39 <lifeless> ruh roh
21:01:39 <elmiko> \o/
21:01:41 * ttx likes to relax on the back chair and heckle
21:01:43 <fungi> way to throw yourself on this grenade
21:01:49 <bknudson> I hope it's a comfy chair
21:01:56 <bknudson> not like the iron throne
21:02:02 * fungi stabs ttx with the fluffy pillow
21:02:15 <markmcclain> bknudson: yeah.. seems to be formed fitted for ttx
21:02:17 <stevebaker> \o
21:02:18 <ttx> the desk in my siute is actually nicer than the one I have at home
21:02:18 * mestery moves to the back by ttx
21:02:20 <lifeless> fungi: tad rough :/
21:02:21 <jeblair> this meeting is violent
21:02:22 <markmcclain> #topic Horizontal Team Announcements
21:02:30 <ttx> Hi! On the release management front...
21:02:42 <ttx> I wanted to point you all to the new release status tracking page at:
21:02:46 <ttx> #link http://status.openstack.org/release/
21:03:00 <ttx> As discussed previously this is now primarily showing what already landed in the development cycle (rather than the prediction of what might land in the next milestone(s))
21:03:01 <mestery> ttx: that is one fancy status page
21:03:04 <jokke_> o/
21:03:08 <bknudson> 26 degrees
21:03:10 <fungi> liberty!
21:03:11 <markmcclain> ttx: cool
21:03:13 <ttx> #info To make things appear (or disappear) from the "tracked work" section, you can use the "series goal" field in Launchpad blueprints (no need to use milestones)
21:03:15 <fungi> (for all)
21:03:18 <bknudson> or mph?
21:03:25 <ttx> But that is totally opt-in. You can use that top track main cycle objectives, all your work, or nothing.
21:03:32 <ttx> -p
21:03:40 <ttx> Depends on what you want to communicate on that page
21:03:46 <ttx> I don't care as much anymore
21:03:58 <morganfainberg> oh neato
21:04:13 <ttx> so in summary, you want it on te list you add it to series goal (which is a drivers-controlled thing)
21:04:20 <j^2> ttx: how often is it refreshed?
21:04:30 <ttx> you don't want it on the list well... you remove the series goal
21:04:36 <ttx> I think it's every 30 min
21:04:40 <j^2> nice
21:04:51 * ttx doublechecks
21:05:09 <jeblair> on the infra side...
21:05:10 <jeblair> we have scheduled our next set of project renames for this friday.  the list of projects currently scheduled is in the email.  if yours isn't listed, write a rename change and add it to https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
21:05:10 <jeblair> #link Gerrit downtime on Friday 2015-06-12 at 22:00 UTC http://lists.openstack.org/pipermail/openstack-dev/2015-June/066366.html
21:05:40 <krotscheck> o/
21:05:42 <markmcclain> jeblair: thanks for the reminder
21:05:44 <ttx> */20
21:05:55 <ttx> j^2: every 20 min
21:06:02 <j^2> ttx: awesome thanks for the check
21:06:04 <markmcclain> Any other horizontal team updates?
21:06:05 <ttx> http://git.openstack.org/cgit/openstack-infra/puppet-releasestatus/tree/manifests/site.pp#n40
21:06:07 <dhellmann> I should also make sure everyone saw the thread I started on bringing library releases back under the release management team
21:06:09 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/066346.html
21:06:17 <elmiko> the api-wg has 4 guidelines up for review currently that are in freeze, they have been posted to the ML, shall i link again here?
21:06:22 <jokke_> ttx: that looks nice ... can we get the same to track what's going on on stables? ;)
21:06:36 <markmcclain> elmiko: can you link the email?
21:06:44 <jeblair> dhellmann: when it gets closer to automation time for that, you may want to pull the infra team into those discussions
21:06:44 <ttx> jokke_: nothing goes on on stable (at least nothing should, those are blueprints / features)
21:06:46 <elmiko> sec, let me dig those up
21:06:54 <dhellmann> jeblair: definitely
21:07:10 <fungi> oh, also release tag merge changes... https://review.openstack.org/#/q/status:open+topic:merge/release-tag,n,z once we get the gate passing jobs in general again, please approve those. the commit messages should make sense now
21:07:28 <jokke_> ttx: ok, let me rewrite that ... can we get interactive releasenotes like that tracking fixed bugs in stables? ;)
21:07:32 <fungi> #link https://review.openstack.org/#/q/status:open+topic:merge/release-tag,n,z
21:07:34 <jeblair> dhellmann: we may want a blueprint if we do significant automation; but also sdague is tentatively planning on investigating adding tag reviewing in gerrit later this summer
21:07:44 <elmiko> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/065923.html
21:07:54 <sdague> jeblair: no, I'm adding a different thing
21:07:55 <markmcclain> elmiko: thanks
21:07:56 <elmiko> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/066378.html
21:08:04 <elmiko> markmcclain: np
21:08:14 <jeblair> sdague: oh, i thought you were looking into reviewing tags
21:08:33 <sdague> no, I'm looking at letting users tag reviews
21:08:37 <dhellmann> jeblair: ok, I was going to do something simple with a bot responding to instructions in text files. I'll write something up
21:08:46 <sdague> and that being searchable
21:08:52 <jeblair> sdague: you may want to consider alternate words.  i suggest 'project'.  ;)
21:08:58 <markmcclain> sdague: cool
21:09:01 <markmcclain> jeblair: haha
21:09:08 * dhellmann notes the confusion about 2 more ways tags are used
21:09:08 <sdague> jeblair: or policy
21:09:23 <jeblair> dhellmann: apparently i was wrong, unless i am able to trick sdague into thinking he meant the other thing
21:09:25 <sdague> "user metadata"
21:09:39 <fungi> catalog. nobody's using that one yet
21:09:50 <dhellmann> jeblair: I support your efforts
21:10:22 <lifeless> TravT: pbr is fixed
21:10:24 <ttx> jokke_: well you can definitely take the code and run with it
21:10:30 <ttx> although it's quite a ugly hack
21:10:43 <lifeless> TravT: [once tag jobs do their thing]
21:11:07 <markmcclain> ok.. looks like we got the horizontal team updates... moving on
21:11:11 <markmcclain> #topic Add requirements management specification (lifeless)
21:11:12 <TravT> lifeless: thanks!
21:11:19 <markmcclain> #link https://review.openstack.org/#/c/186635/
21:11:29 <markmcclain> lifeless: want to start?
21:11:41 <lifeless> markmcclain: +1 it all, thanks!
21:12:29 <lifeless> markmcclain: more seriously, I think this has been discussed to consensus no? On the list and at the summit : are there any concerns folk here have that haven't been addressed ?
21:12:51 <dhellmann> I haven't had a chance to read the write-up, but don't expect any surprises
21:13:02 * morganfainberg withholds snarky non-productive-joke answer.
21:13:09 <markmcclain> lifeless: I believe so, but the review traffic was low on it, so wanted to raise profile
21:13:10 <lifeless> morganfainberg: O M G
21:13:29 <ttx> lifeless: we need to give it some air on the crossproject meeting before we can close it in a TC meeting
21:13:29 <lifeless> markmcclain: thanks! So, I owe an update for some trivia, which I'll do today.
21:13:51 <ttx> it usually triggers a surge in reviews, too
21:13:54 <lifeless> but there was nothing contentious in it - the stuff is tweaks not semantic changes
21:13:57 * dhellmann notes his procrastination has paid off, and he'll get to read an updated draft tomorrow
21:14:05 <lifeless> so - please look at this now :)
21:14:17 <lifeless> dhellmann: ^ thats for you :)
21:14:31 <ttx> lifeless: if no serious objection appeas by end of week I'll put it on next TC agenda
21:14:35 <ttx> for final approval
21:14:43 <dhellmann> lifeless: early tomorrow, ~16 hrs
21:14:47 <markmcclain> ttx: cool
21:14:53 <lifeless> dhellmann: its all good; teasing :0
21:15:08 <markmcclain> moving on...
21:15:17 <markmcclain> #topic Enabling Python 3 for Application Integration Tests Spec
21:15:23 <markmcclain> #link https://review.openstack.org/#/c/177375/
21:15:34 <markmcclain> dhellmann is the author
21:15:48 <dhellmann> I updated that based on some early feedback today, and added a link to the devstack change to enable it
21:16:09 <markmcclain> dhellmann: thanks for updating it
21:16:23 <dhellmann> if there's general consensus, I'll go ahead and submit a job template definition as an example
21:16:24 <markmcclain> like the last one seems have have gotten low review traffic
21:17:39 <sdague> so, should we be taking these out to mailing list conversations instead of just in meetings?
21:18:17 <markmcclain> sdague: ideally yes, but this also seems to fit some previously discussed approaches to py3 transition
21:18:21 <sdague> to try to get that additional traffic
21:18:30 <dhellmann> that's a good question, but we do have a spec so the point is to get people to discuss it there, no?
21:18:46 <sdague> right, but not everyone is watching every spec
21:18:56 <dhellmann> for this one I just need the PTLs to not act surprised when it lands and then I'll be working with qa and infra to implement it
21:19:11 <sdague> if the concern is review traffic, an ML thread helps with that
21:19:13 <johnthetubaguy> a thread to highlight the spec can be useful though
21:19:17 <johnthetubaguy> sdague: +1
21:19:48 <jokke_> Do we have enough resources to run those 3.4 non-voting jobs for extended times?
21:19:49 <lifeless> speaking of python versions
21:19:50 <johnthetubaguy> dhellmann: FWIW we already merged this for nova: http://specs.openstack.org/openstack/nova-specs/specs/liberty/approved/adding-python34-support-to-nova.html
21:19:59 <lifeless> I am confused about 2.6. Have we EOL'd our support or not ?
21:20:07 <dhellmann> ok. We can do that. The point of this meeting is to have the PTLs talking about this sort of thing, though. Do you all read all of the ML? What topic heading should I use to get your attention?
21:20:40 <bknudson> libraries like python-keystoneclient still support 2.6
21:20:50 <dhellmann> johnthetubaguy: ok. Would have been nice to collaborate a bit more on that, but it doesn't look like you're going off in an unexpected direction.
21:20:55 <sdague> I skim all of the mailing list, topic headers are irrelevant to me. but [all] is probably appropriate
21:21:11 <jokke_> dhellmann: [py3] and bit of advertisement?
21:21:13 <fungi> jokke_: the 3.4 jobs run on the same type of workers as 2.7 jobs, so at least we don't provision special workers specifically for those any longer... they just draw from the same pool
21:21:22 <lifeless> bknudson: why do they?
21:21:26 <dhellmann> jokke_: no one filtering the ML will see that
21:21:42 <jokke_> fungi: cool
21:21:45 <johnthetubaguy> dhellmann: its the same direction I think, its more some folks stepped up to do it, and we didn't want to block them, once it sounded like a sensible proposal
21:22:08 <dhellmann> johnthetubaguy: yep, I just don't want a bunch of teams reinventing 90% of the same thing
21:22:19 <jokke_> dhellmann: thus the advertisement ... I think there would be room for lots of knowledge share between projects around py3
21:22:22 <fungi> lifeless: the original concern was that while we still had stable branches of servers where 2.6 was supported, any libraries they depended on for running/testing needed to continue to support 2.6
21:22:41 <johnthetubaguy> dhellmann: agreed, I don't think they have got that far yet
21:22:45 <fungi> lifeless: that's a bit murkier since we recently added stable branches to all the libs
21:22:53 <dhellmann> johnthetubaguy: ok, good
21:23:08 <fungi> lifeless: i think it's just not been revisited since the lib stable branch addition
21:23:18 <lifeless> fungi: when do those servers EOL; the upper-constraints stuff has no validation for 2.6 and thats not easy to do either
21:23:38 <lifeless> since we'd need a 2.6 on the periodic node
21:23:48 <fungi> what was the last release where we claimed 2.6 support? icehouse or juno?
21:23:52 <sdague> juno
21:24:03 <bknudson> I think we'll need a 2.0 of python-keystoneclient and drop 2.6 and other stuff.
21:24:11 <morganfainberg> bknudson: ++
21:24:15 <fungi> okay, so in theory we need to at least keep 2.6-supporting infrastructure around until juno eol
21:24:20 <sdague> I don't know what the juno eol plan is, stable maint teams should speak up there
21:24:36 <lifeless> do we test python-keystoneclient master against juno ?
21:24:46 <lifeless> if we're not doing that, I don't see why 2.6 testing matters :)
21:24:50 <sdague> lifeless: we used to
21:24:58 <morganfainberg> lifeless: i'd need to go check to see hwat we are doing now
21:25:04 <morganfainberg> the field has changed a bunch
21:25:05 <sdague> a lot of things fell apart during the pinning
21:25:05 <lifeless> sdague: yeah, I know - and I think its good to do so. But are we :)
21:25:05 <jokke_> didn't we discuss 12 or 9 months for juno stable?
21:25:10 <dhellmann> sdague, johnthetubaguy : here's the existing ML thread on this subject, to which no one replied:
21:25:11 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-May/065203.html
21:25:14 <fungi> i'm hoping all the relevant libs have stable/juno branches now and we can consider limiting 2.6 support to those
21:25:16 <lifeless> sdague: I'd like to bring that back in FWIW
21:25:26 <lifeless> sdague: but one thing at a time.
21:25:38 <ttx> currently set at 12 months
21:25:54 <ttx> i.e. asap after liberty release
21:26:17 <ttx> (down from the original promise of 15)
21:27:02 <johnthetubaguy> dhellmann: turns out I remember that thread, thats how I discovered the python3.4 spec, it was a little bit after we merged that nova spec, and we made sure we were not out of whack, if that helps
21:27:29 <dhellmann> johnthetubaguy: great!
21:27:44 <markmcclain> dhellmann: thanks
21:27:45 <johnthetubaguy> dhellmann: totally forgot that till just now though, and re-read an old friend, heh
21:28:30 <markmcclain> ok.. hopefully folks will chime on the review so that we can move forward
21:28:53 <bknudson> progress on PyMySQL?
21:29:31 <fungi> #link https://review.openstack.org/184493
21:29:44 <fungi> that's in need of reviews/merging i believe to switch the devstack default
21:29:54 <fungi> though it does appear to work fine
21:30:01 <sdague> fungi: didn't you say you'd do a final alert ML thread on that one?
21:30:06 <bknudson> cool
21:30:15 <sdague> so that no one was surprised by it
21:30:18 <fungi> sdague: oh! right, i'll do that now. too many things
21:30:23 <sdague> yep, no worries
21:30:36 <fungi> also lots of proposed changes in various states
21:30:42 <fungi> #link https://review.openstack.org/#/q/status:open+topic:pymysql-switch,n,z
21:30:43 <markmcclain> #action fungi to alert on pending PyMySQL change
21:30:48 <sdague> I'll merge it once that email has been out for a day and no one freaks out
21:30:59 <fungi> sdague: sounds great, thanks
21:31:06 <markmcclain> sounds good
21:31:13 <markmcclain> #topic Vertical Team Announcements
21:31:37 <markmcclain> Any vertical teams have any items of interest to everyone?
21:32:13 <ttx> don't forget to use #info so that it sticks on the minutes
21:32:34 <markmcclain> ttx: thanks for the reminder.. forgot that in my notes
21:33:15 <markmcclain> #topic Next Week's Chair
21:33:24 <markmcclain> so this meeting has moved to a rotating chair
21:33:37 <markmcclain> the cool thing is that it is not limited to ttx or other members of the TC
21:33:58 <markmcclain> any PTL can sign up to chair the meeting
21:34:00 <markmcclain> #link https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
21:34:10 <dhellmann> if everyone signs up once, no one should have to sign up twice
21:34:38 <ttx> it's fnu! really!
21:34:40 <lifeless> quick add more projects
21:34:43 <ttx> except the 11pm part
21:34:47 <lifeless> if we add them fast enough
21:34:47 <markmcclain> dhellmann: yes that would nice... anyone can feel free to remove my name from future dates :)
21:34:51 <lifeless> noone ever repeats
21:35:04 <markmcclain> #topic Open Discussion
21:35:06 <nikhil_k> I don't mind signing up. Will double check schedule and do so.
21:35:13 <dhellmann> nikhil_k: thanks!
21:35:15 <markmcclain> nikhil_k: thanks
21:35:20 <ttx> nikhil_k: awesome thx
21:35:26 * ttx should make a chair guide
21:35:34 <markmcclain> ttx: good idea
21:35:56 <ttx> with the whole "pick openstack-specs" thing
21:37:11 <markmcclain> yeah.. tricky which ones to discuss.. there are some with several -1s that don't feel mature and then there are others that need attention before they can be approved even if folks agree
21:38:07 <markmcclain> I think we've cover everything for today, so we'll end a bit early.
21:38:29 <markmcclain> Thanks to everyone for dropping in.
21:38:33 <markmcclain> #endmeeting