15:00:03 <thomasem> #startmeeting craton
15:00:03 <thomasem> #chair sigmavirus sulo jimbaker thomasem
15:00:03 <thomasem> #link https://etherpad.openstack.org/p/craton-meetings
15:00:04 <openstack> Meeting started Mon Mar 13 15:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is thomasem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <thomasem> #topic Roll Call
15:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <openstack> The meeting name has been set to 'craton'
15:00:09 <openstack> Current chairs: jimbaker sigmavirus sulo thomasem
15:00:20 <thomasem> o/
15:01:23 <sulo> o/
15:01:42 <fsaad> o/
15:03:28 <git-harry> hi
15:03:47 <thomasem> #topic Action Items from Last Meeting
15:03:48 <thomasem> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-03-06-15.01.html
15:04:06 <thomasem> punting first two
15:04:11 <thomasem> this one got done, I believe ACTION: sigmavirus to spec out a testing plan for python-cratonclient in python-cratonclient repo
15:04:21 <thomasem> #action thomasem to write BP regarding deployment as a starting point for iterating on a suggested deployment model
15:04:30 <thomasem> #action jimbaker to map Dusty's requirements to work or existing features of Craton, especially with respect to short-term deliverable
15:04:50 <thomasem> #topic Stand-up
15:04:51 <thomasem> #info each team member briefly describes what they are working on this week, and describes blockers (if there are any)
15:05:01 <thomasem> #topic Stand Up :: thomasem
15:06:33 <thomasem> Working through issues with variable resolution search with jimbaker and JSON Path patch here: https://review.openstack.org/#/c/443941/, which is my primary focus right now.
15:06:34 <thomasem> done
15:06:41 <thomasem> #topic Stand Up :: sulo
15:07:20 <sulo> finished the dbsync patch .. nothing much going on .. looking though soem bugs and reviews
15:07:21 <sulo> done
15:07:38 <thomasem> #topic Stand Up :: fsaad
15:08:19 <sigmavirus> Sorry for being late
15:08:29 <sigmavirus> Internet died and forgot to reconnect to IRC
15:08:34 <fsaad> Trying to get things together for demo tomorrow for the most part, (check e-mail btw :))
15:08:56 <fsaad> also got a first RPC customer data access permission, so can start playing with that
15:09:07 <fsaad> done
15:09:26 <thomasem> #topic Stand Up :: git-harry
15:09:29 <thomasem> (no problemo sigmavirus!)
15:10:01 <git-harry> finishing off https://bugs.launchpad.net/craton/+bug/1665015
15:10:01 <openstack> Launchpad bug 1665015 in craton "All text errors reported by the Craton REST API should be JSON encoded" [High,New] - Assigned to git-harry (git-harry)
15:10:01 <git-harry> done
15:10:12 <thomasem> #topic Stand Up :: sigmavirus
15:10:53 <sigmavirus> Working on some kinks in the first patch to implement the testing spec. Looking for a work appropriate GIF to describe my crashing into this meeting like that. ;) Planning to do some reviews later
15:11:09 <thomasem> lol
15:11:23 <sigmavirus> ('tis all from me)
15:11:39 <thomasem> #topic This Week's Priorities
15:12:37 <thomasem> I'd say getting in-flight work reviewed and merged, really. Other than that, we have https://bugs.launchpad.net/craton/+milestone/v0.1.0 and https://launchpad.net/python-cratonclient/+milestone/v0.1.0 as priorities
15:13:05 <thomasem> And the upcoming demo.
15:13:20 <jimbaker> thomasem, i think we are getting close to nested json search, so that's good
15:13:28 <thomasem> Yeah, I think so, too.
15:13:45 <jimbaker> it was only a bit more than anticipated...
15:13:47 <thomasem> The meat's there. It's nuance now.
15:13:58 <thomasem> And testing
15:14:04 <sigmavirus> When are we cutting 0.1.0 and starting work on 0.2.0?
15:14:18 <sigmavirus> When are we going to stop altering the initial alembic migration?
15:14:33 <jimbaker> sigmavirus, as soon as we get that alembic script in place
15:14:33 * sigmavirus is not helping
15:14:45 <thomasem> We need to get https://review.openstack.org/#/c/441644/ merged for that.
15:14:54 <thomasem> But that means we need to get
15:15:02 <thomasem> https://review.openstack.org/#/c/443170/ merged first
15:15:28 <jimbaker> i will take a look at the dbsync stuff immediately after this meeting
15:15:37 <thomasem> Thank you
15:15:58 <jimbaker> the nested search work consumed all of my available weekend time for craton
15:16:05 <jimbaker> but it is good, and nearly there
15:16:16 <thomasem> Can we also get this merged? https://review.openstack.org/#/c/433505/
15:16:29 <thomasem> It's been hanging around a while and is really straightforward.
15:17:06 <jimbaker> sure, although i have heard that before, and we have had a subsequent broken build ;)
15:17:16 <thomasem> So, in order of priority (imo):
15:17:23 <thomasem> https://review.openstack.org/#/c/443170/
15:17:32 <thomasem> https://review.openstack.org/#/c/441644/
15:17:38 <thomasem> https://review.openstack.org/440929
15:17:44 <thomasem> https://review.openstack.org/443186
15:17:47 <thomasem> https://review.openstack.org/443941
15:17:52 <sigmavirus> thomasem: I'm not a fan of merging things by people who spam the same review to every project they can find
15:18:14 <thomasem> sigmavirus: Ah... okay, I don't know anything about that practice.
15:18:16 <jimbaker> certainly we do not prioritize such things
15:18:46 <jimbaker> i learned my lesson when it caused some additional rebasing pain
15:18:47 <sigmavirus> thomasem: approving their patches merely encourages them to send more extraordinarily low value changes to us and nag us to merge it
15:19:30 <jimbaker> uuid gen is certainly one of them
15:19:40 <sigmavirus> jimbaker: but that was absolutely straight-forward ;)
15:19:46 <sigmavirus> just a wafer-thin change
15:19:54 <sigmavirus> :->
15:19:59 <thomasem> Heh, okay. Wells, up to y'all.
15:20:09 <jimbaker> yes, and the point of the extra abstraction layer is... ? ;)
15:20:13 <thomasem> Anyway, do those priorities I listed seem appropriate?
15:20:18 <jimbaker> thomasem, yes
15:20:30 <jimbaker> thomasem, so i want to back up and ask
15:20:39 <sigmavirus> thomasem: they seem appropriate to me
15:21:08 <jimbaker> why is the update to sqlalchemy 1.1 stuff failing on tests, even when run out of the gate?
15:21:46 <thomasem> I haven't dug in yet, as I was waiting for us to finalize your resolved variable search patch, which it's based on.
15:22:06 <thomasem> But, I can probably give you an answer shortly. :)
15:22:10 <jimbaker> thomasem, ok, i can certainly do that, but let's put our collective energy on that
15:22:21 <jimbaker> because otherwise all of this 0.1.0 stuff will not happen :)
15:22:40 <thomasem> I'll focus on that, then.
15:23:05 <jimbaker> so our work is cut out for us then
15:23:24 <thomasem> Yes
15:23:50 <jimbaker> we still need to support tojuvone in milan
15:24:28 <jimbaker> https://etherpad.openstack.org/p/MIL-ops-inventory-and-fleet-management
15:24:32 <thomasem> sulo: would you mind putting some focus on that, with maybe a recorded demo of latest stuff?
15:24:58 <jimbaker> i have had no time to put on that, so just need volunteers :)
15:25:33 <thomasem> Feel free to decline, just thought I'd ask since you've got the most experience in the showmanship department. :P
15:25:41 <thomasem> as far as Craton demos go
15:26:30 <jimbaker> tojuvone did ask for the latest. given we are putting together a latest version of demo for tomorrow, timing is good
15:26:40 <jimbaker> just need a screencast version
15:27:03 <sulo> thomasem: yeah its prolly not for me. whoever does the demo tomorrow, we can simply record that
15:27:13 <thomasem> #link https://etherpad.openstack.org/p/MIL-ops-inventory-and-fleet-management
15:27:16 <thomasem> Sounds good
15:27:32 * fsaad awaits the raising hand
15:28:58 <jimbaker> fsaad, i was going to volunteer you for the recording bit... i could put together screencast myself once 0.1.0 is marked ready, but i got a ton on plate this moment. this needs to be done by end of day tues mar 14 at latest
15:29:09 <jimbaker> so that's the constraint
15:30:43 <jimbaker> anything else?
15:31:20 <fsaad> not sure what's the recording bit, I'm mostly interested in the support demo for tomorrow
15:31:43 <fsaad> which yeah I can do come think of it
15:32:01 <fsaad> or should be :)
15:32:01 <jimbaker> fsaad, this recording is for tojuvone at the openstack operators midcycle that is taking place mar 15 & 16 in milan
15:32:33 <fsaad> yeah that I'll punt on
15:32:37 <jimbaker> he just wanted a short screencast (so let's say 5 min) demo-ing craton functionality
15:33:17 <fsaad> but I'll go through setting it up myself and try to load stuff into it, see if I can get it to work and show filters with real data, and that should sum up for the support folks hopefully
15:33:18 <jimbaker> so basically if we showed what we plan to show tomorrow, that would be fine
15:33:28 <thomasem> jimbaker: Do you want me to take over your patches and let you focus on the demo stuff? Might save us some rebase pain, too.
15:33:39 <thomasem> Rather, the Craton patches regarding variable search
15:33:52 <jimbaker> thomasem, i'm happy for you to take over the whole chain of var search patches
15:34:04 <jimbaker> it's going to be easier to move stuff around i think
15:34:15 <jimbaker> but i will still work with you on corner case/overall review
15:34:31 <thomasem> Sounds good. I'll take those over.
15:34:37 <jimbaker> cool
15:35:03 <jimbaker> i'm going to focus on alembic + those priority reviews (not tox --cover !)
15:35:17 <jimbaker> then will have time hopefully for demo + meeting prep
15:35:47 <thomasem> fsaad: sulo: Does that work?
15:36:24 <thomasem> Wouldn't hurt for several people to get experience setting up the demo, so.
15:36:29 <fsaad> jimbaker: will you do the screencast or the support demo as well?
15:36:36 <jimbaker> thomasem, +1
15:36:41 <thomasem> Build some redundancy into our team.
15:36:49 <fsaad> either way works just want to know if I need to get an env going and try it myself too
15:36:53 <jimbaker> fsaad, i will certainly do the screencast, and sure, i will look at support demo
15:36:55 <fsaad> which shouldn't be a bad exercise either way
15:37:09 <jimbaker> i haven't looked at doing stuff with real data for a while, even though it has been my intent
15:37:10 <fsaad> cool then do that, I'll do the same on my end and report on problems I find as I go too
15:37:12 <jimbaker> time to do that
15:37:35 <thomasem> Cool. Smiles all around, then?
15:37:37 <jimbaker> cool, sounds like we are in agreement
15:37:46 <fsaad> good deal
15:37:50 <jimbaker> and maybe wrap up? chafing to get reviews done here...
15:38:04 <thomasem> I don't see any topics in Open Discussion.
15:38:18 <thomasem> So, I'm cool w/ cutting the meeting here and going back to #craton for our varied shenanigans.
15:38:23 <jimbaker> very good
15:38:28 <thomasem> #endmeeting