15:01:54 <jimbaker> #startmeeting craton
15:01:55 <openstack> Meeting started Mon Mar  6 15:01:54 2017 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:56 <jimbaker> #chair sigmavirus sulo jimbaker thomasem
15:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:58 <jimbaker> #link https://etherpad.openstack.org/p/craton-meetings
15:01:59 <openstack> The meeting name has been set to 'craton'
15:02:00 <jimbaker> #topic Roll Call
15:02:01 <openstack> Current chairs: jimbaker sigmavirus sulo thomasem
15:02:06 <thomasem> Ah, beat me to it
15:02:07 <fsaad> o/
15:02:08 <thomasem> o/
15:02:09 <sigmavirus> o/
15:02:12 <jimbaker> o/
15:02:16 <jimbaker> thomasem, :)
15:02:25 <sigmavirus> thomasem: looks like jimbaker wants to chair this meeting ;)
15:02:31 <thomasem> Yep.
15:02:33 * thomasem passes torch
15:02:38 * thomasem kids
15:02:49 <jimbaker> oh i'm so sure you want me to chair...
15:02:52 <sulo> o/
15:02:57 * sigmavirus sets bridge on fire using torch
15:03:28 <thomasem> #topic Action Items from Last Meeting
15:03:28 <thomasem> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-27-15.04.html
15:03:51 * thomasem thomasem to write BP regarding deployment as a starting point for iterating on a suggested deployment model
15:04:04 <thomasem> #action thomasem to write BP regarding deployment as a starting point for iterating on a suggested deployment model
15:04:13 * thomasem jimbaker to map Dusty's requirements to work or existing features of Craton, especially with respect to short-term deliverable
15:04:23 <jimbaker> defer...
15:04:24 <thomasem> #action jimbaker to map Dusty's requirements to work or existing features of Craton, especially with respect to short-term deliverable
15:04:33 <jimbaker> thx
15:04:39 * thomasem sigmavirus finish up client/cli testing
15:04:57 <jimbaker> so is this something we can ever say is done?
15:05:09 <jimbaker> seems to me that sigmavirus did a lot of work on this
15:05:15 <thomasem> Yeah.
15:05:22 <thomasem> It can be done.. up to us.
15:05:23 <thomasem> ;)
15:05:40 <jimbaker> let's just rewind context here, and i think it was something along the lines of
15:05:53 <thomasem> Probably not enough detail in the noted item.. yeah
15:06:03 <jimbaker> the client/CLI need better testing in this way, because of inconsistency in column ordering etc
15:06:04 <sigmavirus> I still have more testing to do
15:06:24 <sigmavirus> I have yet to set up tests that actually talk to a craton server
15:06:28 <jimbaker> sigmavirus, sure, so how about the following action item for you
15:06:38 <sigmavirus> We can split it up into multiple items
15:06:41 <jimbaker> sigmavirus will work out testing plan
15:06:53 <jimbaker> such as assurance testing
15:06:59 <jimbaker> and present back to us
15:07:51 <sigmavirus> yep
15:07:51 <jimbaker> what we don't want a mega action item that's just a recurring standing task. better code! better testing! more customers! :)
15:07:53 <sigmavirus> I mean
15:07:54 <sigmavirus> I have a plan
15:07:57 <sigmavirus> but =P
15:08:42 <thomasem> #action sigmavirus to detail a testing plan for python-cratonclient for the team
15:08:45 <jimbaker> +1
15:09:20 <thomasem> Then we can generate bugs/BPs from said plan for any things that need to be done.
15:09:23 <sigmavirus> I'll spec it out in python-cratonclient repo
15:09:28 <thomasem> +1
15:09:31 <jimbaker> +1
15:09:38 <thomasem> #undo
15:09:40 <openstack> Removing item from minutes: #action sigmavirus to detail a testing plan for python-cratonclient for the team
15:09:50 <thomasem> #action sigmavirus to spec out a testing plan for python-cratonclient in python-cratonclient repo
15:10:23 <thomasem> #topic Stand-up
15:10:23 <thomasem> #info each team member briefly describes what they are working on this week, and describes blockers (if there are any)
15:10:40 <thomasem> #topic Stand Up :: thomasem
15:11:56 <thomasem> Finishing up CLI vars patch, code reviews, and taking the next highest priority item after the CLI vars patch is done
15:12:01 <thomasem> patches*
15:12:14 <thomasem> done
15:12:26 <thomasem> #topic Stand Up :: fsaad
15:13:14 <fsaad> not much from my end, got the demo box (ajaxterm) playbook going in case it's useful
15:13:33 <fsaad> cloudnull mentioned he's starting work on a deploy playbook, in case it's useful https://github.com/os-cloud/craton/blob/master/tools/craton-deploy/deploy-craton.yml
15:13:51 <fsaad> plans on converting to role for OSA
15:13:53 <fsaad> done
15:14:04 <cloudnull> ++ I should have that done today
15:14:14 <thomasem> #topic Stand Up :: sigmavirus
15:14:21 <sigmavirus> I am currently standing up
15:14:25 <sigmavirus> Er, wait, that's not what you wanted
15:14:33 <thomasem> It is, actually. Thank you for sharing.
15:14:38 <sigmavirus> /fin
15:14:38 <thomasem> I am sitting down.
15:14:51 <jimbaker> i too stand up if possible in an irc meeting
15:15:03 <sigmavirus> In reality, I did a bunch of refactoring on the cratonclient shell nonsense
15:15:18 <sigmavirus> Made the column ordering deterministic and seem to have annoyed sulo into making a quick patch :)
15:15:33 <sigmavirus> I'm going to work on the spec as soon as the meeting is done
15:15:39 <sigmavirus> /fin-for-real
15:15:48 <thomasem> #topic Stand Up :: jimbaker
15:15:55 <jimbaker> Review outstanding code, especially vars support in client (hopefully finalize and get in this morning)
15:15:56 <jimbaker> Implement testing for the var search query filter so we can get in
15:16:00 <jimbaker> Triage bugs (one critical is left without in progress: https://bugs.launchpad.net/craton/+bug/1666536)
15:16:00 <openstack> Launchpad bug 1666536 in craton "Cyclical hierarchies using parent_id" [Critical,New] - Assigned to Jim Baker (jimbaker)
15:16:00 <jimbaker> Work on Dusty's requirements - especially production-oriented aspects - this should translate into a spec as well
15:16:02 <jimbaker> Back to RBAC later this week
15:16:04 <jimbaker> done
15:16:18 <thomasem> #topic Stand Up :: sulo
15:17:04 <sulo> hola, mostly testing the patches right now for the demo and making some minor changes in the process
15:17:11 <jimbaker> +100
15:17:28 <thomasem> #topic This Week's Priorities
15:17:33 <sulo> done
15:17:36 <thomasem> #undo
15:17:37 <openstack> Removing item from minutes: #topic This Week's Priorities
15:17:40 <thomasem> #topic This Week's Priorities
15:18:02 <jimbaker> obviously today's demo
15:18:12 <thomasem> Finishing up CLI vars support
15:18:36 <jimbaker> let me suggest that for tues meeting we use that meeting time as a retrospective
15:18:58 <jimbaker> (at least in part)
15:18:59 <thomasem> Okay. Please add retrospective topics to the Etherpad.
15:19:02 <sulo> would be good to look at the bug to add --resolved-vars =false to show command
15:19:11 * sulo goes to find the lp link
15:19:46 <sulo> https://bugs.launchpad.net/python-cratonclient/+bug/1669508
15:19:46 <openstack> Launchpad bug 1669508 in Craton's Python Client "Resource GET calls need to allow filtering" [Undecided,New]
15:19:54 <sigmavirus> jimbaker: should we tag a release this afternoon in craton/cratonclient?
15:19:57 <jimbaker> #action jimbaker plan retrospective meeting for tues mar 7 with appropriate topics
15:20:25 <jimbaker> sigmavirus, the cmdb milestone? so long as we get this alembic stuff in
15:20:49 <thomasem> Distilling it down:
15:20:51 <sigmavirus> jimbaker: I mean a tag in the repo
15:21:00 <sigmavirus> We can call it 0.1.0 or whatever
15:21:05 <sigmavirus> just gives the tiger team something to use
15:21:07 <jimbaker> sigmavirus, +1
15:21:08 <sigmavirus> (rather than HEAD)
15:21:11 <sulo> sigmavirus: +1
15:21:32 <jimbaker> i think stating that says something about today's demo
15:21:38 <thomasem> Yeah, finalize that and backport for any things we want to get in there before the next release?
15:22:00 <sigmavirus> thomasem: backport?
15:22:28 <jimbaker> having said that, would like alembic in, because otherwise we have some possible unnecessary pain, https://review.openstack.org/#/c/441644/
15:22:54 <jimbaker> so just needs some reviews
15:22:55 <sigmavirus> jimbaker: will review
15:22:58 <jimbaker> thanks
15:23:05 <thomasem> sigmavirus: Posing the question of discriminating new patches to HEAD and whether we want to also get some of them into the 0.1.0 tag as well?
15:23:34 <sigmavirus> thomasem: ah, so nothing has tagged yet. When i think of backporting, I think of having a separate branch that we cherry-pick commits to
15:23:36 <sigmavirus> We can do that
15:23:39 <thomasem> In which case a branch may be better.
15:23:42 <sigmavirus> but I think we should be releasing from head frequently
15:23:46 <jimbaker> basically anything that sulo demos
15:23:47 <thomasem> Okay
15:23:57 <jimbaker> today should go in 0.1.0
15:24:08 <sigmavirus> thomasem: I think we should create separate branches *when* we want to support old releases for a while
15:24:13 <thomasem> Sure, sounds good. I just don't know if everything will get in, if history tells.
15:24:18 <thomasem> Got it
15:24:27 <thomasem> everything will get in *today*
15:24:31 <thomasem> I mean to say
15:24:45 <jimbaker> var search query is a good example
15:24:46 <sigmavirus> thomasem: we don't have to do 0.1.0 today
15:24:48 <sigmavirus> we can do it tomorrow
15:24:51 <sigmavirus> but
15:24:55 <sigmavirus> we should do it *soon*
15:24:58 <jimbaker> right
15:25:00 <thomasem> I agree.
15:25:33 <thomasem> Okay, so, let's distill this down
15:25:45 <thomasem> 1. demo today
15:25:49 <thomasem> 2. CLI vars patch
15:25:51 <jimbaker> there's one outstanding bug that was marked critical, and therefore supposed to be in the cmdb milestone, https://bugs.launchpad.net/craton/+bug/1666536
15:25:51 <openstack> Launchpad bug 1666536 in craton "Cyclical hierarchies using parent_id" [Critical,New] - Assigned to Jim Baker (jimbaker)
15:25:52 <thomasem> 3. Alembic changes
15:26:41 <thomasem> jimbaker: where does that fit in this week's priorities?
15:26:47 <jimbaker> (i can unassign it to me if anyone has free cycles)
15:26:58 <jimbaker> thomasem, so this is a data corruption bug
15:27:22 <jimbaker> if one creates such a cycle, the db is corrupted from the standpoint of subsequent queries against devices
15:27:34 <thomasem> What about not assigning until you're ready to work on it?
15:27:47 <jimbaker> thomasem, yep, sounds like a better plan
15:27:49 <thomasem> That way there never has to be the question if someone else wants to pick it up and work on it.
15:27:51 <jimbaker> i will unassign myself now
15:28:01 <thomasem> +1
15:28:14 <sigmavirus> thomasem: yeah, I think we have people on the team who just assign themselves to things they intend to work on at some point in the vague future
15:28:18 <sigmavirus> It's incredibly unhelpful
15:28:39 <sigmavirus> And it's not just jim
15:28:44 <sigmavirus> also, the openstack infra bot will assign you once you submit a review
15:28:54 <jimbaker> nice to know
15:28:57 <sigmavirus> so unless you anticipate it taking days or longer, best to just let it auto-assign you
15:28:58 <thomasem> Yep. That bot takes care of a lot of stuff for you.
15:29:05 * sigmavirus nods
15:29:17 <thomasem> It'll set the bug to in progress, it'll auto-assign you, it'll link the review.
15:29:23 <thomasem> All you have to do is tag the bug in the commit message
15:29:23 <sulo> need more bots to unassign
15:29:50 <thomasem> Lol
15:29:54 <sulo> bot = "you are taking too long ... "
15:29:56 <jimbaker> so best coordinate interest in our meetings, or on #craton. but don't sit on an assignment
15:30:19 <thomasem> Correct. I don't imagine we're territorial people, but it does have that effect sometimes.
15:30:22 <sigmavirus> sulo: I think launchpad can do stuff like that for you
15:30:26 <sigmavirus> there's a concept of a Launchpad Janitor
15:30:34 <sigmavirus> it also cleans up stale bug reports if you want
15:30:47 <sulo> sigmavirus: cool :)
15:30:52 <jimbaker> great retrospective topics btw
15:30:56 <thomasem> Yep
15:31:13 <sigmavirus> "How to bring development progress to a halt > Assign all the bugs to yourself"
15:31:27 <thomasem> Yep. So, we're drifting a bit.
15:31:42 <sulo> this is like the age of bots
15:31:43 <thomasem> Basically, priorities are in order of priority in LP for cmdb v0.1.0 milestone in both repositories.
15:31:49 <sulo> lets write some bot to do more things
15:32:12 <thomasem> demo is a big deal. Other than that, any in-flight code reviews for critical priority items in LP need eyes.
15:32:48 <jimbaker> yeah, anything else we need to cover?
15:32:52 <thomasem> Does that make sense and resonate with everyone?
15:33:18 <jimbaker> otherwise, let's just postpone discussion until tomorrow
15:33:26 <thomasem> Open Discussion, you mean?
15:33:36 <jimbaker> and this meeting as well
15:33:41 <thomasem> Cool.
15:34:00 <thomasem> Alright, let's get back to it!
15:34:07 <jimbaker> awesome, thanks!
15:34:07 <fsaad> y'all want to do a demo dry-run ?
15:34:09 <thomasem> #endmeeting