15:04:49 <thomasem> #startmeeting craton
15:04:50 <openstack> Meeting started Mon Feb 27 15:04:49 2017 UTC and is due to finish in 60 minutes.  The chair is thomasem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:53 <openstack> The meeting name has been set to 'craton'
15:05:58 <thomasem> #chair sigmavirus sulo jimbaker thomasem
15:05:58 <thomasem> #link https://etherpad.openstack.org/p/craton-meetings
15:05:59 <openstack> Warning: Nick not in channel: jimbaker
15:06:00 <openstack> Current chairs: jimbaker sigmavirus sulo thomasem
15:06:30 <thomasem> #topic Roll Call
15:07:06 <farid> o/
15:07:35 <git-harry> hi
15:07:36 <thomasem> o/
15:08:55 <thomasem> #topic Action Items from Last Meeting
15:08:56 <thomasem> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-20-15.00.html
15:09:11 * thomasem thomasem to write BP regarding deployment as a starting point for iterating on a suggested deployment model
15:09:16 <thomasem> carrying forward; higher priority items
15:09:23 <sulo> o/
15:09:32 <thomasem> #action thomasem to write BP regarding deployment as a starting point for iterating on a suggested deployment model
15:09:39 * thomasem jimbaker to map Dusty's requirements to work or existing features of Craton, especially with respect to short-term deliverable
15:10:03 <jimbaker> thomasem, deferred for later
15:10:14 <thomasem> #action jimbaker to map Dusty's requirements to work or existing features of Craton, especially with respect to short-term deliverable
15:10:34 <thomasem> Bah... wrong link, actually
15:10:40 <thomasem> I apologize. Lemme find it.
15:11:52 <thomasem> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-23-17.05.html
15:11:59 * thomasem sigmavirus finish up client/cli testing
15:13:26 <thomasem> Going to assume defer
15:13:38 <thomasem> #action sigmavirus finish up client/cli testing
15:13:44 <thomasem> #topic Stand Up
15:13:54 <thomasem> #info each team member briefly describes what they are working on this week, and describes blockers (if there are any)
15:14:02 <thomasem> #topic Stand Up :: farid
15:14:26 <farid> playing with my craton docker install, looking forward to demo laters ;)
15:14:29 <farid> done
15:14:37 <thomasem> #topic Stand Up :: git-harry
15:15:52 <git-harry> Making some changes to the client for devices given there was nothing in the review queue, need to check with jimbaker if I've just been duplicating effort given he picked this up last Friday.
15:15:56 <git-harry> done
15:16:47 <jimbaker> git-harry, sounds good
15:17:41 <git-harry> jimbaker: it's a bit rough and ready but it should be good enough for the demo if you ahven't already done anything
15:17:56 <jimbaker> understood
15:18:05 <thomasem> #topic Stand Up :: thomasem
15:18:12 <thomasem> cloud patch merged; clouds CRUD for CLI patch merged; fix for requiring region_id and cloud_id for networks call merged; code reviews; working on bootstrap issue to properly set up the initial project/user - https://bugs.launchpad.net/bugs/1668251, doesn't look like we can create root users from API, so would be interested in discussing how we want that to work
15:18:12 <openstack> Launchpad bug 1668251 in craton "Including project in var resolution order causes error" [Critical,New] - Assigned to Thomas Maddox (thomas-maddox)
15:18:12 <thomasem> done
15:18:36 <thomasem> #topic Stand Up :: sulo
15:18:45 <jimbaker> thomasem, another bootstrap problem...
15:19:04 <sulo> moslty working on getting stuff ready to show a running craton install
15:19:13 <sulo> fixing a few bugs on the way
15:19:20 <sulo> one of them my own doing :)
15:19:23 <sulo> done
15:19:33 <thomasem> #topic Stand Up :: jimbaker
15:20:32 <jimbaker> get ready for demos this week, esp around loading/consuming inventory data; finalize variables support in client/CLI (but has been updated to reflect client changes); get to that alembic refactoring
15:20:33 <jimbaker> done
15:20:58 <thomasem> #topic This Week's Priorities
15:21:20 <thomasem> We've got some unassigned work here https://launchpad.net/craton/+milestone/v0.1.0
15:21:32 <thomasem> Do those still reflect our priorities?
15:21:38 <sulo> we need to work on client
15:21:43 <sulo> i think we need to make that our priority
15:21:44 <thomasem> https://launchpad.net/python-cratonclient/+milestone/v0.1.0
15:22:01 <sulo> client is missing a lot of things
15:22:04 <thomasem> Okay, so any critical/high bugs that we need for v0.1.0 need to get added to that milestone ^^
15:22:08 <jimbaker> thomasem, the one that needs work is https://bugs.launchpad.net/craton/+bug/1661226
15:22:08 <openstack> Launchpad bug 1661226 in craton "Filter by variables lacks resolved variables" [Critical,Confirmed]
15:22:10 <sulo> ill file separete bug later today
15:22:14 <jimbaker> given critical
15:23:00 <sulo> thomasem: yeah, ill add them to that milestone, but i think testing client should be one of the top task
15:23:10 <jimbaker> remaining high bugs for craton look like nice to haves
15:23:21 <thomasem> Priorities go like so:
15:23:39 <jimbaker> i can take on the resolution bug that is unassigned
15:23:48 <thomasem> jimbaker: the one you linked?
15:24:00 <farid> what are resolved vars ?
15:24:33 <sulo> farid: ill show you in the demo ;)
15:24:51 * sigmavirus missed his standup =P
15:24:51 <farid> awesome thanks sulo !
15:25:14 <sulo> farid: but basically vars getting handed down follwing a resolution order
15:25:20 <jimbaker> thomasem, yes
15:25:23 <sulo> region to cell to host
15:25:28 <thomasem> Priorities are CLI critical bugs in milestone v0.1.0 and the resolution bug that jimbaker mentioned. Other than that, all in-flight work in those milestones need eyes on reviews when they're ready.
15:25:30 <sulo> parent host -> child host etc
15:25:40 <farid> oh ok cool
15:25:43 <sulo> farid: basically resolving variables using that order
15:26:06 <farid> good deal, sulo did you get to try pwnall's import script ?
15:26:23 <jimbaker> it's a unique & nice feature of what we provide, which is inspired by active directory, puppet hiera, and ansible group vars
15:26:27 <thomasem> farid: for instance Project has varA = "foo" and varB = "baz", and a host in that project has varA = "bar", the host should have variables resolved to: varA = "bar", varB = "baz".
15:26:42 <sulo> farid: yes, it mostly works .. i used it with some additions
15:27:12 <thomasem> Does my statement about our priorities have consensus?
15:27:21 <jimbaker> thomasem, _+1
15:27:22 <sulo> thomasem: yes sounds good to me
15:27:23 <thomasem> #info Priorities are CLI critical bugs in milestone v0.1.0 and the resolution bug that jimbaker mentioned. Other than that, all in-flight work in those milestones need eyes on reviews when they're ready.
15:27:41 <thomasem> #link https://launchpad.net/python-cratonclient/+milestone/v0.1.0
15:27:45 <thomasem> #link https://launchpad.net/craton/+milestone/v0.1.0
15:27:56 <thomasem> #link https://bugs.launchpad.net/craton/+bug/1661226
15:27:56 <openstack> Launchpad bug 1661226 in craton "Filter by variables lacks resolved variables" [Critical,Confirmed] - Assigned to Jim Baker (jimbaker)
15:28:07 <sulo> also i would encourage folks to use the cli during core developement so that we catch these
15:28:14 <jimbaker> +100
15:28:51 <thomasem> Great.
15:28:56 <thomasem> #topic Open Discussion
15:29:07 <thomasem> jimbaker: it's THE resolution problem that I was referring to.
15:29:19 <thomasem> s/resolution/bootstrap/
15:29:22 <thomasem> wires crossed... sorry
15:29:36 <jimbaker> thomasem, well they have similar meta qualities don't they :)
15:29:45 <thomasem> That they do.
15:29:58 <sulo> thomasem: is this the same issue i was talking about earlier ?
15:30:07 <jimbaker> so i take it that we can create users just fine from the db, but we are missing the ability to do this from the api
15:30:13 <farid> good deal thanks sulo , and jimbaker / thomasem for the quick rundown
15:30:25 <jimbaker> with sufficient root powers that is
15:30:32 <thomasem> jimbaker: Yeah... the idea I was toying with was, right
15:30:37 <thomasem> Having a default user
15:30:40 <thomasem> in the data migration
15:30:46 <thomasem> so it's not dependent on using our docker_run.sh
15:30:57 <thomasem> for bootstrapping
15:31:06 <thomasem> And then having the ability for a root user to create other root users
15:31:12 <jimbaker> eg generate_fake_data
15:31:13 <thomasem> So they could create a root user, then delete the default
15:31:21 <jimbaker> makes sense
15:31:28 <sulo> thomasem: +1 thats what the thinking was behind the current root user
15:31:45 <sulo> except its not in defult migration
15:31:50 <jimbaker> even if we say "real rbac solves", we still need to identify specific points where this support is required
15:31:53 <sulo> so totally agree with you
15:32:09 <jimbaker> all that "real rbac solves" is just gives us better fine grained permissions fwiw
15:32:24 <thomasem> We still have that lovely beginning chicken/egg problem.
15:32:30 <thomasem> So, let's pull that into the migration
15:32:36 <jimbaker> +1
15:32:38 <sulo> +1
15:32:57 <sulo> ok now i have a question that i was discussing in #craton
15:32:58 <sulo> https://gist.github.com/sulochan/d8f36481216a02491b0e608d2c93fdd4
15:33:17 <sulo> what am i missing in that output with regards to descendants
15:33:21 <thomasem> Now, we can start with a default user anyway without adding the ability to add a root user right away. We can one-two punch it. Just the workaround would be that one has to change the default token for the root for security reasons.
15:33:38 <thomasem> And that'd required a DB call... but it's better than a series of DB calls to bootstrap until we get the rest set up.
15:34:30 <git-harry> sulo: you need to specify a parent_id
15:34:34 <jimbaker> thomasem, right, we just very limited use of the bootstrap user
15:34:43 <sulo> git-harry: so in the query say parent_id=x ?
15:34:51 <git-harry> yes
15:34:53 <jimbaker> sulo, yes
15:35:03 <sulo> rgr, let me try that
15:35:33 <jimbaker> sulo, it should intersect with other query params as well
15:35:53 <jimbaker> and we could add this parent_id support to v1/hosts and v1/network-devices
15:36:16 <jimbaker> to just ask for members in those respective collections
15:36:18 <sulo> git-harry: jimbaker: https://gist.github.com/sulochan/d8f36481216a02491b0e608d2c93fdd4
15:36:35 <sulo> :+1
15:36:39 <thomasem> So, let me ask, do we care to mess with this bootstrap problem right now, or point me at another priority?
15:36:56 <jimbaker> thomasem, so i don't see it as a priority for this week
15:37:07 <thomasem> Such as the one jimbaker just assigned to himself, given the other stuff jimbaker is working on
15:37:08 <jimbaker> thomasem, do you want to help me on the client testing stuff for vars?
15:37:27 <farid> tim mentioned vars are not removed when host is deleted, not sure if y'all saw that in his e-mail btw
15:37:42 <jimbaker> thomasem, but in general, us working together on issues sounds good to me
15:37:55 <jimbaker> i can use as much cycles as you can provide :)
15:38:03 <thomasem> jimbaker: okay, cool. Would you like for me to be submitting patches to your review?
15:38:18 <jimbaker> thomasem, sure, let's just go with that
15:38:20 <thomasem> I'm assuming you're talking about https://bugs.launchpad.net/bugs/1659110?
15:38:20 <openstack> Launchpad bug 1659110 in Craton's Python Client "Support get/set/delete variables in Python client/CLI" [Critical,In progress] - Assigned to Jim Baker (jimbaker)
15:38:26 <jimbaker> thomasem, yep
15:38:34 <thomasem> Okay, I'll dig in to that one.
15:38:40 <jimbaker> awesome, much appreciated
15:38:44 <thomasem> Sure thing
15:38:56 <jimbaker> farid, taking a look at tim's email
15:39:20 <farid> I can create a ticket if y'all think it is a bug
15:39:23 <jimbaker> farid, so it looks like we need to look at the foreign key constraint
15:39:31 <farid> seems like one, but not sure if already being addressed by one of the tickets in flight
15:39:33 <jimbaker> and verify ondelete=cascade
15:39:46 <jimbaker> farid, bug report is great. if invalid, we can mark it as such
15:39:55 <jimbaker> but better reported than not
15:40:04 <jimbaker> farid, not to my knowledge
15:40:05 <farid> allright I'll go ahead and file it! thanks jimbaker
15:40:15 <jimbaker> delete is usually the last thing that gets tested, fwiw :)
15:40:22 <farid> yeah makes sense :)
15:42:05 <thomasem> Alrightyo. Any other topics?
15:42:15 <jimbaker> i think we are good and in heads down mode
15:42:22 <thomasem> Okay. Back to it!
15:42:24 <thomasem> #endmeeting