17:02:19 <jimbaker> #startmeeting craton
17:02:21 <openstack> Meeting started Thu Feb 16 17:02:19 2017 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:24 <openstack> The meeting name has been set to 'craton'
17:02:50 <jimbaker> #chair sigmavirus sulo jimbaker thomasem
17:02:51 <openstack> Current chairs: jimbaker sigmavirus sulo thomasem
17:02:58 <jimbaker> #link https://etherpad.openstack.org/p/craton-meetings
17:03:51 <jimbaker> sigmavirus, around?
17:04:08 <jimbaker> if not we can have thomasem chair again...
17:04:40 <thomasem> I don't mind. It'll be my first time, if you don't mind offering up some halps with the commands.
17:04:50 <jimbaker> thomasem, sounds good
17:04:53 <thomasem> #topic Roll Call
17:05:05 <jimbaker> and looks like you have it down already
17:05:05 <jimbaker> :)
17:05:09 <jimbaker> o/
17:05:12 <thomasem> o/
17:05:13 <jovon> hello
17:05:40 * jimbaker should not chair, is the general consensus of the group, i believe :)
17:05:45 <thomasem> Welcome to the party, jimbaker, jovon
17:06:09 <thomasem> #topic Agenda
17:06:14 <thomasem> #undo
17:06:15 <openstack> Removing item from minutes: #topic Agenda
17:06:23 <thomasem> #topic Action Items
17:06:50 <thomasem> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-01-30-15.00.html
17:07:18 <thomasem> #undo
17:07:20 <openstack> Removing item from minutes: #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-01-30-15.00.html
17:07:21 <thomasem> I think that one was old
17:07:34 <jimbaker> http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-13-15.00.html
17:07:41 <thomasem> Here we are
17:07:44 <jimbaker> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-13-15.00.html
17:07:50 <sigmavirus> I'm chairing the OSSP meeting
17:07:50 <thomasem> Thanks, jimbaker
17:07:54 <sigmavirus> sorry
17:07:58 <thomasem> We'll miss you, sigmavirus
17:08:04 <sigmavirus> yeah, unlikely
17:08:06 <sigmavirus> =P
17:08:11 <sigmavirus> Working on the docker fix right now for infra too
17:08:18 <thomasem> Excellent!
17:08:38 <jimbaker> sigmavirus, very nice. i think i can repeat here, +1000
17:08:41 <thomasem> jimbaker: turn Dusty's document into etherpad, I guess our poorly name etherpad is sufficient?
17:09:44 <thomasem> https://etherpad.openstack.org/p/cmdb_prototype_meeting_2017_02_09
17:09:45 <thomasem> That guy
17:09:46 <jimbaker> #link https://etherpad.openstack.org/p/cmdb_prototype_meeting_2017_02_09
17:09:52 <jimbaker> yes, that one
17:10:00 <jimbaker> let's just paste dusty's doc at the end
17:10:13 <jimbaker> and we will work on making it better. sounds good?
17:10:38 <thomasem> Yeah, sounds good to me.
17:11:03 <thomasem> jimbaker: Add reviewing said etherpad as a standard agenda item to our meeting template
17:11:46 <jimbaker> dusty's doc added to cmdb tracking doc
17:12:10 <thomasem> Awesome. Let's also add that as a standing item for our meeting template
17:12:35 <thomasem> To review progress-wise, I imagine
17:13:31 <jimbaker> right, the doc as added is not terribly useful for the review process, but we will put it in a form to do so
17:14:01 <thomasem> #action thomasem to write BP regarding deployment as a starting point for iterating on a suggested deployment model
17:14:02 <jimbaker> this is something that toan effectively asked me to do - to match requirements to work
17:14:09 <thomasem> Right
17:14:44 <thomasem> So, do we want to turn that into an action item?
17:14:59 <jimbaker> thomasem, sure, let's do that
17:15:46 <thomasem> #action jimbaker to map Dusty's requirements to work or existing features of Craton, especially with respect to short-term deliverable (~2 weeks remaining)
17:15:56 <jimbaker> thomasem, +1
17:16:20 <thomasem> sigmavirus's pagination stuff got finished and merged
17:16:34 <jimbaker> and to be clear - this will be selective - only will consider short term stuff (first 3 reqs iirc)
17:16:41 <jimbaker> for this mapping
17:17:00 <thomasem> jimbaker: I would confirm that... I still think some folks are expecting more than what we are.
17:17:30 <thomasem> Do you mean UC1-3 are all that's expected?
17:18:10 <jimbaker> thomasem, https://etherpad.openstack.org/p/cmdb_prototype_meeting_2017_02_09, starting at line 89
17:18:24 <jimbaker> not another set of stories we have been recently looking at
17:18:39 <jimbaker> which have the UCn numbering
17:19:03 <thomasem> Oh, okay
17:19:05 <jimbaker> clear? i'm hoping to make it so :)
17:19:15 <jimbaker> for my sanity's sake at least
17:19:28 <thomasem> Haha, indeed. Not entirely clear to me yet. I'll review it in more detail.
17:19:58 <thomasem> I've read through all of the things, but they continue to have additional scope that I don't think we can meet with Craton, at least.
17:19:59 <jimbaker> going from reqs to something actionable is always a challenge
17:20:04 <thomasem> Definitely
17:20:14 <jimbaker> thomasem, feel free to add your comments accordingly
17:20:18 <jimbaker> so we can converge
17:20:29 <thomasem> And scoping that by responsibility so Craton doesn't become the Australian from Futurama.
17:21:02 <thomasem> #action thomasem to review Dusty and Bjorn's stories/use-cases and add notes on concerns or questions
17:21:10 <jimbaker> and now i know that meme...
17:21:26 <thomasem> I hope it's the one I was thinking of, and not something bad.
17:21:32 <thomasem> Well... tasteless.
17:21:54 <jimbaker> i believe we have a joint understanding. but hey, brains
17:22:01 <thomasem> Anyway, does anyone know the status of the CLI testing that sigmavirus had an action item for?
17:22:09 <thomasem> Lol, indeed
17:22:52 <thomasem> I'll carry that one forward until we can get a status on it.
17:23:01 <thomasem> #action sigmavirus to finish up testing on cli
17:23:17 <jimbaker> that will be a good hamster wheel for sigmavirus
17:23:27 <sigmavirus> o_O
17:23:30 <thomasem> Do we then do Stand Up in this meeting?
17:23:39 <Syed__> o/
17:23:56 <thomasem> #topic Stand Up
17:24:00 <jimbaker> yes. but sigmavirus is here, so let's cover that action item?
17:24:11 <jimbaker> #undo
17:24:12 <openstack> Removing item from minutes: #topic Stand Up
17:24:23 <thomasem> #undo
17:24:24 <openstack> Removing item from minutes: #action sigmavirus to finish up testing on cli
17:24:37 <thomasem> Pardon the onslaught of pings
17:24:43 <jimbaker> some handy commands here...
17:25:12 <thomasem> I dunno, jimbaker, I think he's busy.
17:25:53 <jimbaker> sigmavirus just pops in with emoticons as necessary
17:25:59 <thomasem> Yep
17:26:03 <thomasem> Alright, let's move on.
17:26:12 <jimbaker> +1
17:26:28 <thomasem> #action sigmavirus to finish up testing on cli
17:26:32 <thomasem> #topic Stand Up
17:26:39 <thomasem> #info each team member briefly describes what they are working on this week, and describes blockers (if there are any)
17:26:58 <thomasem> #topic Stand Up :: jimbaker
17:27:58 <jimbaker> finish up WIP on vars in client/CLI; map reqs to craton tasks, focused on short term for the cmdb milestone; review stuff
17:27:59 <jimbaker> done
17:28:15 <thomasem> #topic Stand Up :: thomasem
17:29:20 <thomasem> project vars merged (yay!); working on some bugs found during that work, then moving back to adding clouds; reviewing queue; review user stories and use-cases for concerns/questions I have so we can improve communication and expectations there.
17:29:22 <thomasem> done
17:29:36 <thomasem> #topic Stand Up :: jovon
17:30:50 <jovon> cleaning some current doc patches as well as investigating current doc tools available doc generating more autoimatic
17:31:03 <jovon> automatic*
17:31:11 <jimbaker> +1
17:31:13 <thomasem> awesome
17:32:10 <thomasem> Anything else, jovon, or 'done'? :)
17:32:11 <openstackgerrit> Ian Cordasco proposed openstack/craton master: Fix up functional testing  https://review.openstack.org/435038
17:32:15 <jovon> done
17:32:17 <sigmavirus> ^ should be fun to watch
17:32:18 <jovon> sorry
17:32:26 <thomasem> No problem at all!
17:32:31 <thomasem> #topic Stand Up :: Syed__
17:32:54 <Syed__> Working on patch for update project and users
17:33:00 <Syed__> tests are broken now and its a mess :/
17:33:11 <Syed__> but well, hoping to get it going today
17:33:17 <jimbaker> sigmavirus, nice about that possible bug fix
17:33:38 <Syed__> apart from that working over CLI tests
17:33:43 <sigmavirus> be back in ~10 min
17:34:01 <thomasem> Syed__: mind linking the review? I'll pull it down when I get a moment and see if anything jumps out at me that might help?
17:34:20 <Syed__> thomasem: https://review.openstack.org/#/c/425463/
17:34:25 <Syed__> thomasem: thanks
17:34:29 <jimbaker> this is an important thing to get fixed
17:34:36 <thomasem> #link https://review.openstack.org/#/c/425463/
17:34:39 <thomasem> You bet!
17:34:46 <Syed__> once i get this merged, have couple of minor reviews in the queue i would like y'all to check them out
17:35:01 <Syed__> then will focus towards CLI users and projects
17:35:04 <Syed__> done
17:35:19 <thomasem> #topic Open Discussion
17:35:27 <jimbaker> basically all the refactoring that has hit projects... it's good, but definitely a lot of stepping on each other, given centrality
17:35:49 <thomasem> Yes. It's caused a fair amount of pain for all involved.
17:36:10 <thomasem> But, we're trucking through it. I am curious how everyone's feeling? We've been going at a bit of a pace here. :)
17:36:23 <thomasem> Working early/late/weekends
17:36:33 <jimbaker> thomasem, well, if i tried to sustain yesterday's pace for much longer, i will fall over
17:36:55 <git-harry> I could do with some reviews on https://review.openstack.org/#/c/435005/
17:37:01 <git-harry> before I start on the code
17:37:13 <jimbaker> so no, not sustainable. but i think it was important to pitch in here to break logjams
17:37:29 <thomasem> #link https://review.openstack.org/#/c/435005/
17:37:30 <openstackgerrit> Ian Cordasco proposed openstack/craton master: Fix up functional testing  https://review.openstack.org/435038
17:37:44 <jimbaker> git-harry, thanks, will take a look
17:38:42 <jimbaker> to summarize, git-harry captures in that spec our discussion about a heterogeneous device collection, to accommodate for now net devices and hosts, but other devices in the future
17:39:13 <jimbaker> so important stuff to be able to fully query with respect to a given switch for example
17:39:33 <thomasem> Right, since /hosts doesn't support that?
17:40:07 <thomasem> And we don't want /[switches,firewalls,hosts,etc.], rather just /devices
17:40:08 <jimbaker> thomasem, correct - /hosts not surprisingly only returns host objects
17:40:18 <thomasem> LOL yes, I was surprised at least..
17:40:22 * thomasem kids
17:40:31 <jimbaker> :)
17:40:42 <thomasem> Excellent
17:40:47 <jimbaker> so switches, firewalls - presumably network devices
17:40:51 <thomasem> Right
17:40:57 <thomasem> Cool. I will take a look also
17:41:28 <jimbaker> the intent is that /devices will also in the future cover such usage as AWS resources, which are not hosts
17:41:40 <jimbaker> but are they devices...
17:41:43 <jimbaker> ;)
17:42:10 <jimbaker> we may have to accept that generalization may mean we are not going to refactor our names. i don't know
17:42:30 <thomasem> refactor our names?
17:42:44 <jimbaker> s/device/resource/ in our code base, or something like that
17:42:56 <thomasem> Ahhhhhhhhh, gotcha
17:43:29 <thomasem> Alright, cool. Any other topics of discussion?
17:43:34 <jimbaker> anyway, for rackspace private cloud (potential customer #1 for craton), this is moot
17:43:41 <thomasem> Yep
17:43:41 <jovon> i like the idea
17:43:57 <jimbaker> jovon, i like it too, other than the pain it will cause
17:44:21 <thomasem> c'est la vie!
17:44:37 <git-harry> I think we should make the functional testing non-voting to unblock the gate.
17:45:11 <jimbaker> but i was on a project at canonical where we decided to change the name from ensemble to juju. this was a very pervasive change, and impacted tooling, bug trackers, launchpad projects, etc
17:45:17 <git-harry> I know sigmavirus is trying to fix the problem but we risk not being able to merge anything for a while if the issue ends up being problematic to solve.
17:45:42 <jimbaker> git-harry, +1
17:45:44 <jovon> +1
17:45:51 <thomasem> Yeah, let's be sure it's working before gating on it.
17:46:08 <jimbaker> i believe sigmavirus stated he had submitted something to that effect
17:46:13 <jimbaker> https://review.openstack.org/#/c/435038/ can be done in parallel
17:46:15 <Syed__> i feel like functional testing is an important aspect and once its out there it will be greate
17:46:17 <git-harry> jimbaker: https://review.openstack.org/#/c/434979/
17:46:18 <Syed__> great **
17:46:25 <git-harry> It's been marked as -W
17:46:54 <jimbaker> by sigmavirus, yeah we need to reverse that
17:47:47 <thomasem> Added notes to that effect on the review
17:47:58 <jimbaker> in retrospect, a bit of settling in with a nonvoting gate would have been nice. but funct testing had been stable quite recently
17:48:25 <thomasem> Yeah. This is always a concern when executing in a different environment, though.
17:48:40 <thomasem> I think in the future it'd be nice to see it pass there at least once before making it voting.
17:48:43 <jimbaker> so i would say non-voting for a week or so might be the right way to do this
17:49:13 <jimbaker> once the gate starts *working* of course
17:49:23 <thomasem> yep
17:49:34 <thomasem> Alright, cool. Well, let's follow up with sigmavirus about that.
17:49:50 <thomasem> Any other topics? Or do we want 10 minutes back?
17:50:12 <jimbaker> thomasem, maybe cli testing?
17:50:26 <thomasem> Integration testing?
17:50:36 <jimbaker> of course the vagueness of the action item for sigmavirus suggests that it is his forever & ever
17:50:43 <jimbaker> eg hamster wheel
17:50:44 <thomasem> Pretty much.
17:50:52 <jimbaker> but yes, integration testing
17:50:55 <thomasem> Wait, so you mean to tell me he doesn't want to do that forever?
17:51:35 <thomasem> So, how has integration testing typically been done in OpenStack, especially between client and API?
17:51:38 <jimbaker> thomasem, i don't know. let's ask him? sigmavirus, it's ok if you work on that task forever? remember silence means yes
17:51:48 <thomasem> Cruel
17:52:05 <jimbaker> ;)
17:52:33 <jimbaker> ok, so yeah, i mean actually testing the client/CLI in some reasonably robust way against the api sever
17:52:46 <jimbaker> tox -e integration
17:53:07 <thomasem> Is it a usual pattern for that to live in the client project, or API server?
17:53:23 <jimbaker> we could start with the generate fake data as a way of loading up fixture data, suitably modified to support the changes we make
17:53:43 <jimbaker> so we decided not to make it a dependency on the api server. because circularity
17:54:22 <jimbaker> craton itself should be tested via rest tests, as we now do in tox -e functional
17:54:36 <jimbaker> that's the only true contract it provides
17:54:43 <thomasem> So, then you'd tox -e integration in python-cratonclient project?
17:55:06 <thomasem> And that would... set up a craton-api and go to town exercising the code paths, or would it be a mock craton API?
17:55:12 <jimbaker> yes, and it can potentially take advantage of projects for suitable isolation
17:55:23 <thomasem> Ah
17:55:43 <thomasem> Yeah, generate a couple of projects specific to the integration test and then mutate those projects
17:55:44 <jimbaker> we already have some form of mock craton api testing going on the client. that's good, but we need stronger
17:55:57 <thomasem> and all of their descendants.
17:56:43 <jimbaker> i'm sure we can get some fun stuff going, but i just want to verify stuff works. such as the recent pagination stuff comes to mind
17:57:02 <jimbaker> passing sort_keys should be tested, and verified it goes end-to-end
17:57:06 <jimbaker> hence tox -e integration
17:57:18 <thomasem> I don't think anyone is going to disagree with that.
17:57:35 <jimbaker> cool. and again, silence means a chorus of resounding yeses ;)
17:58:05 <thomasem> My only concern is how the python-cratonclient project now has to know how to deploy a craton-api for testing.
17:58:20 <jimbaker> thomasem, i'm ok if we put in a separate project as well
17:58:36 <thomasem> I was imagining that's what, like, tempest tests did.
17:58:37 <jimbaker> but that's just extra stuff in all likelihood
17:59:04 <jimbaker> so for tempest, that makes a lot of sense, because there are multiple projects
17:59:16 <thomasem> As there are here
17:59:30 <jimbaker> right now, we just have one client. so until we grow more, easier to track in place
17:59:33 <jimbaker> in one place
17:59:46 <jimbaker> can always refactor by pulling out
17:59:51 <thomasem> Sure. I do anticipate it moving out, though. With a separate project, you can more easily manage versions and such that are being tested.
18:00:01 <jimbaker> good points indeed
18:00:02 <thomasem> But, I'm not going to plant my feet over it
18:00:09 <thomasem> And that may take up valuable time
18:00:15 <jimbaker> yeah, i just want one test script that can grow over time
18:00:17 <thomasem> So, I appreciate where you're coming from.
18:00:33 <jimbaker> and start with generate_fake_data.py, and start updating it
18:01:06 <thomasem> Honestly, a lot of the stuff from our functional tests can apply here.
18:01:13 <thomasem> Just would need to be leveraged by python-cratonclient
18:01:23 <thomasem> Since that sets up a craton-api
18:01:27 <jimbaker> i'm pretty sure we can just use in some fashion. it should be dockerized
18:01:38 <thomasem> And has all of the logic for create/teardown
18:01:39 <thomasem> and such
18:01:42 <jimbaker> and it's available as an import, etc
18:01:57 <thomasem> Yeah, I guess it is.
18:02:02 <thomasem> didn't think about that
18:02:03 <thomasem> handy
18:02:03 <jimbaker> there's no reason the test harness in the integration testing cannot just use
18:02:08 <thomasem> Yep
18:02:18 <jimbaker> yeah, those pieces can continue to live in the craton project
18:02:35 <thomasem> So, as long as we maintain that contract, the integration tests will be fine.
18:03:10 <thomasem> Save for legitimate breakage. :P
18:03:20 <thomasem> I'm going to end the meeting (over time)
18:03:23 <thomasem> but we can continue this chat
18:03:29 <thomasem> #endmeeting