15:00:09 <sigmavirus> #startmeeting craton
15:00:10 <openstack> Meeting started Mon Feb 13 15:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is sigmavirus. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'craton'
15:00:15 <sigmavirus> #chair jimbaker sulo
15:00:15 <openstack> Current chairs: jimbaker sigmavirus sulo
15:00:42 <sigmavirus> #info There is no agenda for this meeting this week
15:00:54 <thomasem> o/
15:01:13 <sigmavirus> #link https://etherpad.openstack.org/p/craton-meetings
15:01:15 <sigmavirus> damnit
15:01:19 <sigmavirus> #link https://etherpad.openstack.org/p/craton-meetings
15:01:25 <sigmavirus> #topic Roll Call
15:01:26 <jimbaker> sigmavirus, properly, there is no unique agenda for this meeting
15:01:30 <sigmavirus> (now you should wave thomasem)
15:01:38 <jimbaker> o/
15:01:40 <thomasem> o/ o/
15:01:54 <sigmavirus> jimbaker: most teams will have a basic format which people add items to
15:01:55 <sigmavirus> Hence creating a semi-unique agenda
15:01:56 * sigmavirus shugs
15:01:59 <sigmavirus> We're barely a team though
15:02:40 <jimbaker> working on it
15:02:49 <sigmavirus> sulo: git-harry?
15:03:00 <thomasem> I think sulo's out
15:03:35 <jimbaker> that was sulo's communication from earlier today - he is out for the entire week
15:03:46 <sigmavirus> Ah, I did not receive that email
15:03:51 * sigmavirus assumes it was an email
15:04:05 <jimbaker> it was on irc
15:04:20 <sigmavirus> Ah. Okay. (Still haven't read this morning's scrollback either)
15:04:29 <jimbaker> and folks if you are going to be out, i would like to know about it
15:04:37 <jimbaker> it does help on the planning
15:04:47 <jimbaker> your manager knows. i do not know
15:05:19 <sigmavirus> o/ git-harry
15:05:27 <git-harry> apologies all, I lost track of time.
15:05:39 <jimbaker> git-harry, must be in flow
15:05:52 <sigmavirus> #info We should all treat jimbaker as our manager and inform him of all time off taken
15:06:00 <sigmavirus> secondary manager?
15:06:05 <sigmavirus> assistant to the regional manager?
15:06:07 <thomasem> Assistant to the regional manager
15:06:08 <thomasem> AH!
15:06:11 <thomasem> sigmavirus!
15:06:12 <sigmavirus> jinx
15:06:14 <jimbaker> something like that :)
15:06:29 <git-harry> we have a calendar for that internally
15:06:41 <jimbaker> farid will be joining us end of month, at which point he can take on that responsibility
15:07:03 <sigmavirus> git-harry: so while our corporate diversity is currently quite poor, that won't work for long
15:07:16 <jimbaker> git-harry, also awesome, i have never seen that calendar
15:08:09 <sigmavirus> Moving along
15:08:16 <jimbaker> anyway, it's atypical for me to kvetch
15:08:49 <sigmavirus> #topic Action Items From Last Monday's Meeting
15:08:53 <sigmavirus> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-06-15.00.html
15:09:08 <sigmavirus> jimbaker: should we carry forward the doc -> etherpad task?
15:09:29 <jimbaker> sigmavirus, yes, this got caught up in the best process of doing so
15:09:33 <sigmavirus> #action jimbaker to turn dusty's doc into an etherpad
15:09:44 <sigmavirus> #action jimbaker once the etherpad is created, add reviewing it as a standing item to our meeting template
15:10:01 <sigmavirus> git-harry: thomasem did either of you decide who should write the spec we discussed last week?
15:10:10 <thomasem> yes. I will.
15:10:12 <jimbaker> etherpad. launchpad. waffle. back to launchpad. how to split
15:10:29 <sigmavirus> #action thomasem to write the spec discussed in last Monday's meeting
15:10:43 <sigmavirus> I'm still working on my action item, so I'll carry that forward
15:10:45 <sigmavirus> #action sigmavirus to update pagination API work to add functional tests now that sulo's work has landed
15:10:47 <thomasem> I'd like to discuss that, jimbaker, in open discussion.
15:10:53 <sigmavirus> #action sigmavirus to finish up testing on cli
15:10:54 <jimbaker> thomasem, +1
15:11:04 <sigmavirus> thomasem: add it to the agenda? https://etherpad.openstack.org/p/craton-meetings
15:11:11 <thomasem> on it
15:11:35 <sigmavirus> thomasem: did you get around to making a blueprint for the deployment docs?
15:11:54 <jimbaker> sigmavirus, i would like to discuss the CLI testing later in today's meeting
15:12:06 <thomasem> I did not, I'm afraid. Can we carry that forward?
15:12:08 <sigmavirus> #action thomasem to create BP, with initial thoughts, regarding suggested production deployment documentation
15:12:14 <sigmavirus> thomasem: everything is carry-forwardable ;)
15:12:17 <sigmavirus> jimbaker: add it to the agenda?
15:12:19 <thomasem> Excellent
15:12:32 <sigmavirus> Note, this is why we review those items :)
15:12:35 <jimbaker> sigmavirus, +1 to agenda add, if that works for you
15:12:41 <sigmavirus> jimbaker: gopherit
15:12:52 <jimbaker> indeed, we can all edit :)
15:13:28 <sigmavirus> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-02-09-17.02.html
15:13:32 <sigmavirus> There were no action items added on Thursday
15:13:35 <sigmavirus> So, moving along
15:13:40 <sigmavirus> #topic Stand-Up
15:14:17 <sigmavirus> #info each team member briefly describes what they are working on this week, and describes blockers (if there are any)
15:14:33 <sigmavirus> #topic Stand-Up :: git-harry
15:15:20 <git-harry> currently the only task I have for the week is https://bugs.launchpad.net/craton/+bug/1662496
15:15:20 <openstack> Launchpad bug 1662496 in craton "Host response is missing parent_id property" [High,New] - Assigned to git-harry (git-harry)
15:15:36 <sigmavirus> #link https://bugs.launchpad.net/craton/+bug/1662496
15:15:39 <sigmavirus> git-harry: any blockers?
15:15:41 <git-harry> This was something sulo asked me to pick up while he's off.
15:15:47 <git-harry> Nope
15:15:50 <git-harry> Done
15:15:59 <jimbaker> git-harry, +1
15:16:02 <sigmavirus> #topic Stand-Up :: thomasem
15:16:18 <thomasem> Fixing up Project vars patch (almost done) to work with jimbaker's fix for variable delete
15:16:36 <thomasem> Then the CLI changes are awaiting jimbaker's patch for get/set vars for other resources
15:17:01 <thomasem> working on adding cloud resource, which will also have vars support and such
15:17:15 <thomasem> and continuing to mosy through the review queue in between things
15:17:18 <thomasem> done
15:17:42 <sigmavirus> #topic Stand-Up :: jimbaker
15:18:37 <jimbaker> unblock thomasem. this includes finalizing variable delete change, which thomasem likes, except for some overly strong tests. so we will negotiate on exactly what those are after this meeting
15:19:08 <jimbaker> along with finalizing the get/set/delete vars client/CLI work
15:19:33 <jimbaker> refactor alembic is next; then finally start getting rbac going to WIP
15:20:24 <jimbaker> and in general, hope to see us having a useful project state done in the next 2 weeks so we can work with antonym and team when they are back
15:20:31 <jimbaker> done
15:20:40 <sigmavirus> #topic Stand-Up :: sigmavirus
15:20:56 <sigmavirus> Still hacking on tests round-robin when I get time between other tasks.
15:21:08 <sigmavirus> I'm blocked by not being able to get some things off my plate =P
15:21:31 <sigmavirus> Looking into cloudnull's cruton rewrite to see if there's anything to learn from that
15:21:34 <sigmavirus> Done.
15:21:42 <cloudnull> :)
15:21:49 <cloudnull> o/
15:21:53 <sigmavirus> #topic This Week's Priorities
15:21:55 <Syed__> o/
15:22:33 <sigmavirus> Welcome Syed__
15:22:34 <sigmavirus> #undo
15:22:35 <openstack> Removing item from minutes: #topic This Week's Priorities
15:22:40 <sigmavirus> #topic Stand-Up :: Syed__
15:22:44 <jimbaker> cruton? love it
15:22:48 <Syed__> Haha
15:23:09 <cloudnull> https://github.com/cloudnull/cruton yw
15:23:11 <Syed__> well i have been working over some patches which are in reviews, need to add functional testing for Craton Projects and Users update calls
15:23:53 <Syed__> apart from that, will be taking over few more things this week from launchpad
15:24:12 <Syed__> thats all from my side :)
15:25:02 <sigmavirus> I don't see Jovon, so I'll move on to the next topic
15:25:07 <sigmavirus> #topic This Week's Priorities
15:25:26 <Syed__> thanks ian
15:25:33 <sigmavirus> Let's try to figure out what we as a group of developers want to prioritize to get done this week
15:25:43 <sigmavirus> You're welcome Syed__. I'm sorry I didn't see you sneak in :)
15:26:36 <jimbaker> so toan has challenged us a team to see if we are ready for what the rackspace tiger team needs in terms of tooling
15:26:47 <jimbaker> in one corner, craton
15:26:53 <jimbaker> in the other corner, cruton
15:27:05 <Syed__> cruton and craton are two diff things :/
15:27:34 <sigmavirus> Well that makes it the 10th rewrite of the thing Rackers call CORE then ;)
15:27:34 <Syed__> need to look into cruton, will do that after meeting
15:27:41 <git-harry> jimbaker: what does that mean in practise?
15:27:42 <jimbaker> why it wasn't named crouton, cloudnull would have to explain
15:28:08 <jimbaker> git-harry, in practice it means for craton
15:28:08 <cloudnull> there's a project called crouton already for chrome books
15:28:25 <jimbaker> cloudnull, yep
15:28:44 <jimbaker> back to git-harry
15:28:46 <cloudnull> so i used cruton which is crouton from urban dictionary
15:29:42 <jimbaker> for craton: does our stuff actually work as advertised? so full client support of what is in the schema, including parent-child support
15:29:42 <cloudnull> http://www.urbandictionary.com/define.php?term=cruton&defid=4820110
15:29:50 <cloudnull> anyway.
15:30:06 * cloudnull goes back doing something else
15:30:35 <jimbaker> the second definition for cruton works better
15:30:46 <cloudnull> http://www.urbandictionary.com/define.php?term=cruton&defid=1371652
15:31:27 <jimbaker> urban dictionary just keeps on going, doesn't it?
15:31:35 <cloudnull> it does
15:31:47 <thomasem> sec
15:31:47 <cloudnull> ok, done for real
15:31:49 <jimbaker> ok, i don't see this discussion as a high priority item
15:31:59 <jimbaker> even though it's infinitely amusing
15:32:03 <git-harry> jimbaker: when does that need to be done?
15:32:14 <jimbaker> git-harry, we have 2 weeks
15:33:35 <git-harry> of the bugs in launchpad, are all the required ones currently marked high priority or tagged in someway?
15:33:39 <jimbaker> and we are going to go against dusty's requirements, plus the modeling that cloudnull out together
15:33:54 <jimbaker> git-harry, that would be an awesome thing to do
15:34:05 <jimbaker> and i encourage everyone to put some time in doing so
15:34:30 <sigmavirus> jimbaker: into marking the required ones in some way?
15:34:41 <jimbaker> sigmavirus, yes
15:34:43 <sigmavirus> Because, I have no visibility into that besides what would end up in launchpad
15:34:59 <git-harry> okay, so would it be fair to say that as it stands we don't know the scope of the remaining work?
15:34:59 <jimbaker> sigmavirus, so i will put dusty's doc in launchpad
15:35:10 <thomasem> git-harry: I think so.
15:35:13 <jimbaker> git-harry, did you get dusty's doc?
15:35:28 <thomasem> We have a general idea, but not concrete steps.
15:35:50 <jimbaker> thomasem, that is understandable
15:35:50 <git-harry> Yes, but I don't find it particularly helpful in determining what's left.
15:36:07 <jimbaker> git-harry, and more of the same
15:36:07 <git-harry> assuming we're talking about the doc from last year.
15:36:38 <jimbaker> git-harry, a simplified version was distributed last week and discussed on tues iirc
15:36:48 <thomasem> Furthermore, the doc in question has some things outside of the scope of Craton identified.
15:37:08 <thomasem> And other things that we talked about being out-of-scope for this 2 week timeframe being referred to, but none of that is documented anyway, afaict.
15:37:14 <thomasem> s/anyway/anywhere/
15:37:18 <git-harry> jimbaker: that was probably done in one of the last minute meetings
15:37:19 <jimbaker> so our chance to do just that
15:37:24 <thomasem> So, I'd say the actual scope is pretty vlurry
15:37:26 <thomasem> blurry*
15:37:41 <jimbaker> thomasem, i wish i had the magic sharpener
15:37:46 <thomasem> Lol, yep
15:37:47 <jimbaker> but i don't
15:38:10 <sigmavirus> jimbaker: can you at least zoom and enhance for us? =P
15:38:56 <jimbaker> sigmavirus, let's go back to the demo we had two weeks ago. if we deliver that without sharp edges, i think we are good
15:39:15 <jimbaker> and project -> cloud -> region
15:39:16 <jimbaker> ...
15:39:20 <sigmavirus> Which demo? The one I wasn't invited to or the one I wasn't invited to?
15:39:27 <thomasem> Shared devices sounds out of scope
15:39:34 <sigmavirus> Were either of them recorded at least?
15:39:36 <jimbaker> thomasem, yes
15:39:57 <jimbaker> sigmavirus, the first was held in the vidyo meeting we have every tues
15:40:15 <jimbaker> tojuvone for example attended that meeting
15:40:43 <thomasem> I do suspect we'll have more trouble getting patches landed with sulo out, btw.
15:40:57 <sigmavirus> Right, I had a different meeting during that one and didn't make it :/
15:40:58 <jimbaker> thomasem, i may have to +2 my own stuff. it's ok
15:41:10 <sigmavirus> jimbaker: link me to priority stuff and I'll prioritize that over testing
15:41:17 * thomasem didn't hear that
15:41:51 <jimbaker> thomasem, yep. but i also didn't know about sulo's being out until this morning
15:41:53 <sigmavirus> thomasem: i'm glad. This is IRC, it shouldn't be talking to you =P
15:42:12 <thomasem> sigmavirus: now you know my secret
15:42:43 <thomasem> jimbaker: understood
15:42:46 <thomasem> same here
15:43:33 <thomasem> Anyway, not trying to be Debbie Downer. Wanting to be sure we keep our expectations grounded.
15:43:58 <jimbaker> thomasem, yes, i was thinking about the same thing just now
15:44:33 <jimbaker> so that's my emphasis - if we show what we demoed, and it works as expected, i think we are good
15:44:55 <jimbaker> plus the parent-child stuff
15:45:16 <thomasem> Alright, so, to enumerate:
15:45:18 <jimbaker> but that's just a matter of properly exposing what's already there
15:45:30 <thomasem> 1. parent-child stuff in working state
15:45:53 <thomasem> Which the remaining thing is what's on git-harry's plate?
15:45:57 <git-harry> ^ I've picked that up with https://bugs.launchpad.net/craton/+bug/1662496
15:45:57 <openstack> Launchpad bug 1662496 in craton "Host response is missing parent_id property" [High,New] - Assigned to git-harry (git-harry)
15:46:03 <git-harry> yep
15:46:05 <thomasem> sweet
15:46:15 <thomasem> 2. adding cloud resource and project variables
15:46:33 <thomasem> let's break those apart
15:46:37 <thomasem> 2. adding project variables
15:46:39 <thomasem> 3. adding cloud resource
15:46:41 <jimbaker> and ideally it's a bit more than making parent_id visible - it should be ergonomic as well
15:46:58 <thomasem> Both #2 and #3 require CLI support as well.
15:47:02 <jimbaker> and exposed to the python client/CLI
15:47:17 <thomasem> Okay, all of these assume support in API and CLI
15:47:21 <jimbaker> it's cleaned up. json works
15:47:23 <thomasem> and 4. polish
15:47:29 <jimbaker> especially #4
15:47:39 <git-harry> 5. spit
15:47:41 <thomasem> So, taking some time toa audit the calls weknow should work
15:47:47 <jimbaker> yes
15:47:48 <thomasem> to audit*
15:47:53 <thomasem> and filing bugs for what doesn't work
15:48:04 * thomasem crosses fingers
15:48:04 <Syed__> +!
15:48:10 <Syed__> +1 for filing bugs
15:48:19 <jimbaker> if we get that done, we are good
15:48:47 <jimbaker> polish and spit, simple enough
15:48:59 <thomasem> Feels do-able, though I fear Hofstadter's will bite us.
15:49:05 <thomasem> Let's see what happens!
15:49:20 <jimbaker> yep, that's what we have been experiencing for a month or so
15:49:26 <thomasem> jimbaker: when you say especially #4, are you suggesting we ought to prioritize polish over the others?
15:49:48 <jimbaker> thomasem, so #4 is prioritized over stuff like device sharing or rbac
15:50:00 <thomasem> Okay, but not the ones before it (1-3)?
15:50:10 <jimbaker> we have to the basic functionality :)
15:50:14 <jimbaker> have to have
15:50:23 <thomasem> So, then, would it be safe to say my enumeration above is reflective of the priorities we wanted to get out of this topic?
15:50:37 <thomasem> in the correct order
15:50:47 <git-harry> What about the pagination stuff, is that a priority for the next two weeks?
15:50:51 <jimbaker> thomasem, i agree with this enumeration
15:50:55 <thomasem> Excellent
15:51:05 <jimbaker> git-harry, no. it's super important work
15:51:20 <jimbaker> but it has NOT come up in these discussions
15:51:33 <jimbaker> everyone expects that we are the long term solution
15:51:42 <jimbaker> the question is: can we be the short term solution as well
15:51:44 <jimbaker> ?
15:52:04 <sigmavirus> jimbaker: we can't be everything to everyone
15:52:09 <thomasem> The goal being to get actual runtime with this thing and have real use-cases from organic use driving our continued development
15:52:17 <thomasem> is my understanding
15:52:18 <jimbaker> sigmavirus, i agree. we but we can be something for someone
15:52:36 <jimbaker> these are modest tasks
15:52:54 <jimbaker> and they will ensure we actually walk before we run, by putting us in a real customer usage
15:53:00 <jimbaker> every project should be so lucky
15:53:33 <sigmavirus> jimbaker: I'm not sure "real customer usage" is a thing we'll see from the tiger team
15:53:47 <sigmavirus> Most of the customers I know of are far too afraid to adopt new technologies
15:54:07 <jimbaker> but it will get us closer to being not so new
15:54:21 <jimbaker> again, nothing here is derailing our longterm plans
15:54:37 <sigmavirus> Right, I agree that none of that derails long term plans
15:54:44 <jimbaker> inserting a cloud in the resource hierarchy, that's a good thing
15:55:10 <jimbaker> getting our client/CLI completely usable - and tested! - awesome stuff
15:55:39 <jimbaker> i would also add docs to that spit & polish
15:56:41 <jimbaker> so the good thing is, we are almost there. i hope everyone can see that. that's why i mentioned the tues demo we did, because that showed we could do things people cared about
15:56:57 <jimbaker> even though it's a fraction of what we are trying to build :)
15:57:44 <jimbaker> ok, so this is no st crispin's day speech
15:58:19 <jimbaker> but hopefully that gives you all what we are trying to aim at
15:59:11 <jimbaker> so a few things left on our agenda
15:59:24 <jimbaker> :)
15:59:43 <jimbaker> but time is running short
15:59:46 <jimbaker> #endmeeting