15:00:41 <jimbaker> #startmeeting craton
15:00:42 <openstack> Meeting started Mon Jan 23 15:00:41 2017 UTC and is due to finish in 60 minutes.  The chair is jimbaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <openstack> The meeting name has been set to 'craton'
15:01:30 <sigmavirus> o/
15:01:46 <jimbaker> sigmavirus, o/
15:02:28 <jimbaker> Syed__, hi
15:02:44 <Syed__> hey jimbaker
15:02:45 <jimbaker> sulo, hi
15:03:09 <sulo> o/
15:03:32 <jimbaker> sigmavirus, do you plan to chair today's meeting again? or i can do this
15:04:03 <sigmavirus> jimbaker: well I'm not a meeting chair so that's a moot point ;)
15:04:06 <sigmavirus> I can chair it if you want
15:04:07 <jimbaker> at this point we have quorum
15:04:14 <sigmavirus> git-harry: ping
15:04:17 <jimbaker> sigmavirus, it's just a matter of some command. which i do not know
15:04:32 <sigmavirus> I think it's in the etherpad
15:04:47 <git-harry> hi
15:05:06 <sigmavirus> #link https://etherpad.openstack.org/p/craton-meetings
15:05:07 <jimbaker> sigmavirus, got it
15:05:18 <jimbaker> #chair sigmavirus sulo jimbaker
15:05:19 <openstack> Current chairs: jimbaker sigmavirus sulo
15:05:27 <sigmavirus> #topic Roll Call
15:05:44 <sigmavirus> #info looks like everyone's here ( Syed__ jimbaker sulo git-harry myself)
15:05:56 <sigmavirus> #topic Action Items from the Last Meeting
15:06:18 <sigmavirus> #link http://eavesdrop.openstack.org/meetings/craton/2017/craton.2017-01-19-17.03.html
15:06:24 <sigmavirus> #info No action items from the last meeting
15:06:44 <sigmavirus> #topic We Have No Topics On Our Agenda
15:07:03 <jimbaker> so standing agenda then
15:07:28 <sigmavirus> #action jimbaker to add standing agenda items to template for meetings
15:07:38 <jimbaker> sigmavirus, sounds good, and will do
15:07:46 <sulo> i just added: Do some reviews y'all.
15:08:11 <jimbaker> so our usual standing agenda is to do 1) a stand up for the week; 2) discuss reviews as part of that
15:08:28 <jimbaker> basic coordination stuff
15:08:34 <sigmavirus> #topic Stand-up
15:08:42 <sigmavirus> #info I'll go around and ask each person for their stand-up
15:08:47 <sigmavirus> #topic Stand-Up :: jimbaker
15:08:56 <jimbaker> thanks
15:09:30 <jimbaker> i continue to work on rbac. i'm going to post what i have as a spec as WIP, just so everyone can see my thought process here
15:10:17 <jimbaker> we also had a very good discussion last week on secrets, specifically on how we should be able to treat as just as a case of virtualized variables with some backend storage (like hashicorp vault). will follow up on that
15:10:19 * sigmavirus thinks we might need a signal that ends each person's stand-up
15:10:36 <jimbaker> sigmavirus, sounds good
15:10:43 <sigmavirus> to move on?
15:10:43 <jimbaker> and continuing
15:10:48 <jimbaker> on my stuff
15:11:29 <jimbaker> i'm going to be talking more with FAWS (fanatical AWS support at rackspace) this week to see how craton can be helpful
15:11:47 <jimbaker> end standup (good signal?)
15:11:55 <sigmavirus> sgtm
15:12:01 <sigmavirus> #topic Stand-Up :: sulo
15:12:39 <sulo> 1. some of the pending work from before my PTO is now on gerrit
15:12:52 <sulo> 2. ill be working on cli this week
15:13:09 <jimbaker> sulo, awesome about CLI
15:13:10 <sulo> thats all i got this week
15:13:44 <sigmavirus> #topic Stand-Up :: Syed__
15:13:44 <sulo> end standup
15:13:56 * sigmavirus assumed as much from "that's all I got this week" ;)
15:13:57 <Syed__> Cool,
15:14:04 <sulo> heh yeah
15:14:22 <Syed__> i have been working over schemas mismatch between craton and client, will be merging that this week
15:14:45 <Syed__> plus looking into RBAC enforcer authorize and using oslo.policy rules
15:15:08 <Syed__> thats all i got this week , will try to put in both of these this week out there
15:15:53 <sigmavirus> #topic Stand-Up :: git-harry
15:17:44 <sulo> git-harry: you still around ?
15:17:45 <git-harry> - the obligatory reviews
15:17:46 <git-harry> - finishing up schema validation/testing patches related to https://bugs.launchpad.net/craton/+bug/1644270
15:17:46 <git-harry> - looking to write a spec for variables/labels regarding current design e.g. DELETEs with data in request, PUTs with partial resource updates etc. Currently looking at using API-WG design for metadata/tags, a second spec for etags and then potentially PATCH depending on user demand
15:17:46 <openstack> Launchpad bug 1644270 in craton "Add test to validate routes/schema" [Medium,In progress] - Assigned to git-harry (git-harry)
15:18:16 <git-harry> DONE
15:18:26 <sigmavirus> #topic Stand-Up :: sigmavirus
15:18:49 <sigmavirus> #link https://review.openstack.org/#/c/421523/
15:18:55 <sigmavirus> #link https://review.openstack.org/#/c/424179/1
15:19:06 <sigmavirus> Working on pagination work, still more patches to come
15:19:22 <sigmavirus> I've split what was 1 WIP into two patches so they're easier to review, but one is failing tests for some reason
15:19:23 <jimbaker> sigmavirus, thanks for that important work
15:19:39 <jimbaker> and also splitting for review purposes :)
15:19:42 <sigmavirus> Still need to create bugs, link them to the blueprint, and then mark each one as closing a bug
15:20:01 <sigmavirus> Hoping to also get around to reviewing Sulo's spec(s) and git-harry's work this week
15:20:14 <sigmavirus> #topic Priority Reviews
15:20:32 <sigmavirus> We should prioritize something like 5 reviews currently open for review
15:20:44 <sigmavirus> The Glance team has been doing this with some success
15:20:53 <jimbaker> so here's the chance for people with pending reviews to say "i need this reviewed ASAP" :)
15:21:23 <Syed__> i think this qualifies as per priority review https://review.openstack.org/410260
15:21:51 <jimbaker> (at least for me, this sort of signal is very helpful to get this prioritized. i would like to read every email, etc. but it's not going to happen)
15:22:03 <Syed__> been playing around with sulo functional testing but getting some error's, need to dig into that today more
15:23:06 <sulo> Syed__: what kind of errors ?
15:23:07 <jimbaker> sulo, any additions to that?
15:23:24 <Syed__> sulo:  will post that on craton after meeting
15:23:30 <jimbaker> Syed__, thanks
15:23:40 <jimbaker> and maybe add to the review itself
15:23:52 <sulo> yeah just add it to the review
15:24:02 <Syed__> cool, will do
15:24:26 <jimbaker> anything else?
15:24:42 <jimbaker> surely there are a few more that we need to prioritize...
15:24:42 <sigmavirus> #link https://review.openstack.org/410260
15:26:43 <git-harry> There are only 10 to review, of which one is from proposal bot, one already has a +2 and at least one other is a fairly trivial fix to a bug.
15:27:34 <jimbaker> git-harry, right, we can start picking them off
15:28:09 <jimbaker> sulo, you have a bunch. but https://review.openstack.org/410260 is the key one, right?
15:28:57 <sulo> so thats the tests one .. i have a few more smaller patches too
15:29:45 <jimbaker> sulo, ack
15:30:09 <jimbaker> sigmavirus, sounds like we are good with priority reviews
15:30:19 <jimbaker> and therefore close to end of the standing agenda
15:30:25 <sigmavirus> #action All should review these reviews
15:30:30 <jimbaker> :)
15:30:31 <sulo> so
15:30:40 <sigmavirus> So that sounds like we're done 30 min early ;)
15:30:44 <sulo> there are only a few reviews ... we just need to do reviews
15:30:47 <jimbaker> use that time wisely
15:30:51 <jimbaker> such as reviewing
15:30:54 <sigmavirus> ^++
15:30:54 <sulo> even one a day from each will take care of it
15:31:09 <sigmavirus> Also, it turns out craton wasn't receiving global requirements updates
15:31:19 <sigmavirus> that should be fixed, but I haven't seen an update since that 'fix' was merged
15:31:21 <jimbaker> sigmavirus, ahhh, well that's an important detail
15:31:24 <sigmavirus> I might poke -infra again
15:31:27 <sulo> yeah
15:31:37 <sulo> i need to add one more that not in global
15:31:46 <sulo> whats the req for getting it into global
15:31:55 * sulo will look at sigmavirus's last patch
15:32:16 <jimbaker> maybe the standing agenda includes "random, but possibly important things we should be all aware of"
15:32:29 <jimbaker> eg global req
15:33:15 <jimbaker> i will add to this two items. 1. we have a boston openstack rfp to consider doing. tojuvone reached out to me, and we are hashing something out
15:33:43 <jimbaker> 2. we are trying to get a demo together of current inventory, using CLI, by end of this month
15:33:55 <jimbaker> ok, that's it for random yet important stuff
15:34:32 <jimbaker> so we are all set to end this meeting?
15:35:18 <jimbaker> cool, looks like we are good for today. anything else, please discuss as usual in #craton
15:35:25 <jimbaker> #endmeeting