16:01:10 <strigazi> #startmeeting containers
16:01:10 <openstack> Meeting started Tue Oct  3 16:01:10 2017 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:14 <openstack> The meeting name has been set to 'containers'
16:01:14 <strigazi> #topic Roll Call
16:01:16 <adrian_otto> Adrian Otto
16:01:23 <strigazi> Spyros Trigazis
16:01:46 <ykarel> Yatin Karel
16:02:39 <strigazi> Thanks for joining the meeting ykarel adrian_otto
16:03:21 <strigazi> our agenda:
16:03:22 <strigazi> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-10-03_1600_UTC
16:03:28 <strigazi> #topic Announcements
16:03:36 <strigazi> change on magnum jobs for zuulv3 https://review.openstack.org/#/c/508676/
16:03:41 <strigazi> thanks ykarel
16:04:00 <ykarel> adrian_otto, can you check ^^ and approve
16:04:25 <adrian_otto> sure
16:04:47 <strigazi> #topic Review Action Items
16:04:59 <strigazi> strigazi to draft a bp or bug for changes in cluster-update command [move to next week]
16:05:05 <strigazi> #action strigazi to draft a bp or bug for changes in cluster-update command
16:05:45 <strigazi> #topic Blueprints/Bugs/Reviews/Ideas
16:06:16 <strigazi> Add support of k8s cluster over opensuse distro https://blueprints.launchpad.net/magnum/+spec/k8s-opensuse-support [good progress]
16:06:26 <adrian_otto> 508676 is approved for merge
16:06:32 <ykarel> adrian_otto, Thanks
16:06:35 <adrian_otto> np
16:06:42 <strigazi> slunkad: is not here, but see did some good progress on this item
16:06:49 <strigazi> thanks adrian_otto
16:07:03 <strigazi> adrian_otto i have one more for you wait a few minutes
16:07:21 <strigazi> Use the heat agent and Software Deployments in heat templates https://blueprints.launchpad.net/magnum/+spec/heat-agent [review needed]
16:07:31 <strigazi> ykarel: can you have a look in this ^^ ?
16:07:52 <strigazi> Cluster upgrades https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades [review needed]
16:07:58 <ykarel> strigazi, sure will look at it
16:08:19 <strigazi> also this one ykarel adrian_otto : Cluster upgrades https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades [review needed]
16:08:40 <ykarel> strigazi, Ok will look
16:08:54 <strigazi> And this spec, I think it is pretty much in good shape:
16:09:00 <strigazi> Add Federation API specification https://review.openstack.org/#/c/489609/
16:09:07 <strigazi> adrian_otto: ykarel ^^
16:09:41 <strigazi> Next topic, is some bugs that we need to fix for pike too:
16:09:46 <ykarel> strigazi, yes i missed the latest patchset will look on it
16:09:56 <strigazi> kubernetes-fedora: Fix prometheus config https://bugs.launchpad.net/magnum/+bug/1719187 [Good progress]
16:09:57 <openstack> Launchpad bug 1719187 in Magnum "kubernetes-fedora: Fix prometheus config" [Undecided,In progress] - Assigned to Spyros Trigazis (strigazi)
16:10:08 <strigazi> adrian_otto: this is ready to be approved ^^
16:10:20 <adrian_otto> ok
16:10:25 <strigazi> this is the patch: https://review.openstack.org/507445
16:11:22 <strigazi> I'll just reference the following ones for the log and make them action items
16:11:27 <adrian_otto> 507445 is approved for merge
16:11:36 <strigazi> adrian_otto: thanks
16:11:53 <adrian_otto> np
16:12:09 <strigazi> #action strigazi to find an assignee for sync cluster task not running with send cluster metrics enabled https://bugs.launchpad.net/magnum/+bug/1719267 [Needs assignee]
16:12:10 <openstack> Launchpad bug 1719267 in Magnum "sync cluster task not running with send cluster metrics enabled" [Undecided,New]
16:12:23 <strigazi> #action strigazi to find an assignee for : Limit the name of the Instance names https://bugs.launchpad.net/magnum/+bug/1718947 [Need assignee]
16:12:24 <openstack> Launchpad bug 1718947 in Magnum "Limit the name of the Instance names" [Critical,Confirmed] - Assigned to Sayali Lunkad (sayalilunkad)
16:12:49 <strigazi> oh this is assigned ^^
16:12:53 <strigazi> #undo
16:12:54 <openstack> Removing item from minutes: #action strigazi to find an assignee for : Limit the name of the Instance names https://bugs.launchpad.net/magnum/+bug/1718947 [Need assignee]
16:13:14 <strigazi> #action strigazi to find an assignee for : OSC client can not delete cluster-template with . (period) in name https://bugs.launchpad.net/magnum/+bug/1718930 [Needs assignee]
16:13:16 <openstack> Launchpad bug 1718930 in Magnum "OSC client can not delete cluster with . (period) in name" [Undecided,New]
16:13:32 <strigazi> Finally, I have done some progress to kubernetes-dashboard is accesible without authorixation or authentication with NodePort https://bugs.launchpad.net/magnum/+bug/1719548 [slow progress]
16:13:33 <openstack> Launchpad bug 1719548 in Magnum "kubernetes-dashboard is accesible without authorixation or authentication with NodePort" [Undecided,New]
16:14:02 <strigazi> Final exciting item IMO is: Kubernetes packages and container images available for 1.8.0 https://hub.docker.com/r/openstackmagnum/kubernetes-kubelet/tags/
16:14:39 <strigazi> it works (with minor issues) with fedora-atomic and with tls enabled
16:15:13 <strigazi> magnum pike can be used with kubernetes 1.8.0, we used in our cloud 5 hours after the official release
16:15:25 <strigazi> #topic Open Discussion
16:15:37 <adrian_otto> sweet!
16:15:49 <ykarel> Good
16:15:51 <adrian_otto> what minor issues did you see, strigazi ?
16:16:49 <strigazi> adrian_otto it doesn't work without tls because kubelet uses kubeconfig to connect to the apiserver
16:17:25 <strigazi> and the kubnelet in master doesn't start for the same reason. but kubelet in master is *not* used anymore
16:17:44 <strigazi> the problem is that the kubelet param --apiservers is removed
16:17:51 <strigazi> that's it
16:18:15 <strigazi> these issues are trivial to fix
16:18:49 <strigazi> Any other business?
16:18:56 <ykarel> adrian_otto, strigazi https://launchpad.net/~magnum-drivers/+members#active needs update
16:20:53 <strigazi> #action strigazi to update https://launchpad.net/~magnum-drivers/+members#active with the current magnum core reviewer list
16:21:01 <strigazi> ykarel: I added you
16:21:17 <ykarel> strigazi, Thanks
16:21:26 <ykarel> strigazi, This one would need your +1: https://review.openstack.org/#/c/508804/, and one more i will send to openstack-zuul-jobs repo for legacy jobs cleanup
16:22:08 <strigazi> ykarel add Depends-On ?
16:22:28 <strigazi> for cross-project dependency
16:22:45 <ykarel> is it required
16:23:09 <ykarel> Depends on required only when we need changes in the test, isn't it?
16:23:50 <strigazi> ykarel: if 508676 is not merged, 508804  won't merge either
16:24:05 <ykarel> yes
16:24:17 <strigazi> it is for queueing also, not only tests
16:24:34 <ykarel> hmm, ok will add that
16:25:09 <strigazi> ykarel: thanks
16:27:11 <strigazi> Any other business?
16:28:20 <strigazi> Said once
16:28:32 <strigazi> Said twice
16:28:48 <strigazi> Thanks for joinning adrian_otto and ykarel
16:28:53 <strigazi> #endmeeting