16:00:00 <strigazi> #startmeeting containers
16:00:01 <openstack> Meeting started Tue Sep 12 16:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'containers'
16:00:06 <strigazi> #topic Roll Call
16:00:20 <slunkad_laptop> Sayali Lunkad
16:00:22 <strigazi> Spyros Trigazis
16:00:26 <jgr> Johannes Grassler
16:00:47 <DimGR> Dimitris Theoharis
16:01:50 <adrian_otto> Adrian Otto
16:02:13 <strigazi> Thanks for joining the meeting slunkad_laptop jgr DimGR adrian_otto
16:02:31 <strigazi> Today's agenda:
16:02:34 <strigazi> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-09-12_1600_UTC
16:02:45 <strigazi> #topic Announcements
16:03:15 <strigazi> Queens plan is complete:
16:03:35 <strigazi> #link https://etherpad.openstack.org/p/magnum-queens-planning
16:03:45 <strigazi> #link https://blueprints.launchpad.net/magnum/queens
16:04:51 <strigazi> This are the blueprint that we will aim for queens, contributors can still pick blueprints from the short-list, which are doable for Queens and nice to have
16:05:32 <strigazi> These are the blueprints that we will aim for queens. Contributors can still pick blueprints from the short-list, which are doable for Queens and nice to have.
16:05:50 <strigazi> too many typos :)
16:06:20 <strigazi> #topic Review Action Items
16:06:36 <strigazi> strigazi to target BPs for specific queens milestones DONE :)
16:06:52 <strigazi> #topic Essential Blueprints Review
16:07:51 <strigazi> This is mostly about ideas, I'll change it in the next meeting.
16:08:08 <strigazi> Before the first item, just a TODO for Adrian Otto
16:08:22 <adrian_otto> ok
16:08:37 <strigazi> adrian_otto: Can you make administrator in Launchpad?
16:08:52 <adrian_otto> yes
16:09:02 <strigazi> Thanks
16:09:33 <adrian_otto> #action adrian_otto to coordinate with strigazi to be sure he has access to all resources needed for PTL duties
16:10:32 <strigazi> I have only one item which is related with reviewing and follow development during the cycle, after that we can discuss other ideas/blueprint proposals.
16:10:47 <strigazi> adrian_otto: thanks :)
16:11:10 <strigazi> Create a white board to add topics for each week https://etherpad.openstack.org/p/magnum-whiteboard
16:12:04 <strigazi> I created this etherpad that we can use for whiteboard, since the wiki and launchpad isn't appealing to everyone we can try the etherpad.
16:13:13 <strigazi> Magnum contributors and team member can add notes each week there and we can discuss those notes during the meetings. Of course gerrit and the email are are the primary tools.
16:13:19 <strigazi> Thoughts?
16:13:52 <adrian_otto> sounds like it's worth a try
16:14:27 <strigazi> I'll add it in our wiki and I'll send an email to the ML.
16:14:36 <slunkad_laptop> I think wiki is a more visible option
16:14:46 <slunkad_laptop> but we can add a link to the etherpad on the wiki
16:15:01 <strigazi> We keep it for a month and then we see.
16:15:39 <strigazi> yup, the etherpad won't replace anything is just to try attract more people if they find it easier.
16:15:50 <slunkad_laptop> ok
16:16:48 <slunkad_laptop> sounds good
16:16:57 <strigazi> So, the plan for queens is out I think, starting next week we can start reporting on blueprints.
16:17:24 <strigazi> I'm working on upgrades and the only small prereq I have now is:
16:17:41 <strigazi> #link https://blueprints.launchpad.net/magnum/+spec/heat-agent
16:18:05 <strigazi> In the next meeting, you can expect udates on this item.
16:18:25 <strigazi> The work is already in progress and you can see it here:
16:18:42 <strigazi> #link https://review.openstack.org/#/c/468816/
16:19:07 <strigazi> I'll link it properly, i created the bp today.
16:19:31 <strigazi> slunkad_laptop: Will you have an update on the suse driver next week?
16:19:52 <slunkad_laptop> yes looks like we have most of the patches we need in pike
16:20:13 <jgr> We went through the patches today: https://gist.github.com/jgrassler/ed05ebab2133069e80bf32526a482406
16:20:21 <jgr> Looks like we're mostly good there :-)
16:20:34 <slunkad_laptop> strigazi: jgr is also going to help with the suse driver
16:20:39 <jgr> This is actually the only place where we still _have_ local patches: https://build.opensuse.org/package/show/Cloud:OpenStack:Newton/openstack-magnum
16:20:52 <strigazi> ok, nice to see you again jgr
16:21:19 <jgr> And all of them (or their functional equivalents)  are present in Pike at the very least
16:21:36 <jgr> Pleasure's all mine :-)
16:22:27 <strigazi> So we there are only three patches to push?
16:23:03 <jgr> So none of the patches from https://build.opensuse.org/package/show/Cloud:OpenStack:Newton/openstack-magnum need pushing, actually
16:23:30 <jgr> The first two are not upstream but upstream has functional equivalents
16:23:31 <strigazi> looking
16:23:41 <jgr> And the other three are upstream already
16:23:47 <jgr> (only not in Newton)
16:23:56 <jgr> But since we're at Pike right now...
16:24:02 <slunkad_laptop> strigazi: yeah those are the ones merges in ocata i think
16:24:08 <slunkad_laptop> merged*
16:24:47 <strigazi> ok, Do we miss anything then or we can just move in magnum/drivers ?
16:25:05 <slunkad_laptop> strigazi: I will be testing it once just to be sure
16:25:16 <slunkad_laptop> with opensuse not sles
16:25:23 <slunkad_laptop> and then we can move it
16:25:25 <strigazi> You can add a functional test too
16:25:41 <slunkad_laptop> I can create a patch for that soon after testing
16:25:49 <strigazi> it won't run in the CI but reviewrs can run it locally
16:26:19 <slunkad_laptop> yup, about the ci also jgr and me are trying to get it asap so will keep you updated on that
16:26:59 <strigazi> cool, let me add the action to put in next week agenda.
16:28:17 <strigazi> #action strigazi to update the meeting agenda with the heat-agent and k8s-opensuse-support BPs
16:28:26 <strigazi> and
16:28:54 <strigazi> #action strigazi to update the wiki with the whiteboard etherpad + ML
16:30:06 <strigazi> Before Open discussion, do you plan to add the heat-agent runnning in a container(or not) for the suse driver?
16:30:52 <strigazi> the container I have created, could be ported in opensuse
16:30:59 <slunkad_laptop> strigazi: If we want to do that for all the drivers in magnum we would be onboard for it
16:31:50 <strigazi> it is not mandatory but takes away a lot of limitations.
16:32:11 <strigazi> I'll push it in the review tomorrow.
16:32:37 <slunkad_laptop> strigazi: I have not looked closely at the heat-agent but we would be happy to if it makes it better
16:32:42 <slunkad_laptop> strigazi: ok great
16:32:46 <strigazi> for fedora we run it with the atomic utility but it can be executed with just runc
16:33:59 <strigazi> is there an alternatice container storage option than docker for opensuse or sle?
16:34:24 <strigazi> That would be very useful too.
16:34:57 <slunkad_laptop> strigazi: not that I am aware of but will check with out containers team
16:35:26 <strigazi> fyi, this is the container agent so far, I'll push it in-tree of course. https://github.com/strigazi/heat-container-agent/tree/system-container
16:36:07 <strigazi> And before Open Discussion
16:36:29 <strigazi> #action strigazi to prepare magnum 5.0.2
16:36:35 <strigazi> #topic Open Discussion
16:37:15 <strigazi> Any other business?
16:38:48 <strigazi> We can and the meeting then.
16:39:01 <strigazi> Thanks for joinning!
16:39:05 <strigazi> #endmeeting