16:01:28 <adrian_otto> #startmeeting containers
16:01:33 <openstack> Meeting started Tue Mar  7 16:01:28 2017 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:37 <openstack> The meeting name has been set to 'containers'
16:01:37 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2017-03-07_1600_UTC Our Agenda
16:01:41 <adrian_otto> #topic Roll Call
16:01:45 <adrian_otto> Adrian Otto
16:01:46 <Drago> o/
16:01:48 <strigazi> Spyros Trigazis
16:01:51 <hieulq_> o/
16:01:54 <jvgrant_> Jaycen Grant
16:02:00 <coreyob> Corey O'Brien
16:02:00 <yatinkarel> o/
16:02:03 <vijendar> o/
16:02:27 <adrian_otto> hello Drago strigazi hieulq_ jvgrant_ coreyob yatinkarel and vijendar
16:03:05 <adrian_otto> #topic Announcements
16:03:33 <adrian_otto> we do not have prepared announcements for today. Any announcements from team members?
16:03:59 <strigazi> gate-experimental-functional-dsvm-magnum-k8s-multinode-ubuntu-xenial I'm waiting for this :)
16:04:08 <strigazi> multinode gate
16:04:19 <adrian_otto> when is that expected, strigazi ?
16:04:34 <strigazi> It's merged and a job is running as we speak
16:04:48 <adrian_otto> how exciting!!
16:04:49 <strigazi> I hope it will improve our ci
16:04:58 <jvgrant_> nice!
16:05:03 <adrian_otto> indeed.
16:05:08 <yatinkarel> strigazi, So with multinode cluster loadbalancer
16:05:19 <adrian_otto> it's election day (again) in the US
16:05:37 <adrian_otto> at least it is in California, for local elections
16:05:52 <adrian_otto> ok, let's move on
16:05:55 <strigazi> we might be able to test lbaas, but let's wait
16:06:02 <yatinkarel> strigazi, Ok
16:06:19 <adrian_otto> #topic Review Action Items
16:06:19 <adrian_otto> (none)
16:06:31 <adrian_otto> #topic Blueprints/Bugs/Reviews/Ideas
16:06:35 <adrian_otto> Essential Blueprints
16:06:41 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/flatten-attributes Flatten Attributes [strigazi]
16:07:27 <strigazi> As I was moving forward with this I realized that we move all the fields from CT to cluster. The problem is we don't want all there fields
16:07:37 <strigazi> eg apiport
16:07:59 <strigazi> the Driver resource will have a blob
16:08:24 <strigazi> and cluster will have a bunch of attrs that not all drivers need
16:08:28 <adrian_otto> right
16:08:42 <strigazi> Should we procceed this way?
16:08:57 <strigazi> thoughts?
16:09:04 <adrian_otto> we should first flatten what we have into Cluster
16:09:28 <jvgrant_> adrian_otto: +1, i think we should do this in steps.
16:09:30 <adrian_otto> then reduce that list as a secondary effort with the driver config
16:09:37 <strigazi> ok
16:09:41 <Drago> The alternative would be to implement driver config first
16:09:42 <adrian_otto> try not to conflate too many things together
16:10:02 <strigazi> one more thing regarding small patches
16:10:15 <adrian_otto> strigazi: do you have a sense which ordering would be more efficient in terms of work?
16:11:07 <adrian_otto> my gut sense was that flatten attributes first would advance us sooner toward the vision
16:11:10 <strigazi> I was thinking to break the patch in pieces and instead of adding new db migrations iterating on the latest one to reach the desired schema
16:11:45 <adrian_otto> that sounds okay to me
16:11:54 <strigazi> others?
16:12:03 <Drago> Which migrations?
16:13:13 <strigazi> Eg I could drop the _id suffix in a later patch and first move the attributes with the current names to cluster
16:13:17 <strigazi> then
16:13:35 <strigazi> in the same migration reduce the number of attributes to a dict
16:14:09 <adrian_otto> strigazi: can you explain why you want the migration steps to be compressed in that way?
16:14:10 <strigazi> basically ClusterAttributes is our dict
16:14:33 <Drago> Are you saying blobify our attributes now?
16:14:56 <strigazi> As a second step
16:15:47 <strigazi> adrian_otto to avoid schema transformations since it's one feature. This was the initial plan.
16:16:05 <strigazi> I haven't investigated if transformations affect performance
16:16:09 <Drago> This might make migrating attributes to nodegroups harder
16:16:27 <strigazi> Drago the blob?
16:16:38 <strigazi> or migrations?
16:16:38 <Drago> yes
16:16:54 <strigazi> ok
16:17:14 <Drago> But maybe not much harder, just something to consider
16:17:45 <Drago> If attributes are in a blob in the db, you'll have to write something that moves them out into the nodegroup attribute blob
16:18:56 <strigazi> OK, seems that I'll lose time on that. I'll move with the proposed approach and move all attributes to cluster_attributes
16:19:32 <adrian_otto> any more remarks on the Flatten Attribute blueprint today?
16:19:41 <Drago> We should concentrate on the nodegroup migrations as early as we can
16:20:18 <juggler> o/
16:20:23 <adrian_otto> Drago: before Driver + config?
16:20:30 <adrian_otto> juggler: hi
16:20:51 <Drago> That's a good question, because they'll affect each other
16:20:55 <juggler> adrian_otto: hello
16:21:01 <Drago> I'll have to think on it more, some other time
16:21:10 <adrian_otto> Drago: right.
16:21:13 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/nodegroups Nodegroups [Drago]
16:21:28 <Drago> No update from me, I've just been chasing Kubernetes bugs...
16:21:42 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/cluster-upgrades Cluster Upgrades [strigazi]
16:21:53 <Drago> Heh, anything from you jvgrant_?
16:21:53 <adrian_otto> thanks Drago
16:22:34 <strigazi> https://review.openstack.org/#/c/439849/
16:22:42 <jvgrant_> not on nodegroups, created a WIP spec for driver resource though that will be needed by nodegroups and cluster upgrades
16:22:49 <jvgrant_> https://review.openstack.org/#/c/439849/
16:23:33 <Drago> Nice!
16:23:49 <adrian_otto> yes, indeed. Nice start.
16:24:13 <juggler> wtg jvgrant_
16:24:28 <jvgrant_> should have an update today or tomorrow, then is should be ready to remove WIP
16:25:05 <adrian_otto> good progress.
16:25:26 <adrian_otto> Any more questions, remarks, or discussion on the subject of Cluster Upgrades?
16:26:10 <adrian_otto> Other Work Items
16:26:45 <adrian_otto> (attendees may identify any work items needing team discussion now)
16:27:12 <Drago> PTG recap on the ML
16:27:20 <Drago> Heat did one
16:27:36 <adrian_otto> Yes, I can take an action item for that
16:28:07 <adrian_otto> #action adrian_otto to publish a PTG summary to our ML
16:28:18 <Drago> Thanks!
16:28:22 <adrian_otto> my pleasure
16:28:33 <strigazi> Would Would someone be interested in debugging the multinode job?
16:29:04 <yatinkarel> strigazi, i can look
16:29:07 <strigazi> We need some changes in how we run the tests.
16:29:09 <adrian_otto> did it fail?
16:29:24 <strigazi> The setup was complete
16:29:42 <strigazi> but we might need to change how we trigger the tests
16:29:56 <strigazi> or some other config
16:31:17 <adrian_otto> ok thanks yatinkarel for stepping up
16:31:27 <adrian_otto> #topic Open Discussion
16:31:36 <adrian_otto> I have two notes from previous meetings
16:31:50 <adrian_otto> one is about changing to cycle-with-milestones
16:32:14 <adrian_otto> nobody has raised any concerns about that change
16:32:32 <adrian_otto> so I'm planning to submit the patches to change it
16:32:46 <adrian_otto> see me if you have concerns
16:33:07 <adrian_otto> the second is about the architecture diagram we have on our wiki page
16:33:24 <adrian_otto> danil, one of our contributors worked on an updated version
16:33:46 <adrian_otto> but I don't think we have the source document that generated the image in order to pick up and finish that work
16:33:59 <adrian_otto> so we might need to start over
16:34:01 <adrian_otto> thgouths?
16:34:07 <adrian_otto> thoughts?
16:34:24 <Drago> I have a powerpoint slide of the diagram that I did for the OSA workshop
16:34:49 <Drago> If I remember correctly, it's pretty close to what danil had and you and randall gave feedback on it
16:34:52 <juggler> is there a link somewhere to the image?
16:35:09 <adrian_otto> juggler: http://imgur.com/a/af5BP
16:35:13 <adrian_otto> that's the proposed revision
16:35:27 <adrian_otto> we have another problem as well
16:35:37 <adrian_otto> the wiki will not allow for any new images to be uploaded at all
16:35:54 <Drago> Well that's dumb
16:35:55 <adrian_otto> so if we do put up a new image, it can't be in-line, it would need to be a link to a diagram
16:36:06 <strigazi> I have a not so attractive diagram in slide number 3 https://docs.google.com/presentation/d/18v8iJkamBGfSamuaVTm8BqGAQGXtf7fV7PxPbCxKcJs/edit#slide=id.g20c51cee01_0_409
16:36:07 <juggler> that's peculiar
16:36:09 <adrian_otto> yeah, that's a battle we need to take up with the wiki maintainers
16:36:29 <Drago> I think we should talk to them, because that's just silly
16:36:35 <adrian_otto> file uploads were disabled in response to abuse
16:37:04 <adrian_otto> but we should come up with some way to whitelist users who are allowed to.
16:37:54 <juggler> any idea what app the original used to make the diagram? Dia? other?
16:38:05 <adrian_otto> or temporarily enable the feature while we make changes, and disable it again when we are done
16:38:16 <juggler> original developer
16:38:18 <Drago> Here's mine http://imgur.com/AxQ8uPY
16:38:42 <Drago> We can update the colors or whatever. I can email you adrian_otto
16:39:01 <adrian_otto> Drago: I like that one
16:39:04 <adrian_otto> tx
16:39:10 <swatson_> yeah the sharp red vs blue is a little harsh to me
16:39:22 <juggler> a little :)
16:39:39 <juggler> red aside, it's a great diagram
16:39:43 <swatson_> ^
16:39:54 <Drago> Magnum too much for you??
16:40:03 <juggler> hehe
16:40:22 <juggler> red=stop
16:40:23 <juggler> lol
16:41:03 <Drago> adrian_otto: Sent!
16:41:11 <strigazi> I think we should add the native clients somehow
16:41:16 <adrian_otto> tx Drago
16:41:27 <adrian_otto> strigazi: good suggestion
16:41:32 <juggler> thx Drago
16:41:32 <Drago> adrian_otto: If you find updating it to be a pain, I can do it
16:41:41 <strigazi> + DC/OS + Cluster Driver
16:41:43 <adrian_otto> I know how to use powerpoint ;-)
16:41:48 <yatinkarel> Drago, little update to base OS supported currently, rkt/docker etc
16:42:06 <strigazi> + baremetal
16:42:12 <yatinkarel> ubuntu meos is missing
16:42:18 <juggler> what's powerpoint? :)
16:43:18 <adrian_otto> juggler: pay no attention to the man behind the curtain
16:43:19 <Drago> yatinkarel: Oh, sure. I mostly fixed the current arch image, changing it as little as possible. It should be updated with more generic things
16:44:05 <yatinkarel> Drago, +1 yes we can incorporate at least what magnum supports currently
16:44:40 <yatinkarel> and update as magnum advances
16:45:01 <adrian_otto> Drago: received.
16:45:31 <vijendar> I have a patch in review for last few weeks. could you guys take a look and let me know your comments https://review.openstack.org/#/c/427507/
16:45:57 <Drago> That poor patch...
16:46:21 <Drago> What tests are flaking?
16:48:13 <vijendar> Drago: without this patch admin operations wouldn't work
16:48:30 <vijendar> Drago: or at least would not work correctly
16:50:56 <Drago> Right
16:51:03 <adrian_otto> ok, should we end a little early today?
16:51:32 <juggler> Did Drago get an answer to his earlier q?
16:51:54 <Drago> I can't remember the question so it must not have been that important
16:52:05 <strigazi> Drago> What tests are flaking?
16:52:09 <Drago> Unless it was about flaking tests. I'll just ask vijendar directly
16:52:27 <Drago> adrian_otto: I think so
16:52:43 <adrian_otto> ok, pausing for just more more moment...
16:53:16 <adrian_otto> Thanks for attending everyone. Our next team meeting will be at 1600 UTC on 2017-03-14 in #openstack-meeting-alt
16:53:18 <strigazi> ο/
16:53:21 <adrian_otto> #endmeeting