16:00:14 <hongbin> #startmeeting containers
16:00:14 <openstack> Meeting started Tue Sep 20 16:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'containers'
16:00:20 <hongbin> #topic Roll Call
16:00:25 <muralia> murali allada
16:00:29 <strigazi> Spyros Trigazis
16:00:30 <tonanhngo> Ton Ngo
16:00:30 <Drago> o/
16:00:34 <jvgrant__> Jaycen Grant
16:00:43 <dane_leblanc_> o/
16:01:20 <hongbin> Thanks for joining the meeting muralia strigazi tonanhngo Drago jvgrant__ dane_leblanc_
16:01:26 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-09-20_1600_UTC Today's agenda
16:01:32 <hongbin> Anything needs to be added to the agenda?
16:01:36 <Hieu> Hieu LE o/
16:01:44 <eghobo> o/
16:01:56 <hongbin> Hieu: eghobo thanks for joining
16:01:58 <diga> o/
16:02:08 <hongbin> #topic Announcements
16:02:14 <hongbin> 1. Magnum is having an election for Ocata PTL
16:02:37 <hongbin> if you have a commit in mitaka or newton cycle, you should receive a link to vote
16:02:51 <hongbin> looking forward to your vote
16:02:59 <hongbin> 2. Magnum 3.1.0 release
16:03:06 <hongbin> #link http://lists.openstack.org/pipermail/openstack-announce/2016-September/001611.html
16:03:16 <hongbin> 3. Branch stable/newton was created and master branch was unfrozen.
16:03:44 <hongbin> the stable branch was created based on 3.1.0 tag
16:03:55 <adrian_otto> o/
16:03:58 <hongbin> however, you can still submit bug fixes to newton
16:04:37 <hongbin> in particular, you can backport fixes to stable/newton branch, as long as it is before sep 30, it can be included in newton release
16:05:12 <hongbin> any question about this?
16:05:42 <adrian_otto> nope
16:06:00 <hongbin> maybe i have a question for you, is any bug fixes you want to be included in newton?
16:06:19 <strigazi> yatin reported one
16:06:27 <strigazi> and I confirm it
16:06:35 <strigazi> fetching link
16:06:45 <tonanhngo> the k8s loadbalancer  for lbaas v1 would be good to have
16:06:57 <tonanhngo> although somewhat limited
16:06:59 <strigazi> #link https://bugs.launchpad.net/magnum/+bug/1625479
16:07:00 <openstack> Launchpad bug 1625479 in Magnum "Kubernetes fedora atomic is not working with cinder volume driver" [Undecided,In progress] - Assigned to yatin (yatinkarel)
16:07:04 <hongbin> strigazi: tonanhngo ack
16:07:16 <hongbin> strigazi: tonanhngo your deadline is sep 30
16:07:48 <hongbin> that is all for the annoucement
16:07:58 <hongbin> anyone else has an annoucement?
16:08:21 <hongbin> #topic Review Action Items
16:08:24 <hongbin> none
16:08:29 <hongbin> #topic Essential Blueprints Review
16:08:34 <hongbin> 1. Support baremetal container clusters (strigazi)
16:08:40 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:08:45 <hongbin> strigazi: ^^
16:09:18 <strigazi> Nothing since last week, trying to finalize mesos for ironic
16:09:48 <hongbin> strigazi: ack
16:10:18 <hongbin> then, move to the next bp
16:10:26 <hongbin> 2. Magnum User Guide for Cloud Operator (tango)
16:10:31 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:10:37 <hongbin> tonanhngo: ^^
16:10:40 <tonanhngo> The Horizon and native client section is under review.  This should round out the user guide.
16:11:05 <tonanhngo> Once this one merges, I would like to backport it to stable/newton so the guide would be more complete
16:11:41 <tonanhngo> There is still the HA section, but I have to think about what should go in there.
16:11:57 <tonanhngo> It's kind of a broad topic
16:12:18 <tonanhngo> That's all I have
16:12:25 <hongbin> tonanhngo: i think the developer doc are always generated from master , i am not sure if it worth to backport it
16:12:26 <adrian_otto> HA for the conductors and API servers
16:12:35 <tonanhngo> and also for the cluster
16:12:43 <adrian_otto> how load balancing works
16:12:51 <strigazi> these are two different topics
16:12:57 <adrian_otto> focus on the control plane for the user guide
16:13:18 <adrian_otto> the data plane (actual workloads) HA concerns are intractable for a guide like this.
16:13:27 <adrian_otto> but we could include some high level guidance
16:13:43 <tonanhngo> also best practice like for etcd for large cluster
16:13:45 <adrian_otto> as a lower priority than HA for the magnum service.
16:14:15 <tonanhngo> anyway, this might be a good topic for a design session.
16:14:30 <strigazi> for HA for the magnum service
16:14:40 <strigazi> you can have a look here #link http://docs.openstack.org/ha-guide/
16:15:01 <tonanhngo> thanks
16:15:27 <hongbin> thanks tonanhngo
16:15:38 <hongbin> 3. COE Bay Drivers (muralia)
16:15:44 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/bay-drivers
16:15:47 <hongbin> muralia: ^^
16:16:04 <muralia> I have fixed all the failing tests from last week. I'm currently rebasing with master
16:16:12 <muralia> i have not done so since the bay to cluster rename,
16:16:27 <muralia> lots of merge conflicts, but just renames basically.
16:16:44 <muralia> nothing else to report.
16:17:04 <hongbin> muralia: you have a link to the patch?
16:17:17 <muralia> not yet. i'll submit once rebase is done.
16:17:27 <hongbin> muralia: ack
16:17:38 <strigazi> how many thousant line?
16:17:42 <strigazi> how many thousant lines?
16:17:58 <muralia> oh, i did not check.
16:18:22 <strigazi> ok
16:18:47 <hongbin> thanks muralia
16:18:56 <hongbin> 4. Rename bay to cluster (jvgrant)
16:19:02 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/rename-bay-to-cluster
16:19:05 <hongbin> jvgrant__: ^^
16:19:24 <jvgrant__> nothing new to report, finished up last week.
16:19:35 <muralia> I think this can be removed from the agenda now right?
16:19:44 <hongbin> jvgrant__: ready to close the bp?
16:20:01 <jvgrant__> hongbin: yes, unless someone is aware of another area that needs updated
16:20:13 <hongbin> jvgrant__: ack
16:20:23 <hongbin> will remove this from the agenda
16:20:35 <hongbin> #topic Kuryr Integration Update (tango)
16:20:43 <hongbin> tonanhngo: ^^
16:20:45 <tonanhngo> I attended the Kuryr meeting yesterday
16:21:18 <tonanhngo> They seem happy to go with the 2 alternatives for implementing the multiple ports for containers:
16:21:34 <tonanhngo> VLAN-aware VM and IPVLAN
16:21:55 <tonanhngo> there is more pro/con discussion on IPVLAN
16:22:19 <tonanhngo> I would wait to see a POC, still a lot of unanswered questions
16:22:59 <tonanhngo> the credential issue on VM is still open, they are aware, but I think they will proceed first to get functionality
16:23:13 <tonanhngo> then solve the security issue
16:23:32 <tonanhngo> For us, we still need release 2 and the support for containers in VM
16:23:42 <tonanhngo> I think it will awhile before we can really proceed
16:23:58 <hongbin> i see
16:24:11 <tonanhngo> That's all I have
16:24:21 <hongbin> tonanhngo: thanks for tracking the status of kuryr
16:24:32 <hongbin> any question for tonanhngo ?
16:24:56 <hongbin> #topic Other blueprints/Bugs/Reviews/Ideas
16:24:59 <strigazi> will have a session in the summit for this?
16:25:09 <strigazi> tonanhngo ^^
16:25:21 <strigazi> with the kuryr team
16:25:22 <tonanhngo> Kuryr?
16:25:28 <tonanhngo> I think we should
16:25:37 <tonanhngo> it was helpful last time
16:25:42 <strigazi> ok
16:25:44 <hongbin> i can talk to their ptl about that
16:26:09 <strigazi> ok
16:26:27 <hongbin> #action hongbin talk to kuryr ptl to setup a join-session in design summit
16:26:38 <hongbin> back to the topic
16:26:41 <hongbin> 1. k8s external load balancer is not getting created
16:26:48 <hongbin> #link https://bugs.launchpad.net/magnum/+bug/1524025
16:26:49 <openstack> Launchpad bug 1524025 in Magnum "Kubernetes external loadbalancer is not getting created" [High,In progress]
16:27:30 <tonanhngo> I was trying to replicate Dane's environment:  OpenStack Mitaka with lastest Magnum
16:27:39 <tonanhngo> but ran into a number of issues
16:27:56 <tonanhngo> still trying to get it working.
16:28:08 <strigazi> you mean devstack?
16:28:23 <tonanhngo> Yes, Basically we need LBaas v1, which has been removed
16:29:00 <tonanhngo> I can build devstack with Mitaka, but getting lastest Magnum there is a bit tricky
16:29:28 <tonanhngo> with the removal of Heat from devstack, keystone v3, etc
16:29:54 <tonanhngo> once I get the environment, I can debug the K8s plugin.
16:30:10 <tonanhngo> The error message seems to indicate that the plugin has problem reading the config file
16:31:13 <tonanhngo> so, continuing debugging, working with Dane
16:31:38 <hongbin> thanks tonanhngo for working on this
16:32:04 <hongbin> #topic Open Discussion
16:32:13 <strigazi> Summit sessions
16:32:39 <strigazi> I have to propose one with the Heat team
16:33:00 <strigazi> two reasons for this
16:33:27 <strigazi> 1. we will need their opinion on the nodegroup refactoring
16:33:38 <adrian_otto> strigazi: regarding the nextgen design for diverse clusters (node pools) and orchestrating those?
16:33:47 <strigazi> yes
16:33:49 <strigazi> and 2,
16:34:25 <strigazi> from our benchmarks, magnum bottleneck is heat which scales linearly. Which is not ideal
16:34:40 <strigazi> They might have some insight to offer
16:34:52 <strigazi> to conclude on this
16:35:35 <strigazi> we need to present them how we use heat in detail and they might be able to help. Or at least verify that these are the capablities of heat
16:35:39 <strigazi> that's it
16:35:46 <tonanhngo> do they have Rally benchmarks?
16:36:09 <strigazi> there are plugins for heat but
16:36:15 <strigazi> I don't have any data
16:36:29 <strigazi> and the issue might be
16:36:37 <strigazi> how we (magnum) use heat
16:37:01 <tonanhngo> ok, we are their user
16:37:07 <strigazi> yes
16:37:24 <strigazi> What do you think? Does it make sense?
16:37:34 <hongbin> +1
16:37:40 <tonanhngo> we can request a joint session
16:37:56 <strigazi> That it what I was aiming for
16:38:03 <Drago> strigazi: I think they would like to hear the data you have. They are definitely interested in working on Heat's performance in Ocata
16:38:07 <tonanhngo> and present data
16:38:26 <strigazi> Drago: sure
16:38:50 <strigazi> We can run again the tests at CERN but after the summit
16:39:11 <strigazi> Don't know when exactly
16:40:25 <hongbin> i think we can start on creating a etherpad, and list all the requested session in design summit
16:40:53 <hongbin> then, based on the feedback, we can plan each session accordingly
16:41:24 <strigazi> Are you going to contact the heat team hongbin? We agree on  this session?
16:41:40 <hongbin> strigazi: yes, i can do that
16:42:27 <hongbin> #action hongbin contact the heat team about a join-session for discussing heat performance
16:43:30 <strigazi> #link https://etherpad.openstack.org/p/magnum-ocata-summit-topics
16:43:45 <hongbin> strigazi: thx
16:44:22 <hongbin> any other topic to discuss?
16:44:55 <jvgrant__> the NodeGroup spec has been update some.
16:44:57 <jvgrant__> https://review.openstack.org/#/c/352734/
16:45:02 <jvgrant__> feedback appreciated
16:45:24 <jvgrant__> most of the new proposed operations and some examples are now included
16:45:25 <strigazi> jvgrant__: ack
16:45:45 <strigazi> oh on the spec subject
16:45:49 <tonanhngo> we can probably remove the WIP to get more attention
16:46:23 <strigazi> Most projects have <project>-specs repo and they publish the specs
16:46:35 <jvgrant__> still has a ways to go, but i think some more discussion around it would help
16:46:44 <strigazi> tonanhngo: I think the WIP should remain until the summit
16:49:38 <hongbin> ok, it looks nobody else has a topic
16:49:45 <Drago> I would like feedback on https://review.openstack.org/#/c/368981/. Specifically, what should be included in the script for performing the actual restart of services (currently only `systemctl restart xxx`). That is all.
16:49:46 <hongbin> let's end the meeting a bit earlier
16:49:55 <adrian_otto> I second the motion
16:50:13 <hongbin> Drago: ack
16:50:17 <hongbin> #endmeeting