16:00:30 <hongbin> #startmeeting containers
16:00:31 <openstack> Meeting started Tue Jun 28 16:00:30 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:35 <openstack> The meeting name has been set to 'containers'
16:00:37 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-06-28_1600_UTC Today's agenda
16:00:42 <hongbin> #topic Roll Call
16:00:44 <strigazi> Spyros Trigazis
16:00:46 <muralia_> murali allada
16:00:51 <mkrai_> Madhuri Kumari
16:01:00 <tonanhngo> Ton Ngo
16:01:02 <dane_leblanc> o/
16:01:03 <adrian_otto> Adrian Otto
16:01:23 <hongbin> tonanhngo: you changed your IRC nick?
16:02:06 <hongbin> Thanks for joining the meeting strigazi muralia_ mkrai_ tonanhngo dane_leblanc adrian_otto
16:02:11 <tonanhngo> The nickserver made me, I will see if I can get back to tango :)
16:02:17 <hongbin> #topic Announcements
16:02:28 <hongbin> I have no announcement
16:02:37 <hongbin> Any announcement from our team member?
16:03:06 <hongbin> #topic Review Action Items
16:03:12 <hongbin> 1. muralia confirm the date and location for the Magnum midcycle (DONE)
16:03:18 <hongbin> Date: Aug 4 - 5
16:03:23 <hongbin> Location: 9001 North I H 35 #150, Austin
16:03:29 <hongbin> #link https://www.eventbrite.com/e/magnum-midcycle-tickets-26245489967 Ticket
16:03:56 <hongbin> So far, I sold 11 tickets
16:04:14 <tonanhngo> Good sale!
16:04:17 <muralia_> those who plan to come, please RSVP so I can get a headcount for organizing the event.
16:04:35 <mkrai_> Any way to attend for remote attendees?
16:04:54 <muralia_> yes, we'll try to use google hangouts like we did last time
16:05:32 <mkrai_> Thanks muralia_
16:05:37 <strigazi> muralia_: We have to do anything else than buying a ticket from eventbrite?
16:05:52 <muralia_> nope, just that. hongbin will give me an update
16:05:59 <strigazi> ok
16:06:36 <hongbin> OK. Advance topic
16:06:38 <hongbin> #topic Essential Blueprints Review
16:06:43 <tcammann> o/
16:06:45 <hongbin> 1. Support baremetal container clusters (strigazi)
16:06:51 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:07:15 <hongbin> tcammann: Have you bought the ticket for midcycle? https://www.eventbrite.com/e/magnum-midcycle-tickets-26245489967
16:07:21 <swatson> o/ I'm late!
16:07:41 <strigazi> I have updated the bp's whiteboard. Currently i'm working on setting up a gate job for a k8s ironic bay
16:08:21 <strigazi> Someone could start writing swarm-fedora-ironic templates
16:08:43 <strigazi> similar to k8s-fedora-ironic
16:09:25 <strigazi> I don't have anything else for this bp
16:09:42 <hongbin> strigazi: The k8s-fedora-ironic is working?
16:09:46 <mkrai_> I would like to write the template for swarm
16:09:56 <strigazi> on devstack yes
16:10:03 <strigazi> thanks mkrai_
16:10:22 <tonanhngo> is it possible to test on real baremetal yet?
16:10:26 <strigazi> hongbin, it's better to have a gate job to verify this
16:10:53 <hongbin> strigazi: The gate job is fine, but I guess poeple are looking for verifying it manually as well
16:10:55 <strigazi> I think it is, but you must have a real openstack deployment with ironic
16:11:29 <hongbin> strigazi: ack
16:11:43 <tonanhngo> Is there instruction on the ironic wiki?
16:11:49 <tonanhngo> (for real bare metal)
16:11:51 <strigazi> hongbin, having a job will help us verify that future patches  won't break them and will force us updating them
16:12:14 <strigazi> tonanhngo, haven't check. I'll verify it
16:12:24 <hongbin> strigazi: I agree with that. My point is folks are earger to verify it manually :)
16:12:45 <tonanhngo> ok,  I would be interested to try it on baremetal
16:13:02 <strigazi> tonanhngo ok
16:13:27 <strigazi> tonanhngo, let me what happen
16:13:30 <strigazi> the thing is
16:13:45 <strigazi> that you need at least two baremetal machines for that
16:14:04 <tonanhngo> right, because of our bay
16:14:15 <strigazi> I'll try to find as well
16:14:45 <strigazi> it's exciting to break bare metal and not only vms :)
16:15:34 <hongbin> OK. Any further comment?
16:15:48 <hongbin> 2. Magnum User Guide for Cloud Operator (tango)
16:15:57 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:16:22 <tonanhngo> The Swarm section merged, and the baymodel section is currently under review.  Thanks everyone for the helpful reviews.
16:16:42 <tonanhngo> I am working on the bay section now, should have it uploaded in the next few days
16:16:54 <tonanhngo> so, steady progress.
16:17:00 <tonanhngo> that's all I have
16:17:11 <hongbin> Thanks tonanhngo
16:17:19 <muralia_> also, please take a look at the bay driver section patch everyone
16:17:36 <hongbin> That lead to the next BP
16:17:37 <hongbin> 3. COE Bay Drivers (jamie_h, muralia)
16:18:23 <hongbin> muralia_: status?
16:18:34 <muralia_> so, this patch needs a little bit more work. since I submitted a new patch last week, a few new patches got merged to the old classes. I need to move those today. I'm seeing functional test failures currently and working on those.
16:19:31 <muralia_> do review it thought as its almost done. just needs some tweeking for the failures.
16:19:55 <muralia_> I've removed references to the old classes and moved over swarm related code and templates to the driver folder
16:19:59 <muralia_> thats it for me
16:20:13 <strigazi> muralia_: I have a question
16:20:17 <muralia_> yes
16:21:03 <strigazi> The driver is loaded dynamically? Does magnum searches for the available drivers?
16:21:46 <muralia_> no, not yet. first step it to move the code while still using the config file as the entry point.
16:21:57 <strigazi> ok
16:22:01 <muralia_> however, i've removed the hardcoded paths to the templates
16:22:21 <muralia_> those are discovered as we know the folder structure
16:22:23 <strigazi> I'll try to merge it to my patch and push for k8s
16:23:13 <strigazi> that's all
16:23:18 <hongbin> muralia_: A minor suggestion. Since you patch is large, you can do this
16:23:46 <hongbin> muralia_: When you patch is ready to merge, you can search the list of conflicted patches, and giva -1 on them to request the conflicting patches to merge later or depends on your patch
16:24:18 <muralia_> sure. i will do that. thanks
16:24:24 <hongbin> ok
16:24:44 <hongbin> Hopefully, that will reduce the amout of work to resolve conflicts
16:24:47 <hongbin> 4. Create a magnum installation guide (strigazi)
16:24:54 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-installation-guide
16:24:58 <strigazi> Good news
16:25:00 <strigazi> http://docs.openstack.org/project-install-guide/container-infrastructure-management/draft/
16:25:35 <strigazi> I also pushed and tested with the latest opensuse packages
16:25:40 <strigazi> https://review.openstack.org/#/c/335051/
16:26:34 <strigazi> WIP: build deb packages to test on ubuntu/debian from master and lbaasV1 install notes
16:26:47 <strigazi> that's it
16:27:13 <hongbin> strigazi: Thanks. This one looks professional :) http://docs.openstack.org/project-install-guide/container-infrastructure-management/draft/
16:27:32 <hongbin> strigazi: Thanks for the hard work
16:27:40 <strigazi> :)
16:27:51 <mkrai_> strigazi: Thanks. Looks really cool :)
16:28:25 <hongbin> #topic Magnum UI Subteam Update (bradjones)
16:28:37 <hongbin> I didn't receive any update from brad
16:28:47 <hongbin> So let's skip this
16:28:59 <hongbin> #topic Kuryr Integration Update (tango)
16:29:19 <hongbin> tonanhngo: ^^
16:29:27 <tonanhngo> I attended the Kuryr meeting yesterday
16:30:01 <tonanhngo> most of the discussion was on the code refactoring, which will impact our integration
16:30:40 <hongbin> Then, we need to wait for them to finish?
16:30:42 <tonanhngo> basically, the current code is specific to libnetwork, so it needs to be generalized to accommodate CNI and other drivers
16:31:13 <tonanhngo> no, I am moving ahead with the current code, but our patches will remain WIP until they finish the refactoring
16:31:28 <hongbin> ack
16:31:33 <tonanhngo> So we will make adjustment along the way as they proceed
16:32:07 <tonanhngo> I am still debugging the Swarm bay with Kuryr
16:32:53 <tonanhngo> I tried the container image for openvswitch agent from Kolla.  It needs some config so I am working on this
16:33:15 <tonanhngo> I may need to ping the Kolla team if I get stuck
16:33:57 <tonanhngo> I also asked Vikas to update the Kuryr spec on the part mentioning Magnum API for container
16:34:08 <tonanhngo> He will remove those references
16:34:30 <tonanhngo> That's all for now
16:34:37 <hongbin> Thanks tonanhngo
16:34:47 <hongbin> Any question for Ton?
16:35:13 <hongbin> #topic Other blueprints/Bugs/Reviews/Ideas
16:35:19 <hongbin> 1. Asynchronous Operations for bay?
16:35:24 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/async-container-operations Asynchronous Container Operations
16:35:35 <hongbin> muralia_: I remembered you requested to discuss this one?
16:35:53 <muralia_> yes, there are a few patches out there for async bay apis
16:36:16 <muralia_> it changes the create behavior a little but
16:36:44 <muralia_> the api does not return the entire bay object now, just the uuid as its still being created when the api returns
16:37:06 <muralia_> what does this affect?
16:37:14 <muralia_> will it affect the UI integration?
16:37:24 <muralia_> just wanted everyone to be aware
16:37:38 <hongbin> I am not sure the UI part, need to talk to Shu about that
16:37:56 <muralia_> ok.
16:38:08 <adrian_otto> hongbin is Shu able to attend our team meetings, or is that not practical because of timezones?
16:38:30 <hongbin> adrian_otto: He is in Japan, it is late everning for him
16:38:40 <Drago> Link to Async Bay Operations patch: https://review.openstack.org/#/c/330771/
16:38:41 <adrian_otto> I see
16:38:58 <muralia_> we'll need to update the getting started docs. Can you folks think of anything else this might impact? do leave comments
16:39:49 <strigazi> muralia_: which docs do you mean?
16:39:51 <hongbin> muralia_: Heat has a bay resource. Might worth to check if it is still working after teh patch
16:40:18 <hongbin> muralia_: mkrai_ Murano has a Magnum plugin, does it still work?
16:40:36 <muralia_> strigazi: actually, i just checked again and the getting started guide does not show what bay create returns. so we are good.
16:40:47 <mkrai_> hongbin: I see some error on Magnum App
16:41:01 <mkrai_> But haven't looked in detail
16:41:10 <muralia_> hongbin: thanks. we'll check all of these
16:41:26 <hongbin> mkrai_: ack. Does it related to the aysnc patch or not?
16:41:36 <mkrai_> I guess it is not
16:41:46 <mkrai_> It is some authorization error
16:41:52 <hongbin> mkrai_: OK. We can work on that offline
16:42:01 <mkrai_> Sure
16:42:29 <hongbin> Any other comment on this topic?
16:42:34 <freerunner> hm, somebody says 'Murano' here
16:42:55 <freerunner> hi folks :)
16:43:11 <hongbin> freerunner: Hi, we talked about the magnum-app for murano
16:43:13 <mkrai_> freerunner: Yes we are talking about Magnum app
16:43:16 <freerunner> Looks like we have a bug for your case, yep. https://bugs.launchpad.net/murano-apps/+bug/1595511
16:43:16 <openstack> Launchpad bug 1595511 in murano-apps "[Magnum][Murano] deployment of Magnum bay application is failed" [High,Confirmed] - Assigned to Madhuri Kumari (madhuri-rai07)
16:43:51 <mkrai_> freerunner: Thanks for it. I will try to submit the fix tomorrow
16:44:19 <freerunner> mkrai_: Wow! Thank you very much!
16:44:25 <muralia_> freerunner: thanks for that. we were also discussing a new change to make bay API's async.
16:44:41 <muralia_> it changes the bay create behavior a little bit.
16:45:12 <muralia_> it now only returns a uuid as the bay is being created in the background.
16:45:37 <muralia_> https://review.openstack.org/#/c/330771/
16:45:59 <mkrai_> muralia_: Thanks for putting this up. I will check it for Magnum app
16:46:21 <muralia_> freerunner: can you take a look at this patch and comment on it. we'd like to know if it breaks anything for you
16:46:54 <hongbin> #topic Open Discussion
16:46:57 <freerunner> muralia_: Will try to review it soon :)
16:47:02 <muralia_> thanks
16:47:48 <hongbin> Anyone has a topic to discuss?
16:47:57 <strigazi> yeap
16:48:05 <hongbin> strigazi: go ahead
16:48:36 <strigazi> Do we have a list of magnum users? Do we now people using it?
16:49:10 <strigazi> Can we do something about it?
16:49:41 <strigazi> Is it possible to have section in the wiki page for that?
16:49:49 <hongbin> strigazi: good idea
16:49:52 <strigazi> that's it
16:50:03 <hongbin> strigazi: I believe CERN is a user of Magnum?
16:50:27 <strigazi> yes we have two blog posts about our use case
16:50:50 <hongbin> Yes, from what I know, CERN is the only reported user
16:51:28 <hongbin> muralia_: adrian_otto Does Rackspace have any plan to adopt Magnum?
16:52:19 <muralia_> yes, we have internal deployments, but not available to our users yet. we do plan to.
16:52:38 <hongbin> muralia_: ack
16:52:50 <hongbin> I will create a wiki session for listing the users
16:53:06 <hongbin> For everyone, you can add yourselves if you want
16:53:24 <tonanhngo> I guess we will have solicit and get agreement for the users to be listed
16:53:24 <hongbin> #action hongbin create a wiki session to report a list of Magnum users
16:53:48 <hongbin> tonanhngo: Yes, it is up to them to edit the wiki to list themselves
16:55:13 <hongbin> OK. If there is no other topic, we can finish a bit earlier
16:55:30 <hongbin> #endmeeting