16:02:21 <hongbin> #startmeeting containers
16:02:22 <openstack> Meeting started Tue Jun 21 16:02:21 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:26 <openstack> The meeting name has been set to 'containers'
16:02:29 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-06-21_1600_UTC Today's agenda
16:03:18 <hongbin> #topic Roll Call
16:03:23 <mkrai> Madhuri Kumari
16:03:25 <strigazi> Spyros Trigazis
16:03:27 <tango> Ton Ngo
16:03:45 <vijendar> o/
16:03:51 <dane_leblanc> o/
16:03:55 <Zucan> o/
16:03:58 <rpothier> Rob Pothier
16:04:40 <hongbin> Thanks for joining the meeting mkrai strigazi tango vijendar dane_leblanc Zucan rpothier
16:05:02 <hongbin> Pause a few seconds for late attendee
16:05:45 <hongbin> #topic Announcements
16:05:52 <hongbin> I have no annoucement
16:06:01 <hongbin> Any annoucement from  our team member?
16:06:37 <hongbin> #topic Review Action Items
16:06:44 <hongbin> 1. hongbin follow up with neutron-lbaas team to produce a operator-facing installation guid (DONE)
16:06:51 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/097367.html
16:06:58 <hongbin> #link http://docs.openstack.org/mitaka/networking-guide/adv-config-lbaas.html Neutron-lbaas install guide
16:07:32 <lrensing> o/
16:07:37 <hongbin> The doc team pointed to an official neutron-lbaas guide
16:07:38 <diga> o/
16:08:08 <hongbin> strigazi: It seems we should point to that guide instead?
16:08:17 <strigazi> it's for v2 though
16:08:30 <hongbin> I believe we will upgrade to v2 soon
16:08:48 <strigazi> ok, before the next cycle I'll update
16:08:49 <hongbin> Then, we can use that guide instead
16:09:03 <hongbin> ok
16:09:15 <hongbin> 2. hongbin create a doodle pool to select a location (DONE by strigazi)
16:09:20 <hongbin> #link http://doodle.com/poll/2x9utspir7vk8ter
16:09:44 <hongbin> We will re-visit this later in the agenda
16:09:53 <hongbin> Any comment for the review action item?
16:10:13 <hongbin> #topic Essential Blueprints Review
16:10:26 <hongbin> 1. Support baremetal container clusters (strigazi)
16:10:33 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:10:40 <strigazi> yuanying fixed the template
16:10:52 <strigazi> I managed to create a bay in ironic as well
16:11:02 <hongbin> great!
16:11:07 <strigazi> tango: create the images
16:11:13 <strigazi> *created
16:11:23 <hongbin> link to the image?
16:11:29 <strigazi> the images are already uploaded
16:11:30 <tango> It's on the Fedora site
16:11:37 <strigazi> https://fedorapeople.org/groups/magnum/
16:11:53 <strigazi> fedora-23-*
16:12:02 <strigazi> fedora-23-kunernetes*
16:12:32 <strigazi> There are two iminent issues, as pointed out by yuanying
16:13:08 <strigazi> instance_info must be modified to LONGTEXT in itonic table
16:13:53 <strigazi> and the second is not really an issue. subnets must be updated with dns_nameserver
16:14:00 <strigazi> finally,
16:14:21 <strigazi> I posted instructions in the ML as well if someone wants to test it
16:14:26 <strigazi> that's it
16:14:45 <strigazi> I'll update the whiteboard accordingly
16:14:59 <hongbin> strigazi: sorry, I might miss it. Could you point to the instruction you posted?
16:15:54 <hongbin> BTW, one minor suggestion for the image name, since https://fedorapeople.org/groups/magnum/ has many images, it is unclear to me which one is Ironic
16:15:59 <strigazi> http://lists.openstack.org/pipermail/openstack-dev/2016-June/097759.html
16:16:12 <tango> Let me add some note to the README
16:16:16 <hongbin> I guess we'd better to create a "ironic" folder? or add a "-ironic" suffix?
16:16:25 <tango> OK, good point
16:16:35 <tango> there are 3 images for Ironic, used together
16:16:38 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/097759.html
16:16:52 <hongbin> tango: ack
16:17:04 <strigazi> btw
16:17:13 <hongbin> strigazi: any chance to turn http://lists.openstack.org/pipermail/openstack-dev/2016-June/097759.html to the user guide?
16:17:14 <strigazi> we should add checksums
16:17:23 <strigazi> for the images
16:17:31 <strigazi> hongbin ack
16:17:43 <tango> ok, will do
16:17:52 <hongbin> Thanks strigazi and tango
16:18:06 <tango> So is it time to write some doc for Ironic yet?
16:18:15 <tango> or we still have work to do?
16:18:35 <strigazi> We have work to do, but we are pretty close
16:18:44 <tango> ok
16:18:58 <strigazi> We need tests cause other patches might break ti
16:19:04 <strigazi> s/ti/it
16:19:21 <muralia> o/
16:19:23 <hongbin> Yes, need to setup the gate to test Ironic
16:19:37 <hongbin> That deserved another BP
16:19:47 <hongbin> (maybe)
16:19:59 <tango> +1
16:20:07 <hongbin> OK. Any comment for the Ironic BP?
16:20:07 <strigazi> we might be able to add a rally job soon
16:20:21 <hongbin> strigazi: That would be great
16:20:41 <hongbin> 2. Magnum User Guide for Cloud Operator (tango)
16:20:49 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:21:24 <tango> The Kubernetes section was merged, at least the initial version.  I expect it will be updated frequently
16:21:42 <tango> The Swarm section got good feedback
16:21:49 <adrian_otto> :-)
16:21:56 <tango> it has bee updated as suggested
16:22:01 <tango> s/bee/been
16:22:20 <tango> I am almost done with the section on baymodel, will upload the patch later today
16:22:38 <tango> then after that the section on bay
16:22:47 <tango> that's all for now
16:22:53 <muralia> so i have a question about the bay driver section. the only part missing is a sample driver.
16:23:01 <muralia> do we need that section?
16:23:22 <muralia> cant users look at existing drivers
16:23:25 <tango> It's a thought I want to put out to the team
16:23:40 <adrian_otto> Maybe something like "how to make your own driver"
16:23:51 <tango> I was thinking about something simple like a hello-world bay driver
16:23:59 <muralia> or just point to an existing driver. the doc currently says we'll add a sample driver which uses just docker.
16:24:41 <tango> Well, it will be easy for us to just point to the existing driver, but these can be a bit complicated
16:25:20 <tango> something minimal to get people started might be easier to digest
16:25:31 <tango> but we don't have to do this at the beginning
16:25:41 <hongbin> tango: +1
16:25:42 <muralia> ok. how about we merge the existing patch and revisit this section later. it might take a while for me to work on that section. or i could use some help from you tango
16:25:59 <tango> Yes, we can leave this for later
16:26:05 <muralia> ok. i'll remove the WIP on the commit so we can merge it
16:26:37 <tango> Sure, I will keep it in mind and will probably try to put the same bay driver together
16:26:52 <tango> it will be a good test of our methodology tood
16:27:10 <tango> s/same/sample
16:27:22 <hongbin> Thanks tango
16:27:28 <hongbin> There are lots of progress on the user guide. Thanks Ton for the hard work.
16:27:47 <hongbin> 3. COE Bay Drivers (jamie_h, muralia)
16:27:55 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/bay-drivers
16:28:03 <muralia> so the image scripts for fedora atomic got merged.
16:28:25 <muralia> im currently working on updating my refactor as some new code got merged since i moved stuff
16:28:39 <muralia> im also working on removing hardcoded references to the template and class paths
16:29:01 <muralia> we can discover them automatically as we have a well known folder structure
16:29:12 <muralia> will submit an updated patch soon.
16:29:14 <muralia> thats all for me
16:29:29 <hongbin> thanks muralia
16:29:32 <hongbin> comments?
16:29:57 <adrian_otto> thanks for all your work on this!
16:30:28 <hongbin> 4. Create a magnum installation guide (strigazi)
16:30:35 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-installation-guide
16:30:57 <strigazi> Today there was a meeting for the install guide
16:31:11 <strigazi> I pointed the docteam to our guide
16:31:26 <strigazi> and they said it looks good
16:31:45 <hongbin> That is great
16:32:08 <strigazi> I'll add new distros soon but we could merge one distro at a time
16:32:24 <strigazi> also there are suse packages
16:32:35 <strigazi> updated from the rdo packages
16:32:42 <strigazi> for ubuntu/debian
16:33:01 <strigazi> I have to build the manually cause they are outdated
16:33:10 <strigazi> It's not easy at all
16:33:44 <strigazi> that's all
16:33:49 <hongbin> strigazi: For the ubuntu/debian, any specific issue for the packages?
16:34:02 <hongbin> Or it is just the version is too old?
16:34:04 <adrian_otto> strigazi: the suse ones or the debian ones are not easy?
16:34:16 <strigazi> debian
16:34:27 <strigazi> suse has weekly builds
16:34:36 <adrian_otto> zigo may be able to assist if you get stuck
16:34:46 <zigo> o/
16:34:53 <zigo> Help for?
16:35:07 <hongbin> zigo: we are talking about the debian packages for Magnum
16:35:08 <adrian_otto> building magnum packages for debian. strigazi is working on that.
16:35:11 <strigazi> build packages from master
16:36:01 <zigo> I'd be happy to help as much as I can, though for being able to build for master, I need the packaging-deb stuff to be ongoing, and that needs help from -infra.
16:36:11 <zigo> Feel free to push them to help me making it a reality.
16:36:54 <hongbin> Thanks zigo
16:36:57 <strigazi> I'd like some help to test them locally first
16:37:42 <zigo> strigazi: Be my guest, I have all the scripting in place to do it, I can help you doing that in /query later on.
16:37:56 <strigazi> zigo: thanks
16:38:05 <hongbin> thanks strigazi zigo
16:38:10 <hongbin> other comments?
16:38:33 <hongbin> #topic Magnum UI Subteam Update (bradjones)
16:38:41 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/097417.html Change in magnum-ui core team
16:38:46 <hongbin> + Thai Tran
16:38:50 <hongbin> - David Lyle
16:38:54 <hongbin> - Harsh Shah
16:38:59 <hongbin> - Ritesh
16:39:05 <hongbin> - Adrian Otto (agreed to be removed)
16:39:22 <hongbin> Thanks all for voting to approve the change
16:39:27 <adrian_otto> Mine was duplicative because of membership in magnum-core
16:39:34 <hongbin> yes
16:40:03 <hongbin> any other comment fro that?
16:40:47 <hongbin> Thai has been providing useful comments for magnum-ui patches, I believe the adding him will help the mangnum-ui team a lot
16:41:03 <hongbin> #topic Kuryr Integration Update (tango)
16:41:31 <tango> Hongbin and I attended the Kuryr meeting yesterday
16:42:12 <tango> I updated them on our integration of Kuryr to Swarm bay
16:42:43 <tango> They confirmed the container image for Kuryr
16:43:40 <tango> I also mentioned about running the openvswitch agent as container, and they saw no issue with that
16:43:54 <adrian_otto> that's a good idea
16:44:07 <adrian_otto> as long as it uses --net host
16:44:30 <tango> This approach should allow us to continune using the stock fedora atomic image and avoid building custom image
16:45:06 <strigazi> A slightly of topic: Is kuryr going to be a hard dependency?
16:45:24 <hongbin> strigazi: No. End-users can choose to use flannel
16:45:34 <tango> No, only if the user wants to use libnetwork or CNI
16:45:41 <strigazi> ok
16:45:42 <tango> it's an optional network driver
16:46:01 <hongbin> We knew how bad a hard dependency are
16:46:07 <hongbin> Better to avoid :)
16:46:09 <adrian_otto> we do plan to use kuryr by default, right?
16:46:09 <strigazi> :)
16:46:22 <adrian_otto> but not a hard dependency
16:46:34 <tango> Well, that's something we can decide
16:47:12 <tango> I would think eventually, advanced networking would be common place
16:47:42 <tango> so it's up to us to decide when to make it a default
16:47:56 <hongbin> Yes, we can revisit teh default later
16:48:24 <hongbin> Thanks tango for syncing with Kuryr team
16:48:32 <hongbin> #topic Other blueprints/Bugs/Reviews/Ideas
16:48:40 <hongbin> 1. Midcycle
16:48:45 <hongbin> #link http://doodle.com/poll/2x9utspir7vk8ter Choose location
16:48:51 <hongbin> #link http://doodle.com/poll/5tbcyc37yb7ckiec Choose date
16:49:10 <hongbin> For the location, it looks Austin get more votes
16:49:53 <hongbin> If we go to Austin, it looks Ton and Egor are not able to make it?
16:49:56 <adrian_otto> so if we select Austin, is there any possibility that Egor and Ton can find a way to attend?
16:50:04 <adrian_otto> same question, LOL
16:50:32 <hongbin> tango: ^^
16:50:41 <tango> I should be able too, I was mainly concerned about the heat :)
16:51:03 <tango> but I can make it up with more BBQ
16:51:04 <adrian_otto> I can assure you that the air conditioning works great there
16:51:37 <tango> and all the flooding :)
16:51:38 <adrian_otto> that's good news.
16:51:45 <tango> but I will plan to be there
16:52:20 <adrian_otto> hongbin: ok to select Austin?
16:52:29 <hongbin> adrian_otto: yes. I am fine
16:52:38 <strigazi> so 4-5 of August at Austin?
16:52:43 <adrian_otto> We will need to confirm which dates we can accommodate there, but we can select a tentative date today.
16:53:08 <hongbin> #link http://doodle.com/poll/5tbcyc37yb7ckiec
16:53:27 <adrian_otto> and either muralia or I can send a note to the ML confirming the date, and include the address of the location
16:53:29 <hongbin> By the result, it looks Aug 4-5 is free for everyone
16:53:37 <strigazi> we have 7 votes for 2 to 5 of August
16:53:55 <adrian_otto> yes, that's the best date
16:54:21 <hongbin> adrian_otto: mind take an AI to confirm the date and location?
16:54:46 <adrian_otto> I am on vacation this week, so I asked murali to assist
16:55:00 <hongbin> muralia: ^^
16:55:05 <muralia> yup.
16:55:11 <muralia> i'll work with you hongbin
16:55:17 <adrian_otto> thanks muralia !
16:55:26 <hongbin> #action muralia confirm the date and location for the Magnum midcycle
16:55:36 <hongbin> #topic Open Discussion
16:55:58 <muralia> so i want to bring up the asyn bay apis
16:56:08 <muralia> we have a patch up there https://review.openstack.org/#/c/330771/
16:56:28 <muralia> i'll like to get feedback from you folks
16:56:33 <vijendar> thanks muralia… I am about to ping about that patch
16:56:43 <mkrai_> I also want to bring up an issue with https://review.openstack.org/#/c/322800/
16:57:19 <mkrai_> vijendar: please go ahead
16:57:48 <vijendar> this patch is to support async bay create and delete
16:58:11 <mkrai_> Ok so while bay delete certificates is not deleted with barbican
16:58:14 <vijendar> I marked it as WIP because did not fix the tests
16:58:44 <diga> anyone working on cinder/swipt implementation for container ?
16:58:52 <mkrai_> https://github.com/openstack/magnum/blob/master/magnum/common/cert_manager/barbican_cert_manager.py#L207 because currently we are just deregistering it
16:59:10 <mkrai_> Ok I will put this in ML
16:59:11 <hongbin> Sorry, folks. Time is up
16:59:18 <mkrai_> Thanks!
16:59:22 <hongbin> Overflow on the #openstack-containers channel
16:59:40 <hongbin> All, thanks for joining the meeting
16:59:45 <hongbin> #endmeetings
16:59:49 <diga> hongbin: lets talk on containers
16:59:56 <hongbin> #endmeeting