16:00:03 <hongbin> #startmeeting containers
16:00:04 <openstack> Meeting started Tue May 10 16:00:03 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:08 <openstack> The meeting name has been set to 'containers'
16:00:10 <hongbin> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2016-05-10_1600_UTC Today's agenda
16:00:16 <hongbin> #topic Roll Call
16:00:20 <sheel> Hi
16:00:22 <strigazi> Spyros Trigazis
16:00:25 <madhuri> o/
16:00:26 <tango__> Ton Ngo
16:00:27 <spn> o/
16:00:28 <dane_leblanc_> o/
16:00:31 <bradjones> o/
16:00:32 <jamie_h> o/
16:01:11 <juggler> o/
16:01:21 <adrian_otto> Adrian Otto
16:01:35 <hongbin> Thanks for joining the meeting sheel strigazi madhuri tango__ spn dane_leblanc_ bradjones jamie_h juggler adrian_otto
16:01:58 <hongbin> #topic Announcements
16:02:06 <hongbin> #link http://lists.openstack.org/pipermail/openstack-announce/2016-May/001103.html python-magnumclient 2.1.0 release
16:02:19 <hongbin> This is the first release based on request
16:02:34 <hongbin> Any comment?
16:02:57 <hongbin> #topic Review Action Items
16:03:00 <hongbin> None
16:03:08 <hongbin> #topic Essential Blueprints Review
16:03:14 <hongbin> 1. Support baremetal container clusters
16:03:20 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-baremetal-full-support
16:03:36 <hongbin> For this blueprint, the original assignee is Kennan
16:04:02 <hongbin> However, I received an email from him that he is not able to own it anymore
16:04:13 <hongbin> Therefore, we need a new owner for this one
16:04:41 <hongbin> This is a very important feature for Magnum (most people want to run containers on baremetals)
16:04:50 <hongbin> If nobody want to take it, I will take it
16:04:59 <dane_leblanc_> I'd like to help, but unfortunately have commitments until end of June.
16:05:11 <tango__> I will help also, it's important for us
16:05:11 <hongbin> dane_leblanc_: ack
16:05:22 <strigazi> I 'll help too
16:05:24 <spn> hongbin: Ì can work with you and help
16:05:25 <dane_leblanc_> Can help part time for now
16:05:46 <hongbin> Thanks all
16:05:49 <tango__> maybe you can list the TODO and people can jump in
16:05:56 <strigazi> +1
16:06:05 <hongbin> Let's find an owner
16:06:19 <hongbin> The owner should coordinate efforts from other contributors
16:06:27 <hongbin> Who want to own that BP?
16:06:51 <hongbin> (note: owner don't have to do the job, but coordinate the efforts)
16:07:07 <strigazi> I have many bp already, but I can try
16:07:21 <hongbin> strigazi: thx
16:07:33 <hongbin> strigazi: I will assign it to you
16:07:41 <strigazi> ok
16:07:45 <hongbin> strigazi: Again, you don't have to be the one who do the work
16:07:55 <strigazi> ack
16:08:07 <hongbin> strigazi: I think tango__ spn dane_leblanc_  will interest to help out
16:08:10 <spn> strigazi: I can help
16:08:19 <strigazi> spn: thx
16:08:26 <hongbin> spn: thx
16:08:34 <hongbin> Any further comment for this BP?
16:08:54 <hongbin> 2. Magnum User Guide for Cloud Operator (tango)
16:09:00 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/user-guide
16:09:08 <hongbin> tango__: status?
16:09:22 <tango__> I resumed working on this after a pause for the Summit, currently working on the storage section
16:09:32 <tango__> I added a place holder for bay driver
16:10:11 <tango__> will start writing it as outlined in the spec for now, so we have something to update as we proceed with the implementation
16:10:41 <tango__> The other sections in the guide will cover the supported bay drivers:  Kubernetes, Swarm, Mesos
16:10:53 <strigazi> tango: I think this can actually help the implementation
16:11:08 <tango__> I would expect new bay drivers to have their doc to supplement the guide
16:11:09 <hongbin> yes
16:11:44 <tango__> I will also start consolidating other docs into the guide, like TLS, ...
16:12:07 <hongbin> tango__: thx
16:12:12 <tango__> As usual, any help from the team is welcome
16:12:32 <hongbin> tango__: In particular, which part you need help from the team?
16:12:53 <tango__> The BP list some of the sections that has no content yet
16:12:59 <hongbin> tango__: ack
16:13:05 <tango__> for instance, HA
16:13:07 <strigazi> The documentation team told me that we can publish under docs.openstack with no details on that, but I have a contact
16:13:36 <tango__> Sounds good, I will follow up with you
16:13:43 <strigazi> ok
16:13:52 <hongbin> Any other question for Ton?
16:13:58 <jamie_h> is this spec separate from API documentation?
16:14:30 <tango__> I think API doc should be separate, since it's for a different audience
16:14:31 <hongbin> I think it is separated
16:14:40 <jamie_h> ok
16:14:48 <hongbin> There is a WIP patch for leveraging Swagger for API docs
16:15:00 <hongbin> #link https://review.openstack.org/#/c/303235/
16:15:10 <hongbin> Sync with yuanying if you interest
16:15:23 <hongbin> 3. COE Bay Drivers (Jamie Hannaford)
16:15:41 <hongbin> jamie_h: any update?
16:16:01 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/bay-drivers
16:16:14 <jamie_h> i've been busy last week, but hope to restart things tomorrow
16:16:25 <jamie_h> there's been a lot of feedback, which i almost entirely agree with. i have a few questions though
16:16:35 <wangqun_> o/
16:16:41 <hongbin> wangqun_: hey
16:16:50 <wangqun_> hi
16:16:53 <hongbin> jamie_h: Yes, I think the spec is almost ready
16:17:03 <jamie_h> should the spec dictate what lives inside the version.py manifest file? its structure etc
16:17:09 <jamie_h> or leave that up to the implementor
16:17:28 <hongbin> jamie_h: I think it is up to you
16:17:40 <hongbin> jamie_h: I think the spec don't have to address all the details
16:17:58 <tango__> We can go back and update the spec also as needed
16:18:01 <hongbin> jamie_h: So, just outline the design is good enough for me
16:18:04 <jamie_h> ok, sounds good
16:18:28 <hongbin> Any question for jamie_h regarding the Bay driver BP?
16:19:06 <hongbin> 4. Create a magnum installation guide (strigazi)
16:19:24 <strigazi> The proposed spec https://review.openstack.org/#/c/301284/ to move Big Tent projects from the install guide to repos owned by project teams has been merged. A new spec for the install-guide has been created for Newton https://review.openstack.org/#/c/310588/. The intention is to move from "one install-guide to rule them all" to installation tutorials, many, or a few. For example, debian con
16:19:27 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/magnum-installation-guide
16:19:30 <strigazi> tent (with debconf https://wiki.debian.org/debconf) will be moved in a separate tutorial. Additionally, quite a few people in the design summit were in favor of installation instructions from source.
16:20:00 <strigazi> In https://review.openstack.org/#/c/310588/, a template will be created, which can be followed by project teams. Magnum will have installation instructions in its repo and that content will be published in docs.openstack.org. The exact publishing location for Big Tent projects hasn't been determinted, yet.
16:20:31 <strigazi> We can start by adding my WIP in our repo
16:20:49 <hongbin> strigazi: Yes, that would be great
16:20:50 <strigazi> Which is done and tested for rdo and ubuntu
16:21:04 <strigazi> Do you think we should have a spec?
16:21:04 <tango__> +1.  I have been trying it out on Ubuntu
16:21:33 <strigazi> Thing might change, since the documentation team makes changes
16:21:46 <hongbin> strigazi: I don't think we need a spec for writing the doc
16:21:46 <strigazi> s/thing/things
16:22:27 <strigazi> We can have two, one for packaged installations and one from source
16:22:51 <strigazi> since magnum is under active development from source makes sense
16:23:09 <hongbin> WFM
16:23:13 <adrian_otto> I agree that we don't need a spec for this.
16:23:39 <hongbin> Yes, just get everything landed in the fastest way
16:23:45 <strigazi> ok
16:23:48 <adrian_otto> let's just resubmit the doc for merge under the magnum source tree
16:24:19 <strigazi> I'll remove obs and debian
16:24:40 <hongbin> strigazi: thx.  Any other comments regarding to the installation guide BP?
16:24:47 <adrian_otto> is there a problem with the debian packaging?
16:25:03 <strigazi> I haven't tested it
16:25:18 <strigazi> debconf is a lot diffrent
16:25:37 <hongbin> It looks other projects don't have debian in their documentations
16:25:37 <strigazi> I makes things easier thow if you know what you're doing
16:26:36 <hongbin> Any other comments?
16:26:37 <strigazi> We can point debian users to the packages and to the install from source, until we are ready
16:26:37 <adrian_otto> If we have guidance and it's just not tested for debian, I suggest including it and marking it as untested.
16:26:51 <strigazi> ok
16:27:29 <hongbin> OK. Let's advance topic
16:27:30 <adrian_otto> the more installation options operators have, the more adoption we are likely to see. As folks try it, they can let us know what works and what doesn't
16:27:47 <hongbin> #topic Magnum UI Subteam Update (bradjones)
16:28:14 <hongbin> bradjones: any update from the UI subteam?
16:28:20 <bradjones> both shu & I have been on vacation since summit so nothing new
16:28:32 <bradjones> hoping some of the new bps will get picked up this week
16:28:38 <bradjones> so should be more next week
16:28:47 <hongbin> bradjones: Thanks Brad
16:28:53 <hongbin> Any question for Brad?
16:29:22 <hongbin> #topic Other blueprints/Bugs/Reviews/Ideas
16:29:27 <hongbin> 1. Review Magnum mission statement
16:29:33 <hongbin> #link https://review.openstack.org/#/c/311476/ The proposal
16:29:54 <hongbin> It looks the patch has a lot of +1 already
16:30:08 <hongbin> If you have comments, now is the last minutes
16:30:20 <hongbin> 2. Add an option to turn on Keystone authentication for k8s bay
16:30:28 <hongbin> #link https://blueprints.launchpad.net/magnum/+spec/keystone-for-k8s-bay
16:30:56 <hongbin> This is a proposal to add support for additional auth machnism for k8s
16:31:12 <hongbin> There is a use case from Horizon plugin to leverage it
16:31:41 <hongbin> The idea is to turn on the Keystone support for kubernetes, which is already in updstream
16:32:09 <hongbin> Any comments for this proposal?
16:32:35 <hongbin> Do you think if it is the right direction?
16:32:50 <tango__> Good to have more integration with OpenStack services
16:33:02 <hongbin> tango__: +1
16:33:06 <spn> +1
16:33:08 <adrian_otto> wait a sec
16:33:08 <wangqun> +1
16:33:11 <tango__> this is one of the value Magnum brings
16:33:14 <adrian_otto> what are you proposing exactly?
16:33:19 <madhuri> Yes it is good idea to integrate Keystone
16:33:33 <adrian_otto> to change the default configuration of K8s to use keystone for user auth instead of TLS certs?
16:33:38 <hongbin> adrian_otto: Add an option to turn on Keystone auth in k8s
16:33:52 <hongbin> adrian_otto: The default is still TLS
16:34:31 <adrian_otto> I think the option is fine. The default should be the prevailing way k8s users normally interact with k8s clusters, which is using TLS for auth.
16:34:32 <tango__> There is a link in the BP to the feature in Kubernetes
16:35:13 <hongbin> The BP has nothing to do with the default configuration
16:35:21 <hongbin> It is about adding an alternative option
16:35:21 <adrian_otto> We should avoid a situation where k8s users have to set up their environments differently in order to use a k8s bay on Magnum, versus how they would use k8s elsewhere.
16:35:51 <hongbin> adrian_otto: If we decided to integrate with Kuryr, this is already the case
16:36:05 <adrian_otto> that's different
16:36:22 <hongbin> adrian_otto: Could you elaborate?
16:36:48 <adrian_otto> because you can interact with the docker API regardless if we use kuryr
16:37:03 <hongbin> OK. That is true
16:37:14 <adrian_otto> if you make it so that my usual k8s client enfironment is incompatible with using k8s on openstack, that would be a bad user experience.
16:37:52 <hongbin> I might or might not agree, but that has nothing to do with the BP
16:37:57 <adrian_otto> so I recognize that's not what has been proposed, but I wanted to offer my input of where we should be careful
16:38:27 <hongbin> OK. THen I will approve the BP if there is no objection from others
16:38:42 <hongbin> Any opposing point of view?
16:39:11 <hongbin> Approved
16:39:24 <hongbin> 3. Add labels help text in magnumclient
16:39:36 <hongbin> #link https://review.openstack.org/#/c/307631/
16:39:42 <hongbin> #link https://review.openstack.org/#/c/307642/
16:40:18 <hongbin> wangqun: You are the one who proposed those patches?
16:40:34 <wangqun> yes
16:40:51 <hongbin> These patches have -2 from Tom
16:40:59 <hongbin> So I bring it to the team meeting
16:41:03 <wangqun> I want to add the label help because its paraments is so many.
16:41:20 <hongbin> wangqun: Could you elaborate more?
16:41:43 <hongbin> wangqun: (more details for others to catch up the context)
16:42:13 <wangqun> Yes
16:43:43 <wangqun> I want to add the labels help and it will be easy to introduce the paramenter for users
16:44:01 <hongbin> Yes
16:44:04 <wangqun> Now the mesos flags has been added so many value.
16:44:26 <tango__> I think it's good to have more explanation to help the user.  It's true that label is for general use so it's difficult to know what's supported.
16:44:34 <tango__> The issue is how to organize the help message
16:45:03 <hongbin> The help message have to be in the CLI if we decided to give it
16:45:04 <wangqun> +1
16:45:06 <tango__> to make it easy for the users to find what they need
16:45:28 <wangqun> I find the nova has the example https://github.com/openstack/python-novaclient/blob/master/novaclient/v2/shell.py#L487
16:45:29 <tango__> Looks like in the patch, it will all be under label, which may be too much
16:45:36 <hongbin> Here is the objection from @Tom
16:45:59 <hongbin> He argued that help text in CLI might be outdated if it is under maintain
16:46:06 <hongbin> Therefore, he gave a -2
16:46:35 <hongbin> So, there is two opposing poiint of view
16:46:52 <hongbin> #1 Put help text to CLI to make it close to end users
16:47:23 <hongbin> #2 Don't put detailed help text to CLI to make it easer to maintain
16:47:48 <hongbin> What are your opinions between these two point of views?
16:48:26 <hongbin> comments?
16:48:46 <hongbin> Or you want to discuss it in the ML?
16:48:55 <tango__> If the keky point is to make it easier to maintain, we can have it in the CLI and organize in a way to make it easy to maintain
16:49:04 <tango__> without having to update master
16:49:35 <hongbin> tango__: maybe let the CLI to retrieve help text from server
16:49:47 <tango__> Going back to the doc is not very convenient
16:49:54 <tango__> although it should be documented as well
16:50:21 <tango__> Maybe put it in magnum.conf ?
16:50:34 <hongbin> tango__: magnumclient don't have access to magnu.conf
16:50:47 <tango__> through a call to the server
16:50:58 <hongbin> tango__: Yes, that is an option
16:51:08 <tango__> Anyway, we can discuss the implementation
16:51:16 <wangqun> Yes it is a option
16:51:17 <yuanying_> I added a patch to get parameters from server https://review.openstack.org/#/c/303235/
16:51:29 <hongbin> Let's discuss it further in ML
16:51:36 <tango__> but we don't have to choose one or the other
16:51:41 <tango__> it can be both
16:51:50 <hongbin> #action hongbin start a ML to discuss the CLI help text documentation
16:52:05 <hongbin> #topic Open Discussion
16:52:41 <sheel> hongbin: when we are going to start on higgins?
16:52:51 <sheel> hongbin:   is there any defined roadmap for same?
16:53:24 <hongbin> sheel: It can be started as long as the repo was created
16:53:31 <hongbin> #link https://review.openstack.org/#/c/313935/
16:53:55 <sheel> hongbin: yes i am aware of it being one of the reviewers :)
16:54:00 <hongbin> sheel: Once the patch go through, the repo will be created. Then, it can be started
16:54:25 <sheel> hongbin: nice.. any roadmap defined for same like which fucntionalities specifically to move etc
16:54:39 <hongbin> sheel: Not yet. That needs to be discussed
16:54:39 <sheel> hongbin: will be helpful to track the work
16:54:48 <sheel> hongbin:  ohk...
16:54:59 <hongbin> sheel: BTW, this is a Magnum meeting. This is a bit out of topic :)
16:55:00 <sheel> hongbin: so any plan for discussion in coming days/weeks?
16:55:16 <sheel> hongbin: sorry for asking too many questions but curious to start work on it...
16:55:18 <hongbin> sheel: I will start a ML to schedule a meeting
16:55:44 <sheel> hongbin:  sounds good..
16:55:55 <sheel> thanks
16:56:00 <hongbin> np
16:56:57 <hongbin> Anyone else has a topic to discuss?
16:57:41 <hongbin> If not, let's wrap up
16:58:14 <hongbin> Thanks everyone for joining the meeting
16:58:20 <hongbin> #endmeeting