16:02:37 <adrian_otto> #startmeeting containers
16:02:37 <openstack> Meeting started Tue Oct 20 16:02:37 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:41 <openstack> The meeting name has been set to 'containers'
16:02:53 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-10-20_1600_UTC Our Agneda
16:02:54 <eliqiao_home> o/
16:02:59 <adrian_otto> #topic Roll Call
16:03:01 <mfalatic> o/
16:03:02 <rlrossit> o/
16:03:04 <bradjones> o/
16:03:05 <muralia1> o/
16:03:07 <Tango> Ton Ngo
16:03:07 <rpothier> o/
16:03:07 <adrian_otto> Adrian Otto
16:03:07 <suro-patz> o/
16:03:08 <eghobo_> o/
16:03:08 <juggler> o/ Perry Rivera
16:03:09 <hongbin> p/
16:03:12 <hongbin> o/
16:03:34 <madhuri_> o/
16:03:35 <vilobhmm11> o/
16:04:30 <daneyon> o/
16:05:12 <adrian_otto> #topic Announcements
16:05:48 <adrian_otto> 1) stable/liberty branch is up
16:06:01 <adrian_otto> that's what we will be releasing against.
16:06:32 <adrian_otto> so if you have code up for review that needs to be in the liberty release, it needs to be re-submitted for review against that branch
16:06:36 <adrian_otto> backported
16:07:30 <adrian_otto> 2) No meeting next tuesday… Tokyo Summit
16:07:44 <adrian_otto> any other announcements from team members?
16:08:19 <adrian_otto> #topic Container Networking Subteam Update (daneyon)
16:08:29 <daneyon> thx adrian_otto
16:09:03 <daneyon> we did not have a meeting last week due to a scheduling conflict. Everyone should have seen the notification on the ML
16:09:22 <daneyon> we will not have a meeting this week due to the DS.
16:09:39 <adrian_otto> ok
16:09:44 <daneyon> We will reconvene on 11/5
16:09:54 <daneyon> #link https://review.openstack.org/#/c/224367/
16:10:04 <daneyon> I would like to discuss ^ review
16:10:09 <adrian_otto> and we have DS sessions, including a fishbowl for networking
16:10:24 <daneyon> I have spent a fair bit of time over the last week or so having to rebase and rebase
16:10:35 <adrian_otto> daneyon: so I will make sure that you have the schedule and invite key contributors to attend
16:10:37 <daneyon> I know it's a big one, but it's well tested
16:10:46 <daneyon> I addressed everyone's comments.
16:10:50 <adrian_otto> final schedule should be done later today.
16:11:05 <daneyon> If I need to break it apart, then I will... but hoping you can let it slide this time.
16:11:28 <daneyon> adrian_otto great
16:11:50 <adrian_otto> thanks, daneyon. Ready for the next topic?
16:12:03 <daneyon> adrian_otto you or I need to also respond to gsagie's email about the magnum community joining the kuryr session.
16:12:07 <daneyon> sure
16:12:32 <adrian_otto> daneyon: I'm drowning a little. Please follow up with me today.
16:12:44 <daneyon> adrian_otto will do
16:12:55 <adrian_otto> my inbox is a disaster area currently
16:13:01 <adrian_otto> tx
16:13:26 <adrian_otto> #topic Magnum UI Subteam Update (bradjones)
16:13:29 <bradjones> thanks
16:13:36 <bradjones> so pretty great progress this week
16:13:50 <bradjones> a couple more people are now working on different bits of the UI
16:14:06 <bradjones> Rob Cresswell has been helping out with the containers views and APIs
16:14:16 <bradjones> and helping get the testing up to scratch before the summit
16:14:27 <bradjones> also Shu Muto has done a great job with the Bay UI
16:14:36 <bradjones> #link https://review.openstack.org/#/c/235870/
16:14:53 <bradjones> there is some small feedback that needs to be addressed then I'm happy to merge that
16:15:35 <bradjones> one thing that is blocking a couple of patches is I have included network_driver and labels which are going to be present in the new python client
16:15:56 <bradjones> but currently waiting to merge until the new client is release
16:16:03 <bradjones> do we have an eta on that?
16:16:37 <hongbin> I think the network_driver and labels are already there. Is it?
16:16:53 <bradjones> I couldn't find those labels in 0.2.1
16:17:01 <adrian_otto> I can release a client today
16:17:27 <bradjones> adrian_otto: that will be great then I can hit go on the relevant patches
16:17:27 <adrian_otto> tonight actually
16:18:23 <adrian_otto> ok, next topic?
16:18:36 <adrian_otto> #topic Review Action Items
16:18:53 <bradjones> that's about all from me
16:19:10 <adrian_otto> I owe you one deliverable here, which is the ODS schedule. This is the top item on my todo list, and I expect to complete it today.
16:19:25 <adrian_otto> would you like me to send an update to the ML with a link to the schedule?
16:20:17 <daneyon> adrian_otto please do so.
16:20:20 <bradjones> adrian_otto: that would be great
16:20:26 <vilobhmm11> adrian_otto : ODS ( Design Summit) that will be better IMHO
16:21:29 <adrian_otto> #action adrian_otto to send a message to our ML detailing our Design Summit sessions for requested attendance
16:21:41 <adrian_otto> #topic Blueprint/Bug Review
16:21:49 <adrian_otto> I am going to deviate from the agenda here
16:22:01 <adrian_otto> do something less formal than usual
16:22:23 <adrian_otto> I want to give a final call for any reviews that need to be merged for stable/liberty
16:22:51 <adrian_otto> also, any showstopper bugs that are must-fix for the release
16:23:17 <muralia1> adrian_otto: there is one for TLS. https://review.openstack.org/#/c/232152/6
16:23:33 <muralia1> I'm working on addressing one last comment about trusts
16:23:42 <adrian_otto> muralia1: thanks for that. Please explain why it
16:23:49 <adrian_otto> is a must
16:24:07 <muralia1> current we use user auth tokens. they expire after a while
16:24:13 <muralia1> trust token stick around
16:24:15 <adrian_otto> ok, understood
16:24:43 <adrian_otto> please submit another identical review against stable/liberty for that.
16:24:48 <adrian_otto> ^^ muralia1
16:24:56 <muralia1> ok
16:25:04 <daneyon> adrian_otto: I think i hit a show stopper bug: https://review.openstack.org/#/c/236737/
16:25:04 <adrian_otto> any others?
16:25:39 <daneyon> Using atomic-5/6 images over the weekend, I could not get docker to start on a k8s minion without this patch.
16:25:50 <hongbin> daneyon: I am not able to reproduce the error you saw on that one
16:25:56 <daneyon> There may be other ways to solve the problem... we would need to dig deeper.
16:26:18 <adrian_otto> ok, there is a bunch of discussion on this patch
16:26:23 <daneyon> hongbin: Let me try again today and I will update the review with my findings.
16:26:35 <hongbin> daneyon: k
16:26:35 <adrian_otto> is there a quick fix with a more elegant follow on that we can agree on?
16:26:37 <eghobo_> +1 hongbin
16:26:48 <daneyon> adrian_otto there is. I need to test again and then I will provide updates.
16:26:52 <vilobhmm11> +1 hongbin
16:27:14 <Tango> daneyon: I can help debug if you need a hand
16:27:50 <daneyon> adrian_otto: Not sure why others don;t see this bug. All, the atomic-5/6 image was updated on 10-12-2015. Make sure you are using this image. You may need to download and add to glance.
16:28:05 <adrian_otto> ok, so daneyon please duplicate the review for stable/liberty
16:28:26 <daneyon> Tango: I fixed the problem, it just sounds like we need to see if that;'s the best fix to the issue
16:28:29 <adrian_otto> and muralia1 + daneyon be sure the review comment stream has a link to the permalink between each duplicate review
16:28:47 <adrian_otto> so that reviewers can easily navigate between them
16:28:56 <adrian_otto> rather than discover them separately
16:28:57 <muralia1> ok
16:29:02 <daneyon> hongbin I assume you are using the 10-12-2015 atomic-5 or 6 image, correct?
16:29:05 <adrian_otto> tx
16:29:18 <hongbin> daneyon: yes, I am
16:29:21 <daneyon> ok
16:29:44 <vilobhmm11> i used atomic-5 daneyon
16:29:46 <adrian_otto> if there were a way to have a single patch against two branches at once, that would be a cool trick, but I doubt that's possible
16:31:20 <adrian_otto> ok, are those our only two must-haves?
16:32:04 <muralia1> when are we going to freeze the branch?
16:32:42 <adrian_otto> muralia1: as soon as those two patches land, and I have indication from >1 tested that the release has been functionally tested and is known to work
16:32:49 <daneyon> i would love to have https://review.openstack.org/#/c/236737/ in the relase :-)
16:32:54 <daneyon> release
16:33:16 <adrian_otto> I am seeking volunteers to take the patched stable/liberty code, and deploy it, and use it for everything you can think of looking for problems
16:33:54 <daneyon> going once...
16:34:04 <leecalcote> adrian_otto: is that a bug-finding challenge? ;)
16:34:07 <daneyon> going twice...
16:34:17 <adrian_otto> I will personally hand you cash
16:34:29 <adrian_otto> ;-)
16:34:38 <daneyon> adrian_otto count me in
16:34:39 <adrian_otto> leecalcote: yes sir
16:34:45 <juggler> lol ao
16:34:45 <daneyon> i don;t need the cash though
16:34:47 <adrian_otto> awesome, thanks daneyon
16:34:57 <rlrossit> I'm attempting magnum deployments as well, I can switch that over to liberty
16:34:59 <adrian_otto> drinks on me at the Cisco party.
16:35:03 <eliqiao_home> adrian_otto: hand up.
16:35:04 <daneyon> i will take a beer or two
16:35:04 <rlrossit> I would require the cash though ;)
16:35:08 <daneyon> lol
16:35:11 <adrian_otto> hahah
16:35:45 <daneyon> adrian_otto can you ping me when the magnum and client code is cut?
16:35:57 <adrian_otto> in all seriousness, Rackspace and Intel are holding a reception for the OpenStack Innovation Center. I'd love to see you all there.
16:36:12 <adrian_otto> daneyon: yes.
16:36:18 <eliqiao_home> cool, glad to be there
16:36:23 <eghobo_> adrian_otto: I can play/test with stable/liberty when it's ready
16:36:34 <juggler> i'm there in spirit!
16:36:50 <adrian_otto> thanks eghobo_
16:37:03 <daneyon> is their a list of functionality I can test against?
16:37:04 <eghobo_> ' OpenStack Innovation Center' is it in SF?
16:37:16 <adrian_otto> so my plan is to bundle an initial release once we merge those two patches (hopefully today)
16:37:28 <eghobo_> daneyon: start with dev quick start
16:37:33 <daneyon> ya
16:37:36 <adrian_otto> hold off on the announcement. Get input from each of you on confirmed readiness,
16:37:50 <adrian_otto> iterate if needed, then release based on your guidance
16:37:59 <adrian_otto> and announce the release
16:38:05 <SteveA> I'll try the dev quick start too
16:38:20 <daneyon> adrian_otto I assume you want our whole test stack to use the L release, correct?
16:38:22 <adrian_otto> thanks SteveA
16:38:37 <adrian_otto> daneyon: yes, if possible
16:38:45 <daneyon> got it
16:39:07 <adrian_otto> it's also imformative to know about others who made it work on previous releases and how, but confirmation on liberty is the first priority
16:39:21 <daneyon> makes sense
16:39:44 <adrian_otto> ok, let's open it up
16:39:57 <adrian_otto> #topic Open Dicsussion
16:40:34 <daneyon> Tango: Does the atomic-6 image posted on 10-12-2015 is built from the rpm's in this repo: https://copr.fedoraproject.org/coprs/tango/f21-kubernetes-v1/builds/
16:40:48 <daneyon> of if anyone else has the answer
16:40:56 <Tango> daneyon: Yes it is
16:41:02 <daneyon> great, thx
16:41:13 <eliqiao_home> I would like to bring more attentions on functional testing stuff, started from this patch https://review.openstack.org/#/c/232421/12
16:42:32 <adrian_otto> dimtruck had ideas about how to transition to tempest and allow the func tests to run in parallel.
16:42:37 <vilobhmm11> eliqiao_home : sure
16:42:43 <eghobo_> eliqiao_home: I think we should discuss it at Tokyo
16:42:55 <adrian_otto> this will be a subject of discussion in a workroom session next week, guaranteed
16:43:09 <eliqiao_home> eghobo_: sure , good to know.
16:43:12 <eghobo_> it's big topic and we all should agree how we are going to do func test
16:43:29 <eghobo_> and all will folow
16:43:31 <adrian_otto> absolutely
16:43:39 <hongbin> I have a comment on the magnum-ui depedency
16:44:11 <hongbin> magnum-ui is using master version of magnum, but not master version of magnumclient. Is that correct?
16:44:34 <hongbin> bradjones: ^^
16:44:59 * eliqiao_home go to sleep
16:45:03 <bradjones> it should be using the released versions of both
16:45:19 <bradjones> I think currently we point at magnum from git is that correct?
16:45:41 <hongbin> I think so. But not for magnumclient
16:45:57 <bradjones> I will put out a patch to change that now
16:46:09 <hongbin> k
16:46:09 <bradjones> we should only be pointing at released packages from the ui
16:46:33 <hongbin> get it
16:48:05 <hongbin> A disadvantage is that pointing ui to release might not pick up the latest features from Magnum
16:48:24 <hongbin> But it is good for stableness
16:48:29 <adrian_otto> that's probably ok
16:48:42 <hongbin> k
16:48:58 <hongbin> thx bradjones
16:49:02 <adrian_otto> if we have a compelling new feature, we can just cut a release for it
16:49:12 <bradjones> no problem
16:49:25 <adrian_otto> and assuming the ui picks the current releases, then we surface that without much effort
16:49:59 <hongbin> sure
16:50:24 <bradjones> perhaps I will wait and change it once the new releases go out later today
16:50:33 <bradjones> then we start completely up to date :)
16:51:14 <adrian_otto> I just opened up a chunk of time this afternoon to get taht done
16:52:19 <adrian_otto> ok, should we wrap up a few minutes early for a change?
16:52:34 <vilobhmm11> adrian_otto : is there a common place/etherpad where the design summit discussion will be jotted down for people who won't be able to make it to the summit ?
16:53:38 <juggler> +1 vilo
16:53:43 <vilobhmm11> last time we had a ref here https://wiki.openstack.org/wiki/Design_Summit/Liberty/Etherpads#Magnum that was useful if we have something of that sort this time as well it be useful IMHO
16:54:01 <adrian_otto> vilobhmm11: Yes, I will place it on the Wiki (or find another way to link to it in the main schedule) and email that our on openstack-dev with the [Magnum] topic tag in the subject.
16:54:21 <vilobhmm11> adrian_otto : thanks! that would be nice
16:54:46 <juggler> ^^AI needed?
16:55:25 <adrian_otto> juggler: I already recorded that as an action
16:55:40 <juggler> cool
16:55:58 <adrian_otto> thanks everyone for attending today. Our next meeting will be Tuesday 2015-11-03 at 1600 UTC.
16:56:10 <adrian_otto> #endmeeting