22:00:28 <adrian_otto> #startmeeting containers
22:00:29 <openstack> Meeting started Tue Jul 14 22:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:32 <openstack> The meeting name has been set to 'containers'
22:00:53 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-07-14_2200_UTC Our Agenda
22:00:56 <adrian_otto> #topic Roll Call
22:01:01 <adrian_otto> Adrian Otto
22:01:01 <madhuri_> o/
22:01:03 <sdake_> o/
22:01:03 <yuanying-alt> o/
22:01:05 <dane_leblanc> o/
22:01:06 <mfalatic> o/
22:01:06 <suro-patz> o/
22:01:11 <juggler> Perry Rivera
22:01:15 <Tango> Ton Ngo
22:01:16 <tcammann1> o/
22:01:21 <daneyon> o/
22:01:22 <rods> o/
22:01:29 <hongbin> o/
22:02:01 <adrian_otto> hello madhuri_, sdake_, yuanying-alt, dane_leblanc, mfalatic, suro-patz, juggler, Tango, tcammann1, daneyon, rods, and hongbin
22:02:16 <juggler> hello!
22:02:21 <mfalatic> Howdy!
22:03:37 <eghobo> 0/
22:03:48 <adrian_otto> hello eghobo
22:04:13 <adrian_otto> we have a full agenda today, so let's start
22:04:17 <adrian_otto> #topic Announcements
22:04:39 <adrian_otto> 1) We have made a directional design decision to implement TLS and certificate generation initially using Barbican.
22:04:47 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/069130.html Summary of our TLS Design Meeting
22:04:58 <adrian_otto> this has the exact text of the #agreed for your reference ^
22:05:07 <adrian_otto> #link https://review.openstack.org/194905 Spec Review for TLS Support in Magnum
22:05:16 <adrian_otto> ^ this is the work it relates to
22:05:59 <adrian_otto> there has been some initial delays in response from the Barbican team. Has madhuri_ heard back from redrobot or another Barbican team member?
22:06:10 <madhuri_> Not yet adrian_otto
22:06:22 <adrian_otto> ok, I will take an action item to escalate
22:06:24 <sdake_> I found us another expert
22:06:31 <tcammann1> Are we going to use dogtag as a backend?
22:06:33 <sdake_> Dave McCowan said he could provide guidance on the barbican front
22:06:50 <madhuri_> Yet to be decided tcammann1 with Barbican guys
22:06:54 <sdake_> madhuri you have his email
22:06:55 <adrian_otto> #action adrian_otto to follow up with Barbican team to arrange assistance for integration with Magnum
22:07:09 <adrian_otto> thanks sdake_
22:07:09 <madhuri_> Yes sdake_
22:07:33 <adrian_otto> let's table the Barbican matter until Open Discussion
22:07:36 <sdake_> madhuri_ make sure to cc the mailing list plz
22:07:46 <madhuri_> Sure
22:07:46 <adrian_otto> we're going to get what we need there.
22:07:51 <adrian_otto> next..
22:07:56 <adrian_otto> 2) Welcome Tom Cammann to the magnum-core team.
22:08:01 <tcammann1> :D
22:08:03 <sdake_> o/ welcome aboard dude
22:08:06 <adrian_otto> I will be adding him at the end of our meeting
22:08:06 <madhuri_> Welcome
22:08:08 <juggler> excellent!
22:08:09 <yuanying-alt> welcome!
22:08:10 <tcammann1> thanks guys
22:08:10 <hongbin> welcome
22:08:19 * juggler high fives tcammann
22:08:25 <sdake_> now you can help me on https://blueprints.launchpad.net/magnum/+spec/objects-from-bay ;-)
22:08:38 <tcammann1> yep, sure can
22:08:47 <sdake_> although you could before ;-)
22:09:03 <juggler> heh
22:09:31 <adrian_otto> actually tcammann has been added to https://review.openstack.org/#/admin/groups/473,members
22:09:41 <tcammann1> woop
22:09:50 <adrian_otto> we look froward to your +2 power
22:10:06 <adrian_otto> next announcement...
22:10:08 <adrian_otto> 3) Magnum Midcycle Meetup is 2015-08-05 and 2015-08-06 at IBM
22:10:17 <adrian_otto> in San Jose
22:10:23 <adrian_otto> #link https://wiki.openstack.org/wiki/Magnum/Midcycle Magnum Midcycle Details
22:10:29 <adrian_otto> NOTICE: Seating is limited, so Eventbrite RSVP is required for all in-person attendees. Remote attendees please do not RSVP.
22:10:50 <adrian_otto> this is really important. If you are going to attend in person, be sure to RSVP on eventbrite
22:11:05 <sdake_> seating = 28 seats correct?
22:11:17 <adrian_otto> there are 28 remaining of the 30 I posted
22:11:34 <sdake_> that should be plenty judging by the regular ODS
22:11:42 <Tango> we can manage
22:11:49 <daneyon> adrian_otto lets rent an RV and drive up together... lol!!!!
22:11:57 <adrian_otto> I'm planning of email all of the ticketed participants prior to the event to confirm your attendance, and free up room for anyone waiting
22:12:11 <adrian_otto> daneyon, I own one of those
22:12:20 <adrian_otto> but sorry I can't afford the time to drive.
22:12:24 <daneyon> skip the rent part then
22:12:37 <adrian_otto> we;ll make a good team dinner on that Wed night together
22:12:55 <adrian_otto> questions about the Midcycle?
22:13:14 <sdake_> is there soda on site
22:13:18 <sdake_> or should I pack a cooler ;)
22:13:21 <juggler> is there a call-in number for remotes?
22:13:23 * sdake_ can't live without soda
22:13:30 <juggler> or IRC only?
22:13:31 <Tango> Soda provided :)
22:13:36 * adrian_otto will be sure sdake remains caffeinated at all times
22:13:42 <sdake_> cool thansk tang o: )
22:13:52 <daneyon> juggler i setup a webex
22:13:56 <sdake_> juggler we will roll with webex
22:14:00 <adrian_otto> ok, let's hand off to daneyon for a moment
22:14:02 <juggler> cool beans
22:14:03 <daneyon> the dets should be in the midcycle url above
22:14:04 <adrian_otto> #topic Container Networking Subteam Update
22:14:14 <daneyon> I was in training last week, but I have been adding to the etherpad this week. My focus has been to develop content to the spec draft.
22:14:19 <daneyon> link https://etherpad.openstack.org/p/magnum-native-docker-network
22:14:24 <daneyon> A lot more to come over the next week.
22:14:29 <daneyon> Those interested, please review the content that I’m adding to the spec draft sections and provide your feedback in the etherpad.
22:14:38 <adrian_otto> ok, cool. Thanks.
22:14:46 <daneyon> The networking subgroup will meet this Thursday to continue to collab on t he networking spec
22:14:51 <daneyon> #link https://wiki.openstack.org/wiki/Meetings/Containers#Container_Networking_Subteam_Meeting
22:14:56 <daneyon> ^ for details
22:15:04 <adrian_otto> that's Thursdays at 1800 UTC, correct?
22:15:04 <daneyon> meeting details that is
22:15:13 <adrian_otto> thanks for the link daneyon
22:15:15 <daneyon> i believe so
22:15:18 <daneyon> let me double check
22:15:40 <daneyon> yes, 1800 utc
22:15:42 <adrian_otto> #topic Review Action Items
22:15:48 <daneyon> Docker is having an online metope this Thursday.
22:15:58 <adrian_otto> 1) madhuri to kick off thread about cert provided by stackforge project anchor
22:15:59 <daneyon> one more sec adrian_otto
22:16:04 <daneyon> Docker is having an online metope this Thursday.
22:16:09 <daneyon> #link http://www.meetup.com/Docker-Online-Meetup/events/223796871/
22:16:10 * adrian_otto pausing
22:16:15 <daneyon> I highly suggest attending the meetup if you plan to contribute to magnum networking.
22:16:38 <adrian_otto> +1
22:16:44 <daneyon> otherwise, i look forward to getting together with the net subteam this thurs. feel free to pingme with any questions
22:16:46 <daneyon> thx
22:17:02 <adrian_otto> ok, so in reference to madhuri's action item
22:17:04 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/068993.html Magnum as a CA
22:17:15 <adrian_otto> Status: COMPLETE
22:17:28 <adrian_otto> 2) All core reviewers to review https://review.openstack.org/#/c/194905/
22:17:34 <adrian_otto> Status: Ongoing
22:17:52 <adrian_otto> I can carry that forward if you'd like to keep bird dogging it.
22:18:17 <madhuri_> sure adrian_otto
22:18:33 <adrian_otto> #action All core reviewers to review https://review.openstack.org/194905
22:18:46 <adrian_otto> 3) adrian_otto to begin an ML thread for https://review.openstack.org/194905
22:18:50 <adrian_otto> Status: COMPLETE
22:19:05 <adrian_otto> 4) adrian_otto to assist xu_ with starting an ML thread about the Hyper blueprint for Magnum
22:19:10 <adrian_otto> Status: COMPLETE
22:19:16 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/069402.html ML Thread for Hyper/Magnum Integration
22:19:27 <adrian_otto> 5) adrian_otto to select a date for the Midcycle and announce to the team members
22:19:30 <adrian_otto> Status: COMPLETE
22:19:39 <adrian_otto> #link https://wiki.openstack.org/wiki/Magnum/Midcycle Magnum Midcycle Details
22:19:53 <adrian_otto> that concludes all action item follow-ups
22:19:57 <adrian_otto> next topic
22:20:01 <adrian_otto> #topic Discuss Future of heat-coe-templates
22:20:07 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/068237.html ML Discussion (June)
22:20:12 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/068381.html ML Discussion (July)
22:20:51 <adrian_otto> proposal is to delete heat-coe-temlates, and maintain the code we have separately from the upstream, which will remain in github, not stackforge
22:20:57 <adrian_otto> thoughts on this?
22:21:23 <tcammann1> I don't see this repo working with larsks' repo and he seems to have different aims for the templates
22:21:36 <daneyon> has larsks provided any feedback on this?
22:21:54 <adrian_otto> no, daneyon he has not responded on this topic
22:22:04 <tcammann1> And we aren't getting the required attention on the h-c-t repo to make it useful
22:22:10 <daneyon> tcammann1 can u elaborate on larsks' diff aims?
22:22:37 <sdake_> i asked larsks atlaest 3 times to respond on that thread
22:22:44 <sdake_> he said he would, but has not ;)
22:22:45 <sdake_> so I don't know what else can be done
22:22:59 <tcammann1> He isn't targeting Magnum, he has added several features that aren't compatible with Magnum
22:23:10 <hongbin> +1
22:23:28 <sdake_> if we do delete the heat-coe-template repo, (actually put in attic) we should cut trying to keep the two in sync
22:23:30 <tcammann1> autoscaling and load generators to name a couple
22:23:37 <sdake_> one should be a fork of another
22:23:38 <daneyon> tcammann1 can you give us an example of one of the unsupported features that were added?
22:23:42 <sdake_> a permanent fork
22:23:45 <daneyon> nm
22:23:49 <adrian_otto> so we should express our appreciation for the kickstart this gave us, and acknowledge we are heading different enough directions to warrant a split
22:24:10 <tcammann1> agree
22:24:13 <sdake_> ya we tried to fix the fork problem with heat-coe-tempaltes but it seems like thats more trobule then its worth to everyoene involved
22:24:26 <adrian_otto> but daneyon's questions are valid… so I'll address it this way...
22:24:39 <daneyon> would autoscaling and load generators be features that magnum will eventually want?
22:25:00 <tcammann1> We are doing autoscaling significantly differently, and no we don't want a load geneartor
22:25:00 <sdake_> I find it highly unlikely his autoscaling actually works properly ;-)
22:25:06 <adrian_otto> tcammann volunteered to help consolidate our downstream changes with the stackforge upstream, and that has become a high friction effort for relatively low value
22:25:23 <adrian_otto> if nobody is consuming heat-coe-templated besides magnum, then it might as well be in our source tree
22:25:26 <daneyon> good point
22:25:32 <sdake_> it would make sense if larsks had intent to delete larsks/heat-kubernetes, but he does not
22:25:44 <sdake_> so we will always have 3 repos to deal with rather then one
22:26:03 <sdake_> we aren't actually consuming the library atm
22:26:07 <sdake_> so its dead code for the most part
22:26:14 <sdake_> straight to the attic with no code changes in magnum
22:26:14 <adrian_otto> so, we can delete the stackforge one, and keep an eye on the github one for enhancements that may help us
22:26:24 <tcammann1> +1
22:26:26 <adrian_otto> and selectively cherry pick things that make sense
22:26:50 <hongbin> agree
22:27:03 <eghobo> +1
22:27:07 <yuanying-alt> +1
22:27:30 <adrian_otto> ok, so that's a point of view that tcammann1 and hongbin, and sdake, eghobo, and yuanying-alt, and I agree on. Are there opposing points of view to hear before a decision?
22:27:38 <sdake_> its too bad larsks changed his mind but oh well +1
22:27:39 <daneyon> so, any heat template updates should be made here instead of h-c-t stackforge
22:27:41 <daneyon> #link https://github.com/openstack/magnum/tree/master/magnum/templates
22:27:56 <sdake_> daneyon ack
22:28:06 <daneyon> thx
22:28:08 <sdake_> and someone should move heat-coe-templates to attic
22:28:17 <juggler> not opposing here. is there any value to an archival copy of that stackforge one? [in other words, is the delete absolute and final?]
22:28:17 <adrian_otto> dane_leblanc: yes, or also to the upstream if they are not Magnum specific and you want to be a good open source citizen
22:28:30 <sdake_> juggler you can't delete stackforge projects, they go to an attic
22:28:33 <adrian_otto> sorry dane_leblanc, that was for daneyon
22:28:34 <sdake_> where they are permanent
22:28:41 <juggler> ah, cool
22:28:43 <juggler> +1 then
22:29:14 <adrian_otto> tcammann1: are you willing to own the task of putting it into attic?
22:29:22 <juggler> thx sdake
22:29:34 <adrian_otto> ok, I'm not hearing any opposition, so I'm going to record this as an #agreed
22:29:50 <tcammann1> adrian_otto: yep
22:30:41 <adrian_otto> #agreed tcammann will move heat-coe-templates to the attic, and we will maintain the existing fork in the magnum tree for Magnum heat templates at https://github.com/openstack/magnum/tree/master/magnum/templates
22:30:55 <adrian_otto> if there are objections, I can still undo.
22:31:21 <sdake_> i think itw ould be helpful to annoucne on ml the retirement of that repo
22:31:26 <sdake_> and the reason behind it
22:31:45 <sdake_> and the reason it was created in teh first place ;)
22:31:52 <adrian_otto> #action tcammann to move heat-coe-templates repo to project attic, and to relay our resolution on the ML thread: http://lists.openstack.org/pipermail/openstack-dev/2015-July/068381.html
22:31:53 <sdake_> (bhind the retirement)
22:32:04 <tcammann1> ok!
22:32:29 <sdake_> wfm - such a shame but oh well :)
22:32:52 <adrian_otto> also, it would be helpful, tcammann1 if you would find the original thread, and follow up to that one too with a link to the relevant archived message
22:32:58 <adrian_otto> does that make sense?
22:33:13 <adrian_otto> the one where we discussed the creation of that repo
22:33:28 <adrian_otto> #topic Keystone Support and Devstack Broken Gate
22:33:30 <sdake_> ya thread necromancy generally bad idea but i guess it couldn't hurt here
22:33:45 <adrian_otto> Magnum's gates broke on 7/10 because of a change in Devstack.
22:33:46 <tcammann1> :) sdake_ adrian_otto can do also
22:33:59 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/069398.html Problem Overview
22:34:15 <adrian_otto> long term this gets obviated by:
22:34:17 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-keystone-v3 Keystone v3 API Support Blueprint
22:34:28 <adrian_otto> The actual issue was solved by merging workaround from Hongbin:
22:34:42 <tcammann1> thanks for that hongbin
22:34:44 <adrian_otto> #link https://review.openstack.org/200835 Workaround for Devstack bug
22:34:52 <juggler> yeah hongbin!
22:34:53 <adrian_otto> Once Devstack is fixed, we can back this back out in accordance with:
22:34:58 <hongbin> NP
22:34:59 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1474152 Tech Debt: Reverse temporary gate fix
22:34:59 <openstack> Launchpad bug 1474152 in Magnum "Tech Debt: Reverse temporary gate fix" [Low,Triaged]
22:35:13 <adrian_otto> any questions on this?
22:36:05 <adrian_otto> #topic Blueprint/Bug Review
22:36:17 <adrian_otto> New Blueprints for Discussion
22:36:23 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/hyperstack Power Magnum to run on metal with Hyper
22:36:37 * adrian_otto looks for the ML thread link
22:37:15 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/068574.html Hyper Magnum Integration Discussion
22:37:33 <adrian_otto> there are open questions with active discussion
22:37:42 <adrian_otto> please keep an eye on that one
22:37:54 <adrian_otto> it could potentially be a compelling feature for us
22:38:11 <adrian_otto> any concerns? If not I will revisit it next week
22:38:15 <sdake> i like the idea, would be nice if it ran a coe on top
22:38:26 <sdake> such as kubernetes/etc
22:38:29 <sdake> rather then just raw docker
22:38:34 <adrian_otto> sdake: it might actually work under another coe
22:38:49 <hongbin> So the integration point is k8s or magnum?
22:38:50 <sdake> i get that, I htink that is what I just said ;0
22:38:50 <adrian_otto> so you might use it in combination with our existing Bay types
22:38:52 <eghobo> I am still not sure why integration need to be done at Magnum level
22:39:07 <adrian_otto> eghobo: that's one of the questions in the thread
22:39:18 <adrian_otto> I suggested that it might make more sense as a nova virt driver
22:39:38 <eghobo> I have the same opnion
22:39:56 <hongbin> That nova team accept the proposal, then it makes sence
22:39:57 <adrian_otto> ok, we'll come back to this again next week
22:40:05 <adrian_otto> Essential Blueprint Updates
22:40:09 <eghobo> or they need to integrate with Kub or Messos
22:40:13 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/objects-from-bay Obtain the objects from the bay endpoint (sdake)
22:40:24 <sdake> so i've spent some more time on this
22:40:31 <sdake> it needs to be broken into two peices at minimum
22:40:35 <sdake> peice one is read operations
22:40:39 <sdake> piece two is write operations
22:40:46 <sdake> read easier then write
22:41:02 <sdake> i have not written much code at all
22:41:08 <sdake> mainly because devstack is busted on f21 atm
22:41:12 <sdake> so i am unable to do dev
22:41:27 <adrian_otto> is this at risk, or should we remain calm?
22:41:29 <daneyon> or magnum will need to support different container runtimes per bay or within a bay
22:41:36 <sdake> remain calm for l3
22:41:38 <sdake> at risk for l2
22:41:42 <adrian_otto> ok
22:41:49 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-kubernetes Secure the client/server communication between ReST client and ReST server (madhuri)
22:41:55 <adrian_otto> madhuri_: ^^
22:42:10 <adrian_otto> this one is at risk
22:42:18 <madhuri_> Agree
22:42:23 <adrian_otto> I'm escalating with the Barbican team on the CA portion
22:42:31 <sdake> is the client all set madhuri?
22:42:33 <madhuri_> I just saw reply mail
22:42:34 <sdake> or do you need hep there
22:42:37 <madhuri_> Yes
22:42:37 <adrian_otto> if that effort fails, we'll need a plan-B
22:42:44 <madhuri_> Client all set
22:42:49 <sdake> lets try to bring in Dave McCowan
22:42:52 <sdake> he is keen to work in this area
22:42:54 <madhuri_> Yes we need a B-plan for sure
22:42:59 <sdake> although he said he may nto be available for antoher week or more
22:43:14 <sdake> he is definately a security expert
22:43:22 <sdake> he is the cat who wrote the doc for us that got us kicked off
22:43:24 <madhuri_> That would be a great help sdake
22:43:25 <adrian_otto> ok, madhuri_ if we don't eel comfortable by your end of day thursday
22:43:36 <adrian_otto> let's get on the ML and arrange a Plan-B
22:43:47 <madhuri_> +1 adrian_otto
22:43:51 <adrian_otto> thanks sdake
22:44:02 <juggler> thx madhuri/sdake
22:44:05 <adrian_otto> feel free to ping me at that time
22:44:12 <madhuri_> Sure
22:44:16 <adrian_otto> next BP
22:44:17 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/external-lb Support the kubernetes service external-load-balancer feature (sdake)
22:44:28 <sdake> i dont know why that is assigned to me
22:44:30 <adrian_otto> Tango: ^
22:44:35 <sdake> isn't thtat tango's blueprint?
22:44:38 <adrian_otto> I will fix that for next week, sorry
22:44:44 <Tango> Yep :)
22:44:47 <adrian_otto> it's just wrong in the agenda
22:44:51 <sdake> ok
22:45:00 <sdake> ya i'm at capacity
22:45:41 <Tango> I made some progress, got version 0.19 to run on Magnum
22:45:50 <adrian_otto> oh, good!
22:45:56 <Tango> It was configuration, as sdake said
22:46:09 <sdake> tango note we will want ot get the kube dudes to fix problems soon as they release in a week I think :)
22:46:30 <Tango> It was just not documented anywhere so it was painful to discover
22:46:52 <adrian_otto> Tango: do you have enough help to succeed with this?
22:46:54 <madhuri_> bad documentation, agree Tango
22:47:30 <juggler> is it documented somewhere now?
22:47:48 <sdake> tango any bugs for the template to be corrected then?
22:48:07 <sdake> we will want magnum to run on kube master soon because middle of july is release of kube 1.0
22:48:22 <Tango> Yes, I will update the template when we decide to move on to the newer version
22:48:39 <adrian_otto> what is gating that decision?
22:48:47 <sdake> lets move now
22:48:51 <eghobo> actually next Tue ;)
22:48:52 <sdake> as soon as the tempaltes are working
22:49:14 <sdake> typically it taes u 3-5 days to fix the templates after a major revision
22:49:14 <Tango> I do have an issue with the image building for atomic.
22:49:20 <sdake> so lets suffer the pain now
22:49:47 <adrian_otto> Agreed, let's get on that version. We are going to have to do it before the Liberty release anyway
22:49:51 <Tango> One of the binary is broken and I am not sure why:  kube-apiserver
22:50:13 <adrian_otto> ok, that's a good reason not to
22:50:16 <Tango> I have to work around, so that's why the templates are not in perfect shape yet
22:50:51 <Tango> I mean the binary is OK, just that when we create the Atomic image, Atomic broke it somehow
22:50:55 <adrian_otto> ok, so as soon as that's resolved, let's proceed to moving to 0.19
22:51:19 <Tango> Yes, I will line up the patches to move on
22:51:21 <sdake> it must be the nulecule
22:51:37 <juggler> nulecule?
22:51:37 <adrian_otto> ok, thanks
22:51:40 <sdake> tango make sure to put in a request people actually test it rather then eyeball it
22:52:24 <adrian_otto> ok, I have a couple more BP's to get stauts on
22:52:26 <sdake> and i can ad dyou to the magnum group so you can upload the image
22:52:33 <sdake> contact me offline
22:52:41 <Tango> ok
22:52:42 <adrian_otto> thanks for your help with this sdake
22:52:44 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-swarm-scheduling Provide container anti-affinity through swarm constraint filtering (diga)
22:52:54 <adrian_otto> I'm not sure why we marked this one as Essential
22:53:03 <sdake> me either
22:53:04 <adrian_otto> I think it's important, but I think we could live without it
22:53:06 <sdake> doesn't look essential
22:53:17 <adrian_otto> I'm planning to downgrade it to a Medium
22:53:26 <adrian_otto> unless there is a good reason to keep it as-is
22:54:17 <adrian_otto> it is now a medium. I am willing to revisit it if there is/are (a) compelling argument(s) to consider
22:54:29 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-docker Secure client/server communication using TLS (apmelton)
22:54:32 <juggler> +1
22:54:51 <adrian_otto> apmelton is not present today
22:55:14 <mfalatic> +1
22:55:39 <adrian_otto> this one is a liberty-2 deliverable
22:55:58 <adrian_otto> still marked as Not Started
22:56:18 <tcammann1> Think its heavily linked to the other TLS blueprint, and waiting on the outcome of it
22:56:35 <adrian_otto> tha's what the dependency tree shows
22:57:01 <adrian_otto> basically to implement this we take the same pattern we use in k8s bays, and apply it to Swarm bays
22:57:18 <adrian_otto> so that should be a modest effort
22:57:29 <sdake> probably not going to hit l2
22:57:36 <adrian_otto> madhuri_: is this something you might be willing to tackle once we get the others solved?
22:57:55 <madhuri_> If done with Kubernetes, I will take it
22:58:04 <adrian_otto> ok, I'll add you as a subscriber
22:58:11 <madhuri_> Thanks
22:58:28 <adrian_otto> done
22:58:34 <adrian_otto> ok, that brings us to open discussion
22:58:39 <adrian_otto> with only a moment remaining
22:58:44 <adrian_otto> #topic Open Discussion
22:58:53 <mfalatic> Thanks to all who helped me update the docs!
22:59:03 <adrian_otto> mfalatic: thanks for staying on-task for that
22:59:04 <mfalatic> Also, be advised that tox is broken
22:59:14 <sdake> sounds like needs fixing ;-)
22:59:17 <dane_leblanc> I had a question on the redis example in the quick-start guide, I think it's just a redis issue, if anyone's familiar. Brought it up on the ml: http://lists.openstack.org/pipermail/openstack-dev/2015-July/069357.html
22:59:19 <mfalatic> the mock requirements update means that if you have an old virtualenv it won't work
22:59:34 <mfalatic> e.g., ubuntu 14.04
22:59:43 <madhuri_> Magnum gate was faling yesterday due to new taskflow release
22:59:45 <mfalatic> you have to upgrade virtualenv
22:59:50 <mfalatic> https://rbtcollins.wordpress.com/2015/07/12/bootstrapping-developer-environments-for-openstack/
23:00:02 <adrian_otto> Our next meeting is on 2015-07-21 at 1600 UTC. I look forward to seeing you then!
23:00:07 <mfalatic> or just hammer it with sudo pip install -U virtualenv
23:00:09 <adrian_otto> (sorry I have to end now)
23:00:10 <mfalatic> ok
23:00:17 <adrian_otto> #endmeeting