22:01:17 <adrian_otto> #startmeeting containers
22:01:18 <openstack> Meeting started Tue Jun 16 22:01:17 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:22 <openstack> The meeting name has been set to 'containers'
22:01:35 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-06-16_2200_UTC Our Agenda
22:01:41 <adrian_otto> #topic Roll Call
22:01:44 <adrian_otto> Adrian Otto
22:01:50 <hongbin> o/
22:01:51 <juggler_> Perry Rivera
22:01:53 <mismith> Mike Smith
22:01:54 <rpothier> Rob Pothier
22:01:54 <Tango> Ton Ngo
22:01:55 <yuanying-alt> OTSUKA, Motohiro
22:01:55 <dane_leblanc> Dane LeBlanc
22:01:56 <eghobo> o/
22:01:56 <chirag_> Chirag Arora
22:02:06 <sdake_> o/
22:02:29 <tcammann_> hello there
22:02:39 <juggler_> hey all
22:02:45 <diga__> o/
22:03:01 <adrian_otto> hello hongbin juggler_ mismith rpothier Tango yuanying-alt dane_leblanc eghobo chirag_ sdake_ tcammann_ and diga__
22:03:18 <brendenblanco> Hi all
22:03:18 <sdake> adrian_otto do you have a bot  to type that in or do you do it manually
22:03:29 <mfalatic> o/
22:03:37 <tcammann_> He has the tab button to help!
22:03:42 <sdake> haha :)
22:03:45 <adrian_otto> sdake: I type!
22:03:55 <adrian_otto> but I also use tab completion ;-)
22:04:15 <adrian_otto> welcome everyone, let's begin here in just a moment.
22:04:18 <apmelton> o/
22:04:38 <adrian_otto> hello daneyon and apmelton
22:04:43 <daneyon> hey
22:04:46 <apmelton> yo yo
22:04:52 * sdake needs more minerals
22:04:56 <juggler> o/
22:05:11 <adrian_otto> Our theme for today's meeting is "Adopt the Orphans" ;-)
22:05:27 <mfalatic> Martin Falatic checking in
22:05:29 <juggler> ha
22:05:34 <adrian_otto> #topic Announcements
22:05:42 <thomasem> o/
22:06:29 <adrian_otto> 1) adrian_otto will be on vacation starting 2015-06-19 and will be back to work again 2015-07-05. sdake has agreed to chair our team meetings while I am out.
22:06:39 <adrian_otto> hello thomasem and mfalatic
22:06:52 <juggler> cheers sdake
22:06:59 <thomasem> hi hi
22:07:02 <sdake> i need a beer!
22:07:04 <adrian_otto> any announcements from team members?
22:07:17 * adrian_otto hands an ice cold beet to sdake
22:07:21 <adrian_otto> haha
22:07:24 <adrian_otto> a beet
22:07:27 <adrian_otto> s/beet/beer/
22:07:39 <thomasem> What a substantial difference
22:07:47 <tcammann_> haha pulling beetroots out of the freezer
22:07:50 <dane_leblanc> What a beeting
22:07:52 <adrian_otto> #topic Review Action Items
22:07:52 <apmelton> apparently beet beer is a thing
22:08:05 <sdake> apmelton not in my household :)
22:08:05 <adrian_otto> 1) diga__ to contact ewindsich regarding Swarm+Mesos questions
22:08:10 <adrian_otto> diga__: status?
22:08:47 <diga__> adrian_otto: yes, I mailed him, I am again sending mail to him today by including you
22:09:01 <sdake> ya I got an action
22:09:03 <adrian_otto> ok, should I carry the action item forward to follow up next week?
22:09:03 <sdake> that needs addressing
22:09:12 <diga__> didn;t receive response yet from ewindsich
22:09:22 <adrian_otto> sdake: hang on just one sec, pls
22:09:25 <sdake> will do
22:09:39 <adrian_otto> #action diga__ to follow up with ewindsich regarding Swarm+Mesos questions
22:09:49 <diga__> yep
22:09:51 <adrian_otto> next action...
22:09:52 <adrian_otto> 2) jay-lau-513 Clarify human name generation algorithm plans in BP
22:10:21 <adrian_otto> Jay is not here today because this is a ridiculous time of day for him
22:10:34 <juggler> excuses! :)
22:10:38 <adrian_otto> anyone have discussions on this topic who can share updates?
22:10:52 <adrian_otto> I will carry it forward
22:11:02 <adrian_otto> #topic jay-lau-513 Clarify human name generation algorithm plans in BP
22:11:11 <adrian_otto> #topic Review Action Items
22:11:14 <adrian_otto> #action jay-lau-513 Clarify human name generation algorithm plans in BP
22:11:19 <adrian_otto> that's better.
22:11:32 <adrian_otto> how about this topic:
22:11:33 <adrian_otto> 3) jay-lau-513 Seek consensus on duplicate names on ML
22:11:43 <diga__> I think it is decided to discuss this topic in the meeting
22:11:51 <adrian_otto> the thread concluded that we should auto-generate names
22:12:00 <diga__> yes
22:12:02 <tcammann_> +1
22:12:04 <adrian_otto> with an option to relax unique constraints, correct?
22:12:17 <diga__> yes
22:12:25 <adrian_otto> do we need further discussion on this topic or do we have a clear consensus to proceed?
22:12:36 <tcammann_> lgtm
22:12:36 <adrian_otto> anyone opposed to a #agreed on this point?
22:12:53 <diga__> jay-lau is following docker algorithm for this
22:13:07 <sdake> sounds friieghtening :)
22:13:40 <diga__> :)
22:13:40 <adrian_otto> #agreed Magnum contributors support unique name requirements by default with an option to disable the constraint. If no name is provided at the time of resource creation, a human readable name will be dynamically generated and automatically assigned.
22:13:49 <adrian_otto> I can undo that if there are any objecitons
22:14:20 <apmelton> adrian_otto: unique per tenant?
22:14:21 <adrian_otto> ok, sdake you have the floor for action item review
22:14:23 <sdake> definately a new pattern in openstack ;)
22:14:31 <sdake> no review
22:14:31 <sdake> a requet
22:14:34 <sdake> forwarded from Madhuri
22:14:36 <adrian_otto> apmelton: yes, per tenant, as proposed in our ML thread
22:14:52 <adrian_otto> ok, proceed
22:15:00 <sdake> adrian_otto could you make a non-sharktank introduction to someone responsible in engineering for TLS to Madhuri via email
22:15:05 <sdake> and somehow get that work prioritized
22:15:18 <sdake> she is blocked because we think kubernetes is busted
22:15:31 <sdake> and #google-containers is completely unhelpful forsolving the problem
22:15:39 <adrian_otto> sdake: you mean a Kubernetes dev?
22:15:49 <sdake> someone that knows something about the tls side of  things
22:15:58 <adrian_otto> yes, I can take an action for that intro
22:16:01 <sdake> you may ahve to go thorug hthe sharktank to find the right person :)
22:16:02 <sdake> thanks
22:16:08 <tcammann_> on the same topic of the TLS work, I would really like to see a spec before we start this work formally
22:16:28 <eghobo> sdake: have you heard that kub 1.0 coming within month
22:16:36 <sdake> have not heard
22:16:38 <adrian_otto> #action adrian_otto to help Madhuri identify a resource on the Kubernetes team who can assist us with TLS feature implementation
22:16:40 <sdake> but thats fantastic news :)
22:16:45 <adrian_otto> sdake: does that look good?
22:16:52 <sdake> wfm adrian_otto
22:16:57 <adrian_otto> cool
22:16:58 <eghobo> http://www.kuberneteslaunch.com/
22:17:36 <apuimedo> sorry I'm late
22:17:37 <adrian_otto> eghobo: let's revisit that one in open discussion
22:17:44 <adrian_otto> hello apuimedo
22:17:49 <apuimedo> hi
22:18:19 <adrian_otto> okay, so from 22:18 UTC to 22:28 UTC (or less) sdake will lead us in a brainstorming exercise
22:18:25 <sdake> yay
22:18:28 <adrian_otto> #topic Collaborative brain storm session on etherpad (#link https://etherpad.openstack.org/p/magnum-functional-test-cases) - time boxed to 10 minutes - sdake to take results and create separate bugs per test case
22:18:30 <adrian_otto> proceed
22:18:48 <adrian_otto> #link https://etherpad.openstack.org/p/magnum-functional-test-cases
22:18:49 <sdake> ok folks log in to etherpad - make sure to put your name in the upper right hand corner so we know who added what
22:18:50 <apuimedo> (was the network blueprint discussed?)
22:19:05 <sdake> I'm going to file sepearte bugs for each of these test cases
22:19:23 <sdake> write as many test cases as you can think of that we should add to the functional gate
22:19:57 <adrian_otto> As you can see I bombed the etherpad with a big outline of things
22:20:23 <sdake> looks like someone was busy here ;)
22:20:23 <adrian_otto> but that's not use-case specific, it's more of an anti-regression test plan for avoiding mega-problems
22:20:32 <sdake> ya start fresh at the top
22:20:41 <sdake> line 12 plz
22:20:45 <sdake> i'll sort em out later
22:20:53 <sdake> just write whatever comes to mind
22:21:44 <mfalatic> Seems like Adrian's 1-6 are all pretty important and basic.
22:23:07 <sdake> ok folks, start adding test cases line 12 :)
22:23:18 <sdake> there is 15 people loggedi nto the etherpad there should be atleast 15 test cases by now :)
22:23:39 <adrian_otto> apuimedo: we will get to Blueprint discussion after this
22:23:52 <apuimedo> good :-)
22:24:03 <mismith> I'm an admitted lurker…first time at one of these meetings.  Pretty cool to see things in action
22:24:09 * adrian_otto indicates 5 minutes remaining for brainstorm (half-way point)
22:24:23 <adrian_otto> mismith: we are happy to have you
22:24:49 <mismith> Cool.  I had my team at Overstock watch your vancouver video in our last meeting :)
22:25:14 <sdake> recommend not reading other peoples test cases just put yours in
22:25:32 <sdake> i'll collate em
22:25:40 <sdake> is that the right word?
22:25:41 <sdake> who knows :)
22:25:55 <sdake> i'm like an all in one fax machine
22:26:05 <sdake> taking any test cases :)
22:27:33 * adrian_otto indicates one minute remaining for scheduled brainstorming
22:28:31 <sdake> just a quick note, i'm going to leave hese new wishlist bugs unassigned
22:28:32 <adrian_otto> ok, this concludes our timebox for the brainstorm
22:28:34 <sdake> if folks wnat to pick em up feel free
22:28:42 <adrian_otto> thanks for initiating that one sdake
22:28:44 <sdake> if you want to add more this week, knock yourself out
22:28:55 <sdake> i'll file the bugs next monday
22:29:01 <adrian_otto> next up
22:29:06 <adrian_otto> #topic Blueprint/Bug Review
22:29:13 <adrian_otto> Tasks/Bugs
22:29:21 <adrian_otto> #link http://goo.gl/sIlYla High and Critical Priority Bugs
22:29:30 <adrian_otto> these are the things we can't afford to miss
22:29:40 <adrian_otto> I identified 4 orphans
22:29:54 <adrian_otto> let's see about adopting any that are still orphaned
22:29:58 <adrian_otto> Orphans
22:30:05 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1412380 Magnum Documentation link report 404 error
22:30:07 <openstack> Launchpad bug 1412380 in Magnum "Magnum Documentation link report 404 error " [High,In progress]
22:30:15 <adrian_otto> in progress, but with no owner
22:30:19 <tcammann_> documentation 404 makes me sad :(
22:30:21 <adrian_otto> I can fix that one
22:30:36 <adrian_otto> next is
22:30:38 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1444368 Bay status is still CREATE_IN_PROGRESS after stack create failed
22:30:40 <openstack> Launchpad bug 1444368 in Magnum "Bay status is still CREATE_IN_PROGRESS after stack create failed" [High,Confirmed]
22:30:43 <mismith> That 404 comes up for me :)
22:31:11 <adrian_otto> any takers for this one?
22:31:25 <adrian_otto> seems like convergence may actually be the answer
22:31:35 <tcammann_> this might be fixed now?
22:31:45 <adrian_otto> possible.
22:32:01 <tcammann_> need some proper logs to reproduce it etc
22:32:27 <adrian_otto> I can set it back to incomplete to ask for steps to reproduce and logs
22:32:35 <tcammann_> +1
22:32:41 <tcammann_> need heat logs
22:33:10 <adrian_otto> done
22:33:34 <adrian_otto> tcammann_: please add additional remarks on that bug to guide the submitter to get us exactly what is needed
22:33:45 <tcammann_> sure
22:33:49 <adrian_otto> next is
22:33:50 <adrian_otto> #link https://bugs.launchpad.net/magnum/+bug/1451118 magnum throws db exception on failed bay deletion
22:33:51 <openstack> Launchpad bug 1451118 in Magnum "magnum throws db exception on failed bay deletion" [High,Triaged]
22:34:34 <adrian_otto> this one wants an owner
22:35:11 <adrian_otto> the last orphan I have on the agenda was bogus, so I won't cover that.
22:35:33 <adrian_otto> basically we thgouht that scale down events in ResourceGroups caused all nodes to be replaced
22:35:41 <diga__> I will take this
22:35:45 <adrian_otto> that was an issue in Heat long ago that has since been fixed
22:35:51 <adrian_otto> thanks diga__
22:35:56 <sdake> yjsy odm
22:35:56 <adrian_otto> please assign yourself
22:35:56 <tcammann_> oh fantastic :)
22:36:01 <sdake> that isn't what i thought
22:36:04 <adrian_otto> if you need help let me know
22:36:06 <diga__> adrian_otto: welcome!
22:36:12 <sdake> i thought kubernetes will implode if you delete a minion underneath it :)
22:36:13 <adrian_otto> I proved today that it works properly
22:36:30 <adrian_otto> kubernetes needs to be set up with a proper rc configuration
22:36:37 <adrian_otto> and if you do that, it will heal properly
22:36:50 <adrian_otto> but there is not a heat bug in there
22:37:01 <adrian_otto> Blueprints
22:37:16 <sdake> heal properly as in the container persistent  data will be moved?
22:37:50 <adrian_otto> sdake: no, persistent data is not a feature of k8s so you can only autoscale 12 factor apps
22:38:05 <adrian_otto> #link https://blueprints.launchpad.net/magnum Magnum Blueprints
22:38:24 <adrian_otto> each of the essential bp's should get an update from the assigned owner or delegate
22:38:34 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/async-container-operations
22:38:34 <sdake> what is a 12 factor app? :)
22:38:43 <tcammann_> http://12factor.net/
22:38:44 <adrian_otto> sdake: all state is stored in a db
22:38:55 <sdake> got it wasn't familiar with that term
22:39:14 <adrian_otto> apmelton: any update on async-container-operations?
22:39:18 <apmelton> no update, I might be able to start it before k1, but it definitely won't be finished before k1
22:39:23 <apmelton> er l1
22:39:29 <adrian_otto> ok, I will re-target
22:39:45 <adrian_otto> done
22:40:00 <adrian_otto> next is
22:40:02 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/objects-from-bay
22:40:11 <adrian_otto> sdake: update on this?
22:40:12 <sdake> i bounced that to l2
22:40:17 <adrian_otto> ok, thanks
22:40:21 <sdake> i got some code
22:40:24 <sdake> far from complete
22:40:29 <adrian_otto> next
22:40:31 <sdake> investigating atm
22:40:31 <sdake> its a big job
22:40:31 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-kubernetes
22:40:33 <sdake> xl
22:40:50 <adrian_otto> sdake: we should break it down into smaller bits
22:40:52 <sdake> blocked on kumari intro
22:41:08 <tcammann_> Also think we should put a formal spec together for this bp
22:41:09 <adrian_otto> Madhuri is not here to address the secure-kubernetes blueprint
22:41:11 <sdake> adrian_otto once I figure out how to decompose it i'll file smaller blueprints for it if you like
22:41:17 <adrian_otto> is anyone here as her delegate?
22:41:24 <sdake> i can speak for her
22:41:32 <adrian_otto> sdake: yes, please, or bug tickets that link to the BP.
22:41:32 <sdake> we spoke last night on this topic
22:41:46 <juggler> she expressed the need to speak with someone in the know with tls
22:42:01 <sdake> i intro'ed her ot the guy at csco who wrote the guide for tls setup
22:42:07 <sdake> she needs an intro to a tls cat in google
22:42:16 <sdake> the three of them should be able to sort it out from there
22:42:16 <adrian_otto> ok, so I have the action for that
22:42:22 <juggler> what sdake said :)
22:42:31 <sdake> atm we believe kubernetes is busted
22:42:36 <adrian_otto> ok, any more discussion on this BP?
22:42:49 <adrian_otto> next
22:42:51 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/external-lb
22:42:57 <adrian_otto> Madhuri again
22:43:07 <adrian_otto> Tango
22:43:09 <adrian_otto> sorry
22:43:13 <Tango> Hi :)
22:43:13 <adrian_otto> Tango: update?
22:43:18 <Tango> I have several patches for the Heat temlates to configure Kubernetes services in the bay to talk to Neutron
22:43:26 <Tango> I am adding a few more patches for the conductor to compute the parameters for the templates
22:43:46 <adrian_otto> these are upstream patches, correct?
22:43:56 <adrian_otto> can you please reference them in the BP whiteboard?
22:44:10 <Tango> I think they are linked already
22:44:16 <adrian_otto> ok, good
22:44:20 <Tango> I have been testing the feature with the wordpress example:
22:44:23 <adrian_otto> if there are any new ones, please add them there
22:44:29 <Tango> https://github.com/GoogleCloudPlatform/kubernetes/tree/master/examples/mysql-wordpress-pd
22:44:37 <Tango> So for the functional test, I will see if we can run a variation of this.
22:44:44 <adrian_otto> excellent
22:44:46 <Tango> The OpenStack plugin seems to be still in development.
22:44:50 <daneyon> upstream patches being #link https://github.com/stackforge/heat-coe-templates
22:44:53 <adrian_otto> this is targeted for kilo
22:44:57 <Tango> There was a patch included in the latest release 0.19, and I see at least another WIP patch.
22:45:05 <adrian_otto> I would like to pull it into liberty-2
22:45:10 <adrian_otto> is that realistic?
22:45:18 <apmelton> when's liberty-2 end?
22:45:27 <adrian_otto> 2 months form now
22:45:31 <sdake> july31
22:45:31 <adrian_otto> *from
22:45:44 <Tango> For the external LB?
22:46:12 <adrian_otto> yes, Tango
22:46:20 <sdake> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
22:46:20 <Tango> We can get everything from our side
22:46:35 <sdake> we need it from kube side before they pull triggeron 1.0
22:46:44 <Tango> but there will be some dependency on Kubernetes code
22:46:59 <mfalatic> FYI, I'm interested in taking on https://bugs.launchpad.net/magnum/+bug/1444368
22:47:00 <openstack> Launchpad bug 1444368 in Magnum "Bay status is still CREATE_IN_PROGRESS after stack create failed" [High,Incomplete]
22:47:23 <adrian_otto> mfalatic: please touch base with diga__ on that and split the work as needed
22:47:32 <Tango> Currently, when I try Kubernetes version 0.18 or 0.19 on our Fedora Atomic VM, the services crash with:
22:47:40 <Tango> panic: runtime error: invalid memory address or nil pointer dereference
22:47:44 <adrian_otto> unles he was volunteering for something else
22:47:52 <Tango> Not sure if the image needs updating, so I am building a new Fedora Atomic image with tutelage from sdake
22:47:57 <mfalatic> oh
22:48:09 <adrian_otto> Tango: let's follow up on the ML about this
22:48:16 <Tango> ok
22:48:20 <adrian_otto> best way to deal with situations like this is to make them highly visible
22:48:26 <adrian_otto> can I assign you an action?
22:48:32 <Tango> sure
22:49:01 <adrian_otto> #action Tango to start and ML discussion to explain trouble with Magnum/K8s integration for LB (https://blueprints.launchpad.net/magnum/+spec/external-lb)
22:49:02 <adrian_otto> thanks
22:49:03 <adrian_otto> next
22:49:23 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/magnum-swarm-scheduling (diga__)
22:49:34 <diga__> yes
22:49:39 <adrian_otto> I think this is actually solved, and needs to be withdrawn, correct?
22:49:47 <adrian_otto> or is there more to it?
22:50:25 <diga__> yes, but never got time to work on this, please set target for l2
22:50:32 <adrian_otto> ok, retargeting
22:50:37 <sdake> i htink it is solved by swarm
22:50:40 <tcammann_> At the summit didn't we discuss to only use native scheduling?
22:50:46 <sdake> we agreed at summit we wouldn't do custom scheduling
22:50:50 <adrian_otto> done
22:50:55 <adrian_otto> sdake: +1
22:51:00 <adrian_otto> at least not at this stage
22:51:23 <adrian_otto> next
22:51:28 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/secure-docker (apmelton)
22:51:41 <mfalatic> Ok, so sounds like diga__ is working https://bugs.launchpad.net/magnum/+bug/1444368 and just isn't names in launchpad for some reason.
22:51:42 <openstack> Launchpad bug 1444368 in Magnum "Bay status is still CREATE_IN_PROGRESS after stack create failed" [High,Incomplete]
22:51:42 <adrian_otto> this is in new status
22:51:57 <apmelton> not started
22:52:10 <diga__> adrian_otto: yes
22:52:21 <sdake> apmelton there is a guide kicking around somewhere how to do tls
22:52:31 <sdake> apmelton recommend reading before beginning
22:52:31 <adrian_otto> want to pull in volunteers to help?
22:52:51 <adrian_otto> owning a blueprint only means that you have to respond to status inquiries and coordinate the effort
22:52:58 <adrian_otto> you can get as many contributors to help you as you want
22:53:13 <sdake> *can convince :)
22:53:15 <apmelton> actually, this piece is going to be pretty dependent on how k8s handles tls
22:53:34 <diga__> https://bugs.launchpad.net/magnum/+bug/1444368 & https://bugs.launchpad.net/magnum/+bug/1451118
22:53:36 <openstack> Launchpad bug 1444368 in Magnum "Bay status is still CREATE_IN_PROGRESS after stack create failed" [High,Incomplete]
22:53:37 <openstack> Launchpad bug 1451118 in Magnum "magnum throws db exception on failed bay deletion" [High,Triaged] - Assigned to Digambar (digambarpatil15)
22:53:45 <tcammann_> apmelton: +1
22:53:48 <apmelton> so who ever is working on that can probably modify the swarm template pretty similarly
22:53:58 <diga__> mfalatic: both are same I guess
22:54:15 <adrian_otto> ok, let's link them together for now
22:54:25 <diga__> okay
22:54:29 <adrian_otto> apmelton: can you do that please?
22:54:48 <adrian_otto> associate secure-docker and secure-kubernetes
22:55:00 <apmelton> adrian_otto: sure, let me figure out how
22:55:09 <adrian_otto> that concludes review of the Essential BPs
22:55:16 <adrian_otto> we have 5 min remaining
22:55:18 <juggler> sdake: do you have the recommended reading link handy? thanks
22:55:30 <adrian_otto> normally we do Open Disucssion here.
22:55:34 <sdake> juggler define handy
22:55:43 <apuimedo> I didn't see the discussion about the network one
22:55:49 <juggler> as in an available URL :)
22:55:51 <adrian_otto> but I have one orphan in High priorty:
22:56:03 <apuimedo> https://blueprints.launchpad.net/magnum/+spec/native-docker-network
22:56:06 <sdake> juggler i think tis on the wiki
22:56:08 <mismith> I would love to hear about any plans for RDO packaging for Magnum
22:56:09 <sdake> if you cant find it there ping me
22:56:10 <adrian_otto> apmelton: yes, that one
22:56:22 <adrian_otto> I need a volunteer to drive that one
22:56:31 <sdake> mr smith i packaged magnum for rdo
22:56:33 <juggler> hey mismith welcome
22:56:35 <mismith> The quickstart documentation is all devstack centric - not very helpful for us operators
22:56:40 <adrian_otto> #link https://blueprints.launchpad.net/magnum/+spec/native-docker-network
22:56:41 <apuimedo> adrian_otto: which one?
22:56:44 <mismith> sdake:  Oh yeah?
22:56:45 <apuimedo> ah
22:57:07 <apuimedo> I gave a presentation yesterday at the OpenStack Israel Conference
22:57:09 <mismith> sdake:  Where can one find the RPMs or srpms?
22:57:21 <apuimedo> http://presentation.midokura.me/openstack_israel_2015/#/
22:57:22 <daneyon> i am in the process of adding #link https://github.com/contiv/netplugin to #link https://github.com/stackforge/heat-coe-templates
22:57:26 <adrian_otto> I will start Open Discussion now. If you can help with native-docker-network, please update the BP, or see me.
22:57:33 <adrian_otto> #link Open Discussion
22:57:35 <tcammann_> Any plans on the midcycle meetup adrian_otto?
22:57:38 <apuimedo> http://presentation.midokura.me/openstack_israel_2015/#/23
22:57:39 <sdake> mismith https://copr.fedoraproject.org/coprs/sdake/openstack-magnum/
22:57:43 <apuimedo> starts the magnum part
22:57:48 <sdake> mismith the systemd stuff is untested
22:57:50 <adrian_otto> tcammann_: I will begin planning for that this week.
22:57:54 <sdake> feel free to modify and send me patches :)
22:57:56 <eghobo> mismith: just curios is it just for RHEL or Fedora/CentOS too?
22:57:57 <daneyon> I think it could be a good fit for Magnum networking... meeting a lot of the needs mentioned in #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/066805.html
22:58:10 <mismith> sdake:  Great I'll check it out.  We use CentOS
22:58:25 <apuimedo> adrian_otto: I would be willing to put a lot of time into the networking part
22:58:26 <adrian_otto> #adrian_otto to circulate a poll for dates to hold Magnum MidCycle Meetup for Liberty
22:58:40 <adrian_otto> apuimedo: excellent
22:59:03 <apuimedo> about the three options in the blueprint
22:59:09 <sdake> t-1 minutes
22:59:23 <adrian_otto> sorry for the super full agenda this week
22:59:26 <apuimedo> I feel like we should go for 2 and/or 3,
22:59:39 <mismith> sdake:  Do you know how the RDO folks pick up packages like yours and add it to the official RDO ones?
22:59:55 <adrian_otto> our next meeting is Tuesday 2015-06-23 at 1600 UTC, sdake will be our chair
23:00:01 <sdake> mismisth there is a rdo mailing list for such questions
23:00:05 <mismith> ok thanks all
23:00:10 <adrian_otto> thanks everyone for attending today!
23:00:14 <adrian_otto> #endmeeting