22:00:39 <adrian_otto> #startmeeting containers
22:00:40 <openstack> Meeting started Tue Mar 24 22:00:39 2015 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:44 <openstack> The meeting name has been set to 'containers'
22:00:49 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2015-03-24_2200_UTC Our Agenda
22:00:55 <adrian_otto> #topic Roll Call
22:01:00 <sdake__> o/
22:01:01 <adrian_otto> Adrian Otto
22:01:07 <diga> Digambar Patil
22:01:09 <yuanying-alt> yuanying
22:01:10 <thomasem> Thomas Maddox
22:01:11 <hongbin> o/
22:01:21 <Tango|2> o/
22:01:27 <apmelton> o/
22:02:00 <adrian_otto> hello sdake__ diga yuanying-alt thomasem hongbin Tango|2 apmelton
22:02:14 <diga> Hello adrian_otto
22:02:20 <adrian_otto> we will begin in just a moment.
22:02:32 <madhuri_> madhuri
22:02:34 <adrian_otto> thanks diga for attending at this most inconvenient hour
22:02:37 <thomasem> Please pardon my and apmelton's absence last week. We had our remote team at our main office and were pretty much booked all day Tuesday-Thursday.
22:02:46 <adrian_otto> hi madhuri_
22:02:49 <sdake__> meetings fun :)
22:02:49 <diga> NP :)
22:02:55 <adrian_otto> thomasem: welcome back. We have some great news
22:03:05 <thomasem> What's that? :)
22:03:14 <adrian_otto> #topic Announcements
22:03:33 <adrian_otto> 1) Magnum has officially joined the OpenStack project list upon approval by a unanimous vote by the Technical Committee.
22:03:40 <adrian_otto> #link https://review.openstack.org/161080 OpenStack Governance Update
22:03:42 <daneyon_> congrats!!!
22:03:46 <apmelton> woot!
22:03:47 <yuanying-alt> !!
22:03:48 <openstack> yuanying-alt: Error: "!" is not a valid command.
22:03:54 <yuanying-alt> great!
22:03:56 <madhuri_> Thats greate!
22:04:16 <adrian_otto> thanks to all of our diligent efforts, we have shown that we have what it takes to be a part of this community
22:04:18 <thomasem> Grats! :D
22:04:37 <adrian_otto> we still have a lot of ground to cover to get all the tags we will want
22:05:07 <adrian_otto> there is more good news
22:05:09 <sdake__> for those that dont know, tags are the new way operators will select projects to use
22:05:27 <apmelton> gotcha
22:05:27 <adrian_otto> 2) Magnum has an approves Session at the OpenStack Summit in Vancouver
22:05:30 <thomasem> Yeah, to help operators understand what works well together and all that, right?
22:05:51 <sdake__> one example tag is "team_diversity"
22:05:53 <thomasem> sweet, that's great to hear, adrian_otto
22:05:55 <sdake__> "6mo_release_cycle"
22:05:56 <sdake__> etc
22:06:00 <adrian_otto> #link http://sched.co/2qdw https://openstacksummitmay2015vancouver.sched.org/event/ec3936678ef22681408088ec52a4e80b#
22:06:02 <thomasem> sdake__: ohhhhhh gotcha
22:06:03 <sdake__> we rock on team_diversity
22:06:03 <diga> Congrats adrian_otto, sdake__
22:06:16 <adrian_otto> #undo
22:06:17 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x926c7d0>
22:06:54 <adrian_otto> #link http://sched.co/2qdw Magnum - Containers-as-a-Service for OpenStack
22:06:59 <adrian_otto> that's a bit better
22:07:26 <madhuri_> Page not found
22:07:30 <adrian_otto> ok, so if you plan on attending in Vancouver, get there early. There will not be an open seat in the house. I can guarantee that based on attendance in Paris
22:07:43 <adrian_otto> http://sched.co/2qdw does not work???
22:07:58 <sdake__> it is at 9am, some people may be on a bender the night before and forget to show up ;)
22:07:58 <adrian_otto> works for me, madhuri_
22:08:03 <madhuri_> This one works
22:08:11 <adrian_otto> sdake__: we can only hope ;-)
22:08:15 <apmelton> I had issues, but I think it's the https everywhere plugin mucking it up
22:08:29 <adrian_otto> so I put both of those news items on our Wiki page
22:08:53 <adrian_otto> apmelton: what plugin?
22:09:04 <apmelton> chrome's https everywhere
22:09:22 <adrian_otto> that sounds draconian.
22:09:43 <sdake__> get the anestaphine in the medlocker plz
22:09:44 <adrian_otto> especially considering how weak HTTPS is from a security perspective
22:09:51 <adrian_otto> sometimes just as weak as HTTP
22:10:13 <adrian_otto> I should not criticize the Internet.
22:10:16 <thomasem> Sometimes even more-so given the illusion of security. :P
22:10:24 <apmelton> oh really? might just uninstall it then
22:10:48 <adrian_otto> #topic Review Action Items
22:10:50 <sdake__> all your computers are belong to us
22:10:51 <adrian_otto> (none)
22:11:03 <adrian_otto> #topic Blueprint/Task Review
22:11:13 <adrian_otto> (1) Discussion of bay_type and cluster_type
22:11:27 <adrian_otto> #link https://review.openstack.org/165346 Add cluster_type field in baymodel.
22:11:46 <adrian_otto> now, I can't speak for all of you, but it took me a good long time of thinking about this to get what I thought was clarity on the situation
22:12:00 <adrian_otto> I did my best to express that in the comment stream of the link provided above.
22:12:13 <adrian_otto> I'll pause for a moment to allow those of you to take a look
22:12:18 <adrian_otto> let me know when you are done
22:12:35 <diga> Here only concern remaining about bay_type
22:12:38 <sdake__> I dont care as long as it works for hte 3 layers of cases we have (platform, os, coe)
22:13:16 <sdake__> we can rely on glance image properties for distro name
22:13:21 <adrian_otto> good, so setting aside the question about detecting the instance type (we will revisit this)
22:13:24 <sdake__> but I dont think we want to rely on the image name itself for the type of distro
22:13:30 <diga> I think other things are already there - image_id: OS, flavor_id: platform
22:13:32 <adrian_otto> how much alignment do we have on the rest?
22:14:13 <sdake__> well the patch adds the "os" layer
22:14:17 <sdake__> which we didn't have choices for previously
22:14:24 <sdake__> so it should probably be "os_type"
22:14:34 <sdake__> or none at all as you suggest (and select from glance property)
22:15:05 <hongbin> I have mentioned in the comment about the Sahara solution for a similar problem
22:15:16 <sdake__> which was?
22:15:29 <hongbin> They tag images with plugin, os, version ...
22:15:30 <apmelton> so, my only concern was relying on the user to provide those values, it will probably be a good idea to cache them in our database so we're not going out to glance/nova each time we need to do something with a bay
22:16:19 <hongbin> In Sahara, users don't specify image. They specify flavor and plugin instead
22:16:38 <hongbin> And Sahara choose the image based on provided plugin
22:16:44 <adrian_otto> what does it mean to specify a plugin in Sahara? Can you elaborate a bit?
22:16:44 <sdake__> apmelton sounds like a premature optimization
22:17:01 <hongbin> plugin is Hadoop distr, like bay_type
22:17:31 <hongbin> In magnum, it could be kubernetes, swarm...
22:17:32 <diga> in sahara, they have seperate plugins for hadoop, spark etc
22:17:49 <apmelton> sdake__: that's fair
22:18:00 <adrian_otto> ok, so that's in line with what I'm proposing
22:18:04 <adrian_otto> how about opposing points of view
22:18:18 <sdake__> apmelton openstack is a-ok with fat code - its written in python for example ;)
22:18:29 <sdake__> if it was supposed to be fast, itd be in c:)
22:19:00 <adrian_otto> sorry, had to get off my corporate VPN⦠network trouble there.
22:19:13 <adrian_otto> what's the last thing that made it to the channel?
22:19:22 <apmelton> I do suppose an image-show or a flavor-show should be relatively quick calls
22:19:44 <sdake__> I think there is a specific api for retrieving propertie sbut I am not certain
22:20:21 <sdake__> but if we use that, the patch has to change to not store os_type and instead retreive tehglance property
22:20:35 <sdake__> or it could store it after treiving it for the first time wfm too
22:20:36 <adrian_otto> ping
22:20:42 <hongbin> sdake__: agree
22:20:52 <sdake__> hey adrian_otto
22:20:57 <adrian_otto> oh, I see you again
22:21:43 <sdake__> i htink for this cae a glance image property is the right answer
22:22:07 <sdake__> neighbor redoing roof
22:22:13 <sdake__> hammering about to drive me nutty!
22:22:46 <apmelton> wonder how much of a pain it would be to get people behind a standard extra-spec for ironic/vm
22:22:47 <adrian_otto> ok, so do we have any controversy to address on this topic of bay_type?
22:23:30 <apmelton> though, I was wondering what the actual differences were between our ironic and vm template
22:24:05 <diga> then sdake__ where do we tag bay_type, in glance only
22:24:07 <sdake__> yuanying-alt could answer apmelton
22:24:23 <sdake__> diga, just use an os tag in glance
22:24:31 <diga> ok
22:24:34 <sdake__> the quickstart needs to be updated to set the porperty
22:24:38 <sdake__> and devstack as well
22:24:38 <apmelton> sdake__: diga: bay_type isn't coe, right? just os?
22:24:45 <adrian_otto> bay_type belongs to Bay, but cluster_type can be auto-detected from glance.
22:24:45 <sdake__> right os
22:24:51 <sdake__> that is why bay_type is such a bad name :)
22:25:02 <adrian_otto> ok
22:25:07 <diga> yes :)
22:25:21 <sdake__> at minimum it should be os_type
22:25:25 <sdake__> but it really belongs in glance
22:25:37 <diga> Got it
22:25:42 <yuanying-alt> apmelton: VM template doesn't work because of Neutron Port issue
22:25:48 <yuanying-alt> for Ironic
22:25:50 <apmelton> ahhhh gotcha
22:26:17 <thomasem> what's the issue?
22:26:23 <sdake__> i wonder if it would work if you were running a l3 agent on the node
22:26:38 <apmelton> I'm gonna hit a similar issue when I get to a template that'll work with rackspace
22:27:10 <yuanying-alt> Ironic instance has original mac address because it is bare metal, so Neutron Port doesn't connect to ironic instance
22:27:36 <thomasem> Oh
22:27:39 <thomasem> hmmmm
22:27:47 <sdake__> ironic/neutron should be able to fix that
22:27:55 <thomasem> Yeah, that seems do-able.
22:28:57 <apmelton> so, this is a bit of a tangent, is the model of using floating IPs and manually creating ports a standard model many people are using?
22:29:01 <adrian_otto> cool, so diga, do you feeel that this is specific enough?
22:29:08 <adrian_otto> I think we should record this into a blueprint
22:29:15 <diga> Yes adrian_otto
22:29:25 <adrian_otto> I will work with you on that
22:29:33 <diga> sure
22:30:06 <sdake__> apmelton apparently best practice ;)
22:30:48 <yuanying-alt> but ironic template can't it.
22:31:26 <adrian_otto> ok, any other work items that need team discussion today?
22:31:49 <sdake__> just wanted to say thanks for all the testing on the fedora-atomic-21-2 image
22:32:04 <madhuri_> I need to discss about k8s-client
22:32:08 <madhuri_> Can we?
22:32:29 <adrian_otto> madhuri_: we can in Open Discussion
22:32:40 <adrian_otto> if ther eare no specific work items, then we can do that
22:32:43 <madhuri_> Ok. Sure
22:32:48 <adrian_otto> #topic Open Discussion
22:32:55 <adrian_otto> madhuri_: you are up. Proceed.
22:33:20 <madhuri_> I tried generating pep8 compliant code yesterday using swagger
22:34:00 <madhuri_> And I think it would be hard to push it upstream because that code would be magnum specific
22:34:20 <sdake__> madhuri_ maybe a manual modification of the patch set would work out
22:34:24 <madhuri_> So I want some opinion here how to proceed further?
22:34:28 <sdake__> my quetion would be, does the code work as generated?
22:34:39 <adrian_otto> pep8 is not magnum specific. it's python specific.
22:34:51 <madhuri_> No, it failed
22:35:08 <sdake__> how did it fail
22:35:17 <madhuri_> Yes I agree but the rules defined can't be applied to all projects using swagger
22:35:22 <sdake__> so the code generator is busted, spectacular
22:35:31 <madhuri_> Every project must have their own set of rules
22:35:49 <madhuri_> sdake__: Yes, it doesn't work at all
22:36:03 <madhuri_> Due to syntax error
22:36:20 <sdake__> not inspiring
22:36:21 <madhuri_> I tried fixing that
22:36:25 <sdake__> i'd complain on google-containers
22:36:28 <juggler> Technical debt?
22:36:36 <sdake__> and tell them to write a proper python language binding :)
22:37:04 <juggler> :)
22:37:10 <madhuri_> So, what do you think sdake__ ?
22:37:18 <madhuri_> Should we carry on with this?
22:37:23 <sdake__> madhuri_ can you get it to work
22:37:32 <madhuri_> Yes. I can try
22:37:35 <sdake__> I'd prefer to use the generator in the short term
22:37:47 <sdake__> writing a language binding is a monumental task
22:38:00 <sdake__> maybe not monumental
22:38:00 <madhuri_> Ok. So I will try to fix that issues and try it out with magnum
22:38:03 <sdake__> bit big in scope atleast
22:38:11 <madhuri_> Agree
22:38:14 <sdake__> keep a diff of your work
22:38:20 <sdake__> i'm interested t o see how the code generator fails
22:38:21 <sdake__> pls
22:38:26 <madhuri_> Sure
22:38:49 <sdake__> that is something the swagger upstream needs to fix
22:39:06 <madhuri_> Agree
22:39:08 <hongbin> A question for the pep8
22:39:23 <hongbin> Is that possible to disable pep8 for generated code?
22:39:26 <juggler> yeah is swagger upstream aware of the issue?
22:39:36 <madhuri_> May be.
22:39:58 <madhuri_> I tried contacting them but couldn't
22:40:10 <sdake__> no mailing list?
22:40:25 <madhuri_> I will raise an issue for this
22:40:35 <madhuri_> I haven't mailed yet
22:40:47 <sdake__> ya, evaluate the upstream - see if they are responsive
22:40:51 <sdake__> we need to know that as well
22:40:53 <adrian_otto> oh, in all the excitement during announcements, I forgot to discuss PTL election.
22:40:57 <madhuri_> Ok. sure
22:41:11 <adrian_otto> do you want to take a moment to touch on that?
22:41:19 <sdake__> adrian_otto +1
22:41:39 <juggler> !!
22:41:40 <openstack> juggler: Error: "!" is not a valid command.
22:41:50 <madhuri_> So I will try to make generated code work
22:41:53 <sdake__> !give_me_all_the_money
22:41:54 <openstack> sdake__: Error: "give_me_all_the_money" is not a valid command.
22:41:58 <adrian_otto> ok, so historically Stackforge projects all ran their own elections, announcing candidate openings on openstack-dev ML
22:42:33 <adrian_otto> based on feedback from our _OpenStack_ election official that has been confusing the OpenStack electorate
22:42:52 <adrian_otto> so we have been asked to conduct an election candidate nomination process that does not use the mailing list.
22:43:03 <adrian_otto> so I have a specific proposal for you all to consider.
22:43:20 <adrian_otto> first of all, we only need to hold an election if there is > 1 candidate
22:43:35 <adrian_otto> only contributors are eligible to declare a candidacy.
22:43:57 <adrian_otto> so we can email all contributors and ask them to show up to our next IRC team meeting
22:44:18 <adrian_otto> and if one of us wants to have an election, a candidacy can be announced during that agenda item
22:44:38 <sdake__> i dislike this personally
22:44:44 <adrian_otto> then the election official will run the election. The electorate is made up of the project contributors, should an election be needed.
22:44:47 <sdake__> I htink a permanent mailing list record is beneficial
22:44:55 <adrian_otto> this will only matter for this election
22:45:10 <adrian_otto> because subsequent elections we will fit into the OpenStack election
22:45:21 <sdake__> i'd be surprised if this one should fit in?
22:45:24 <sdake__> since we hit integration
22:45:27 <adrian_otto> sdake__: there is another way to deal with taht
22:45:40 <adrian_otto> sdake__: it is too late for this one, right?
22:45:50 <sdake__> no, the elections haven't been done yet
22:45:53 <adrian_otto> candidate deadlines have elapsed for this cycle?
22:45:53 <sdake__> asfar as i can tell
22:46:03 <adrian_otto> oh, in that case we can just tag along.
22:46:07 <sdake__> i could be out of the loop but beest to double check
22:46:36 <sdake__> usually the elections are after 2015.1.0 is cut - april 25th
22:46:55 <adrian_otto> let me check on that. one moment please.
22:47:42 <adrian_otto> #Link https://wiki.openstack.org/wiki/PTL_Elections_March/April_2014 OpenStack Election
22:47:50 <adrian_otto> March 28 - April 4, 05:59 UTC: Open candidacy to PTL positions
22:48:04 <adrian_otto> so this is a solved problem!!
22:48:13 <sdake__> winning:)
22:48:14 * sdake__ the voice of reason
22:48:31 <juggler> yeah
22:48:42 <adrian_otto> ok, so I will take no further action on this topic
22:48:42 <juggler> correction, ya
22:48:44 <sdake__> we just need to make sure someone actually runs one for us :)
22:49:16 <adrian_otto> all I need to do is declare a candidacy in accordance with the process
22:49:26 <adrian_otto> but we don't need our own election
22:50:28 <sdake__> and any other people that want to run of course ;)
22:50:43 <adrian_otto> actually, I don't see what program we would belong to
22:50:53 <adrian_otto> I will follow up to check
22:51:25 <adrian_otto> #action adrian_otto to check to see if Magnum may participate in the April 4 - April 11: PTL elections.
22:51:28 <juggler> is sdake volunteering? :)
22:51:49 <sdake__> I am not running, I have too much on my plate and adrian_otto is doing a fine job :)
22:51:57 <juggler> agreed
22:52:00 <sdake__> if adrian_otto falls over dead, i'll run :)
22:52:04 <adrian_otto> I can tell you that being PTL of more than one project is extremely hard
22:52:35 <juggler> that begs the question and i'm not volunteering, but is there an alternate PTL?
22:52:36 <sdake__> agree I dont know why anyone would do two :)
22:52:39 <adrian_otto> I don't know if anyone else has tried that besides me
22:52:58 <sdake__> one is enough work for two people imo
22:53:14 <adrian_otto> well said!
22:57:00 <adrian_otto> ok, time to wrap up for today?
22:57:07 <sdake__> yup
22:57:10 <thomasem> I'm hearing crickets. :)
22:57:44 <adrian_otto> Our next meeting is 2015-03-31 at 1600 UTC. I look forward to seeing you all there.
22:57:49 <adrian_otto> thanks everyone!
22:57:54 <thomasem> Cheers!
22:57:57 <juggler> take care all
22:58:04 <adrian_otto> #endmeeting