16:00:16 <adrian_otto1> #startmeeting containers
16:00:17 <openstack> Meeting started Tue Oct 14 16:00:16 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto1. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:21 <openstack> The meeting name has been set to 'containers'
16:00:24 <adrian_otto1> #link https://wiki.openstack.org/wiki/Meetings/Containers#Agenda_for_2014-10-14_1600_UTC Our Agenda
16:00:28 <adrian_otto1> #topic Roll Call
16:00:33 <adrian_otto1> Adrian Otto
16:01:56 <kebray> \o
16:02:03 <nelsnelson> \o
16:02:22 <adrian_otto1> hello there kebray and nelsnelson
16:02:44 <nelsnelson> greetings, adrian_otto1
16:03:45 <iqbalmohomed> Hello
16:03:51 <adrian_otto1> hi iqbalmohomed
16:04:07 <adrian_otto1> we will begin in just a moment
16:05:32 <dguryanov> Hello!
16:05:40 <adrian_otto1> ok, let's begin. Anyone who has not chimed in yet, you may type at any time to be recorded in attendance.
16:05:44 <adrian_otto1> hi dguryanov
16:05:54 <adrian_otto1> #topic Announcements
16:06:41 <adrian_otto1> 1) Next Tuesday, we have a scheduled team meeting. I am traveling, and should return on time to chair.
16:07:03 <adrian_otto1> I have taken the day off as a vacation day.
16:07:19 <adrian_otto1> would anyone like to be a chair in the event I can not attend?
16:08:30 <adrian_otto1> the week after that I am speaking at Zendcon
16:08:58 <adrian_otto1> and the week after that we are in Paris for the OpenStack Summit
16:09:51 <adrian_otto1> the week after that is Veterans day in the US (Government holiday)
16:10:11 <adrian_otto1> so… how would you all like to proceed with team meetings?
16:11:07 <adrian_otto1> One option is to schedule our next meeting for Nov 18th
16:11:43 <adrian_otto1> that would give us time to engage with the TC on how Magnum should be run (as part of OpenStack Compute, or as a Stackforge project)
16:12:04 <adrian_otto1> and then regroup once we have clarity on that point. The next TC meeting is rather far out
16:12:32 <nelsnelson> When's the next TC meeting?
16:12:43 <adrian_otto1> October 21
16:12:50 <nelsnelson> Okay.
16:13:02 <adrian_otto1> but on controversial topics they rarely decide in one meeting
16:13:09 <adrian_otto1> it usually takes two or three
16:13:47 <adrian_otto1> so we would need to have most of the discussion in advance on the mailing list if we want a decision to happen on Oct 21.
16:14:57 <adrian_otto1> ok, so another option would be for another team member to step in to chair team meetings in my absense
16:15:00 <adrian_otto1> Thoughts?
16:16:09 <adrian_otto1> Okay, any objections to scheduling our next meeting for Nov 18 at 22:00 UTC?
16:16:21 <iqbalmohomed> No ... that sounds alright
16:16:49 <dguryanov> I argee
16:17:08 <adrian_otto1> #agreed Our next meeting will be 2014-11-18 at UTC 2200
16:17:20 <adrian_otto1> any other announcements from team members?
16:19:31 <adrian_otto1> ok
16:19:47 <adrian_otto1> #topic Review Action Items
16:19:59 * adrian_otto1 adrian_otto to attempt to identify Linux kernel patches that could enable use of nested containers in non-privileged mode
16:20:19 <adrian_otto1> the meeting I had with Docker was rescheduled for later this week
16:20:30 <adrian_otto1> so I will carry this action item forward to next week.
16:21:22 <adrian_otto1> #action adrian_otto to attempt to identify Linux kernel patches that could enable use of nested containers in non-privileged mode
16:22:05 <adrian_otto1> #topic Open Discussion
16:22:19 <manishg> I have a question about networking for containers.
16:22:56 <manishg> Is there any consdieration for multiple IPs for containers?
16:23:26 <iqbalmohomed> you mean multiple vnics inside the container?
16:23:31 <manishg> yeah.
16:23:48 <adrian_otto1> the containers use the IP addresses from the instance they are created in
16:23:57 <adrian_otto1> so if you have a Nova instance with multiple IP
16:24:15 <adrian_otto1> then you can use those with the containers that are create within that instance
16:24:20 <adrian_otto1> +d
16:24:35 <iqbalmohomed> it is definitely possible to have a container with multiple network interfaces
16:24:44 <adrian_otto1> yes.
16:24:47 <manishg> adrian_otto1, iqbalmohomed: thanks.
16:24:49 <iqbalmohomed> I was studying this project recently: https://github.com/zettio/weave
16:25:18 <iqbalmohomed> they add an ethwe to docker containers in addition to the regular eth0 that docker sets up inside the container
16:26:02 <manishg> iqbalmohomed: thanks.  will take a look.
16:26:03 <adrian_otto1> yes, I have looked at weave, and it looks promising, but I have a number of concerns about how it will scale beyond a few hundred containers
16:26:38 <adrian_otto1> the system architecture (at first glance) appears to suffer from the N-Squared problem.
16:26:56 <mspreitz_> Why do we need weave when Neutron can already make overlay networks?
16:27:52 <iqbalmohomed> I don't think we do ... was merely offering it as evidence of multiple vnics inside a container :)
16:28:17 <iqbalmohomed> adrian_otto1: agreed. I am not sure how the overlay would scale
16:33:26 <adrian_otto1> ok, any other topics for discussion today?
16:36:09 <adrian_otto1> thanks everyone for attending!
16:36:13 <adrian_otto1> #endmeeting