23:59:55 <ekcs> #startmeeting congressteammeeting
23:59:56 <openstack> Meeting started Wed Jan 11 23:59:55 2017 UTC and is due to finish in 60 minutes.  The chair is ekcs. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:59:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
23:59:59 <openstack> The meeting name has been set to 'congressteammeeting'
00:00:07 <ramineni_> Hi
00:00:25 <ekcs> hi ramineni_ !
00:00:30 <masahito> hi
00:00:49 <ekcs> hi everyone. hope all is well!
00:01:12 <ekcs> thinrichs won’t be here today due to travels.
00:01:42 <ekcs> just a couple items from me today.
00:01:43 <ekcs> Pike PTL
00:01:44 <ekcs> Ocata-3 patches
00:01:44 <ekcs> Ocata-3 QA
00:01:46 <ekcs> anything else?
00:02:02 <aimeeu> sounds good
00:02:33 <ekcs> ok then let’s dive right ahead.
00:02:43 <ekcs> #topic Pike PTL
00:03:00 <ekcs> Quick item:
00:03:00 <ekcs> Pike PTL nomination week is Jan 23. Feel free to talk to thinrichs or I if you have any questions about that.
00:04:12 <ekcs> moving on then.
00:04:19 <ekcs> #topic Ocata-3 patches
00:04:26 <ekcs> Any patches to discuss for Ocata-3?
00:05:27 <ekcs> oh and good work everyone for getting ocata-3 patches in!
00:06:15 <ekcs> Here are some patches that seem ready to merge. any thoughts on them?
00:06:27 <ekcs> #link https://review.openstack.org/#/c/401960/
00:06:37 <ekcs> #link https://review.openstack.org/#/c/399124/
00:07:01 <ekcs> #link https://review.openstack.org/#/c/404478/
00:07:19 <masahito> sorry, slow responses for some patches. I'll check it in today.
00:07:27 <ekcs> #link https://review.openstack.org/#/c/416814/
00:07:55 <ekcs> np masahito
00:08:15 <ekcs> For reference, here is the list of open patches on congress: https://review.openstack.org/#/q/project:openstack/congress+status:open
00:09:04 <ramineni_> ekcs: I'll also check today ..
00:09:23 <ramineni_> ekcs: ocata 3 is Jan 23 right
00:09:40 <ekcs> awesome.
00:11:10 <ramineni_> I want to complete one more patch also for ocata
00:11:14 <ekcs> ramineni_: yes. jan 23. but since the time between ocata-3 and RC1 is so short (and also because many things become hard to change after O3), we’re aiming to merge everything by Jan 16 to have a full week of testing and fixing.
00:11:50 <ekcs> based on lessons learnt from last cycle’s madness at the end.
00:11:57 <ramineni_> hmm
00:12:45 <ramineni_> Ok ..
00:14:07 <ekcs> it’s not set in stone of course. let’s talk more about it either here or later if we need to adjust  = )
00:14:34 <ramineni_> Sure .. Thanks
00:14:49 <ekcs> one patch I want to bring up. #link https://review.openstack.org/#/c/410705/
00:16:03 <ekcs> I haven’t been following closely, but is this something we can discuss and reach consensus on ramineni_ and masahito ?
00:17:53 <masahito> My comment on this patch is a question.
00:19:01 <ramineni_> Couldn't get time to look into how to do it ..I think if heartbeat has subscription info I can use to list all subscribers right
00:19:14 <masahito> It seems to work well if Congress is deployed in one node.
00:20:36 <ramineni_> Yes ... I'll look into how to implement masahito comment
00:20:51 <ramineni_> I'll update the patch this week
00:21:22 <ekcs> ok. I’ll take a look too.
00:22:46 <ekcs> ok let’s move on then if there’s nothing else to discuss here.
00:23:17 <ekcs> #action review open patches for Ocata-3 aiming to merge by Jan 16
00:23:47 <ekcs> #topic Ocata-3 QA
00:25:07 <ekcs> Like we’ve discussed, we’d like to do more testing on Ocata-3 than last cycle, both because it’s a very short time between O3 and RC1, and because we want to avoid repeating all the difficulty we had in fixing late breaking bugs late in the cycle.
00:26:27 <ekcs> To help us on that front, I setup some QA tasks here: https://bugs.launchpad.net/congress/+bugs?field.tag=qa
00:27:48 <ekcs> The idea is to start manually and aim to automate as much as possible based on the manual work.
00:28:39 <ekcs> It’ll help us have a much more rigorous testing process for future releases.
00:29:16 <ekcs> so feel free to sign up for tasks. (the time frame for these tasks is between Jan 16 and Jan 23).
00:29:41 <ekcs> masahito: I remember you mentioning another QA task we should do, but I forgot what it was.
00:29:53 <ekcs> pulling up notes from last meeting.
00:30:25 <masahito> ekcs: it's about fail over of datasource service
00:31:13 <masahito> ekcs: Should I report it as bug report to track the status?
00:32:03 <ekcs> sure go for it. thanks! and please tag it with qa so we can easily find it.
00:32:20 <masahito> got it.
00:32:30 <ekcs> oh and thanks aimeeu for volunteering for the standalone install task!
00:32:51 <aimeeu> you're welcome. I should be committing a script early next week.
00:33:03 <ekcs> thanks aimeeu
00:33:03 <aimeeu> for single-node install at least
00:33:04 <ekcs> any questions or comments or thoughts around QA for ocata?
00:33:22 <ramineni_> aimeeu: and dashboard part ..Are we targeting for ocata?
00:34:00 <aimeeu> I thought ekcs was concerned about time to test so I am targeting Pike
00:34:23 <ekcs> you mean moving to a new repo?
00:34:26 <aimeeu> yes
00:34:30 <ramineni_> aimeeu: oohok
00:35:18 <aimeeu> my workload in OPNFV is pretty heavy right now so limited time
00:35:29 <ekcs> so my thinking was if we can create the new repo without disturbing the current way it works, then we can try to do it for O if there is time.
00:36:02 <aimeeu> creating the repo and replicating code I think is the easiest part
00:36:13 <ekcs> that way it’s available, but the old one is also available so we don’t need to thoroughly test the new one.
00:36:39 <aimeeu> making sure both projects deploy correctly and dashboard is registered with Horizon is more time consuming
00:36:54 <ekcs> and if so, the new repo and progress at basically any schedule we find convenient without us depending on it to be ready at any particular time.
00:37:33 <aimeeu> I agree. I keep thinking of more deployment scenarios that would need to be tested
00:37:40 <ekcs> so my main concern is keeping the existing thing working in the mean time.
00:37:57 <aimeeu> ekcs: +1
00:38:52 <ramineni_> ekcs : if we split the repo .. we have to do all the release work by Jan end for the new repo too?
00:39:52 <ekcs> ramineni_: I’m not sure. My guess would be we can start the new repo without being forced to include it in the release right away.
00:40:10 <aimeeu> ekcs: yes
00:40:22 <ramineni_> ekcs : ok ..Then should be fine
00:41:03 <ekcs> one more thing on Ocata. please go ahead and target things for Ocata in launchpad for the things you want in ocata. that way we can all get a big picture of what is left to be done. very helpful in planning.
00:41:37 <ekcs> and feel free to ask me to make those changes for those who don’t have permissions on launchpad.
00:42:52 <ekcs> ok then. let’s move on to open discussion.
00:42:56 <ekcs> #topic open discussion
00:44:51 <ekcs> I reported a couple bugs on postgres deployment. #link https://bugs.launchpad.net/congress/+bugs?field.tag=postgres
00:45:46 <ekcs> both seem to boil down to a mysterious 401 error when contacting datasource. I’m going to look into it some more, but throwing it out here too to see if someone happens to have a clue.
00:47:58 <masahito> ekcs: do you know how to deploy openstack with mysql? I've not tried it.
00:48:24 <ekcs> masahito: you mean using devstack or not?
00:48:31 <masahito> using devstack.
00:48:34 <ekcs> by default devstack uses mysql.
00:48:51 <masahito> oops, sorry. s/mysql/postgresql/
00:49:09 <ekcs> to change to postgres you add the following to local.conf
00:49:11 <ekcs> disable_service mysql
00:49:11 <ekcs> enable_service postgresql
00:49:24 <ekcs> before stacking.
00:49:34 <masahito> good to know. thanks!
00:51:13 <ekcs> ok if there’s nothing more to discuss, shall we end early?
00:51:27 <ekcs> I’ll wait a couple minutes = )
00:52:48 <ekcs> ok have a great rest of the week, and see you all later!
00:52:55 <ekcs> #endmeeting