00:01:06 <ekcs> #startmeeting CongressTeamMeeting
00:01:07 <openstack> Meeting started Thu Aug  4 00:01:06 2016 UTC and is due to finish in 60 minutes.  The chair is ekcs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:01:10 <openstack> The meeting name has been set to 'congressteammeeting'
00:01:13 <ramineni_> hi
00:01:16 <aimeeu> Hello
00:01:41 <ekcs> Hi all! Hope everyone's having a good week.
00:01:51 <ekcs> thinrichs is away this week and asked me to fill in on the meeting.
00:02:45 <ekcs> looks like tsandall is with us today. Hi!
00:03:12 <ekcs> Topics for today:
00:03:12 <ekcs> 1. Gating
00:03:13 <ekcs> 2. Status updates
00:03:14 <ekcs> Any other topics?
00:05:00 <ekcs> #topic gating
00:05:13 <ekcs> Big thanks for ramineni_ and others who fixed the recent gating issues.
00:05:57 <ekcs> It seems to have fixed the intermittant gate-congress-new-arch-devstack failures. Only exception is when I tried to recheck but forgot to rebase a patch.
00:05:57 <ekcs> Anything else on the topic?
00:06:36 <ramineni_> ekcs: with your locking patch, hope we wont have any more gating issues
00:07:05 <ekcs> hopefully =)
00:07:11 <ramineni_> it should take care of any further race conditions right
00:07:14 <ramineni_> :)
00:07:29 <masahito> sorry, late.
00:07:34 <ekcs> hi masahito
00:07:53 <masahito> ekcs: hi
00:08:02 <ekcs> masahito, we’re just talking about the recent gating issue and that we seem to have calmed it down.
00:08:25 <masahito> got it.
00:08:39 <ekcs> moving on then.
00:08:41 <ekcs> #topic status
00:08:56 <masahito> I think ramineni_ did great works for it.
00:09:15 <ekcs> masahito: yup!
00:09:24 <ramineni_> masahito:ekcs:  thanks :)
00:09:37 <ekcs> ramineni_: would you like to start us off on status updates?
00:09:55 <ramineni_> ekcs: sure
00:11:14 <ramineni_> ekcs: this week mainly worked on gating issues, and made python3.5 job voting as it seems to be passing now,
00:11:35 <ramineni_> ekcs: planning to add patch on follow up of Timś to remove old dse code
00:11:58 <ramineni_> ekcs: thats it from my side
00:12:24 <ekcs> great! Great work getting on top of all that.
00:13:14 <ekcs> yea it may be a good idea to follow up on remove old DSE before it becomes terribly out of date. Thanks!
00:13:29 <ekcs> aimeeu: would you like to go next?
00:13:33 <aimeeu> sure
00:14:02 <aimeeu> I finally pushed the first version of the HA Overview Guide and deployment instructions.
00:14:02 <aimeeu> https://review.openstack.org/#/c/350731/1  I marked the sections I'd like help with
00:14:43 <aimeeu> For the other minor bug fixes, I was waiting for the Horizon plugin model patch to merge
00:14:48 <aimeeu> #link https://review.openstack.org/#/c/305063/
00:15:15 <aimeeu> so I don't end up in git/gerrit hell
00:15:29 <aimeeu> That's it for me
00:17:02 <ekcs> thanks aimeeu! can you remind us which horizon plugin model patch we’re waiting on?
00:17:06 <aimeeu> I welcome any and all comments on the overview and deployment guides. I did a lot of reading but have no experience with HA
00:17:19 <aimeeu> ekcs:  https://review.openstack.org/#/c/305063/
00:17:35 <aimeeu> Anusha just went in forced a recheck
00:17:58 <ekcs> aimeeu: ah got it.
00:18:32 <aimeeu> Hopefully this coming week I will have more time to work on Congress.
00:19:08 <ekcs> and great work jumping on the HA. let’s all take a quick look to see if there are things we can help aimeeu with on the HA docs.
00:19:51 <ekcs> I’ll help with the section on action execution during failover.
00:20:08 <ekcs> #action ekcs help with action execution failover in HA docs.
00:20:15 <ekcs> thanks aimeeu!
00:20:21 <masahito> ok, I'll check ha-deployment section.
00:20:24 <aimeeu> ekcs: excellent. Many thanks. It's always easier to edit or add, and since I copied a lot from your blueprint...
00:20:54 <aimeeu> masahito: thanks - I added the active-active paragraph to your ha-deployment guide
00:21:27 <ekcs> awesome.
00:21:33 <ekcs> masahito: you wanna go next? and feel free to add topics to the agenda since we missed you during that section.
00:21:50 <masahito> ok
00:21:53 <ekcs> actually sorry
00:22:10 <masahito> I'm working for lazy datasource feature. I pushed first patch that is ready to review and will continue to implement the feature to all datasources.
00:22:23 <ekcs> nvm go ahead =p
00:22:29 <masahito> that's from my side.
00:22:58 <ekcs> thanks masahito!
00:22:59 <masahito> sorry, I didn't go into HAHT stuff this week.
00:23:16 <ekcs> masahito no problem!
00:23:45 <ekcs> masahito: one question about lazy datasource,
00:24:00 <masahito> ok.
00:24:14 <ekcs> here’s the link btw: #link https://review.openstack.org/#/c/346677/
00:25:35 <ekcs> I was having a little trouble understanding whether the same update method would get run multiple times on some existing DSDs not yet adapted specifically for lazy.
00:27:49 <masahito> I expect only tables specified as 'lazy_table' don't pull data from real datasource.
00:29:06 <ekcs> ok thanks. I think I need to understand it more. Will do that this week.
00:29:44 <masahito> ekcs: thanks. I wrote down how to use the feature in commit message.
00:30:01 <ekcs> thanks.
00:30:13 <ekcs> Ok here's my status
00:30:14 <ekcs> The persist push data patch is under review. https://review.openstack.org/#/c/348712/
00:30:30 <ekcs> I think we're ready to do more integration testing on HA, which I'll start this week.
00:31:17 <ekcs> Thanks for the review on that masahito
00:31:19 <ekcs> Another small change to trigger synchronize_policies after adding datasource, and adding a lock to avoid concurrency errors. https://review.openstack.org/#/c/350811/
00:31:51 <ekcs> that’s all for me.
00:33:30 <ekcs> Great let's move on to open discussion then.
00:33:33 <ekcs> #topic open discussion
00:34:32 <masahito> Speaking of HAHT, do we want to have another jenkins job for multi-node deployment like gate-congress-dsvm-multi-node-deployment? or implement tempest tests?
00:36:36 <ramineni_> masahito: ya, i think we should do
00:36:47 <ekcs> masahito: good question.
00:36:52 <ekcs> Any thoughts on pros and cons either way?
00:38:57 <masahito> new job Pros - we can make different tests senario for HA from cold-stanby HA, Cons - we need to implement the test from scratch.
00:39:37 <ekcs> masahito: got it.
00:40:21 <ekcs> do we think we can test the setups we need by adding to existing HA tests?
00:40:49 <masahito> new tempest test Pros - we can re-use tempest scenarios we already have, Cons - we sometimes struggle from some errors.
00:41:27 <ekcs> got it.
00:41:38 <ekcs> ramineni_: do you have any thoughts?
00:42:04 <masahito> I think the existing HA test expects cold-stanby HA.
00:42:25 <ekcs> I guess there are a few options:
00:42:32 <ekcs> 1. add to existing HA scenario
00:42:42 <ekcs> 2. add new HA scenario to exsting gate job
00:42:44 <ramineni_> actually im confused, i thought we need both , we need to add tempest tests for HA anyway right , even if we add a new job
00:42:47 <ekcs> 3. add totally new gate job
00:43:28 <ekcs> and I think we’re saying (1) won’t work.
00:44:10 <ramineni_> i mean add a new job to test HA , where we test all HA scenarios
00:45:07 <ramineni_> for multinode
00:46:00 <ekcs> ramineni_: got it. what’s the benefit of adding new gate job over simply adding scenarios to existing gate job? so that we can get the right multinode setup?
00:46:34 <ramineni_> ya, to run on multinode
00:47:28 <ekcs> ok. I’m just thinking might it be possible to setup multinode setup within the scenario similar to the way we currently do it by starting a replica.
00:47:50 <ekcs> so 1. is that possible, and 2. is that a good idea or not.
00:48:33 <masahito> I think 2 is better to manage multinodes.
00:49:23 <masahito> we can launch multi PE nodes in creating devstack phase.
00:49:57 <ramineni_> masahito: but is it possible to start on different nodes in devstack script
00:50:08 <ekcs> right, that’s the main difference: launch multiple nodes in the scenario, or launch multiple nodes in devstacking.
00:50:48 <masahito> ramineni_: gate only accepts one *VM* for devstack but we have dse_id flag.
00:51:09 <ramineni_> oohok, like we do in HA now right
00:51:19 <masahito> yes.
00:51:27 <ramineni_> ok
00:52:20 <masahito> of course, in HA tests like failover, we need to manage the process in tempests.
00:52:20 <ekcs> ok why don’t we think more on this and maybe decide next week whether we want to add scenarios to current gate job or add a whole new gate job?
00:52:47 <masahito> ekcs: right.
00:53:12 <ekcs> aimeeu how are you feeling about ramping up on Congress so far? Anything you're blocking on or having trouble finding help with?
00:53:17 <ramineni_> adding HA tempest tests in assigned to aimee right
00:53:55 <aimeeu> ekcs: learning a lot but just frustrated at own lack of progress.
00:54:55 <aimeeu> ramineni: I unassigned myself from the basic tempest tests - not ready for that yet and can't get tempest working locally
00:55:53 <ekcs> aimeeu: ok I think you’re ramping up great! do ping me or others if you’re blocked on something.
00:56:11 <ramineni_> aimeeu: ok
00:56:36 <ekcs> 4 minutes. anything else or should we end meeting?
00:56:42 <ramineni_> aimeeu: you can ping me in case you want some help in getting tempest working
00:57:03 <aimeeu> ekcs: thanks! probably the best approach for me would be writing unit tests or implementing a new, simple piece of functionality
00:58:01 <ekcs> aimeeu: are you looking for the next suitable thing to take on?
00:58:51 <aimeeu> I have some low-hanging fruit but I was thinking it may be easier to work on a new easy piece of functionality rather than fixing something
00:59:32 <ekcs> aimeeu: got it that makes sense. let’s talk about it offline then since we’re out of time here.
00:59:36 <aimeeu> like adding and testing a method... but I don't want to take time away from what needs to go in Newton-3
00:59:44 <aimeeu> ekcs: perfect
00:59:59 <ekcs> all right thanks everyone!
01:00:04 <ekcs> have a great week!
01:00:06 <ekcs> #endmeeting