00:06:44 <thinrichs> #startmeeting CongressTeamMeeting
00:06:45 <openstack> Meeting started Thu Mar 17 00:06:44 2016 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:06:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:06:49 <openstack> The meeting name has been set to 'congressteammeeting'
00:07:20 <thinrichs> Note for those reading the logs: we're having a 2nd instance of the meeting since some of us forgot about daylight savings.
00:08:06 <thinrichs> Here are the details about the congress talks…
00:08:07 <thinrichs> Thu 28 11:00a - 11:40a
00:08:07 <thinrichs> Enforcing Application SLAs with Congress and Monasca (fabiog)
00:08:08 <thinrichs> Thu 28 11:50a-12:30
00:08:08 <thinrichs> Congress in NFV-based Mobile Cellular Network Fault Recovery (masahito)
00:08:08 <thinrichs> Thu 28 1:30-2:10p
00:08:08 <thinrichs> Policy Canvas: Draw your policies for OpenStack services (JK)
00:08:08 <thinrichs> Thu 28  2:20-3:00p
00:08:09 <thinrichs> Watcher a Resource Manager for OpenStack: Plans for the N-release and beyond (Congress sibling)
00:08:15 <thinrichs> Mark them down on your calendars so you don't miss out.
00:08:16 <fabig> hi sorry guys I am late
00:08:21 <thinrichs> fabig: no problem
00:08:35 <thinrichs> I was just pointing out that you've got a talk in Austin about Monasca and Congress
00:09:00 <thinrichs> Also for Austin...
00:09:29 <thinrichs> We have been allocated 3 working sessions: smaller rooms where we can have design discussions amongst the team and possibly a few others.
00:09:47 <thinrichs> We also have 1 fishbowl room: a larger one where the goal is to get broader participation
00:10:47 <thinrichs> When asked about what we'd use it for I suggested having a discussion about different integrations with other projects: Monasca for sure, possibly Nova, Keystone
00:11:10 <fabig> thinrichs: maybe having the policy delegation to other project could be a good topic too
00:11:23 <thinrichs> fabig: yep
00:11:42 <fabig> thinrichs: like how to instruct Nova or Neutron to enforce something that Congress has set-up
00:11:56 <thinrichs> fabig: yep
00:12:33 <thinrichs> I think there's plenty to discuss
00:13:54 <thinrichs> Any questions/comments?
00:14:32 <masahito> thinrichs: Mainly what day's we have room?
00:14:50 <masahito> s/day's/days/
00:14:52 <thinrichs> masahito: we don't know about the rooms yet,
00:15:04 <masahito> thinrichs: got it.
00:15:11 <thinrichs> but I did request our rooms not to be scheduled at the same time as any of those talks
00:16:14 <thinrichs> #topic PTL elections
00:16:18 <madhumohan> Is remote participation feasible this time for the design summits?
00:16:49 <thinrichs> madhumohan: usually not, just because there aren't phones, video-conference equipment
00:17:03 <thinrichs> etherpad is possible, of course
00:17:09 <thinrichs> and I think that's what most teams do,
00:17:25 <thinrichs> but it's also pretty difficult to keep the etherpad up to date with the discussion that's happening
00:18:25 <thinrichs> What we usually do is put the topics into the etherpad so that people can put their questions/comments about the topic into the etherpad.
00:18:56 <thinrichs> Then we can be sure to discuss them and try to capture the part of the discussion relevant to that question in the etherpad.
00:19:48 <thinrichs> I was thinking we'd spend 1 session on the distributed architecture, working out any details that are left.
00:20:15 <thinrichs> And then 1 session on how we might use that architecture to deploy Congress with HA and high-throughput.
00:20:16 <ekcs> is it feasible to do a public livestream?
00:20:34 <ekcs> then others can follow and participate via etherpad / irc
00:21:23 <thinrichs> ekcs: there aren't usually phones/vidoe, which would mean someone would try to (furiously) transcribe the discussion into the etherpad
00:21:56 <ekcs> I mean livestream by webcam/microphone sent out over internet
00:22:13 <tsandall> you could have a laptop in the room with a hangout open
00:22:28 <tsandall> but i guess there's no infrastructure for that so it be pretty best-effort...
00:22:53 <ekcs> yea just comes down to how much bandwidth we’ll have.
00:23:05 <thinrichs> And how flakey the hotel wireless is
00:23:41 <thinrichs> So we'll need to play it by ear once we get there,
00:23:46 <ekcs> got it.
00:23:50 <thinrichs> but we can definitely set up the etherpads in advance
00:24:01 <thinrichs> Moving on…
00:24:05 <thinrichs> #topic PTL election
00:24:10 <thinrichs> PTL election season is here.
00:24:32 <thinrichs> I'm running again this cycle, but if anyone else is interested in running, please do so.
00:24:46 <thinrichs> I'm happy to talk with people about what is entailed, how much work is involved, etc.
00:24:55 <thinrichs> Just let me know either now, by email, whatever
00:25:34 <thinrichs> Deadline is soon, so don't wait.
00:25:53 <thinrichs> Questions, comments?
00:26:47 <thinrichs> #topic Mitaka release
00:27:05 <thinrichs> I see no code in review that should be merged before mitaka.
00:27:18 <thinrichs> Does anyone know of any bugs that need to be fixed before Mitaka?
00:27:34 <thinrichs> More generally, how is your testing going?
00:28:52 <ramineni_> thinrichs: im trying to get that congress_ha tempest tests working , but strangely it works fine in local env, but fails in gate
00:29:25 <thinrichs> ramineni_: are those the tests that spin up another instance of Congress?
00:29:32 <ramineni_> thinrichs: yes
00:29:42 <thinrichs> Are you running it locally and using a virtualenv?
00:30:06 <ramineni_> thinrichs: not using venev
00:30:10 <thinrichs> If you run ./run_tempest -N … then you're NOT using a virtualenv
00:30:32 <ramineni_> thinrichs: actually both, i tried with tox too, which uses venev .. then also it works
00:30:42 <ramineni_> thinrichs: both commands owrk in my env
00:30:43 <thinrichs> In the gate, tempest always runs in a virtualenv
00:30:51 <thinrichs> Hmmm.
00:31:34 <thinrichs> Permissions?
00:31:48 <ramineni_> thinrichs: ill check on that again, resolved some issues related to tests , but havent got fully functional yet
00:31:50 <thinrichs> Does the 2nd Congress instance start up properly?
00:32:49 <ramineni_> thinrichs: ya, i can see the pid, ill add some logging again to get the deatils why it fail in gate
00:33:19 <thinrichs> ramineni_: sounds good.
00:33:24 <ramineni_> thinrichs: it would have been esier , if it fails in local env too  :)
00:33:30 <thinrichs> I don't have any better advice for you.
00:33:56 <thinrichs> When I ran into this, I found the most important thing in making progress was figuring out how to make it fail locally
00:34:51 <thinrichs> ramineni_: let me know if you want to bounce ideas off someone.  That can get frustrating quickly, so don't hesitate to reach out.
00:35:16 <ramineni_> thinrichs: sure, thanks
00:35:34 <thinrichs> masahito: how's your testing going?  Had a chance to do some manual testing of the push driver?
00:36:25 <masahito> I tested push-driver and overall it works well.
00:36:40 <thinrichs> masahito: cool!
00:36:48 <masahito> I just find one bug that already resolved.
00:37:10 <thinrichs> ekcs was asking if we had a script of manual tests that we run before a release
00:37:36 <thinrichs> I said I'd try to record some of the manual tests that I run.
00:37:48 <thinrichs> It'd be good if we had a couple push tests too.
00:38:23 <thinrichs> masahito: do we have a CLI command for pushing data into the server?
00:38:35 <masahito> no
00:39:13 <thinrichs> masahito: Unless there's a reason we don't want that CLI command, let's add one in Newton.
00:39:18 <masahito> because we don't have an impl for push driver
00:40:01 <thinrichs> We don't have any drivers that let you push data in?
00:40:08 <masahito> right.
00:40:14 <thinrichs> How did you test it?
00:40:46 <masahito> ooh. I have one that I've not pushed to gerrit yet.
00:41:28 <masahito> I mean we don't have any driver in *master* of Congress community.
00:41:36 <thinrichs> Is it a lot of code?  Does it make sense to merge even a really simple one by Mitaka?
00:42:22 <ekcs> I wonder if it’s easy to make a TestPushDriver.
00:42:33 <masahito> The driver is related to my presentation.
00:43:26 <thinrichs> I was thinking that a simple driver where people can push whatever data, and then write policy over that data.
00:43:49 <thinrichs> I think we'd just need to implement a driver with 1 method, right?
00:43:55 <thinrichs> The only tricky bit was computing the schema.
00:44:03 <thinrichs> But we could hack something in for that.
00:44:14 <masahito> It's not a lot of code, but the schema of its translator isn't fixed yet.
00:45:25 <masahito> thinrichs: right.
00:45:53 <thinrichs> masahito: can you take an action item to explain what is necessary to the rest of us, so we can figure out whether to add something?
00:46:01 <thinrichs> Maybe start a thread on the mailing list
00:46:11 <masahito> thinrichs: got it.
00:46:27 <thinrichs> We need to make the decision soon, and I think having a simple push driver in place would be worth the risk of a bug.
00:46:42 <thinrichs> #action: masahito will follow up on whether to add a push driver for Mitaka
00:47:06 <thinrichs> Anyone else have anything for Mitaka?
00:47:25 <ekcs> I just ran into this: This bug hasn't quite been fixed completely. When I use an unknown name before the :, I get the misleading "rule already exists error"
00:47:25 <ekcs> https://bugs.launchpad.net/congress/+bug/1553433
00:47:27 <openstack> Launchpad bug 1553433 in congress ""Rule already exists" error when using non-existent named parameter" [Undecided,Fix released] - Assigned to Anusha (anusha-iiitm)
00:47:27 <thinrichs> I'm planning to do some manual testing this week.
00:47:27 <ekcs> Not exactly sure what's the correct behavior because when we use an unknown name we don't know whether it's a datasource or not.
00:47:27 <ekcs> I'll re-open the bug when we're done.
00:48:14 <thinrichs> ekcs: Rejecting the rule is correct, but it's a misleading error message?
00:48:33 <ekcs> yup. like this.
00:48:33 <ekcs> $ openstack congress policy rule create classification '
00:48:34 <ekcs> a :- blah:w(id=y)'
00:48:35 <ekcs> Rule already exists::(1008) Rule already exists (HTTP 409) (Request-ID: req-f5b5f25a-40cc-4278-ad7b-cc49d9a72779)
00:48:55 <thinrichs> What if you insert...
00:49:00 <thinrichs> a :- blah:p(x)
00:49:03 <thinrichs> Same problem?
00:49:14 <thinrichs> That is, is this related to column refs or not?
00:49:49 <ekcs> That works fine. The issue is we can’t do column ref elimination.
00:50:21 <ekcs> you did a fix that rejects any column references outright for something that’s a policy table.
00:50:44 <ekcs> and give this message. $ openstack congress policy rule create classification 'a :- action:w(id=y)'
00:50:45 <ekcs> Syntax error for rule::Literal action:w(id=y) uses column references, but 'action' does not reference a datasource policy (HTTP 400)
00:51:11 <thinrichs> I'd think we'd want the same error message for your case, right?
00:51:27 <ekcs> but the fix didn’t apply to unknown name before the :
00:51:31 <thinrichs> Seems like there's a case we're missing then.
00:51:31 <ekcs> Right.
00:51:32 <thinrichs> Got it.
00:51:41 <thinrichs> So that should be a simpl-ish fix.
00:51:44 <thinrichs> Right?
00:51:48 <ekcs> think so.
00:51:55 <thinrichs> Sounds good.
00:52:22 <thinrichs> Let's open it up for discussion the last few minutes.
00:52:27 <thinrichs> #topic open discussion
00:53:21 <thinrichs> Almost forgot...
00:54:13 <thinrichs> Our outstanding items before being ready with the Mitaka release...
00:54:17 <thinrichs> 1. ekcs's fix
00:54:20 <thinrichs> 2. masahito's push driver
00:54:27 <thinrichs> 3. thinrichs's testing pass
00:54:31 <thinrichs> 4. other testing
00:55:02 <thinrichs> If we're all still busy testing, there's no pressure to cut a release candidate and open master for non-mitaka commits.
00:55:30 <thinrichs> So I'd propose working through at least 1 and 3 before cutting a release candidate.
00:56:13 <thinrichs> If (1) and (3) go well, we go ahead and cut the release branch and reopen master.
00:56:18 <thinrichs> How does that sound?
00:56:31 <ekcs> souds good.
00:57:02 <thinrichs> masahito, ramineni_, tsandall, fabig: what do you think?
00:57:27 <masahito> sounds good.
00:57:32 <fabig> +1
00:57:33 <ramineni_> sounds good
00:57:41 <tsandall> +1
00:57:52 <thinrichs> Good.
00:58:04 <thinrichs> Anything else to discuss with our remaining 3 minutes?
00:59:16 <thinrichs> Thanks all!
00:59:54 <thinrichs> Just noticed: only hours left to become a PTL candidate!
01:00:57 <thinrichs> #endmeeting