00:00:25 <thinrichs> #startmeeting CongressTeamMeeting
00:00:25 <openstack> Meeting started Thu Dec 10 00:00:25 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:29 <openstack> The meeting name has been set to 'congressteammeeting'
00:02:03 <thinrichs> Who is here today?
00:06:25 <masahito> sorry, late.
00:06:52 <thinrichs> masahito: hi
00:08:27 <thinrichs> Anyone see this now?
00:13:26 <masahito_> The connection for the freenode isn't good.
00:13:48 <thinrichs1> test
00:14:30 <ramineni> thinrichs1: hi
00:14:48 <thinrichs1> ramineni: hi
00:14:55 <thinrichs1> masahito: you there?
00:15:28 <thinrichs1> #chair thinrichs1
00:15:32 <masahito_> thinrichs1: i'm here
00:15:52 <thinrichs1> another test
00:16:11 <thinrichs1> masahito_: I don't see you.  Did you get this?
00:17:10 <masahito_> thinrichs1: yes
00:17:11 <ekcs> masahito_: do you see thinrichs1 second message saying he doesn’t see you?
00:17:30 <masahito_> ekcs: I saw both message
00:17:36 <thinrichs1> all: something seems wrong with IRC today.
00:17:45 <thinrichs1> I can't see masahito_ messages but he can see mine.
00:18:02 <thinrichs1> So if someone else could resend his messages so I can see them that'd be helpful.
00:18:22 <thinrichs1> Sorry for the late start everyone.
00:18:45 <thinrichs1> Here's my agenda for today
00:18:53 <thinrichs1> 1. distributed arch
00:18:56 <thinrichs1> 2. python3
00:19:07 <thinrichs1> 3. bryan_att and install issues
00:19:10 <thinrichs1> 3. mid-cycle meeting
00:19:19 <thinrichs1> 5. misc
00:19:22 <thinrichs1> Anything else?
00:19:47 <thinrichs1> Let me know as we go then.
00:19:55 <thinrichs1> #topic distributed arch
00:20:02 <thinrichs1> pballand: Want to give a status update?
00:22:00 <thinrichs1> Am I disconnected again?
00:22:10 <ramineni> thinrichs1: no :)
00:22:30 <ramineni> thinrichs1: we can see the messages
00:22:39 <thinrichs1> ramineni: phew!
00:22:47 <thinrichs1> Let's come back to this topic then.
00:22:50 <masahito> thinrichs1: me too.
00:22:50 <thinrichs1> #topic python3
00:23:21 <thinrichs1> ekcs: status update?
00:23:33 <ramineni> ekcs , also doesnt seem to be there in room?
00:23:38 <ekcs> I’m here.
00:24:10 <thinrichs1> Yeah—he seems to have dropped out too.
00:24:35 <thinrichs1> Maybe it's worth canceling this week and going over stuff via email.
00:24:38 <ekcs> ugh. I can see your messages
00:24:50 <ekcs> but you can’t seem to see mine.
00:25:00 <thinrichs1> ramineni: while you're here, want to give an update on the tempest tests (and devstack)?
00:25:02 <egon> I can see the messages from ekcs
00:25:12 <ramineni> thinrichs1: sure
00:25:34 <ramineni> thinrichs1: almost got the tempest tests running on major components :)
00:26:11 <ramineni> thinrichs1: the problem seems to be we are not waiting until data gets converged , exiting before only , so they are failing intermittently
00:26:23 <thinrichs1> ramineni: Nice!
00:26:51 <ramineni> thinrichs1: but we might need to make changes  if tempest does any changes wrt to client
00:26:52 <thinrichs1> ramineni: I thought there was code in place to wait until convergence
00:27:12 <thinrichs1> ramineni: but the tests were definitely flakey
00:27:38 <thinrichs1> ramineni: were there some places where we were waiting correctly, and there were just places we missed?
00:27:47 <ramineni> thinrichs1: yes, it was there , but we are handling exception in between , so exiting instead of calling again
00:28:45 <ramineni> thinrichs:yes
00:35:04 <pballand> ping?
00:35:09 <thinrichs1> pong
00:35:18 <ramineni> pballand: thinrichs1:hi
00:35:29 <thinrichs1> Should we try this again?
00:35:30 <pballand> hmm - maybe things are back?
00:35:37 <masahito> hi
00:35:39 <thinrichs1> Seems okay
00:35:46 <ramineni> ya
00:36:02 <thinrichs1> Let's give it a try.
00:36:12 <openstack> thinrichs1: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
00:36:17 <ekcs> hello
00:36:32 <thinrichs1> Seems like it's remembering that the meeting is still going.
00:36:34 <pballand> haha - going to be an interesting meeting log
00:36:41 <thinrichs1> pballand: :)
00:36:58 <thinrichs1> Let's see how much we can get done in 25 min
00:37:03 <thinrichs1> #topic distributed arch
00:37:06 <thinrichs1> pballand: status update?
00:37:32 <pballand> sure - pushed the bare version of the dsenode - and tweaked for some minor pep errors
00:37:55 <pballand> now working on the feature-rich version, since it seems masahito and ekcs have leads on the fake driver
00:39:01 <pballand> once pep8 passes, I think the commit can/should go in as we discussed last week
00:39:27 <pballand> and other future feature commits can sit in code review pending oslo messaging changes, or we can push them as well, depending
00:39:34 <pballand> that’s it for me
00:39:55 <thinrichs1> Sounds good.  Thanks.  Looking forward to getting that into the tree.
00:40:23 <thinrichs1> ekcs, masahito: quick update on how you plan to fix the fake driver?
00:40:53 <masahito> I found the cause of the oslo bug, so I'm writing the patch now and can push it in this week.
00:41:12 <pballand> masahito: you rock!
00:41:14 <thinrichs1> masahito: great!
00:41:53 <masahito> and I noticed that when we use fake driver we need little tweaks in our test. but it's not a lot :)
00:42:25 <thinrichs1> masahito: I'm looking forward to the details.
00:42:31 <thinrichs1> moving on…
00:42:34 <thinrichs1> #topic python3
00:42:46 <thinrichs1> ekcs: I saw you've made good progress.  Want to report?
00:42:56 <ekcs> Patches were merged. Py34 should be passing. I think we should turn on py34 voting asap to prevent regression.
00:42:57 <ekcs> I'm also happy to help if anyone runs into issues passing py34 on their patches.
00:43:03 <ekcs> Next step: start using congress on python3. We'll probably encounter a few bugs over time.
00:43:50 <thinrichs1> ekcs: fantastic!  That one has been on our list a looong time.  Glad to have it done.
00:44:04 <thinrichs1> I'll try to submit a patch to make it voting.
00:44:19 <thinrichs1> Everyone else: until that merges, make sure python34 tests pass.
00:44:27 <thinrichs1> #action thinrichs will make python34 job voting
00:44:36 <thinrichs1> #topic mid-cycle meeting
00:44:45 <thinrichs1> We finalized dates.  Here's the email.
00:44:52 <thinrichs1> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/081606.html
00:45:10 <thinrichs1> Jan 26-28 in the Bay Area
00:45:16 <thinrichs1> You can see a tentative agenda in there too.
00:45:21 <thinrichs1> Please respond with comments/questions.
00:45:25 <thinrichs1> On the mailing list.
00:45:44 <thinrichs1> #topic Tempest tests
00:45:54 <thinrichs1> ramineni: status update on the tempest tests?
00:46:18 <ramineni> thinrichs1: enabled most of them , i think murano one is pending
00:46:43 <thinrichs1> Is it safe to start asking people to write new tempest tests again?
00:46:55 <ramineni> thinrichs1: we might need to make changes over time , if tempest changes , as they are in huge migration process
00:47:09 <ramineni> thinrichs1: yes , that would be good
00:47:21 <thinrichs1> ramineni: good to know.  So maybe only add tests that we think are pretty important, until they get their migration done
00:47:30 <ramineni> thinrichs1: I will keep an eye on tempest tests
00:47:51 <ramineni> thinrichs1: yes
00:48:01 <thinrichs1> They're gating again, so we'll all keep an eye on them.  :)  Thanks for volunteering
00:48:15 <thinrichs1> ramineni: you're definitely our tempest expert at this point
00:48:28 <ramineni> thinrichs1: :)
00:48:31 <thinrichs1> bryan_att: are you there?
00:48:40 <thinrichs1> #topic Installation
00:49:05 <thinrichs1> bryan_att posted to the openstack mailing list about his experiences getting Congress installed on a non-devstack openstack installation
00:49:14 <thinrichs1> #link http://lists.openstack.org/pipermail/openstack/2015-December/014760.html
00:49:25 <thinrichs1> He had some suggestions for us and I promised him time in the meeting.
00:49:46 <thinrichs1> But it seems he might not be around
00:50:00 <thinrichs1> We can try again next week.
00:50:23 <thinrichs1> #topic Project navigator
00:50:37 <thinrichs1> Just this week Congress was added to the OpenStack project navigator
00:50:38 <thinrichs1> #link 	1.	https://www.openstack.org/software/releases/liberty/components/congress
00:51:08 <thinrichs1> Here's the navigator link (the one above is just for Congress)
00:51:09 <thinrichs1> https://www.openstack.org/software/project-navigator
00:51:43 <thinrichs1> Here's another way to look at it.
00:51:46 <thinrichs1> #link https://www.openstack.org/software/
00:52:17 <thinrichs1> One of the things we're not doing that many other projects are doing is including our APIs in the OpenStack documentation repo…
00:52:52 <thinrichs1> #link http://developer.openstack.org/api-ref.html
00:53:15 <thinrichs1> To include our APIs in that documentation, we need to encode them in XML and contribute them to the appropriate repo.
00:53:34 <thinrichs1> #link https://git.openstack.org/cgit/openstack/api-site/
00:53:53 <thinrichs1> The rest of our docs are hosted on readthedocs...
00:54:00 <thinrichs1> https://congress.readthedocs.org/en/latest/
00:54:06 <thinrichs1> That includes our API.
00:54:32 <thinrichs1> So one thing we'll need to decide is whether we want to move our API to the openstack XML repo or not.
00:55:07 <thinrichs1> I'd say we want it in 1 place (not 2), which means either we cut it out of the RST format it's currently in and rewrite it in XML, or leave everything as is.
00:55:43 <thinrichs1> That's the last thing for me.  So in the last 5 minutes, we'll open it for discussion (and feel free to chime in about the docs).
00:55:47 <thinrichs1> #topic open discussion
00:56:17 <masahito> Do we need have api reference in api-site as OpenStack official project?
00:56:56 <thinrichs1> masahito: no formal requirement that I know of.
00:57:00 <masahito> If so, IMO we should move the RST doc to XML.
00:57:10 <ramineni> thinrichs1: but many other projects do use rst right as of now?
00:57:11 <masahito> If not so, I prefer RST
00:57:55 <masahito> I've written some reference for api-sit, but the structure of the XML is worse to maintain.
00:57:59 <thinrichs1> ramineni: most of the others use XML, though I think that's b/c the documentation team wrote theirs
00:58:27 <ekcs> thinrichs1: does it affect this “indicator”? “Is there an install guide for this project guide (at docs.openstack.org)?” on #link https://www.openstack.org/software/releases/liberty/components/congress
00:58:30 <thinrichs1> murano (another new project) is using rst as well, though whether they plan to use xml in the future I don't know.
00:58:48 <ramineni> thinrichs1: ok
00:58:49 <thinrichs1> ekcs: I think we should add an install guide, independent of the API.
00:59:15 <thinrichs1> ekcs: since the install guide does seem to be visible to our maturity
00:59:39 <ekcs> thinrichs1: got it.
00:59:53 <thinrichs1> I don't know what they're going to do in the long-run.
00:59:58 <ramineni> thinrichs1: i have one last thing https://review.openstack.org/#/c/250598/
01:00:13 <thinrichs1> I'd rather not port to XML, but if that's what everyone will do in the long run, we probably should.
01:00:14 <ramineni> thinrichs1: we can discuss in channel , as time is up
01:00:20 <thinrichs1> ramineni: sounds good.
01:00:33 <thinrichs1> Thanks all!  Sorry about the accelerated meeting and all the hiccups at the start.
01:00:35 <thinrichs1> #endmeeting