00:00:39 <thinrichs> #startmeeting CongressTeamMeeting
00:00:40 <openstack> Meeting started Thu Dec  3 00:00:39 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:44 <openstack> The meeting name has been set to 'congressteammeeting'
00:01:19 <thinrichs> fabiog: hi
00:01:29 <fabiog> thinrichs: hi
00:01:42 <fabiog> nobody else around ?
00:01:50 <thinrichs> fabiog: I remember you sending out a survey.  But then I couldn't find it.
00:01:56 <kzaitsev_mb> o/
00:02:21 <thinrichs> fabiog: a survey for the mid-cycle meetup
00:02:30 <pballand> hi
00:02:37 <ramineni_> hi
00:02:39 <freerunner> o/
00:02:49 <fabiog> thinrichs: http://doodle.com/poll/iinvncz7298rq9wbfqdspft2/admin#table
00:02:53 <ekcs> hi
00:03:04 <fabiog> thinrichs: some people already listed themselves there
00:03:18 <thinrichs> fabiog: thanks.
00:03:22 <fabiog> thinrichs: I would actually get some consensus today, so I can start planning
00:03:34 <fabiog> thinrichs: like to get
00:03:46 <thinrichs> fabiog: understood
00:03:51 <thinrichs> My agenda for today:
00:03:52 <masahito> hi
00:04:06 <joonmyung> hi
00:04:06 <thinrichs> 1. distributed arch
00:04:09 <thinrichs> 2. python3
00:04:13 <thinrichs> 3. midcycle meetup
00:04:20 <thinrichs> 4. tempest tests
00:04:25 <thinrichs> 5. devstack gate
00:04:30 <thinrichs> Anything else?
00:06:16 <thinrichs> #topic distributed arch
00:06:23 <thinrichs> pballand: how's it going?
00:07:21 <pballand> was on vacation last week, sorry for not sending an update for last weeks meeting
00:07:54 <pballand> I’ve been trying various angles at getting the fake driver working in oslo.messaging
00:08:08 <pballand> it seems that it doesn’t work with multiple topics, namespaces, or versions
00:08:39 <pballand> unfortunately, we need one of those for the design to work
00:08:57 <pballand> the rabbit driver does appear to work, but that makes it difficult for testing or running without dependencies
00:09:16 <pballand> options: continue with functionality using rabbit, don’t do testing
00:09:23 <pballand> (1)
00:09:34 <pballand> 2) continue debugging the oslo.messaging fake driver
00:09:44 <pballand> 3) write a new olso messaging driver
00:10:02 <pballand> we can try multiple things in parallel
00:10:16 <pballand> but I’m stuck on 2 and could use help
00:10:24 <pballand> thoughts?
00:10:45 <fabiog> pballand: have you reached out to the oslo folks?
00:11:09 <thinrichs> I'm in favor of having good unit tests (eventually).
00:11:14 <masahito> oslo team said they don't maintenance fake driver now. so they said it would be a bug.
00:11:31 <thinrichs> Can we have good unit tests without the fake driver?
00:11:58 <pballand> I think an in-memory driver is necessary for unit tests
00:12:16 <pballand> others may disagree I guess...
00:13:01 <su_zhang> hello all
00:13:25 <su_zhang> what's the current topic for congress?
00:13:39 <thinrichs> su_zhang: status on the distributed arch
00:13:48 <pballand> proposal: I will move forward pushing the existing code and add the rest of the functionality using manual testing with rabbit driver
00:13:49 <su_zhang> sounds beautiful
00:14:15 <pballand> in parallel (hopefuly) someone else can pick up trying to fix or replace the fake driver
00:14:19 <pballand> anyone up for that?
00:15:27 <thinrichs> pballand: so you're proposing to merge the existing code (without adding any tests that gate future commits) and let us all jointly work on getting the gating tests in place.
00:15:27 <pballand> ping?
00:15:39 <pballand> thinrichs: exactly
00:15:47 <masahito> i try to do it
00:15:51 <pballand> the cude is compeltely standalone so far, so it shouldn’t affect much
00:16:28 <thinrichs> So effectively this makes it easier for people to collaborate on getting the unit tests working than if the code were sitting in gerrit.
00:16:53 <pballand> masahito: that would be great!
00:16:55 <thinrichs> The system will function exactly the same before and after the merge.
00:17:00 <thinrichs> ?
00:17:43 <pballand> yup - no affect whatsoever
00:17:48 <pballand> just a couple new files
00:17:59 <thinrichs> That seems like a good way to give everyone a chance to get involved.
00:18:11 <thinrichs> It also sounds like we can start doing several things in parallel…
00:18:23 <thinrichs> 1. continue development of dsenode
00:18:30 <thinrichs> 2. develop unit tests for dsenode
00:18:43 <thinrichs> 3. integrate datasources, policy engine, api with new dsenode
00:19:12 <pballand> ok, then I will move forward with pushing the standalone dsenode2
00:19:22 <thinrichs> (The last we want to be careful of — to ensure we can run either in the distributed or non-distributed mode — but we can make progress.)
00:19:35 <thinrichs> pballand: sounds good to me.
00:19:58 <pballand> thanks
00:20:05 <fabiog> pballand: could you please post the review link?
00:20:06 <thinrichs> any other questions, comments, concerns?
00:21:05 <masahito> who will be assigned to 2 and 3?
00:21:28 <thinrichs> masahito: I think you signed up for (2)
00:21:36 <masahito> yes
00:22:08 <thinrichs> pballand is working on (1), though it seems it should be mostly working
00:22:39 <thinrichs> I think we want to make progress on unit tests (2) so we know whether we're doing the integration (3) correctly.
00:22:56 <pballand> I still have some methods to throw back in (they were pulled out to make testing easier until the fake driver was working)
00:23:58 <thinrichs> pballand: do you have any manual tests in code that we could expand to check if we're doing integrations properly?
00:25:13 <thinrichs> That is, is there a test framework for running with the real rabbit driver?
00:25:21 <pballand> yes - it’s all in there
00:25:40 <pballand> but it is standalone, so you need to create a venv to run it
00:25:50 <thinrichs> are there instructions?
00:26:06 <pballand> I’ll add them before pushing
00:26:56 <thinrichs> Can we have one person other than pballand and masahito volunteer to try out pballand's test framework for the rabbit driver by next week?
00:27:12 <thinrichs> pballand: I should have asked this first: when do you think we'll push it in?
00:27:32 <thinrichs> Sorry—when do you think you will push the code in?
00:27:32 <pballand> I should have it in by end of day tomorrow (PST)
00:27:44 <ekcs> I can work with pballand on it too.
00:28:06 <thinrichs> That's enough time for someone to try out the instructions.
00:28:08 <thinrichs> ekcs: great!
00:28:27 <thinrichs> Some actions items...
00:28:39 <thinrichs> #action pballand will commit the DseNode code
00:29:04 <thinrichs> #action masahito will work on getting a unit test framework (e.g. couple of example tests) in place and working
00:29:27 <thinrichs> #action ekcs will try out pballand's test framework for the real rabbit driver
00:30:04 <thinrichs> Then if all goes well, next week we can have a couple of people do an integration or two of the API and policy engine.
00:30:09 <thinrichs> Sound good?
00:30:28 <ekcs> #agreed
00:31:02 <thinrichs> #
00:31:07 <thinrichs> next topic
00:31:11 <thinrichs> #topic python3 status
00:31:17 <thinrichs> ekcs: how's python3 going?
00:31:29 <ekcs> It's going well. Number of Py34 test fails dropping quickly with each patch.
00:31:29 <ekcs> ~400 fails in antlr patch
00:31:30 <ekcs> ~100 fails in datalog patch #link https://review.openstack.org/#/c/248946/
00:31:31 <ekcs> ~30 fails in datasources patch #link https://review.openstack.org/#/c/252165/
00:31:41 <ekcs> API patch coming this week.
00:31:42 <ekcs> After that only loose ends should remain.
00:31:42 <ekcs> My goal is to be down to zero fails sometime next week. Then hopefully we can make Py34 voting when all these patches are merged.
00:32:20 <thinrichs> Nice progress!
00:32:50 <masahito> great!
00:33:00 <ekcs> like before, reviews appreciated.
00:33:39 <thinrichs> I didn't make a review pass today like I'd planned.  I'm planning to do it tomorrow or after the meeting.
00:33:43 <thinrichs> Sorry all.
00:33:58 <thinrichs> ekcs: I just noticed a py27 antlr failure.  Don't know how widespread this is.
00:33:59 <thinrichs> #link http://logs.openstack.org/09/247109/11/check/gate-congress-python27/abc02fc/console.html
00:34:21 <thinrichs> It's just a requirements.txt update
00:34:23 <thinrichs> #link https://review.openstack.org/#/c/247109/
00:34:36 <thinrichs> The error is saying that there's no antlr3 module found.
00:35:13 <ramineni> thinrichs: why is setup.py modified here, i think failure because of that
00:35:34 <ekcs> yea that makes sense. setup.py sets up the symlinks for antlr3.
00:36:19 <ekcs> maybe we’re not supposed to do that.
00:36:48 <ekcs> there are alternatives, but none of them pretty.
00:38:30 <ekcs> one alternative to the symlink setup is to let each file decode based on py version which antlr3 runtime to import. That works, the drawback is that we have to modify the import section of generated code (CongressParser and CongressLexer)
00:38:47 <thinrichs> That seems bad if the auto-jobs are deleting something we depend on.
00:39:22 <ekcs> I’ve been thinking about doing it that way instead for easier testing (don’t have to run setup.py each time), but it seems bad to have to modify generated code too. This situation may just push to in that direction though.
00:39:31 <ekcs> thinrichs: #agreed
00:39:37 <thinrichs> ekcs: could you look into this?  Maybe post to openstack-dev?
00:40:04 <ekcs> thinrichs: ok
00:40:09 <thinrichs> ekcs: seems you have a lot on your plate.
00:40:52 <thinrichs> ekcs: but we need to keep our requirements up to date.  It's not urgent, but we should start looking into it this week.
00:41:07 <ekcs> thinrichs: got it.
00:41:45 <thinrichs> ekcs: would you rather someone else work with pballand on working with the rabbit driver test framework?
00:42:17 <ekcs> thinrichs: sure that could help, just to ensure that py3 stuff doesn’t get delayed.
00:43:10 <thinrichs> Any volunteers?
00:43:15 <ramineni> thinrichs: let me try it out
00:43:22 <thinrichs> ramineni: thanks!
00:43:28 <ekcs> ramineni: thanks
00:43:41 <thinrichs> pballand: could you work with ramineni once you get the dsenode code merged?
00:44:19 <pballand> sure, will do
00:44:39 <thinrichs> #topic midcycle meetup
00:45:06 <thinrichs> Anyone who is interested in attending the mid-cycle meetup, which will be held in the bay area, needs to fill out this poll.
00:45:08 <thinrichs> http://doodle.com/poll/iinvncz7298rq9wbfqdspft2/admin#table
00:45:33 <thinrichs> I haven't done this yet; anyone else planning on filling it out?
00:46:09 <fabiog> thinrichs: I just found out that Mon 18 is MLK Day
00:46:33 <fabiog> thinrichs: are we shooting for 3 days?
00:46:57 <thinrichs> fabiog offered to host and asked that we get some dates settled today.  But I think that by Friday or next Wed is more likely
00:47:42 <thinrichs> The topics we settled on were: distributed architecture, HA architecture, and monasca integration.
00:47:42 <fabiog> thinrichs: I will not be able to attend next wed since I am at an offsite
00:48:10 <thinrichs> fabiog: is it okay if I email you final dates next wed?
00:48:20 <fabiog> thinrichs: yes, perfectly fine
00:48:47 <thinrichs> All: we'll close the poll this Friday.  Next week I'll look at the options and let fabiog know which ones seem to work best.
00:48:55 <fabiog> thinrichs: I just need to take care of logistics, like room, catering and dinner before I leave for the break :-)
00:49:09 <thinrichs> Any thoughts about whether we should have 2 days or 3 days?
00:49:20 <thinrichs> fabiog: totally understand; thanks so much for arranging everything!
00:49:29 <fabiog> thinrichs: my pleasure
00:51:57 <thinrichs> I'd lean toward 3 days: (i) distributed architecture: overview, status, code sprint.  (ii) monasca integration where hopefully we can have that discussion in light of the distributed architecture.  (iii) HA discussion.
00:52:10 <thinrichs> I'd hope the monasca team could attend the overview part of day 1
00:52:22 <thinrichs> so we're all on the same page wrt day 2
00:52:33 <ekcs> Makes sense.
00:52:58 <thinrichs> And then the HA day is last so we take the monasca integration into account, if necessary.
00:53:24 <thinrichs> That's just off the top of my head, though.  So other suggestions would be great.
00:54:25 <thinrichs> 5 minutes left.  Let's just open for discussion.
00:54:29 <thinrichs> #topic open discussion
00:55:02 <ramineni> had patch up , for having diff gate jon for stable branches , https://review.openstack.org/#/c/250598/4
00:55:08 <kzaitsev_mb> hi freerunner and came here to give you tell you, that murano-integration gate has landed )
00:55:15 <freerunner> Hey guys! Murano team have some news for you. First: As you can see, the murano-congress integration gate appeared in congress repo ;) Second: What about merging this patch https://review.openstack.org/#/c/249023/ ;)
00:55:30 <ramineni> appreciate any reviews :)
00:55:39 <kzaitsev_mb> freerunner: although it seems red right now ))
00:55:50 <fabiog> thinrichs: I am still working on a Monasca driver, but I have to get the python-monasca client in the global requirements that opened a bunch of stuff to be done, so it will take longer than planned
00:56:27 <alexsyip> My changes to finish the synchronizer merged a couple weeks ago.  I haven’t tested it, but all the code for basic HA should be in place now.
00:56:29 <freerunner> kzaitsev_mb: Not exactly =) I hope, that thinrichs help us to land https://review.openstack.org/#/c/249023/ , then the gate become green.
00:56:57 <thinrichs> kzaitsev_mb: Great!  I saw that.  Thanks for getting that done.
00:57:08 <thinrichs> ramineni: will do.  Thanks for pointing us to it.
00:57:46 <thinrichs> freerunner: I'll get to that patch hopefully tonight
00:58:42 <freerunner> thinrichs: Great news ;)
00:58:55 <thinrichs> fabiog: great!  let us know if we can help
00:59:15 <thinrichs> alexsyip: it's great to have the synchronizer code in our back pocket once the distributed arch lands.
00:59:59 <alexsyip> You can use basic HA without the rest of the distributed architecture.
01:00:53 <thinrichs> alexsyip: right—if we deploy multiple congresses.  Thanks for the reminder!
01:01:00 <thinrichs> We're out of time for this week.  Thanks all!
01:01:02 <thinrichs> #endmeeting