17:01:43 <thinrichs> #startmeeting CongressTeamMeeting
17:01:43 <openstack> Meeting started Tue Jun 23 17:01:43 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:47 <openstack> The meeting name has been set to 'congressteammeeting'
17:02:00 <thinrichs> Who's here this week?  I know alexsyip is out of town.
17:02:10 <masahito> Hi
17:03:04 <thinrichs> masahito: hi!
17:03:19 <thinrichs> pballand: ping
17:04:39 <bryan_att> Hi
17:05:52 <pballand> hi
17:06:00 <thinrichs> bryan_att, pballand: hi
17:06:16 <thinrichs> We have a few items to discuss today.
17:06:51 <thinrichs> So instead of everyone doing status updates, does anyone have anything they need help from the group for?
17:07:03 <bryan_att> thinrichs: for the agenda, I'm looking to replicate or re-use the Vancouver Contgress hands-on-lab environment, for internal and OPNFV education/experimentation
17:07:05 <thinrichs> #topic quick-status
17:08:06 <thinrichs> bryan_att: got it.
17:08:11 <thinrichs> Anyone else?
17:08:25 <thinrichs> Here's the agenda then.
17:08:26 <thinrichs> mid-cycle sprint
17:08:26 <thinrichs> talk submission
17:08:27 <thinrichs> oslo liaison
17:08:27 <thinrichs> milestones
17:08:27 <thinrichs> HOL
17:08:36 <thinrichs> #topic mid-cycle sprint
17:09:45 <thinrichs> We have 6 people interested in the mid-cycle sprint: masahito, peter, alex, zhenzan, sayaji, and me
17:10:01 <thinrichs> So we need to find date, time, and place.
17:10:53 <thinrichs> Since at least half are in the bay area, it makes sense to host it there.
17:10:54 <pballand> I won’t be able to make during july
17:11:22 <thinrichs> June is almost gone, so how about August?
17:11:28 <pballand> +1 for bay area
17:12:09 <masahito> +1 for August
17:12:18 <pballand> I can look into hosting it at VMware again if that works for people
17:12:34 <thinrichs> pballand: that'd be great!  Thanks!
17:12:42 <thinrichs> masahito: does the Bay Area work for you?
17:12:56 <pballand> last year we had quite a large turnout - if we can lock down dates I can see about reserving some space
17:13:10 <masahito> everywhere in U.S is Ok
17:13:22 <masahito> because I will fly from Tokyo
17:13:47 <bryan_att> Would you have ability to dial-in or use webex etc? If possible I will try to be there but remote attendance would be a good option.
17:14:15 <pballand> bryan_att: last year we tried and had mixed results for those online
17:14:31 <bryan_att> yes, mixed at best I know
17:14:32 <thinrichs> masahito: understood.  (On a side note, I'll be hitting you up for tourist stuff at the next summit.  :))
17:14:36 <pballand> we can certainly do it again, but no promises on quality
17:15:06 <thinrichs> bryan_att: the plan was for more of a code sprint than a general policy summit.
17:15:31 <pballand> how about Aug 3-4 or 6-7?
17:15:33 <thinrichs> we were talking about working on a specific feature: making our message bus work across processes and across machines
17:15:41 <thinrichs> and then writing the code to implement.
17:15:54 <thinrichs> Also some design discussions for scale out assuming that feature is in place.
17:16:03 <thinrichs> But yes a remote option is a good idea.
17:16:13 <pballand> how long? I think 2 days makes sense if people are traveling out
17:16:33 <thinrichs> pballand: I'm avail Aug 3-4 and 6-7.  And 2 days seems good.
17:16:48 <thinrichs> I think we should defer to those who are traveling longer distances, of course.
17:16:51 <masahito> 6-7 is better for me.
17:17:29 <thinrichs> Let's find a couple of dates, since there are some people who would like to attend but aren't at this meeting.
17:17:33 <pballand> I could also do July 30-31 if we want it closer to the middle of the cycle :)
17:18:32 <thinrichs> The week of July 30-31 is the OpenDaylight conf.
17:18:53 <thinrichs> I have a panel, but I don't know the exact day yet.  I'm looking.
17:19:51 <thinrichs> Found it.  It's July 28, so July 30-31 works for me.
17:19:56 <masahito> 3-4 is also ok if others isn't available Aug 6-7.
17:20:00 <pballand> fyi: here are the other sprints: https://wiki.openstack.org/wiki/Sprints
17:20:41 <thinrichs> masahito: would 3-4 be preferable to July 30-31 for you?
17:21:01 <masahito> 3-4 is better than July 30-31.
17:21:13 <masahito> I have a private plan in Aug 1.
17:21:30 <thinrichs> masahito: sounds good.
17:22:01 <thinrichs> Let's find one more option the next week, in case someone is on vacation the whole first week of August.
17:23:11 <thinrichs> My next week is free.  Masahito: what days that week work for you?
17:23:27 <masahito> In August?
17:23:33 <thinrichs> Aug 10-14
17:23:41 <pballand> 10-14 is clear for me as well
17:24:01 <masahito> 10-13 is available.
17:24:23 <thinrichs> Thanks.  We've got some options now.
17:24:51 <thinrichs> #info Possible dates, in order of preference Aug 6-7, Aug 3-4, Aug 10-13
17:25:05 <thinrichs> #action pballand will look into hosting at VMware
17:25:31 <pballand> thinrichs: are you going to post to the ML?
17:25:41 <thinrichs> #action thinrichs will touch base with other 3 who were interested to settle on date and I will post the decision to ML
17:26:13 <thinrichs> Next topic: milestones
17:26:18 <thinrichs> #topic milestones
17:26:42 <thinrichs> We have a bunch of blueprints that are up, but few people have signed up for them or chosen a milestone (liberty-1, liberty-2, liberty-3)
17:26:57 <thinrichs> #link https://blueprints.launchpad.net/congress
17:27:02 <thinrichs> This week is the end of liberty-1
17:27:13 <thinrichs> Time flies.  :)
17:27:42 <thinrichs> So let's have everyone create blueprints, sign up for them, and assign a milestone.
17:28:53 <masahito> ok. btw, If anyone doesn't assign in blueprint, is it ok I get assignee?
17:28:56 <thinrichs> And if you don't have the right to assign a milestone, tell me when you think it'll get done.
17:29:17 <pballand> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
17:29:40 <thinrichs> masahito: yep—feel free to sign up for anything that doesn't have an assignee
17:29:48 <thinrichs> pballand: thanks for the link.
17:30:39 <thinrichs> It's worth mentioning that unlike the last cycle where we let the feature freeze period slip, this cycle we're going to do feature freeze at the same time as everyone else.
17:30:55 <thinrichs> It'll help us get on track for the next cycle.
17:32:02 <thinrichs> Any questions about the blueprints?
17:32:14 <thinrichs> In particular, I'd like to see us sign up for the highest priority BPs.
17:33:38 <thinrichs> #action everyone will sign up for blueprints and assign milestones or email thinrichs with milestone requests
17:34:14 <thinrichs> Next topic is whether we want to submit a talk for the next OpenStack summit
17:34:23 <thinrichs> #topic talk submission at summit
17:34:40 <pballand> it seems the HOL was popular in Vancouver, so it seems we should propose that again
17:34:42 <thinrichs> I think we should submit at least one talk.  Ideas?
17:34:58 <thinrichs> pballand: sounds good.  Anything qualitatively different from last time?
17:35:06 <masahito> sorry, what does HOL mean?
17:35:11 <thinrichs> hands-on-lab
17:35:27 <masahito> thinrichs: thank you.
17:35:41 <thinrichs> HOL from vancouver:
17:35:42 <thinrichs> #link https://docs.google.com/document/d/1lXmMkUhiSZYK45POd5ungPjVR--Fs_wJHeQ6bXWwP44/pub
17:36:02 <pballand> thinrichs: no changes come to mind, unless there was feedback from the last one
17:36:05 <thinrichs> It would be nice to highlight some new feature we added this cycle.
17:36:45 <thinrichs> Seems we're focusing on scale/performance/architecture this cycle.
17:36:49 <thinrichs> That's hard to put into a HOL.
17:37:05 <thinrichs> Maybe we could do something around delegation?
17:37:35 <pballand> from a proposal perspective, do  we need to decide this now?
17:37:48 <thinrichs> Ok.  We should think about the details.  But we can put that off until it's been accepted.
17:37:56 <thinrichs> Any other talk ideas?
17:38:02 <bryan_att> It would be good to have an update on the feature roadmap, e.g. state of proactive enforcement work
17:38:17 <masahito> I plan to submit a general session about congress with my use-case.
17:39:21 <thinrichs> bryan_att: The update at Vancouver wasn't well attended.  So I'm hesitant to just propose a 'Congress Update' talk.
17:39:39 <thinrichs> masahito: I like the idea of a use-case driven talk.
17:39:59 <thinrichs> I was thinking of something like… Policy Federation between Congress, Keystone, and CloudFoundry
17:40:11 <masahito> but I think this idea is too specific to get congress official time slots.
17:40:44 <thinrichs> masahito: I'd imagine targeting a use-case talk to a specific track, like telcos.
17:41:00 <pballand> I like operator-driven use-case talks, but don’t have a specific topic
17:41:04 <thinrichs> If there's an audience that is deeply interested in the use case, and there's a track for that audience, you may have better luck.
17:42:02 <thinrichs> For the policy federation talk, I was thinking about doing some sort of inter-service policy exchange with Keystone and CloudFoundry.
17:42:18 <thinrichs> Maybe start by pulling policy.json out of OpenStack and comparing that to a Congress policy.
17:42:38 <thinrichs> Then maybe gate CloudFoundry operations on a Congress policy.
17:42:41 <thinrichs> Thoughts?
17:43:07 <bryan_att> Maybe some federation discussion around OpenDaylight GBP and Congress?
17:43:38 <thinrichs> bryan_att: that's been on the stack for a while.  Good thought.
17:44:01 <thinrichs> jwy: here for the Congress meeting?
17:44:10 <bryan_att> e.g. how do we know when an SDNC action has violated a policy expressed in Congress - I guess it needs a driver...
17:44:25 <jwy> thinrichs: hi, yep, albeit a bit late..
17:44:54 <thinrichs> bryan_att: what's an SDNC?
17:45:03 <bryan_att> SDN Controller
17:45:11 <thinrichs> jwy: we're brainstorming talk ideas for the summit.  Any thoughts?
17:46:05 <thinrichs> bryan_att: I think we typically expect the SDNC to do the correct thing, i.e. we have a datasource driver for the SDNC, but we don't have datasource drivers for the underlying components that the SDNC is manipulating.
17:46:45 <thinrichs> bryan_att: at least, that's how we typically think about it.  I don't know if anyone has thought about applying Congress to check the correctness of the SDNC.
17:46:46 <jwy> looking at the meeting log for today so far. agreed about doing the hol again
17:48:18 <thinrichs> ok.  low on time.  Let's everyone keep thinking since the deadline is coming up soon.
17:48:24 <jwy> another intro talk? probably a different mix of attendees, being in asia vs. north america
17:49:11 <thinrichs> jwy: It's worth submitting for sure, but I'm dubious it'll be accepted.
17:49:30 <thinrichs> Let's jump to bryan's topic.
17:49:39 <bryan_att> thinrichs: the idea is that a valid action at the SDNC may nonetheless cause some side-effect that is discoverable through a datasource driver
17:49:54 <thinrichs> #topic redeployment of the HOL
17:50:33 <thinrichs> bryan_att: I see the attraction of applying Congress to monitor the SDNC's behavior.  I just don't know what the ramifications are.
17:50:50 <thinrichs> bryan_att: want to tell us what you want to do with the HOL?
17:52:11 <bryan_att> Sorry, browser issue
17:52:37 <bryan_att> We want to replicate the HOL to educate internal teams and OPNFV on what you can do with Congress
17:53:12 <bryan_att> We are looking to the role of Congress in our NFVI and need to demo use cases that people care about
17:53:31 <thinrichs> bryan_att: Cool!
17:53:46 <bryan_att> Also inform them about the roadmap, e.g. how proactive enforcement can be done today but what it implies re Congress-external functions
17:54:26 <bryan_att> So it would be a great thing to be able to replicate the HOL environment in our lab, and then expose that to people who want to learn more about it.
17:54:45 <bryan_att> Similar to TryStack, but with Congress and scripted activities
17:55:11 <thinrichs> bryan_att: Got it.  You basically want the setup instructions for getting the VMs to the state they were in at the start of the HOL.
17:55:14 <thinrichs> Right?
17:55:18 <bryan_att> Yes
17:55:43 <thinrichs> The people who did that aren't on IRC right now.  I'll take an action item to chase them down and see what they can give us.
17:55:56 <thinrichs> #action thinrichs will look into setup instructions for the Vancouver HOL.
17:56:06 <bryan_att> Thanks, I don't want to create a lot of work for folks but appreciate any help
17:56:06 <thinrichs> bryan_att: anything else we can do to help?
17:56:28 <bryan_att> For now, any details you can send will be helpful
17:56:33 <thinrichs> It'd be good to have basic setup instructions available.  Hopefully next time we'll tack them on at the end of the doc, at least.
17:56:40 <thinrichs> bryan_att: will do.
17:57:21 <thinrichs> Just a couple of minutes left.
17:57:28 <thinrichs> #topic open discussion
17:58:50 <thinrichs> One thing we're supposed to do is migrate congress/openstack/common/log  to oslo.logging
17:58:59 <thinrichs> Any takers?  I can add a Blueprint for it.
17:59:20 <thinrichs> Or maybe just a bug report.
18:00:22 <thinrichs> We're out of time.  We hammered through a bunch of stuff this week.  Nice work all!
18:00:24 <masahito> If there is a bug report or bp to track it, I will patch it.
18:00:37 <thinrichs> masahito: deal.  I'll put up the bug report and email it to you.
18:00:49 <thinrichs> Thanks all!
18:00:56 <thinrichs> #endmeeting